Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-03-2008 13:39:14

Bloody-wave
Membre
Inscription : 26-02-2008

Problème de sécurité

Bonjour tout le monde!!

Je suis tout nouveau dans le monde de linux et je cherche de l'aide!!

Il y à peu de temps, je me suis fait hacké un serveur qui sert aux tests, donc pas trop de soucis, mais il y à 10 minutes on s'en est pris à mon dédié principale...

A chaque fois je me fait squizzer mes pass root, là j'ai eu de la chance, j'ai juste eu le temps d'éditer mes pass avant la cata.

Je voudrais savoir si il existe un système du genre anti brute force pour les accès quelqu'ils soient (root & users).

Je suis sous débian 4.0, mon dédié est chez OVH, mes pass font à chaque foir 32 caractères avec chiffres lettres minuscules et majuscule, arobas ect, je pige pas comment on peut me hack aussi facilement...

Merci d'avance pour vos réponses, cordialement, Bloody-wave

Hors ligne

#2 08-03-2008 15:50:49

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : Problème de sécurité

faudrai mettre en place un Firewall iptable, c est etonnant avec 32 caractère de se faire hacké. Avec iptable tu pourra caché les ports interdire les ping etc.....

je te passe un lien qui pourra t'aider ici

\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#3 09-03-2008 01:53:09

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Problème de sécurité

Bonjour,

Il y a knockd qui permet d'ouvrir un port (ssh par exemple) uniquement pendant un certain temps à la suite d'une combinaison prédéfinie de tentatives de connexions sur des ports définis. On peut par exemple décider qu'il faut une tentative de connexion sur un port X, suivi dans un délai d'une minute par deux connexions sur le port Y, suivi par une connexion sur le port Z pour pouvoir accéder au port ssh (pendant un certain temps), et donc tenter un login.

edit: Ah, j'ai retrouvé, il y a aussi le module limit de iptables qui permettent de fixer un maximum de connexions par espace de temps.

Si ça peut aider... smile

Dernière modification par tux12 (09-03-2008 02:37:14)

Hors ligne

#4 09-03-2008 16:24:15

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : Problème de sécurité

Une solution plus qu'efficace et sûrement la plus simple à mettre en oeuvre consiste tout simplement à changer le port par défaut de ssh....c'est radical..
Plus aucune attaque chez moi depuis.....

Il y a aussi pas mal d'options dans le wiki wink

Hors ligne

#5 09-03-2008 17:16:21

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : Problème de sécurité

on est pas sur que s est le service ssh qui merde chez lui smile

\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#6 09-03-2008 17:23:09

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Problème de sécurité

Bonjour Palmito,

Effectivement, c'est le plus simple. Par contre ça ne résiste pas à un scan de la machine; une fois le nouveau port détecté , on est revenu au point de départ. Ça peut donc protéger contre des attaques automatisées qui ne testent que le port ssh, mais pas d'un attaquant humain déterminé.

De plus, cette solution n'est pas envisageable dans le cas ou il existe un filtrage en amont sur lequel tu n'as pas de possibilité d'intervention. Dans ce cas on est bien obligé de laisser le ssh sur son port standard. Le port knocking risque de ne pas fonctionner non plus dans ce cas, seule la solution du module limit reste applicable.

Bon, ben Bloody-wave n'a plus maintenant que l'embarras du choix. big_smile

edit: @ MaTTux qui à posté pendant que je rédigeais ma réponse, ce que tu dis est tout à fait exact, merci de nous le rappeler. wink

Dernière modification par tux12 (09-03-2008 17:33:04)

Hors ligne

#7 09-03-2008 18:51:44

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : Problème de sécurité

oui c'est vrai.....quilébon ce mattux big_smile
Donc reste en priorité le bon parefeu wink

@+

Hors ligne

#8 10-03-2008 03:59:11

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : Problème de sécurité

J ai toujours dit que j etais le meilleurs des newbies big_smile

\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#9 10-03-2008 14:01:57

Bloody-wave
Membre
Inscription : 26-02-2008

Re : Problème de sécurité

Merci pour toutes vos réponses, je vais installer un des pare feu cité au dessus, mais je me suis rendu compte que le problème viens d'ailleurs...

En fait je subi des attaques DOS sur les ports tcp, au bout de 200 requêtes mon dédié crash, je voudrais savoir comment limiter le nombre de requêtes max pendant un temps défini et je voudrais savoir si vous auriez également un lien vers un bon tuto, simple ( n'oublions pas que je débute avec débian 4.0 ) afin de sécuriser au maximum mon installation.

Merci pour votre aide, cordialement, Bloody-wave

Hors ligne

#10 10-03-2008 14:11:58

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : Problème de sécurité

Donc tu vas pouvoir nous dire quel service est visé wink

Hors ligne

#11 10-03-2008 14:18:56

Bloody-wave
Membre
Inscription : 26-02-2008

Re : Problème de sécurité

le panel admin de mon serveur teamspeak2 pour être exacte

Hors ligne

#12 10-03-2008 22:53:34

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Problème de sécurité

Bonjour,

Pour répondre à la demande de documentation; un document assez complet (mais peut-être pas totalement à jour) existe chez debian; Le manuel de sécurisation Debian

Le parefeu est fourni avec Linux, il fait partie du noyau et s'appelle Netfilter. La commande pour le configurer (écrire les règles de filtrage) s'appelle iptables. On trouve des interfaces permettant la gestion du parefeu sans mettre les mains dans le cambouis, voir ShoreWall par exemple, l'emploi de la commande iptables restant AMA d'une finesse de réglage inégalable en comparaison avec un interface quelqu'il soit.
Didacticiel sur iptables

Le module limit évoqué dans un post précédent répond au besoin de limiter le nombre de connexions par unité de temps. Je ne sais pas si ce genre de réglages existe dans shorewall ou autres (j'écris mes règles, je suis parano wink ), mais bon, voilà les pistes que je peux te suggérer. Ça reste pas simple, j'en conviens, mais on peut déjà commencer en local avec sa ou ses propre(s) machine(s).

Bon courage smile

Hors ligne

#13 10-03-2008 23:21:51

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : Problème de sécurité

Il éxiste aussi guarddog et firestarter pour configurer le parefeu avec une belle interface graphique wink

Hors ligne

#14 12-03-2008 03:37:50

jdautz
Membre
Lieu : Grenoble
Inscription : 13-12-2007

Re : Problème de sécurité

Un peu plus tard...  je rapelle que OVH a des faq pas trop mal foutues concernant les dédiés. Il y a aussi un support, sans se pendre au fil, un mail...

jdautz

Hors ligne

#15 13-03-2008 02:21:30

fraiddo
Membre
Inscription : 02-03-2008
Site Web

Re : Problème de sécurité

palmito a écrit :

Une solution plus qu'efficace et sûrement la plus simple à mettre en oeuvre consiste tout simplement à changer le port par défaut de ssh....c'est radical..
Plus aucune attaque chez moi depuis.....

Il y a aussi pas mal d'options dans le wiki wink


pour ssh,
on peut simplement aussi y mettre (entre autre) ceci:

[c]
PermitRootLogin no
MaxStartups 2:50:4
AllowUsers fred@192.168.0.* toto@192.168.0.*
DenyUsers root pierre paul jacques[/c]

non?

ça empêche root, et utilisateurs pas locaux... des risques toujours? lol

++


http://www.strapontins.org c'est bon pour ton poil et bien plus encore tongue

Hors ligne

#16 13-03-2008 13:52:31

Bloody-wave
Membre
Inscription : 26-02-2008

Re : Problème de sécurité

fraiddo a écrit :

pour ssh,
on peut simplement aussi y mettre (entre autre) ceci:

[c]
PermitRootLogin no
MaxStartups 2:50:4
AllowUsers fred@192.168.0.* toto@192.168.0.*
DenyUsers root pierre paul jacques[/c]

non?

ça empêche root, et utilisateurs pas locaux... des risques toujours? lol


Le problème c'est que pour se co chez ovh en local, a part me taper 1000 bornes pour aller dans leurs locaux je vois pas comment faire avec une ip dynamique, même avec un service dns ça vas être dure tongue

En tout cas merci pour vos réponse, j'ai pas mal de lecture en perspective wink

A bientot, cordialement, Bloody-wave

Hors ligne

Pied de page des forums