Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-12-2011 19:34:15

capolino
Membre
Lieu : On Earth
Distrib. : Wheezy (64bit)
Noyau : 3.1
(G)UI : Gnome 3
Inscription : 09-08-2011

[Résolu] Configurer Jackd

Bonjour à tous, j'ai installé quelque truc de MAO (musique assistée par ordinateur) comme Qtractor donc il faut que Jackd soit démarré... J'ai installé jackd présent dans les dépots mais impossible à faire marcher... J'ai suivi quelques post sur des forums Ubuntu mais sans succé... Alors est ce que quelqu'un ici utilise Jackd sur une debian afin qu"il m'aiguille sur la manip à faire ?

Merci

Dernière modification par capolino (09-12-2011 16:20:14)

Hors ligne

#2 08-12-2011 19:50:56

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Configurer Jackd

Bonjour,

Il faudrait plus détails sur ta façon de procéder, les messages d'erreurs rencontrées, etc...

Aussi je te conseille d'utiliser qjackctl du paquet du même nom.

Sinon une façon simple de démarrer jackd :

jackd -u -R -d alsa


tu pourras nous dire si c'est façon de faire fonctionne, et si, elle ne fonctionne
pas tu voudras bien nous reporter les problèmes rencontrés, ainsi que les messages
d'erreurs.


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#3 08-12-2011 20:10:40

capolino
Membre
Lieu : On Earth
Distrib. : Wheezy (64bit)
Noyau : 3.1
(G)UI : Gnome 3
Inscription : 09-08-2011

Re : [Résolu] Configurer Jackd

voila le message d'erreur que j'ai dans Qjackctl :

19:08:52.319 JACK a été démarrer avec le PID=4097.
jackdmp 1.9.7
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2011 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 10
control device hw:0
control device hw:0
audio_reservation_init
Acquire audio card Audio0
creating alsa driver ... hw:0|hw:0|1024|2|44100|0|0|nomon|swmeter|-|32bit
control device hw:0
configuring for 44100Hz, period = 1024 frames (23.2 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 32bit integer little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 2 periods for playback
19:08:59.376 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Erreur de communication serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.
JackProcessSync::LockedTimedWait error usec = 5000000 err = Connection timed out
Driver is not running
Cannot create new client
JackSocketClientChannel read fail
Cannot open qjackctl client
jackd: ../common/JackGraphManager.cpp:45: void Jack::JackGraphManager::AssertPort(jack_port_id_t): Assertion `port_index < fPortMax' failed.
19:08:59.442 JACK a été arrêté avec succès.
19:08:59.442 JACK a planté.


Merci

Hors ligne

#4 08-12-2011 20:31:10

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Configurer Jackd

et quels sont les messages d'erreurs de la commande que je t'avais proposais ?

jackd -u -R -d alsa


Ça sera peut être plus explicite...

Remarque avant de faire cela il faut t'assurer qu'aucun soft n'utilises ta carte son, et
qu'il n'y a aucun processus jackd qui tourne déjà.


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#5 08-12-2011 20:42:26

capolino
Membre
Lieu : On Earth
Distrib. : Wheezy (64bit)
Noyau : 3.1
(G)UI : Gnome 3
Inscription : 09-08-2011

Re : [Résolu] Configurer Jackd

C'est le même message partout big_smile que ce soit en console ou par Qjackctl

Quand jouvre Qtracktor j'ai ca :

The audio/MIDI engine could not be started.

Make sure the JACK audio server (jackd) and/or
the ALSA Sequencer kernel module (snd-seq-midi)
are up and running and then restart the session.


Oui j'ai cru comprendre qu'il fallait laisser la carte son libre (qui est celle de ma carte mére). Disons que j'ai juste gnome 3 alors je sais pas si quelque chose l'utilise déja nativement...

Hors ligne

#6 09-12-2011 10:38:50

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Configurer Jackd

Je ne sais pas exactement comment gnome3 gère le son.
Il est probable qu'il utilise pulseaudio.

Pour savoir si pulseaudio tourne, tu peux utiliser la commande :

pgrep pulseaudio


Dans ce cas, il faudrait essayer d'arrêter pulseaudio, pour voir si cela te permets
de lancer jackd. Mais je ne sais comment pulseaudio est géré dans ton
système et je n'ai pas de bonne méthode pour cela.
Une méthode radicale serait de faire en tant que root :

pkill pulseaudio


Cela te permettra de tester à nouveau jackd.
Cette solution n'est que temporaire. Et dès que tu
redémarrera ton système pusleaudio sera redémarré.

Si c'est pusleaudio qui est utilisé sur ton système, 
deux solutions sont possibles.

La première  consiste à lui demander d'utiliser jackd au
lieu de alsa comme entrée audio.

La seconde est de ne pas utiliser pulseaudio.
Dans ce cas un problème se pose, car un certains nombres de
soft ne savent pas utiliser jackd directement pour l'audio.
Ceci peut être contourné en disant à ces applications d'utiliser
directement alsa, et en configurant alsa (dans le fichier ~/.asoundrc)
pour qu'il utilise jackd.

Cette seconde solution peut paraître plus compliqué, mais je te la recommande.
Cela évite d'avoir une cascade de daemon pour gérer l'audio.


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#7 09-12-2011 16:19:17

capolino
Membre
Lieu : On Earth
Distrib. : Wheezy (64bit)
Noyau : 3.1
(G)UI : Gnome 3
Inscription : 09-08-2011

Re : [Résolu] Configurer Jackd

C'est bon j'ai reussi à faire marcher Jackd, simplement en tapant ca et sans rien tuer comme processus:

 jackd -d alsa -P hw:0,0


Avec d'autres d'options cela ne marche pas... bizarre... pourtant j'en ai testé pleins des options... j'y comprend rien...

Comme disait je ne sais plus qui : La théorie c'est quand on sait tout mais que rien ne marche, la pratique c'est quand tout fonctionne mais que personne ne sait pourquoi...

Pourtant avec Qjackdctl j'avais bien spécifié hw:0,0 comme interface mais sans succés...
Je donne le lien de la page où j'ai trouvé mon bout de code : Jackaudio.org

Alors oui c'est vrai que ce n'est pas pratique de tout lancer en console, surtout qu'une fois Jackd lancé une simple musique mp3 ne sort plus de  son, donc dans Qjacdctl il ya dans les options,  un script qu'on peut exécuter à son lancement et  quand on le quitte...

Merci de tes réponses... je reposterai une récap pour voir d'où venait le problème réellement...
A+

Hors ligne

Pied de page des forums