Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 18-03-2008 12:26:06

pirlouit
Membre
Distrib. : sid
Noyau : 2.6.35.10-amd64-perso
(G)UI : gnome
Inscription : 18-11-2007

[Résolu] Ma session met 5 min à s'afficher après un upgrade de Lenny

Bonjour,
Tout d'abord, je précise ma modeste config : Duron 850 Mhz, 640 Mo RAM.

Je viens de faire mon premier apt-get upgrade de l'année 2008.
Je regarde la liste : on me propose plein de mise à jour de mes logiciels préférés, tiens SMPlayer est maintenant disponible sous Lenny (je me l'étais procuré dans les dépôts de Sid, enfin un GUI digne de ce nom pour MPlayer), et surtout, ouaaaais, gnome-core passe en version 2.20 (j'avais la 2.14).

Mais problème.
M'étant fait une netinstall allégée autour de gnome-core, j'étais content de mon temps de boot : 40 s pour arriver sur gdm, je tapais mon login/pw et mon bureau s'affichait ensuite en moins de 10 s.
Après l'upgrade, toujours 40 s pour gdm et une fois mon login/pw entré, le bureau met 5 MINUTES 25 SECONDES pour se charger !!! mad
Je précise que je me passe d'un splash-screen, lourd et inutile selon moi.

Une fois sur le bureau, tout marche impeccablement.

Quelqu'un a-t-il rencontré le même problème ?
A quoi cet énorme ralentissement peut-il être dû ?
Le passage à Gnome 2.20 serait-il seul en cause ?

Je vois pas trop comment revenir en arrière, à moins de tout réinstaller en Etch sad

Un conseil ?

Dernière modification par pirlouit (20-03-2008 15:53:15)

Hors ligne

#2 18-03-2008 17:59:00

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : [Résolu] Ma session met 5 min à s'afficher après un upgrade de Lenny

Salut et bienvenue wink

Je ne suis pas avec ma debian là mais en fouinant ptetre un peu dans /var/log/ on devrait sûrement trouver quelque chose.....voir ce qui bloque ou prend du temps...

EDIT: regarde dans /var/log/syslog

Hors ligne

#3 19-03-2008 11:40:13

pirlouit
Membre
Distrib. : sid
Noyau : 2.6.35.10-amd64-perso
(G)UI : gnome
Inscription : 18-11-2007

Re : [Résolu] Ma session met 5 min à s'afficher après un upgrade de Lenny

Salut Palmito et merci pour ta réponse.
J'ai jeté un oeil sur /var/log/syslog ,heu, je pige pas tout...

Voilà où j'en suis :

J'avais donc fait un apt-get upgrade.
On m'a conseillé plutôt apt-get dist-upgrade que je pensais être réservé aux changements de versions (stable -> testing -> Sid) après avoir édité son sources.list.
J'ai donc fait un dist-upgrade (mon sources.list toujours en Lenny) en espérant une "gestion plus intelligente des changements de dépendances dans les nouvelles versions des paquets" qu'avec un simple apt-get upgrade, ainsi qu'une "résolution d'éventuels conflits" qui résoudrait mon problème... ça a pô marché.

Je me suis baladé sur http://bugs.debian.org concernant gdm et gnome-core et je n'ai rien trouvé qui ressemble à mon cas.

J'ai désinstallé --purgé gdm, rebooté, et après avoir tapé startx, j'ai encore attendu 5 min 25 s roll ,ça vient donc pas de gdm.
J'ai désinstallé gnome-core, édité mon sources.list en Etch, réinstallé gnome-core en version 2.14 et c'est toujours aussi looong, ça vient donc pas de gnome-core 2.20.

Et vas-y que je me fume une clope à chaque reboot hmm
Bref, j'ai réinstallé gdm et gnome-core en Lenny.

J'ai ensuite créé un nouvel utilisateur, et là, HOURRA !! pas de problème : la nouvelle session s'affiche en 10 s après identification dans gdm big_smile
Je change d'utilisateur pour revenir à ma session normale : elle met toujours + de 5 min à s'afficher et je vois toujours pas ce qui coince et ce qui a pu se passer au niveau de quel fichier de conf spécifique à ma session lors de l'upgrade mad
J'ai regardé mon fichier /home/$USER/.xsession-errors, je n'ai rien vu qui m'éclaire.
Et comme je t'ai dit, mon /var/log/syslog, c'est un peu du chinois pour moi...

Donc, en résumé : ni les nouvelles versions de gdm et gnome-core, ni ma petite config ne sont en cause, j'ai le strict minimum comme applets sur ma session normale, le boot est satisfaisant (40s), c'est après avoir rentré mon login/pwd dans gdm que je me retrouve devant un écran vierge en attendant longtemps que ma session utilisateur démarre... et je ne sais pas comment tracer ce qui se passe pendant cette période.

Arf

Dernière modification par pirlouit (19-03-2008 14:13:37)

Hors ligne

#4 19-03-2008 14:59:34

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : [Résolu] Ma session met 5 min à s'afficher après un upgrade de Lenny

Salut
L'expérience que tu as faite avec un autre users prouve que cela vient de quelque chose dans ton home, donc oublie le /var/log/syslog.
Il y a certainement dans tes fichiers de conf de gnome un truc que le perturbe, reste a trouver quoi et ou

Je procèderai de façon empirique et sans garantie de succès:
   - Se delloguer,
   - Depuis la console fair un mv sur  les répertoire en .gno de ton home (.gconf, .gnome, .gnome2)

mv .gnome .gnome-bck


- Se relloguer en mesurant le temps, théoriquement il devra recréer le répertoire que tu as mv
   - Si c'est toujours aussi long, remet le fichier d'origine en place après t'être délogguer

rm .gnome
puis
mv .gnome-bck .gnome


- recommencer avec un autre répertoire de gnome
   - Avec un peu de chance, tu tomberas sur le bon (demmarage rapide), il te restera plus qu' a procéder de même avec le contenu de ce répertoire jusqu'a identifier le fichier qui pose soucis

Bon courrage wink


Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#5 20-03-2008 15:51:54

pirlouit
Membre
Distrib. : sid
Noyau : 2.6.35.10-amd64-perso
(G)UI : gnome
Inscription : 18-11-2007

Re : [Résolu] Ma session met 5 min à s'afficher après un upgrade de Lenny

GLOIRE A TOI, Ô FREDDEC !! big_smile

J'ai suivi ta méthode quasi à la lettre (en faisant rmdir -r pour supprimer un dossier plein avant de rétablir l'original soigneusement backupé comme tu me l'avais indiqué ;-)
Et j'ai fini par trouver le fichier qui coinçait :
~/.gconf/desktop/gnome/sound/%gconf.xml

Je sais pas pourquoi ce fichier avait été créé là : le fait de le neutraliser ne modifiait en rien la config de mon son, j'ai pu le virer sans refaire un alsaconf ni rien.

aaaaah... ça fait du bien smile

Et au passage, en fouinant dans les fichier de conf, j'ai appris quelques trucs.

Bref, UN GRAND MERCI pour ta méthode excellemment bien détaillée.

__

Dernière modification par pirlouit (20-03-2008 15:58:56)

Hors ligne

#6 20-03-2008 20:28:19

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : [Résolu] Ma session met 5 min à s'afficher après un upgrade de Lenny

Content d'avoir pu t'aider

Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

Pied de page des forums