Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-02-2012 17:40:09

geronimo57
Membre
Distrib. : Squeeze 6.0.4 stable i386
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 04-02-2012

[Résolu] Problème de configuration wifi atheros Ath9k

Bonjour,

  Je suis passé il y a peu sur Debian, j'accède presque parfaitement bien à Internet via wifi, mais pourtant mon périphérique wifi n'est pas reconnu?!?

Pour tenter de traiter le problème, j'ai installé Wicd et désinstallé Network-manager, j'ai également installé wireless-tools et pourtant ma carte n'est toujours pas reconnue par Wicd ( qui reste non connecté ), est-ce qu'une âme charitable saurait m'aider?

Quelques renseignements :

 root@debian-jojo:/home/joel# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1d:72:db:0d:35  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interruption:16

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:560 (560.0 B)  TX bytes:560 (560.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:17:c4:3b:9a:7f  
          inet adr:192.168.0.11  Bcast:192.168.0.255  Masque:255.255.255.0
          adr inet6: 2a01:e35:8ac7:95d0:217:c4ff:fe3b:9a7f/64 Scope:Global
          adr inet6: fe80::217:c4ff:fe3b:9a7f/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:995 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1018 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:654370 (639.0 KiB)  TX bytes:141489 (138.1 KiB)


root@debian-jojo:/home/joel# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"*************"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: E6:47:63:93:BD:A4  
          Bit Rate=36 Mb/s   Tx-Power=20 dBm  
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:CA94-ACB0-BC
          Power Management:on
          Link Quality=41/70  Signal level=-69 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

pan0      no wireless extensions.

Dernière modification par geronimo57 (05-02-2012 17:33:45)

Hors ligne

#2 04-02-2012 17:55:29

vrms33
Modérateur
Distrib. : stable
(G)UI : LXDE
Inscription : 06-11-2011

Re : [Résolu] Problème de configuration wifi atheros Ath9k


Donnez votre avis ou participez :  projet ebook Debian débutants.

Hors ligne

#3 04-02-2012 18:11:31

geronimo57
Membre
Distrib. : Squeeze 6.0.4 stable i386
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 04-02-2012

Re : [Résolu] Problème de configuration wifi atheros Ath9k

Merci vrms33,

J'ai effectivement déjà tenté de configurer le wifi avec ces deux wikis, ça n'a pas changé grand chose pour ma part : j'ai bien accès à Internet via mon wifi, c'est d'ailleurs par là que je te répond actuellement:o Le problème vient surtout du fait que Wicd ne parviens pas à se connecter ( point d'exclamation sur l'icone près de l'horloge, sur la fenêtre les commentaires non connecté et aucun réseau sans fil détecté ), et je soupçonne que ce soucis m'empêche d'accéder à mes mails avec Evolution

Hors ligne

#4 04-02-2012 18:43:39

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : [Résolu] Problème de configuration wifi atheros Ath9k

wlan0     Link encap:Ethernet  HWaddr 00:17:c4:3b:9a:7f 
          inet adr:192.168.0.11  Bcast:192.168.0.255  Masque:255.255.255.0

s'il y a une adresse IP , ça doit bien être configuré quelque part...

Il ne reste pas une configuration manuelle dans /etc/network/interfaces ? Il ne faut laisser que l'interface0 lo (la boucle locale), ce fichier est prioritaire sur les conf automatiques et pourrait expliquer que wicd refuse de la gérer.

« Un optimiste, explique Raymond Aubrac, n’est pas un être satisfait, content de la situation actuelle. C’est quelqu’un qui pense qu’il peut faire quelque chose qui servira. »

Hors ligne

#5 04-02-2012 18:58:27

geronimo57
Membre
Distrib. : Squeeze 6.0.4 stable i386
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 04-02-2012

Re : [Résolu] Problème de configuration wifi atheros Ath9k

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug wlan0
iface wlan0 inet dhcp
  # wireless-* options are implemented by the wireless-tools package
  wireless-mode managed
  wireless-essid **************
  wireless-key1 *************


Voilà mon fichier interfaces, je devrais changer wlan0 par lo?

Hors ligne

#6 04-02-2012 19:30:51

eol
Membre
Inscription : 03-09-2009

Re : [Résolu] Problème de configuration wifi atheros Ath9k

geronimo57 a écrit :

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug wlan0
iface wlan0 inet dhcp
  # wireless-* options are implemented by the wireless-tools package
  wireless-mode managed
  wireless-essid **************
  wireless-key1 *************


Voilà mon fichier interfaces, je devrais changer wlan0 par lo?


Non, si tu veux faire comme proposé, tu laisses juste

auto lo
inet lo inet loopback


dans le fichier.

Hors ligne

#7 04-02-2012 20:15:39

geronimo57
Membre
Distrib. : Squeeze 6.0.4 stable i386
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 04-02-2012

Re : [Résolu] Problème de configuration wifi atheros Ath9k

Eh non, après relance je n'ai plus Internet, donc je suis revenu en arrière ( vive les backups! ), dans la quête de la vérité je suis allé voir les logs de wicd :

2012/02/04 18:43:53 :: ---------------------------
2012/02/04 18:43:53 :: wicd initializing...
2012/02/04 18:43:53 :: ---------------------------
2012/02/04 18:43:53 :: wicd is version 1.7.0 552
2012/02/04 18:43:53 :: setting backend to external
2012/02/04 18:43:53 :: trying to load backend external
2012/02/04 18:43:53 :: successfully loaded backend external
2012/02/04 18:43:53 :: trying to load backend external
2012/02/04 18:43:53 :: successfully loaded backend external
2012/02/04 18:43:53 :: Couldn't detect a wireless interface.
2012/02/04 18:43:53 :: setting wireless interface None
2012/02/04 18:43:53 :: automatically detected wired interface eth0
2012/02/04 18:43:53 :: setting wired interface eth0
2012/02/04 18:43:53 :: setting wpa driver wext
2012/02/04 18:43:53 :: setting use global dns to False
2012/02/04 18:43:53 :: setting global dns
2012/02/04 18:43:53 :: global dns servers are None None None
2012/02/04 18:43:53 :: domain is None
2012/02/04 18:43:53 :: search domain is None
2012/02/04 18:43:53 :: setting automatically reconnect when connection drops True
2012/02/04 18:43:53 :: Setting dhcp client to 0
2012/02/04 18:43:53 :: Wireless configuration file found...
2012/02/04 18:43:53 :: Wired configuration file found...
2012/02/04 18:43:53 :: chmoding configuration files 0600...
2012/02/04 18:43:53 :: chowning configuration files root:root...
2012/02/04 18:43:53 :: Using wireless interface...
2012/02/04 18:43:53 :: Using wired interface...eth0
2012/02/04 18:43:59 :: Autoconnecting...
2012/02/04 18:44:01 :: No wired connection present, attempting to autoconnect to wireless network
2012/02/04 18:44:01 :: Unable to autoconnect, you'll have to manually connect
2012/02/04 18:44:04 :: Autoconnecting...
2012/02/04 18:44:04 :: No wired connection present, attempting to autoconnect to wireless network
2012/02/04 18:44:04 :: Unable to autoconnect, you'll have to manually connect
2012/02/04 18:44:09 :: Autoconnecting...
2012/02/04 18:44:09 :: No wired connection present, attempting to autoconnect to wireless network
2012/02/04 18:44:09 :: Unable to autoconnect, you'll have to manually connect
2012/02/04 18:44:14 :: Autoconnecting...
2012/02/04 18:44:14 :: No wired connection present, attempting to autoconnect to wireless network
2012/02/04 18:44:14 :: Unable to autoconnect, you'll have to manually connect
2012/02/04 18:55:33 :: Autoconnecting...
2012/02/04 18:55:33 :: No wired connection present, attempting to autoconnect to wireless network
2012/02/04 18:55:33 :: Unable to autoconnect, you'll have to manually connect
2012/02/04 18:55:33 :: Daemon going down, killing wicd-monitor...
2012/02/04 18:55:33 :: Removing PID file...
2012/02/04 18:55:33 :: Shutting down...
2012/02/04 18:55:33 :: Exception KeyError: KeyError(-1220376896,) in <module 'threading' from '/usr/lib/python2.6/threading.pyo'> ignored
2012/02/04 18:56:19 :: ---------------------------
2012/02/04 18:56:19 :: wicd initializing...
2012/02/04 18:56:19 :: ---------------------------
2012/02/04 18:56:19 :: wicd is version 1.7.0 552
2012/02/04 18:56:19 :: setting backend to external
2012/02/04 18:56:19 :: trying to load backend external
2012/02/04 18:56:19 :: successfully loaded backend external
2012/02/04 18:56:19 :: trying to load backend external
2012/02/04 18:56:19 :: successfully loaded backend external
2012/02/04 18:56:19 :: Couldn't detect a wireless interface.
2012/02/04 18:56:19 :: setting wireless interface None
2012/02/04 18:56:19 :: automatically detected wired interface eth0
2012/02/04 18:56:19 :: setting wired interface eth0
2012/02/04 18:56:19 :: setting wpa driver wext
2012/02/04 18:56:19 :: setting use global dns to False
2012/02/04 18:56:19 :: setting global dns
2012/02/04 18:56:19 :: global dns servers are None None None
2012/02/04 18:56:19 :: domain is None
2012/02/04 18:56:19 :: search domain is None
2012/02/04 18:56:19 :: setting automatically reconnect when connection drops True
2012/02/04 18:56:19 :: Setting dhcp client to 0
2012/02/04 18:56:19 :: Wireless configuration file found...
2012/02/04 18:56:19 :: Wired configuration file found...
2012/02/04 18:56:19 :: chmoding configuration files 0600...
2012/02/04 18:56:19 :: chowning configuration files root:root...
2012/02/04 18:56:19 :: Using wireless interface...
2012/02/04 18:56:19 :: Using wired interface...eth0
2012/02/04 18:56:25 :: Autoconnecting...
2012/02/04 18:56:27 :: No wired connection present, attempting to autoconnect to wireless network
2012/02/04 18:56:27 :: Unable to autoconnect, you'll have to manually connect
2012/02/04 18:56:30 :: Autoconnecting...
2012/02/04 18:56:30 :: No wired connection present, attempting to autoconnect to wireless network
2012/02/04 18:56:30 :: Unable to autoconnect, you'll have to manually connect
2012/02/04 18:56:35 :: Autoconnecting...
2012/02/04 18:56:35 :: No wired connection present, attempting to autoconnect to wireless network
2012/02/04 18:56:35 :: Unable to autoconnect, you'll have to manually connect
2012/02/04 18:56:40 :: Autoconnecting...
2012/02/04 18:56:40 :: No wired connection present, attempting to autoconnect to wireless network
2012/02/04 18:56:40 :: Unable to autoconnect, you'll have to manually connect
2012/02/04 19:00:05 :: Autoconnecting...
2012/02/04 19:00:05 :: No wired connection present, attempting to autoconnect to wireless network
2012/02/04 19:00:05 :: Unable to autoconnect, you'll have to manually connect


Ca ne me mène pas très loin perso, alors go dans les configs :

/etc/wicd/wireless-settings.conf ==> Choux blanc, c'est vide!
/etc/wicd/manager-settings.conf :

[Settings]
wireless_interface = None
pref_width = 499
prefer_wired = False
flush_tool = 0
use_global_dns = False
global_dns_dom = None
always_show_wired_interface = False
global_dns_1 = None
global_dns_2 = None
global_dns_3 = None
backend = external
should_verify_ap = 1
link_detect_tool = 0
main_height = 452
dhcp_client = 0
sudo_app = 0
wired_connect_mode = 1
debug_mode = 0
pref_height = 394
wired_interface = eth0
signal_display_type = 0
global_search_dom = None
auto_reconnect = True
main_width = 530
wpa_driver = wext


... HEEEELLLPPP hmm

Hors ligne

#8 04-02-2012 22:00:44

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Problème de configuration wifi atheros Ath9k

Je n'utilise pas le wifi, je ne connais rien au wifi, je hais le wifi, je pulvérise le wifi... (source les tontons flingueurs - Audiard)

Toutefois, si tu utilises wicd, ne faut-il pas que tu conserves network-manager avec ? roll

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#9 04-02-2012 22:07:55

geronimo57
Membre
Distrib. : Squeeze 6.0.4 stable i386
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 04-02-2012

Re : [Résolu] Problème de configuration wifi atheros Ath9k

D'après la plupart des tutos que j'ai lu non... De toute network-manager ne marchait pas mieux d'où mon départ vers wicd

Hors ligne

#10 04-02-2012 22:29:16

Invité-5
Banni(e)

Re : [Résolu] Problème de configuration wifi atheros Ath9k

J'ai ne pas tout lu pour le moment, mais il me semble que j'ai la même carte sur le portable qui fonctionne à merveille (sous stable/Squeeze en plus)

Fais voir ton fichier /etc/apt/sources.list

EDIT :

03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
05:00.0 Ethernet controller: Atheros Communications AR8131 Gigabit Ethernet (rev c0)

Dernière modification par Invité-5 (04-02-2012 22:51:21)

#11 04-02-2012 22:52:18

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [Résolu] Problème de configuration wifi atheros Ath9k

Voici un extrait du manuel de reference Debian: http://www.debian.org/doc/manuals/debia … simplified

5.2.1. Outils graphiques de configuration du réseau

Les documentations officielles de NM et Wicd sous Debian sont fournies respectivement par « /usr/share/doc/network-manager/README.Debian » et « /usr/share/doc/wicd/README.Debian ».

Essentiellement, la configuration réseau pour l’ordinateur de bureau est faite de la manière suivante :

    Rendez l’utilisateur du bureau, par exemple toto, membre du groupe « netdev » à l’aide de la commande suivante (vous pouvez aussi le faire automatiquement à l’aide de D-bus sous les environnements de bureau modernes comme GNOME et KDE) :

    $ sudo adduser toto netdev

    Gardez la configuration de « /etc/network/interfaces » aussi simple que possible comme ce qui suit :

    auto lo
    iface lo inet loopback

    Redémarrez NM ou Wicd de la manière suivante :

    $ sudo /etc/init.d/network-manager restart

    $ sudo /etc/init.d/wicd restart

    Configurez votre réseau à l’aide d'une interface graphique.

[Note]     Note

Afin d'éviter les conflits avec ifupdown, seules les interfaces qui ne sont pas listées dans « /etc/network/interfaces » ou qui ont été configurées avec « auto … » ou « allow-hotplug … » et « iface … inet dhcp » (avec aucune autre option) sont gérées par NM.
[Astuce]     Astuce

Si vous désirez étendre les possibilités de configuration de NM, veuillez récupérer les modules d’extension appropriés et les paquets supplémentaires tels que network-manager-openconnect, network-manager-openvpn-gnome, network-manager-pptp-gnome, mobile-broadband-provider-info, gnome-bluetooth, etc. Il en va de même pour ceux de Wicd.
[Attention]     Attention

Ces outils de configuration automatique peuvent ne pas être compatibles avec des configurations ésotériques de l’ancien ifupdown dans « /etc/network/interfaces » telles que celles se trouvant en Section 5.5, « Configuration de base du réseau avec ifupdown (ancienne) » et Section 5.6, « Configuration réseau avancée avec ifupdown (ancienne) ». Consultez le BTS de network-manager et le BTS de wicd pour les problèmes et les limitations actuels.

Hors ligne

#12 05-02-2012 10:33:25

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] Problème de configuration wifi atheros Ath9k

J'adore les documents "simplifiés". big_smile
N'empêche, il y a juste ce qu'il faut. Merci.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#13 05-02-2012 10:44:06

Invité-5
Banni(e)

Re : [Résolu] Problème de configuration wifi atheros Ath9k

La vie de tous les jours n'est pas si simple. Ceci-dit, tant qu'on ne sait pas quelle branche Debian utilise notre ami geronimo57 cette "affaire" ne pourrait être résolu, malgré les sacro-saints commandes.

Il faudra voir aussi de côté de sa box/routeur etc...

Dernière modification par Invité-5 (05-02-2012 10:58:29)

#14 05-02-2012 13:15:35

geronimo57
Membre
Distrib. : Squeeze 6.0.4 stable i386
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 04-02-2012

Re : [Résolu] Problème de configuration wifi atheros Ath9k

Merci beaucoup deuchdeb pour ce bout de manuel ! Ca me donne une sacrée piste pour continuer à me fracasser sur ce problème avec mes mains tremblantes et mon mal de cheveux.

  Alors je reprend (difficilement) dans l'ordre :

sources.list :

 #

# deb cdrom:[Debian GNU/Linux 6.0.4 _Squeeze_ - Official i386 NETINST Binary-1 20120129-00:42]/ squeeze main

# deb cdrom:[Debian GNU/Linux 6.0.4 _Squeeze_ - Official i386 NETINST Binary-1 20120129-00:42]/ squeeze main

deb http://ftp.u-strasbg.fr/debian/ squeeze main
deb-src http://ftp.u-strasbg.fr/debian/ squeeze main

deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main

# squeeze-updates, previously known as 'volatile'
deb http://ftp.u-strasbg.fr/debian/ squeeze-updates main
deb-src http://ftp.u-strasbg.fr/debian/ squeeze-updates main
deb http://www.debian-multimedia.org squeeze main non-free


Ma branche de debian : squeeze


root@debian-jojo:/etc/apt# uname -a
Linux debian-jojo 2.6.32-5-686 #1 SMP Mon Jan 16 16:04:25 UTC 2012 i686 GNU/Linux


Enfin mon modem routeur/modem, tout ça c'est du free ( freebox wifi )

Voilà, je vous suis le temps de me débarbouiller big_smile

Hors ligne

#15 05-02-2012 13:48:12

Invité-5
Banni(e)

Re : [Résolu] Problème de configuration wifi atheros Ath9k

Je trouve ton fichier /etc/apt/sources.list assez pauvre.

N'hésites pas à consulter =>  http://debian-facile.org/manuel:sources.list-df

As-tu bien configuré ta freebox ?

En plus si tu veux tu peux renseigner ton profil matériel sur le forum

#16 05-02-2012 13:53:05

geronimo57
Membre
Distrib. : Squeeze 6.0.4 stable i386
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 04-02-2012

Re : [Résolu] Problème de configuration wifi atheros Ath9k

D'accord, mon sources.list m'avais posé pas mal de problème pendant l'installation, vu netinst à eu tout le mal du monde à trouver les package, ensuite moi qui est completement neuf dans le circuit j'ai listé tous les miroirs proposé un à un jusqu'à trouver un miroir qui marche : je vais le modifier du coup, puis supression et reinstallation de Wicd ça ne mange pas de pain.

Je vais également renseigner mon profil matériel aussi smile

Edit : Woow, un aptitude update et un safe-upgrade, ça à fait un sacré ménage déjà!

Dernière modification par geronimo57 (05-02-2012 13:59:30)

Hors ligne

#17 05-02-2012 14:09:21

Invité-5
Banni(e)

Re : [Résolu] Problème de configuration wifi atheros Ath9k

À titre personnel j'utilise le serveur de mines Nancy :

deb http://debian.mines.inpl-nancy.fr/debian/ sid main
deb-src http://debian.mines.inpl-nancy.fr/debian/ sid main

deb http://mirror.home-dn.net/debian-multimedia/ sid main
deb-src http://mirror.home-dn.net/debian-multimedia/ sid main


qui n'a jamais failli  wink

N'oublies pas de paramétrer la freebox (l'adresse IP)

#18 05-02-2012 14:13:16

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Problème de configuration wifi atheros Ath9k

Moi celui de la suisse.

Nous pouvons tester les serveurs et voir les plus adaptés à notre position géographique par ce tuto :
http://debian-facile.org/doc:systeme:apt:apt-spy

smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#19 05-02-2012 15:14:24

geronimo57
Membre
Distrib. : Squeeze 6.0.4 stable i386
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 04-02-2012

Re : [Résolu] Problème de configuration wifi atheros Ath9k

Genial cette appli smolski merci!


Edit : Pour info, j'ai mis à jour mes packs, redémarré, désinstallé entièrement wicd avec toutes les dépendances possible + réinstallé, inscrit mon compte utilisateur à netdev comme précisé dans le manuel, redémarrage mais wicd n'est toujours pas connecté...

Dernière modification par geronimo57 (05-02-2012 15:30:56)

Hors ligne

#20 05-02-2012 16:12:44

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : [Résolu] Problème de configuration wifi atheros Ath9k

Yep!

Si wicd ne te donne pas la main, c'est peut être tout simplement parce que quelqu'un d'autre l'a déjà prise.

Commentes ta ligne : allow-hotplug wlan0

# The primary network interface
#allow-hotplug wlan0
iface wlan0 inet dhcp
...


Vérifies avant tout que le daemon wicd est bien activé ici :

cat /etc/defaults/wicd

# Don't start the daemon by default, let the user set it.
# Use "yes" (without quotes) to make /etc/init.d/wicd start the WICD daemon.
START_DAEMON=yes


wicd a une partie service(daemon) et une partie cliente. Si le daemon n'est pas actif, le client est inutile.

@+

Zoroastre.

Hors ligne

#21 05-02-2012 17:12:43

geronimo57
Membre
Distrib. : Squeeze 6.0.4 stable i386
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 04-02-2012

Re : [Résolu] Problème de configuration wifi atheros Ath9k

Merci zoroastre74 ! Malheureusement cette manip m'a mis dans la même sitation qu'en supprimant toutes les lignes

allow-hotplug wlan0
iface wlan0 inet dhcp
    # wireless-* options are implemented by the wireless-tools package
    wireless-mode managed
    wireless-essid **************
    wireless-key1 *************


Donc mon accès internet tiens bien sur ces quelques lignes

Mon daemon est bien activé, et par ailleurs mon compte est reconnu par celui-ci ( paramètré à l'installation de wicd )
roll Mais quelle galère!

Hors ligne

#22 05-02-2012 17:33:20

geronimo57
Membre
Distrib. : Squeeze 6.0.4 stable i386
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 04-02-2012

Re : [Résolu] Problème de configuration wifi atheros Ath9k

Mais quel âne je suis ! Problème résolu, je suis retourné faire un tour sur le fichier de configuration de wicd /etc/wicd/manager-setting.conf :

[Settings]
wireless_interface = None
pref_width = 499
prefer_wired = False
flush_tool = 0
use_global_dns = False
global_dns_dom = None
always_show_wired_interface = False
global_dns_1 = None
global_dns_2 = None
global_dns_3 = None
...


Et j'ai remplacé la ligne

wireless_interface = None


par

wireless_interface = wlan0


et c'est passé comme une lettre à la poste

Mais pourquoi est-ce que la configuration ne s'est pas immédiatement faite avec wlan0 comme périphérique wifi?!?

Bref je remercie les contributeurs pour leurs aide très précieuse!

Hors ligne

#23 05-02-2012 17:54:26

Invité-5
Banni(e)

Re : [Résolu] Problème de configuration wifi atheros Ath9k

Genial

smolski a écrit :

Nous pouvons tester les serveurs et voir les plus adaptés à notre position géographique par ce tuto :
http://debian-facile.org/doc:systeme:apt:apt-spy


Tu peux ouvrir un nouveau topic et nous allons tous participer, j'espére. wink

#24 05-02-2012 17:58:13

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Problème de configuration wifi atheros Ath9k

smolski passe la main à Darien pour le nouveau topic... hop ! big_smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#25 05-02-2012 18:49:34

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [Résolu] Problème de configuration wifi atheros Ath9k

Quelle belle passe, c'est un plaisir ce jeu collectif que l'équipe de Debian facile nous donne à voir.

Tout à fait mon cher Thiérry. lol

Hors ligne

Pied de page des forums