Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-02-2012 16:11:12

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

[Résolu] paquet perl quelle version choisir?

Salut,

Suite à une mise à jour de iceweasel des dépots backports vers la version 10.0.1avec un:

aptitude update
aptitude full-upgrade -s


Il voulait me supprimer pidjin le logiciel de messagerie instantanée et lib... quelque chose.

En fait ma version de perl n'était pas la bonne.

Il voulait la version 5.10.1-17squeeze3 0 et moi j'avais la version 5.10.1-17squeeze2

Mais aptitude ne veux pas changer de version.

Cela vient en fait de mon fichier preferences, enfin je crois.

Security est 980 et Debian à 970 voulant faire passer la sécurité avant tout.

Voici le résultat de apt-cache policy perl

~$ apt-cache policy perl
perl:
  Installé : 5.10.1-17squeeze2
  Candidat : 5.10.1-17squeeze2
 Table de version :
     5.10.1-17squeeze3 0
        970 http://ftp.fr.debian.org/debian/ squeeze/main i386 Packages
 *** 5.10.1-17squeeze2 0
        980 http://security.debian.org/ squeeze/updates/main i386 Packages


La question: puis je mettre security moins haut que Debian ou égal dans mon fichier preferences sans risques?

Et puis deux versions de perl pour la même distribution ne trouvez vous pas ça un peu bizarre?

Dernière modification par deuchdeb (12-02-2012 13:03:27)

Hors ligne

#2 11-02-2012 18:38:12

Invité-5
Banni(e)

Re : [Résolu] paquet perl quelle version choisir?

5.10.1-17squeeze3 fait partie du dépôt squeeze/main

5.10.1-17squeeze2 viens du dépôt squeeze/updates/main

Security est 980 et Debian à 970 voulant faire passer la sécurité avant tout.


Mauvaise idée. Trouvé oû ? Comme ça tu as bloqué la version la plus récente.

Pour l'utiliser exclusivement la branche stable je ne vois pas d'intérêt de fichier /etc/apt/preferences.

P.S. En parlant de perl à l'occasion tu pourrais installer libcrypt-ciphersaber-perl. Sait-on jamais.

Amicalement. Darien

#3 12-02-2012 01:23:18

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [Résolu] paquet perl quelle version choisir?

Merci pour le renseignement.

j'ai trouvé ça nul part juste une intuition qu'il valait mieux privilégier la sécurité et depuis plusieurs années c'est la 1ere fois que j'ai ce problème

Le fichier preferences était à l'origine pour les dépôts backports qui n'étaient pas officiels et à 200 d'origine et il est resté .
Il y avait aussi le problème avec vlc et le dépôt Multimedia pour lui préférer le paquet Debian.
Et maintenant il y a Debian Mozilla.



Package: *
Pin: release o=Debian,a=stable,l=Debian-Security
Pin-priority: 980


Package: *
Pin: release o=Debian,a=stable,l=Debian
Pin-priority: 970


Package: *
Pin: release o=Unofficial Multimedia Packages,a=stable
Pin-priority: 480

Package: *
Pin: release o=Debian Mozilla Team,l=Debian Mozilla Team
Pin-priority: 200

Package: *
Pin: release o=Debian Backports,l=Debian Backports
Pin-priority: 200


Est-ce utile?

Dernière modification par deuchdeb (12-02-2012 01:26:04)

Hors ligne

#4 12-02-2012 01:42:02

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [Résolu] paquet perl quelle version choisir?

Finalement j'ai résolu le problème en mettant la même valeur à Debian-Security et Debian (980 aux deux)

Toutes les mises à jours ont été faites sans que aptitude ne bronche.

Mais est-ce qu'un fichier preferences est utile dans mon cas.

Hors ligne

#5 12-02-2012 08:32:10

Invité-5
Banni(e)

Re : [Résolu] paquet perl quelle version choisir?

Salut deuchdeb,

Je veux essayer de m'appliquer pour répondre à la totalité des questions que tu te pose.

Premièrement, tu pourrais me faire plaisir en oubliant Lenny pour toujours, merci bcp. wink

Mais est-ce qu'un fichier preferences est utile dans mon cas.


Parfois le dépôt squeeze/updates/main = securité prend du retard  pour divers raisons (passons)

Pour combler cet "oubli" le dépôt squeeze/main vient à son secours d'oû inutilité de fichier /etc/apt/preferences sous une seule branche (stable/Squeeze dans ton cas)

Le dépôt multimedia ne pose strictement aucun problème sous Squeeze (contrairement à Lenny)

Le dépôt squeeze-backports est à 100 par defaut (je ne vois pas d'utilité de monter à 200)

Mozilla peut rester à 500 quand tu supprimeras ton fichier preferences et la mise à jour c'est fera automatiquement pour Iceweasel y compris la prise en charge de la langue française (tout en sachant que tu maîtrise parfaitement anglais)

Pour résumer, nous disons donc, au revoir le fichier /etc/apt/preferences !

Le temps de changer ordinateur, je vais poster plus bas le fichier apt-cache policy existant sur ordi de mon épouse qui fonctionne sans le moindre problème et sans preferences bien sûr smile

#6 12-02-2012 08:39:07

Invité-5
Banni(e)

Re : [Résolu] paquet perl quelle version choisir?

Chose promise, chose due. Pour comparer (le seul paquet non-free = flashplayer vient de multimedia)

hhh@Aline:~$ apt-cache policy
Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 500 http://mozilla.debian.net/ squeeze-backports/iceweasel-release amd64 Packages
     release o=Debian Mozilla Team,a=squeeze-backports,n=squeeze-backports,l=Debian Mozilla Team,c=iceweasel-release
     origin mozilla.debian.net
 500 http://www.debian-multimedia.org/ squeeze/non-free amd64 Packages
     release v=6.0,o=Unofficial Multimedia Packages,a=stable,n=squeeze,l=Unofficial Multimedia Packages,c=non-free
     origin www.debian-multimedia.org
 500 http://www.debian-multimedia.org/ squeeze/main amd64 Packages
     release v=6.0,o=Unofficial Multimedia Packages,a=stable,n=squeeze,l=Unofficial Multimedia Packages,c=main
     origin www.debian-multimedia.org
 100 http://backports.debian.org/debian-backports/ squeeze-backports/main amd64 Packages
     release o=Debian Backports,a=squeeze-backports,n=squeeze-backports,l=Debian Backports,c=main
     origin backports.debian.org
 500 http://debian.mines.inpl-nancy.fr/debian/ squeeze-proposed-updates/main Translation-en
 500 http://debian.mines.inpl-nancy.fr/debian/ squeeze-proposed-updates/main amd64 Packages
     release v=6.0-updates,o=Debian,a=proposed-updates,n=squeeze-proposed-updates,l=Debian,c=main
     origin debian.mines.inpl-nancy.fr
 500 http://debian.mines.inpl-nancy.fr/debian/ squeeze-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=squeeze-updates,l=Debian,c=main
     origin debian.mines.inpl-nancy.fr
 500 http://security.debian.org/ squeeze/updates/main amd64 Packages
     release v=6.0,o=Debian,a=stable,n=squeeze,l=Debian-Security,c=main
     origin security.debian.org
 500 http://debian.mines.inpl-nancy.fr/debian/ squeeze/main Translation-fr
 500 http://debian.mines.inpl-nancy.fr/debian/ squeeze/main amd64 Packages
     release v=6.0.4,o=Debian,a=stable,n=squeeze,l=Debian,c=main
     origin debian.mines.inpl-nancy.fr
Paquets étiquetés :

#7 12-02-2012 12:56:33

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [Résolu] paquet perl quelle version choisir?

Voilà une réponse claire et précise.

Adieu preferences. cool

Merci Darien pour tes réponses

Résolu donc et sans le mais. smile

je suis loin de maîtriser parfaitement l'anglais mais mais la traduction du wiki Debian est le seul truc que j'ai trouver pour aider Debian et rendre un peu de tout ce qu'ils nous donnent.

Alors ça me prend souvent du temps et Harrap's est mon ami.

Mais j'aime ça alors pas de problèmes.

Dernière modification par deuchdeb (12-02-2012 13:02:55)

Hors ligne

Pied de page des forums