Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 18-02-2012 09:59:54

Hansa
Membre
Distrib. : Squeeze
(G)UI : Gnome
Inscription : 27-06-2009

[abandonné] demande d'install d'un paquet deja installé

Bonjour

Après une installation de Lenny sur une machine virtuelle, une config des dépots... j'ai voulu installer flashpugin-nonfree. J'ai le message d'erreur suivant :

flashplugin-nonfree:
  Dépend : libgtk2.0-0 (>=2.14) mais 2.12.12-1~lenny2 doit être installé

Or la version de libgtk demandé est bien installée !

Que faire ?

Par avance merci

Hansa

Dernière modification par Hansa (12-05-2012 11:43:11)


Tout le monde disait que c'était imossible. Un jour, il est arrivé quelqu'un qui ne le savait pas... et qui a réussit.

Hors ligne

#2 18-02-2012 20:45:21

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [abandonné] demande d'install d'un paquet deja installé

Salut

1) Comme mentionné dans les News, le suivi en sécurité de Lenny est arrivé à son terme. Aussi, il devient important, voir essentiel, de faire la migration vers la stable actuelle soit Squeeze.

2) Le paquet flashplugin-nonfree que tu tentes d'installer est celui présent dans lenny-backports. La version du paquet libgtk2.0-0 dont il a besoin se trouve elle aussi dans ce dépôt. As-tu un fichier /etc/apt/preferences ? La commande

apt-cache policy


te donnera aussi la priorité de ce dépôt. Ton problème vient du fait que ton gestionnaire de paquets ne va pas chercher la version présente dans lenny-backports mais celle dans le dépôt lenny.


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#3 19-02-2012 19:50:55

Hansa
Membre
Distrib. : Squeeze
(G)UI : Gnome
Inscription : 27-06-2009

Re : [abandonné] demande d'install d'un paquet deja installé

bonjour Martin,

Je te remercie pour ta réponse. Je tiens à préciser que c'est une install virtualisé. Cependant, j'aurais du télécharger squeeze... en effet.

pour ce qui est de mon problème, je n'ai pas de fichier /etc/apt/preferences.

est-ce qu'une réinstallation pur et simple (en installant squeeze cette fois-ci) résolverait le problème ?

Merci

Hansa

Tout le monde disait que c'était imossible. Un jour, il est arrivé quelqu'un qui ne le savait pas... et qui a réussit.

Hors ligne

#4 19-02-2012 22:22:15

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [abandonné] demande d'install d'un paquet deja installé

Salut

J'avais passé un peu rapidement sur le fait que tu as fait ton installation dans une machine virtuelle, un petit oublie donc.

Outre le fait qu'il est préférable d'utiliser squeeze, vu que lenny n'est plus supportée, ton problème vient de l'absence du fichier preferences. Dans le cas de lenny-backports, la priorité par défaut de ce dépôt est de 1. Il faut donc "forcer", si on peut dire, l'installation des paquets. On fera donc par exemple un :

aptitude -t lenny-backports install "package"


On trouve dans le wiki des explications sur les dépôts lenny-backports

Il y a aussi la page des instructions sur le site Debian Backports

En bref, pas besoin de réinstaller pour arriver à installer ton paquet flashplugin-nonfree, mais il vaut mieux utiliser Squeeze maintenant.


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#5 12-05-2012 11:42:50

Hansa
Membre
Distrib. : Squeeze
(G)UI : Gnome
Inscription : 27-06-2009

Re : [abandonné] demande d'install d'un paquet deja installé

Je reviens après un long déplacement. Le problème n'a plus lieu d'être puisque le PC hote à rendu l'âme...

Merci pour tout.

Hansa

Tout le monde disait que c'était imossible. Un jour, il est arrivé quelqu'un qui ne le savait pas... et qui a réussit.

Hors ligne

Pied de page des forums