Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-02-2012 16:18:39

fowl
Membre
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-powerpc
(G)UI : LXDE
Inscription : 28-02-2012

[Résolu] Conflit avec les locales.

Bonjour,
Afin de reconfiguer les locales, j'ai édité en root, /etc/locale.gen en commentant fr_FR pour le remplacer par les locales fr_CA en les décommentant toutes. Afin de faire appliquer ce changement, j'ai fait

locales-gen


.
Cependant, si je tape

locales


, voici ce que j'obtiens:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=fr_FR.UTF-8
LANGUAGE=
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=


Est-ce normal? Avez vous une idée du problème?

Dernière modification par fowl (29-02-2012 05:05:32)

Hors ligne

#2 28-02-2012 16:29:14

hector
Membre
Distrib. : Debian Testing/Sid
Noyau : 4.7.0-1-amd64
(G)UI : KDE Plasma 5
Inscription : 13-12-2011

Re : [Résolu] Conflit avec les locales.

Bonjour,

Pour reconfigurer les locales je fais plutôt :

# dpkg-reconfigure locales -plow


en ne cochant que celles désirées.

http://debian-facile.org/doc:systeme:ap … os_locales

Dernière modification par hector (28-02-2012 16:36:01)

Hors ligne

#3 29-02-2012 01:53:43

fowl
Membre
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-powerpc
(G)UI : LXDE
Inscription : 28-02-2012

Re : [Résolu] Conflit avec les locales.

En allant voir, c'est bien les 2 locales fr_CA qui étaient sélectionnées.
En se connectant en root, j'ai le message suivant:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
  LANGUAGE = "fr_FR:fr",
  LC_ALL = (unset),
  LANG = "fr_FR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

Dernière modification par fowl (29-02-2012 05:03:58)

Hors ligne

#4 29-02-2012 05:04:46

fowl
Membre
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-powerpc
(G)UI : LXDE
Inscription : 28-02-2012

Re : [Résolu] Conflit avec les locales.

En redémarrant, tout fonctionne à présent.

Hors ligne

Pied de page des forums