Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-02-2012 21:21:18

Yagermoe
Membre
Lieu : Entre Lyon et Valence
Distrib. : Jessie/Stretch
Noyau : 3.16.0-4-amd64/4.0-amd64
(G)UI : Openbox+Tint2/Xcfe
Inscription : 15-12-2011

[Résolu] .gtk-bookmarks : raccourcis qui disparaissent

Salut salut,
Dans .gtk-bookmarks, j'ai créé 2 raccourcis vers un NAS et un vers une freebox. Ca donne un truc du genre :

smb://nom_du_nas/un-dossier/
smb://nom_du_nas/autre_dossier/
ftp://freebox@hd1.freebox.fr/

Le problème, c'est que de temps à autre, ces raccourcis disparaissent du fichier .gtk-bookmarks, et je ne sais pas pourquoi !

J'utilise normalement Thunar. Mais j'ai aussi PCmanFM dans un coin. Si les raccourcis sont dans .gtk-bookmarks:

Quand j'ouvre PCmanFM, j'ai les 3 raccourcis dans le panneau latéral, que les cibles soient montées ou pas.
Dans Thunar, les raccourcis ne sont pas visibles. Il faut que j'ouvre les cibles pour que les raccourcis apparaissent quand je relance Thunar.

Je n'ai aucun problème pour accéder au NAS comme à la freebox.

La question(s) est donc : pourquoi est-ce donc que les raccourcis disparaissent-ils ? pourquoi est-ce donc que je ne les vois pas dans Thunar quand ils n'ont pas encore disparus ?

Merci, à+

Dernière modification par Yagermoe (12-03-2013 22:03:05)


Asus M5A97 - Phenom X4 965 - 8 Go - Radeon HD6850
"Ceux qui ne savent rien en savent toujours autant que ceux qui n'en savent pas plus qu'eux" (P. Dac)

Hors ligne

#2 29-02-2012 21:42:33

dbkblk
Membre
Distrib. : Debian Wheezy 64bits
Noyau : 3.2
(G)UI : Gnome 3.2
Inscription : 24-10-2010

Re : [Résolu] .gtk-bookmarks : raccourcis qui disparaissent

Ca sert à quoi gtk-bookmarks ? c'est un dossier qui centralise les liens ?

M. Gandhi: "C'est une erreur de croire nécessairement faux ce qu'on ne comprend pas."
C'est quoi ce bordel ?

Hors ligne

#3 29-02-2012 22:31:42

Yagermoe
Membre
Lieu : Entre Lyon et Valence
Distrib. : Jessie/Stretch
Noyau : 3.16.0-4-amd64/4.0-amd64
(G)UI : Openbox+Tint2/Xcfe
Inscription : 15-12-2011

Re : [Résolu] .gtk-bookmarks : raccourcis qui disparaissent

Salut

dbkblk a écrit :

Ca sert à quoi gtk-bookmarks ? c'est un dossier qui centralise les liens ?


Oui, c'est ça. Si tu crées un signet dans Thunar, tu le retrouves dans ce fichier sous la forme :

file:///media/nom_partition nom_signet pour une partition (Les partitions apparaissent comme des dossiers, pas comme des disques) ou
file:///home/nom_user/nom_dossier nom_signet pour un dossier

Et réciproquement si tu ajoutes la ligne dans le fichier, tu retrouves ton disque ou dossier dans le panneau latéral.
C'est aussi utilisé par PCmanFM, peut-être par d'autres aussi.

A+

Edit : Plus exactement, c'est un fichier caché dans le dossier /home/user

Dernière modification par Yagermoe (01-03-2012 00:20:28)


Asus M5A97 - Phenom X4 965 - 8 Go - Radeon HD6850
"Ceux qui ne savent rien en savent toujours autant que ceux qui n'en savent pas plus qu'eux" (P. Dac)

Hors ligne

#4 01-03-2012 10:03:33

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] .gtk-bookmarks : raccourcis qui disparaissent

A tout hasard, peut-être que Thunar et PCManFM n'utilisent pas le même monteur ?

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#5 01-03-2012 21:35:35

Yagermoe
Membre
Lieu : Entre Lyon et Valence
Distrib. : Jessie/Stretch
Noyau : 3.16.0-4-amd64/4.0-amd64
(G)UI : Openbox+Tint2/Xcfe
Inscription : 15-12-2011

Re : [Résolu] .gtk-bookmarks : raccourcis qui disparaissent

Salut,

paskal a écrit :

A tout hasard, peut-être que Thunar et PCManFM n'utilisent pas le même monteur ?


Peut-être bien, je n'en sais strictement rien et je n'ai rien trouvé à ce sujet.
En tout cas ils utilisent tous les 2 le même fichier pour les signets.
Merci, à+


Asus M5A97 - Phenom X4 965 - 8 Go - Radeon HD6850
"Ceux qui ne savent rien en savent toujours autant que ceux qui n'en savent pas plus qu'eux" (P. Dac)

Hors ligne

#6 02-03-2012 13:02:22

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] .gtk-bookmarks : raccourcis qui disparaissent

J'ai peut-être une piste.

Quand un utilisateur fait un montage de partition, il devient propriétaire exclusif du point de montage dans /media : le groupe et les autres n'ont aucune autorisation, même pas de lecture.
Du coup, dans le PCManFM d'un autre utilisateur, la partition n'est plus affichée dans la partie supérieure du panneau des raccourcis.

Il est vrai que cette partie supérieure n'est pas en relation avec .gtk-bookmarks (c'est peut-être réglé par un autre script ?), mais le comportement que tu décris pourrait être dû au même mécanisme.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#7 02-03-2012 19:07:26

Yagermoe
Membre
Lieu : Entre Lyon et Valence
Distrib. : Jessie/Stretch
Noyau : 3.16.0-4-amd64/4.0-amd64
(G)UI : Openbox+Tint2/Xcfe
Inscription : 15-12-2011

Re : [Résolu] .gtk-bookmarks : raccourcis qui disparaissent

Salut

paskal a écrit :

J'ai peut-être une piste.


C'est peut-être une piste, effectivement, mais je ne sais pas trop quoi chercher dans ce sens. Je pense quand même que ce n'est pas un problème de montage.

En début de session, sans avoir encore rien fait, je lance Thunar. Dans le menu, je fais "Aller à", "Réseau", et là, je vois bien le NAS et je peux accéder au contenu sans problème.
Si j'ai ouvert le dossier correspondant au lien dans .gtk-bookmarks, que je ferme Thunar, et que je l'ouvre à nouveau, j'ai bien le signet dans le panneau latéral, et j'ai toujours l'accès.

C'est vrai que les autres liens qui apparaissent tout le temps correspondent à des partitions internes que je monte dans le fstab. Peut-être que Thunar ne prends pas en compte ce qui concerne les partitions non-montées, alors que PCmanFM le fait. (je ne monte pas les partitions réseau automatiquement, le nas est éteint de temps à autre).

J'ai contourné le problème en utilisant le menu Openbox, ça marche très bien. Mais c'est un peu bête d'avoir Thunar ouvert et d'avoir à le ré-ouvrir pour avoir l'accès.

Et ça n'explique pas pourquoi les liens disparaissent de temps à autre ?

A+


Asus M5A97 - Phenom X4 965 - 8 Go - Radeon HD6850
"Ceux qui ne savent rien en savent toujours autant que ceux qui n'en savent pas plus qu'eux" (P. Dac)

Hors ligne

#8 05-03-2012 21:53:40

Yagermoe
Membre
Lieu : Entre Lyon et Valence
Distrib. : Jessie/Stretch
Noyau : 3.16.0-4-amd64/4.0-amd64
(G)UI : Openbox+Tint2/Xcfe
Inscription : 15-12-2011

Re : [Résolu] .gtk-bookmarks : raccourcis qui disparaissent

Bonjour,
L'explication du problème des signets qui n'apparaissent pas dans Thunar se trouve à mon avis ici, à la rubrique "Nouveau panneau latéral pour Thunar", avec un lien vers cette page en anglais. L'article commence à dater, les dév doivent s'arracher les cheveux, je vais donc attendre les prochaines mises à jour.
Quant au problème de signets qui disparaissent, je pense que c'est dû à l'utilisation conjointe de Thunar et de PCmanFM à des fins de tests. Les signets sont toujours là depuis que je n'utilise que Thunar.
Problème non réglé, donc, mais en attente d'évolution.
Salut.

Asus M5A97 - Phenom X4 965 - 8 Go - Radeon HD6850
"Ceux qui ne savent rien en savent toujours autant que ceux qui n'en savent pas plus qu'eux" (P. Dac)

Hors ligne

#9 12-03-2013 22:02:39

Yagermoe
Membre
Lieu : Entre Lyon et Valence
Distrib. : Jessie/Stretch
Noyau : 3.16.0-4-amd64/4.0-amd64
(G)UI : Openbox+Tint2/Xcfe
Inscription : 15-12-2011

Re : [Résolu] .gtk-bookmarks : raccourcis qui disparaissent

Salut,
Je profite d'avoir 5 minutes (ha là là, quelle vie qu'on vit...) pour déterrer ce fil, que je passe en résolu.
Parce que ce problème l'est. Les raccourcis vers des éléments réseaux fonctionnent dans Thunar et sont persistants. Et pour peu que gvfs-fuse soit installé, c'est un bonheur d'aller sur son nas.
Bon, on n'a rien sans rien : Ca marche avec la version 1.6.2 de Thunar, qui est dans le dépôt "expérimental".
Cette version marche très bien, pas eu de bogue à ce jour.
@+

Asus M5A97 - Phenom X4 965 - 8 Go - Radeon HD6850
"Ceux qui ne savent rien en savent toujours autant que ceux qui n'en savent pas plus qu'eux" (P. Dac)

Hors ligne

Pied de page des forums