Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-03-2012 20:13:07

huit
Membre
Distrib. : Satable + Dépots Backport & Multimédia main
Noyau : 2.6.32-5-686
(G)UI : KDE 4.4.5
Inscription : 01-03-2012

[Résolu] PB mise à jour iceweasel 3.5 ver 10 depot mozilla.debain bpo

Bonjour à tous,

Petit problème de mise à jour de iceweasel sur debian stable.
(ce qui me surprend beaucoup c'est qu'apparemment je suis le seul à le rencontré ... ou pas le seul lien trouvé en rapport avec mon PB c'est ce lien sur pastbin : http://pastebin.com/jVB6Kn1s qui le reprend justement)

Je viens juste d'installer debian stable dans une machine virtuel pour découvrir la distribution. J'ai tout naturellement voulut mettre à jour iceweasel de la version 3.5 à la 10 pour cela j'ai suivi les explications indiquées sur cette page: http://debian-facile.org/logiciel:iceweasel

Dans le doute voici mon source list :

#

# deb cdrom:[Debian GNU/Linux 6.0.4 _Squeeze_ - Official i386 NETINST Binary-1 20120129-00:42]/ squeeze main

#deb cdrom:[Debian GNU/Linux 6.0.4 _Squeeze_ - Official i386 NETINST Binary-1 20120129-00:42]/ squeeze main

deb http://ftp.fr.debian.org/debian/ squeeze main
deb-src http://ftp.fr.debian.org/debian/ squeeze main

deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main

# squeeze-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ squeeze-updates main
deb-src http://ftp.fr.debian.org/debian/ squeeze-updates main

# Dépot backpot
deb http://backports.debian.org/debian-backports squeeze-backports main

# Dépôt mozilla debian
deb http://mozilla.debian.net/ squeeze-backports iceweasel-release

# Dépôt multimédia
deb http://www.debian-multimedia.org squeeze main


Comme indiqué dans le wiki j'ai complètement désinstallé iceweasel et son paquet linguistique.
J'ai mis à jour ma liste des paquets puis j'ai voulut installer iceweasel avec aptitude, mais voila à cause d'un problème de dépendance il veut me virer la moitié de mon système pour pouvoir installer iceweasel. Problème de dépendance causé par xulrunner-10.0  avec  libnss3-ld et libpixman-1-0, je pessais pourtant que les dépôt "backports" étaient censés gérer ce genre de désagrément...

La sortie de aptitude vous en dira bien plus :

# aptitude install iceweasel
Les NOUVEAUX paquets suivants vont être installés :                                                                                                                                            
  iceweasel libmozjs10d{a} libvpx1{a} xulrunner-10.0{ab}                                                                                                                                      
Les paquets suivants seront ENLEVÉS :                                                                                                                                                          
  libxcb-render-util0{u}                                                                                                                                                                      
Les paquets suivants seront mis à jour :                                                                                                                                                      
  libcairo2{b}                                                                                                                                                                                
1 paquets mis à jour, 4 nouvellement installés, 1 à enlever et 0 non mis à jour.                                                                                                              
Il est nécessaire de télécharger 15,7 Mo d'archives. Après dépaquetage, 32,1 Mo seront utilisés.                                                                                              
Les paquets suivants ont des dépendances non satisfaites :                                                                                                                                    
  libcairo2: Dépend: libpixman-1-0 (>= 0.18.0) mais 0.16.4-1 est installé.                                                                                                                    
  xulrunner-10.0: Dépend: libnss3-1d (>= 3.13.1) mais 3.12.8-1+squeeze4 est installé.                                                                                                          
                  Dépend: libpixman-1-0 (>= 0.18.0) mais 0.16.4-1 est installé.                                                                                                                
Les actions suivantes permettront de résoudre ces dépendances :                                                                                                                                
                                                                                                                                                                                               
       Supprimer les paquets suivants :                                                                                                                                                        
1)       akregator                                                                                                                                                                            
2)       ark                                                                                                                                                                                  
3)       browser-plugin-gnash                                                                                                                                                                  
4)       desktop-base                                                                                                                                                                          
5)       dolphin                                                                                                                                                                              
6)       dragonplayer                                                                                                                                                                          
7)       gcj-4.4-jre                                                                                                                                                                          
8)       gcj-jre                                                                                                                                                                              
9)       gimp                                                                                                                                          
10)      gnash                                                                                                                                        
11)      gnash-common                                                                                                                                  
12)      gnome-icon-theme                                                                                                                              
13)      gnupg-agent                                                                                                                                  
14)      gnupg2                                                                                                                                        
15)      google-gadgets-qt                                                                                                                            
16)      google-gadgets-xul                                                                                                                            
17)      gstreamer0.10-plugins-bad                                                                                                                    
18)      gwenview                                                                                                                                      
19)      juk                                                                                                                                          
20)      k3b                                                                                                                                          
21)      k3b-i18n                                                                                                                                      
22)      kaddressbook                                                                                                                                  
23)      kappfinder                                                                                                                                    
24)      kate                                                                                                                                          
25)      kcalc                                                                                                                                        
26)      kde-plasma-desktop                                                                                                                            
27)      kde-standard                                                                                                                                  
28)      kde-window-manager                                                                                                                            
29)      kdebase-apps                                                                                                                                  
30)      kdebase-bin                                                                                                                                  
31)      kdebase-runtime                                                                                                                              
32)      kdebase-workspace                                                                                                                            
33)      kdebase-workspace-bin                                                                                                                        
34)      kdepasswd                                                                                                                                    
35)      kdepim-runtime                                                                                                                                
36)      kdeplasma-addons                                                                                                                              
37)      kdesudo                                                                                                                                      
38)      kdm                                                                                                                                          
39)      kerneloops                                                                                                                                    
40)      kfind                                                                                                                                        
41)      khelpcenter4                                                                                                                                  
42)      kinfocenter                                                                                                                                  
43)      klipper                                                                                                                                      
44)      kmail                                                                                                                                        
45)      kmix                                                                                                                                          
46)      knm-runtime                                                                                                                                  
47)      knotes                                                                                                                                        
48)      konq-plugins                                                                                                                                  
49)      konqueror                                                                                                                                    
50)      konqueror-nsplugins                                                                                                                          
51)      konsole                                                                                                                                      
52)      kopete                                                                                                                                        
53)      korganizer                                                                                                                                    
54)      kscreensaver                                                                                                                                  
55)      kscreensaver-xsavers                                                                                                                          
56)      ksnapshot                                                                                                                                    
57)      ksysguard                                                                                                                                    
58)      kwalletmanager                                                                                                                                
59)      kwrite                                                                                                                                        
60)      libakonadi-contact4                                                                                                                          
61)      libbonoboui2-0                                                                                                                                
62)      libcairo2                                                                                                                                    
63)      libcanberra-gtk-module                                                                                                                        
64)      libcanberra-gtk0                                                                                                                              
65)      libgail18                                                                                                                                    
66)      libgcj10-awt                                                                                                                                  
67)      libgegl-0.0-0                                                                                                                                
68)      libgimp2.0                                                                                                                                    
69)      libglade2-0                                                                                                                                  
70)      libgnomecanvas2-0                                                                                                                            
71)      libgnomeui-0                                                                                                                                  
72)      libgraphicsmagick3                                                                                                                            
73)      libgtk2.0-0                                                                                                                                  
74)      libgtk2.0-bin                                                                                                                                
75)      libgtkglext1                                                                                                                                  
76)      libgvc5                                                                                                                                      
77)      libhsqldb-java                                                                                                                                
78)      libhsqldb-java-gcj                                                                                                                            
79)      libk3b6                                                                                                                                      
80)      libk3b6-extracodecs                                                                                                                          
81)      libkcddb4                                                                                                                                    
82)      libkde4-ruby1.8                                                                                                                              
83)      libkdepim4                                                                                                                                    
84)      libkonq5                                                                                                                                      
85)      libkopete4                                                                                                                                    
86)      libmagickcore3-extra                                                                                                                          
87)      libmessagelist4                                                                                                                              
88)      libnotify1                                                                                                                                    
89)      libokularcore1                                                                                                                                
90)      libpango1.0-0                                                                                                                                
91)      libplasma-ruby                                                                                                                                
92)      libplasma-ruby1.8                                                                                                                            
93)      libpoppler-glib4                                                                                                                              
94)      libqt4-ruby1.8                                                                                                                                
95)      librsvg2-2                                                                                                                                    
96)      librsvg2-common                                                                                                                              
97)      libscim8c2a                                                                                                                                  
98)      libsmokekdecore4-3                                                                                                                            
99)      libsmokekdeui4-3                                                                                                                              
100)     libsmokekfile3                                                                                                                                
101)     libsmokekhtml3                                                                                                                                
102)     libsmokekio3                                                                                                                                  
103)     libsmokeknewstuff2-3                                                                                                                          
104)     libsmokeknewstuff3-3                                                                                                                          
105)     libsmokekparts3                                                                                                                              
106)     libsmokektexteditor3                                                                                                                          
107)     libsmokekutils3                                                                                                                              
108)     libsmokenepomuk3                                                                                                                              
109)     libsmokephonon3                                                                                                                              
110)     libsmokeplasma3                                                                                                                              
111)     libwebkit-1.0-2                                                                                                                              
112)     libwmf0.2-7                                                                                                                                  
113)     libwnck22                                                                                                                                    
114)     libxine1                                                                                                                                      
115)     libxine1-misc-plugins                                                                                                                        
116)     libxine1-plugins                                                                                                                              
117)     network-manager-kde                                                                                                                          
118)     notification-daemon                                                                                                                          
119)     okular                                                                                                                                        
120)     openoffice.org                                                                                                                                
121)     openoffice.org-base                                                                                                                          
122)     openoffice.org-base-core                                                                                                                      
123)     openoffice.org-calc                                                                                                                          
124)     openoffice.org-common                                                                                                                        
125)     openoffice.org-core                                                                                                                          
126)     openoffice.org-draw                                                                                                                          
127)     openoffice.org-emailmerge                                                                                                                    
128)     openoffice.org-filter-binfilter                                                                                                              
129)     openoffice.org-filter-mobiledev                                                                                                              
130)     openoffice.org-gcj                                                                                                                            
131)     openoffice.org-help-en-us                                                                                                                    
132)     openoffice.org-help-fr                                                                                                                        
133)     openoffice.org-impress                                                                                                                        
134)     openoffice.org-java-common                                                                                                                    
135)     openoffice.org-kde                                                                                                                            
136)     openoffice.org-math                                                                                                                          
137)     openoffice.org-officebean                                                                                                                    
138)     openoffice.org-report-builder-bin                                                                                                            
139)     openoffice.org-style-galaxy                                                                                                                  
140)     openoffice.org-style-oxygen                                                                                                                  
141)     openoffice.org-thesaurus-en-us                                                                                                                
142)     openoffice.org-thesaurus-fr                                                                                                                  
143)     openoffice.org-writer                                                                                                                        
144)     phonon                                                                                                                                        
145)     phonon-backend-xine                                                                                                                          
146)     pinentry-gtk2                                                                                                                                
147)     plasma-dataengines-workspace                                                                                                                  
148)     plasma-desktop                                                                                                                                
149)     plasma-runners-addons                                                                                                                        
150)     plasma-scriptengine-googlegadgets                                                                                                            
151)     plasma-scriptengine-python                                                                                                                    
152)     plasma-scriptengine-ruby                                                                                                                      
153)     plasma-scriptengine-superkaramba                                                                                                              
154)     plasma-scriptengines                                                                                                                          
155)     plasma-widget-folderview                                                                                                                      
156)     plasma-widget-lancelot                                                                                                                        
157)     plasma-widgets-addons                                                                                                                        
158)     plasma-widgets-workspace                                                                                                                      
159)     policykit-1-gnome                                                                                                                            
160)     polkit-kde-1                                                                                                                                  
161)     python-cairo                                                                                                                                  
162)     python-glade2                                                                                                                                
163)     python-gnome2                                                                                                                                
164)     python-gtk2                                                                                                                                  
165)     python-kde4                                                                                                                                  
166)     python-notify                                                                                                                                
167)     python-uno                                                                                                                                    
168)     sweeper                                                                                                                                      
169)     system-config-printer                                                                                                                        
170)     systemsettings                                                                                                                                
171)     xscreensaver                                                                                                                                  
172)     xscreensaver-data                                                                                                                            
173)     xscreensaver-data-extra                                                                                                                      
174)     xscreensaver-gl                                                                                                                              
175)     xscreensaver-gl-extra                                                                                                                        
176)     xscreensaver-screensaver-bsod                                                                                                                
177)     xulrunner-1.9.1                                                                                                                              

       Conserver les paquets suivants dans leur version actuelle :                                                                                    
178)     iceweasel [Non installé]                                                                                                                      
179)     xulrunner-10.0 [Non installé]                                                                                                                

       Laisser les dépendances suivantes non satisfaites :                                                                                            
180)     acpi-support recommande xscreensaver | gnome-screensaver                                                                                      
181)     gconf2 recommande libgtk2.0-0                                                                                                                
182)     gimp-data recommande gimp                                                                                                                    
183)     libgimp2.0 recommande gimp                                                                                                                    
184)     gnash-common recommande gstreamer0.10-plugins-bad                                                                                            
185)     libgtk2.0-common recommande libgtk2.0-0                                                                                                      
186)     gvfs recommande policykit-1-gnome                                                                                                            
187)     imagemagick recommande libmagickcore3-extra                                                                                                  
188)     kdelibs5-plugins recommande kdebase-runtime (>= 4:4.4)                                                                                        
189)     kscreensaver recommande kscreensaver-xsavers (= 4:4.4.5-1)                                                                                    
190)     kdebase-workspace-bin recommande plasma-scriptengines                                                                                        
191)     plasma-desktop recommande kdebase-workspace                                                                                                  
192)     konqueror recommande konqueror-nsplugins (= 4:4.4.5-2)                                                                                        
193)     konqueror recommande dolphin                                                                                                                  
194)     libkopete4 recommande kopete (= 4:4.4.5-2+squeeze1)                                                                                          
195)     kmail recommande pinentry-qt4 | pinentry-x11                                                                                                  
196)     konq-plugins-l10n recommande konq-plugins (>= 4:4.2.4)                                                                                        
197)     libcanberra-gtk0 recommande libcanberra-gtk-module                                                                                            
198)     kde-plasma-desktop recommande kdm (>= 4:4.4.3)                                                                                                
199)     openoffice.org-help-en-us recommande openoffice.org-core (> 1:3.2.1) | language-support-translations-en                                      
200)     openoffice.org-help-fr recommande openoffice.org-core (> 1:3.2.1) | language-support-translations-fr                                          
201)     openoffice.org-l10n-fr recommande openoffice.org-core (> 1:3.2.1) | language-support-translations-fr                                          
202)     openoffice.org-writer recommande openoffice.org-filter-binfilter                                                                              
203)     openoffice.org-writer recommande default-jre | gcj-jre | java-gcj-compat | openjdk-6-jre | sun-java5-jre | sun-java6-jre | java5-runtime | jre
204)     openoffice.org-writer recommande openoffice.org-math                                                                                          
205)     openoffice.org recommande openoffice.org-filter-binfilter                                                                                    
206)     libpango1.0-common recommande libpango1.0-0                                                                                                  
207)     knm-runtime recommande kwalletmanager                                                                                                        


Accepter cette solution ? [Y/n/q/?]


Voila, une idée ?

Dernière modification par huit (03-03-2012 15:20:49)

Hors ligne

#2 01-03-2012 23:19:30

tetrix
Invité

Re : [Résolu] PB mise à jour iceweasel 3.5 ver 10 depot mozilla.debain bpo

Salut,

si tu as fais la modif du sources.list faut pas t'étonner que cela chamboule ton système, si tu réponds non a la MAJ, quels sont les choix suivants

Tu peux faire ça aussi wink http://debian-facile.org/atelier:indications-forum?s[]=infodistri

Smolski : aboule le chocolat, viiiiiiiiiiite smile

Dernière modification par tetrix (01-03-2012 23:20:32)

#3 02-03-2012 22:01:11

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] PB mise à jour iceweasel 3.5 ver 10 depot mozilla.debain bpo

Ah fort le tetrix, je te colle un point supp vers le nivarna chocatesque ! smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#4 02-03-2012 22:17:51

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] PB mise à jour iceweasel 3.5 ver 10 depot mozilla.debain bpo

Bonsoir Huit,

Mhh…

1) Est-ce que ton gestionnaire de paquet est dans un état sain ?

Si tu commentes les backports et les dépôts mozilla, puis que tu fais

aptitude update
aptitude install -f


Il bronche ?

2) Est-ce que ton système est à jour ?

Si tu réactives les dépôts backports mais pas les dépôts mozilla, et que tu fais

aptitude update
aptitude full-upgrade


Il bouge ?

3) Finalement, après avoir remis les dépôts mozilla dans le sources.list, fait le

aptitude update


Et puis tenté l'installation de la nouvelle version.

aptitude install iceweasel


Quelles sont les différentes solutions qu'il te propose ?
(tu peux faire "n" pour passer d'une solution à l'autre)


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#5 03-03-2012 12:42:42

huit
Membre
Distrib. : Satable + Dépots Backport & Multimédia main
Noyau : 2.6.32-5-686
(G)UI : KDE 4.4.5
Inscription : 01-03-2012

Re : [Résolu] PB mise à jour iceweasel 3.5 ver 10 depot mozilla.debain bpo

Merci pour l'aide.

@captnfab

J'ai effectué le test dans l'ordre indiqué mais cela n'a rien changé à part que mon problème disparait bien si j'enlève le dépôt "mozilla debian".

Après le "aptitude update" j'ai fait le "aptitude install -f" :

# aptitude -f install
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.


Un aptitude "full-upgrade" après désactivation du dépôt "mozilla debian" me dit que je n'ai aucune mise à jour disponible et après réactivation il me renvoi une érreur du même type que pour l'instalation de iceweasel :

# aptitude full-upgrade
Les paquets suivants seront ENLEVÉS :        
  libxcb-render-util0{u}
Les paquets suivants seront mis à jour :
  libcairo2{b}
1 paquets mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 930 ko d'archives. Après dépaquetage, 475 ko seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
  libcairo2: Dépend: libpixman-1-0 (>= 0.18.0) mais 0.16.4-1 est installé.
Les actions suivantes permettront de résoudre ces dépendances :

       Supprimer les paquets suivants :                                                                                                                
1)       akregator                                                                                                                                    
2)       ark                                                                                                                                          
3)       browser-plugin-gnash                                                                                                                          
4)       desktop-base                                                                                                                                  
5)       dolphin                                                                                                                                      
6)       dragonplayer                                                                                                                                  
7)       gcj-4.4-jre                                                                                                                                  
8)       gcj-jre                                                                                                                                      
9)       gimp                                                                                                                                          
10)      gnash                                                                                                                                        
11)      gnash-common                                                                                                                                  
12)      gnome-icon-theme                                                                                                                              
13)      gnupg-agent                                                                                                                                  
14)      gnupg2                                                                                                                                        
15)      google-gadgets-qt                                                                                                                            
16)      google-gadgets-xul                                                                                                                            
17)      gstreamer0.10-plugins-bad                                                                                                                    
18)      gwenview                                                                                                                                      
19)      juk                                                                                                                                          
20)      k3b                                                                                                                                          
21)      k3b-i18n                                                                                                                                      
22)      kaddressbook                                                                                                                                  
23)      kappfinder                                                                                                                                    
24)      kate                                                                                                                                          
25)      kcalc                                                                                                                                        
26)      kde-plasma-desktop                                                                                                                            
27)      kde-standard                                                                                                                                  
28)      kde-window-manager                                                                                                                            
29)      kdebase-apps                                                                                                                                  
30)      kdebase-bin                                                                                                                                  
31)      kdebase-runtime                                                                                                                              
32)      kdebase-workspace                                                                                                                            
33)      kdebase-workspace-bin                                                                                                                        
34)      kdepasswd                                                                                                                                    
35)      kdepim-runtime                                                                                                                                
36)      kdeplasma-addons                                                                                                                              
37)      kdesudo                                                                                                                                      
38)      kdm                                                                                                                                          
39)      kerneloops                                                                                                                                    
40)      kfind                                                                                                                                        
41)      khelpcenter4                                                                                                                                  
42)      kinfocenter                                                                                                                                  
43)      klipper                                                                                                                                      
44)      kmail                                                                                                                                        
45)      kmix                                                                                                                                          
46)      knm-runtime                                                                                                                                  
47)      knotes                                                                                                                                        
48)      konq-plugins                                                                                                                                  
49)      konqueror                                                                                                                                    
50)      konqueror-nsplugins                                                                                                                          
51)      konsole                                                                                                                                      
52)      kopete                                                                                                                                        
53)      korganizer                                                                                                                                    
54)      kscreensaver                                                                                                                                  
55)      kscreensaver-xsavers                                                                                                                          
56)      ksnapshot                                                                                                                                    
57)      ksysguard                                                                                                                                    
58)      kwalletmanager                                                                                                                                
59)      kwrite                                                                                                                                        
60)      libakonadi-contact4                                                                                                                          
61)      libbonoboui2-0                                                                                                                                
62)      libcairo2                                                                                                                                    
63)      libcanberra-gtk-module                                                                                                                        
64)      libcanberra-gtk0                                                                                                                              
65)      libgail18                                                                                                                                    
66)      libgcj10-awt                                                                                                                                  
67)      libgegl-0.0-0                                                                                                                                
68)      libgimp2.0                                                                                                                                    
69)      libglade2-0                                                                                                                                  
70)      libgnomecanvas2-0                                                                                                                            
71)      libgnomeui-0                                                                                                                                  
72)      libgraphicsmagick3                                                                                                                            
73)      libgtk2.0-0                                                                                                                                  
74)      libgtk2.0-bin                                                                                                                                
75)      libgtkglext1                                                                                                                                  
76)      libgvc5                                                                                                                                      
77)      libhsqldb-java                                                                                                                                
78)      libhsqldb-java-gcj                                                                                                                            
79)      libk3b6                                                                                                                                      
80)      libk3b6-extracodecs                                                                                                                          
81)      libkcddb4                                                                                                                                    
82)      libkde4-ruby1.8                                                                                                                              
83)      libkdepim4                                                                                                                                    
84)      libkonq5                                                                                                                                      
85)      libkopete4                                                                                                                                    
86)      libmagickcore3-extra                                                                                                                          
87)      libmessagelist4                                                                                                                              
88)      libnotify1                                                                                                                                    
89)      libokularcore1                                                                                                                                
90)      libpango1.0-0                                                                                                                                
91)      libplasma-ruby                                                                                                                                
92)      libplasma-ruby1.8                                                                                                                            
93)      libpoppler-glib4                                                                                                                              
94)      libqt4-ruby1.8                                                                                                                                
95)      librsvg2-2                                                                                                                                    
96)      librsvg2-common                                                                                                                              
97)      libscim8c2a                                                                                                                                  
98)      libsmokekdecore4-3                                                                                                                            
99)      libsmokekdeui4-3                                                                                                                              
100)     libsmokekfile3                                                                                                                                
101)     libsmokekhtml3                                                                                                                                
102)     libsmokekio3                                                                                                                                  
103)     libsmokeknewstuff2-3                                                                                                                          
104)     libsmokeknewstuff3-3                                                                                                                          
105)     libsmokekparts3                                                                                                                              
106)     libsmokektexteditor3                                                                                                                          
107)     libsmokekutils3                                                                                                                              
108)     libsmokenepomuk3                                                                                                                              
109)     libsmokephonon3                                                                                                                              
110)     libsmokeplasma3                                                                                                                              
111)     libwebkit-1.0-2                                                                                                                              
112)     libwmf0.2-7                                                                                                                                  
113)     libwnck22                                                                                                                                    
114)     libxine1                                                                                                                                      
115)     libxine1-misc-plugins                                                                                                                        
116)     libxine1-plugins                                                                                                                              
117)     network-manager-kde                                                                                                                          
118)     notification-daemon                                                                                                                          
119)     okular                                                                                                                                        
120)     openoffice.org-base-core                                                                                                                      
121)     openoffice.org-common                                                                                                                        
122)     openoffice.org-core                                                                                                                          
123)     openoffice.org-emailmerge                                                                                                                    
124)     openoffice.org-filter-binfilter                                                                                                              
125)     openoffice.org-gcj                                                                                                                            
126)     openoffice.org-help-en-us                                                                                                                    
127)     openoffice.org-help-fr                                                                                                                        
128)     openoffice.org-java-common                                                                                                                    
129)     openoffice.org-kde                                                                                                                            
130)     openoffice.org-math                                                                                                                          
131)     openoffice.org-style-galaxy                                                                                                                  
132)     openoffice.org-style-oxygen                                                                                                                  
133)     openoffice.org-thesaurus-en-us                                                                                                                
134)     openoffice.org-thesaurus-fr                                                                                                                  
135)     openoffice.org-writer                                                                                                                        
136)     phonon                                                                                                                                        
137)     phonon-backend-xine                                                                                                                          
138)     pinentry-gtk2                                                                                                                                
139)     plasma-dataengines-workspace                                                                                                                  
140)     plasma-desktop                                                                                                                                
141)     plasma-runners-addons                                                                                                                        
142)     plasma-scriptengine-googlegadgets                                                                                                            
143)     plasma-scriptengine-python                                                                                                                    
144)     plasma-scriptengine-ruby                                                                                                                      
145)     plasma-scriptengine-superkaramba                                                                                                              
146)     plasma-scriptengines                                                                                                                          
147)     plasma-widget-folderview                                                                                                                      
148)     plasma-widget-lancelot                                                                                                                        
149)     plasma-widgets-addons                                                                                                                        
150)     plasma-widgets-workspace                                                                                                                      
151)     policykit-1-gnome                                                                                                                            
152)     polkit-kde-1                                                                                                                                  
153)     python-cairo                                                                                                                                  
154)     python-glade2                                                                                                                                
155)     python-gnome2                                                                                                                                
156)     python-gtk2                                                                                                                                  
157)     python-kde4                                                                                                                                  
158)     python-notify                                                                                                                                
159)     python-uno                                                                                                                                    
160)     sweeper                                                                                                                                      
161)     system-config-printer                                                                                                                        
162)     systemsettings                                                                                                                                
163)     xscreensaver                                                                                                                                  
164)     xscreensaver-data                                                                                                                            
165)     xscreensaver-data-extra                                                                                                                      
166)     xscreensaver-gl                                                                                                                              
167)     xscreensaver-gl-extra                                                                                                                        
168)     xscreensaver-screensaver-bsod                                                                                                                
169)     xulrunner-1.9.1                                                                                                                              

       Laisser les dépendances suivantes non satisfaites :                                                                                            
170)     acpi-support recommande xscreensaver | gnome-screensaver                                                                                      
171)     gconf2 recommande libgtk2.0-0                                                                                                                
172)     gimp-data recommande gimp                                                                                                                    
173)     libgimp2.0 recommande gimp                                                                                                                    
174)     gnash-common recommande gstreamer0.10-plugins-bad                                                                                            
175)     libgtk2.0-common recommande libgtk2.0-0                                                                                                      
176)     gvfs recommande policykit-1-gnome                                                                                                            
177)     imagemagick recommande libmagickcore3-extra                                                                                                  
178)     kdelibs5-plugins recommande kdebase-runtime (>= 4:4.4)                                                                                        
179)     kscreensaver recommande kscreensaver-xsavers (= 4:4.4.5-1)                                                                                    
180)     kdebase-workspace-bin recommande plasma-scriptengines                                                                                        
181)     plasma-desktop recommande kdebase-workspace                                                                                                  
182)     konqueror recommande konqueror-nsplugins (= 4:4.4.5-2)                                                                                        
183)     konqueror recommande dolphin                                                                                                                  
184)     libkopete4 recommande kopete (= 4:4.4.5-2+squeeze1)                                                                                          
185)     kmail recommande pinentry-qt4 | pinentry-x11                                                                                                  
186)     konq-plugins-l10n recommande konq-plugins (>= 4:4.2.4)                                                                                        
187)     libcanberra-gtk0 recommande libcanberra-gtk-module                                                                                            
188)     kde-plasma-desktop recommande kdm (>= 4:4.4.3)                                                                                                
189)     openoffice.org-help-en-us recommande openoffice.org-core (> 1:3.2.1) | language-support-translations-en                                      
190)     openoffice.org-help-fr recommande openoffice.org-core (> 1:3.2.1) | language-support-translations-fr                                          
191)     openoffice.org-l10n-fr recommande openoffice.org-core (> 1:3.2.1) | language-support-translations-fr                                          
192)     openoffice.org-writer recommande openoffice.org-filter-binfilter                                                                              
193)     openoffice.org-writer recommande default-jre | gcj-jre | java-gcj-compat | openjdk-6-jre | sun-java5-jre | sun-java6-jre | java5-runtime | jre
194)     openoffice.org-writer recommande openoffice.org-math                                                                                          
195)     libpango1.0-common recommande libpango1.0-0                                                                                                  
196)     knm-runtime recommande kwalletmanager                                                                                                        


Accepter cette solution ? [Y/n/q/?]


Apparemment la version de la libcairo présente dans le dépôt "mozilla debian" requiert une version supérieur de la libpixman. La majorité des paquets ayant besoin de ces libraries ont l'aire de dépendre de la version actuelement présente dans stable, la mise à jour de celle ci me choute donc tout ces paquets.

Peut importe la solution alternative que propose aptitude dant tout les cas ca revient au même...



Alors comme ça je constate que la comunauté debain-facile tourne qu chocolat... C'est du beau !

Hors ligne

#6 03-03-2012 14:15:38

tetrix
Invité

Re : [Résolu] PB mise à jour iceweasel 3.5 ver 10 depot mozilla.debain bpo

Si tu fais une installation simplement, cela te donne quoi comme retour ? Il faudrait vérifier que la version que tu cherches à installer soit presente dans les backports, sinon, tu devras faire un pinning pour aller la chercher dans Sid => voir wiki pinning

apt-get update
apt-get install -t squeeze-backports iceweasel


http://mozilla.debian.net/

Dernière modification par tetrix (03-03-2012 14:16:36)

#7 03-03-2012 14:41:46

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] PB mise à jour iceweasel 3.5 ver 10 depot mozilla.debain bpo

Essaye d'installer la libpixman des backports:

aptitude install libpixman-1-0 -t squeeze-backports


Puis d'installer iceweasel après ça.

8 a écrit :

Alors comme ça je constate que la comunauté debain-facile tourne qu chocolat... C'est du beau !


Si tu savais ! Mais ce n'est pas tout, smolski fait du trafic de chocolat frelaté... smile


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#8 03-03-2012 15:19:32

huit
Membre
Distrib. : Satable + Dépots Backport & Multimédia main
Noyau : 2.6.32-5-686
(G)UI : KDE 4.4.5
Inscription : 01-03-2012

Re : [Résolu] PB mise à jour iceweasel 3.5 ver 10 depot mozilla.debain bpo

J'ai dabor tésté en premier la méthode de "tetrix" et aussi navran que soit un truc aussi évident ... ca a marché !!!
Et de plus cela à même réglé mes problèmes de mises à jour :

# aptitude install -t squeeze-backports iceweasel
Les NOUVEAUX paquets suivants vont être installés :
  iceweasel libmozjs10d{a} libvpx1{a} xulrunner-10.0{a}
Les paquets suivants seront ENLEVÉS :
  libxcb-render-util0{u}
Les paquets suivants seront mis à jour :
  libcairo2 libnss3-1d libpixman-1-0
3 paquets mis à jour, 4 nouvellement installés, 1 à enlever et 94 non mis à jour.
Il est nécessaire de télécharger 17,2 Mo d'archives. Après dépaquetage, 32,4 Mo seront utilisés.
Voulez-vous continuer ? [Y/n/?] y
Prendre : 1 http://mozilla.debian.net/ squeeze-backports/iceweasel-release libcairo2 i386 1.10.2-6~bpo60+1 [930 kB]
Prendre : 2 http://backports.debian.org/debian-backports/ squeeze-backports/main libpixman-1-0 i386 0.24.0-1~bpo60+1 [398 kB]
Prendre : 3 http://backports.debian.org/debian-backports/ squeeze-backports/main libnss3-1d i386 3.13.3-1~bpo60+1 [1 036 kB]
Prendre : 4 http://mozilla.debian.net/ squeeze-backports/iceweasel-release libmozjs10d i386 10.0.2-1~bpo60+1 [1 530 kB]                                                                        
Prendre : 5 http://mozilla.debian.net/ squeeze-backports/iceweasel-release libvpx1 i386 1.0.0-1~bpo60+1 [270 kB]                                                                              
Prendre : 6 http://mozilla.debian.net/ squeeze-backports/iceweasel-release xulrunner-10.0 i386 10.0.2-1~bpo60+1 [11,2 MB]                                                                      
Prendre : 7 http://mozilla.debian.net/ squeeze-backports/iceweasel-release iceweasel i386 10.0.2-1~bpo60+1 [1 827 kB]                                                                          
 17,2 Mo téléchargés en 1min 15s (228 ko/s)                                                                                                                                                    
Lecture des fichiers de modifications (« changelog »)... Terminé
(Lecture de la base de données... 100561 fichiers et répertoires déjà installés.)
Préparation du remplacement de libpixman-1-0 0.16.4-1 (en utilisant .../libpixman-1-0_0.24.0-1~bpo60+1_i386.deb) ...
Dépaquetage de la mise à jour de libpixman-1-0 ...
Préparation du remplacement de libcairo2 1.8.10-6 (en utilisant .../libcairo2_1.10.2-6~bpo60+1_i386.deb) ...
Dépaquetage de la mise à jour de libcairo2 ...
(Lecture de la base de données... 100560 fichiers et répertoires déjà installés.)
Suppression de libxcb-render-util0 ...
Sélection du paquet libmozjs10d précédemment désélectionné.
(Lecture de la base de données... 100555 fichiers et répertoires déjà installés.)
Dépaquetage de libmozjs10d (à partir de .../libmozjs10d_10.0.2-1~bpo60+1_i386.deb) ...
Préparation du remplacement de libnss3-1d 3.12.8-1+squeeze4 (en utilisant .../libnss3-1d_3.13.3-1~bpo60+1_i386.deb) ...
Dépaquetage de la mise à jour de libnss3-1d ...
Sélection du paquet libvpx1 précédemment désélectionné.
Dépaquetage de libvpx1 (à partir de .../libvpx1_1.0.0-1~bpo60+1_i386.deb) ...
Sélection du paquet xulrunner-10.0 précédemment désélectionné.
Dépaquetage de xulrunner-10.0 (à partir de .../xulrunner-10.0_10.0.2-1~bpo60+1_i386.deb) ...
Sélection du paquet iceweasel précédemment désélectionné.
Dépaquetage de iceweasel (à partir de .../iceweasel_10.0.2-1~bpo60+1_i386.deb) ...
Ajout de « détournement de /usr/bin/firefox en /usr/bin/firefox.real par iceweasel »
Traitement des actions différées (« triggers ») pour « man-db »...
Traitement des actions différées (« triggers ») pour « hicolor-icon-theme »...
Traitement des actions différées (« triggers ») pour « menu »...
Paramétrage de libpixman-1-0 (0.24.0-1~bpo60+1) ...
Paramétrage de libcairo2 (1.10.2-6~bpo60+1) ...
Paramétrage de libmozjs10d (10.0.2-1~bpo60+1) ...
Paramétrage de libnss3-1d (3.13.3-1~bpo60+1) ...
Paramétrage de libvpx1 (1.0.0-1~bpo60+1) ...
Paramétrage de xulrunner-10.0 (10.0.2-1~bpo60+1) ...
Paramétrage de iceweasel (10.0.2-1~bpo60+1) ...
update-alternatives: utilisation de « /usr/bin/iceweasel » pour fournir « /usr/bin/gnome-www-browser » (gnome-www-browser) en mode automatique.
Traitement des actions différées (« triggers ») pour « menu »...
                                             
État actuel : 94 mises à jour restantes [-3].            
root@debian-kde-virt:/home/toto# aptitude upgrade
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.
                                             
root@debian-kde-virt:/home/toto# aptitude full-upgrade
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.


Par contre je souhaite quand même une petite explication les priorités des dépôt, car il y a quelques chose que j'ai mal compris :

# aptitude versions iceweasel
p   3.5.16-11                stable                        500
p   3.5.16-12                stable                        500
i   10.0.2-1~bpo60+1        squeeze-backports              500


J'avais penssé comprendre qu'en cas de priorité équivalentes la version la plus récentes du paquet serais choisis, ce qui était bien la cas...
J'avais supposé donc que dans ce cas, aptitudes irrait chercher implicetement la verssion de "squeeze-backprot".
Qu'es qui as changé en luis disant explicitement d'utiliser le backport au niveau de la résolution des dépendance ?


captnfab a écrit :

Si tu savais ! Mais ce n'est pas tout, smolski fait du trafic de chocolat frelaté... smile


Et ou c'est malheureux, les temps sont dures et chacun fait comme il peut... mais la quand même le chocolat...


Merci pour votre aide.

Hors ligne

#9 03-03-2012 16:23:08

huit
Membre
Distrib. : Satable + Dépots Backport & Multimédia main
Noyau : 2.6.32-5-686
(G)UI : KDE 4.4.5
Inscription : 01-03-2012

Re : [Résolu] PB mise à jour iceweasel 3.5 ver 10 depot mozilla.debain bpo

Je vien de lire ici que normalement le dépôt backport devrait avoir une priorité de 100 or chez moi il a une priorité de 500 par défaut.
Je précise tout de même que je n'ai encore crée aucun fichier de préférence pour le moment.

Re correction :
aptcache policy me donne :

$ apt-cache policy
Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 500 http://www.debian-multimedia.org/ squeeze/main i386 Packages
     release v=6.0,o=Unofficial Multimedia Packages,a=stable,n=squeeze,l=Unofficial Multimedia Packages,c=main
     origin www.debian-multimedia.org
 500 http://mozilla.debian.net/ squeeze-backports/iceweasel-release i386 Packages
     release o=Debian Mozilla Team,a=squeeze-backports,n=squeeze-backports,l=Debian Mozilla Team,c=iceweasel-release
     origin mozilla.debian.net
 100 http://backports.debian.org/debian-backports/ squeeze-backports/main i386 Packages
     release o=Debian Backports,a=squeeze-backports,n=squeeze-backports,l=Debian Backports,c=main
     origin backports.debian.org
 500 http://ftp.fr.debian.org/debian/ squeeze-updates/main i386 Packages
     release o=Debian,a=stable-updates,n=squeeze-updates,l=Debian,c=main
     origin ftp.fr.debian.org
 500 http://security.debian.org/ squeeze/updates/main i386 Packages
     release v=6.0,o=Debian,a=stable,n=squeeze,l=Debian-Security,c=main
     origin security.debian.org
 500 http://ftp.fr.debian.org/debian/ squeeze/main Translation-fr
 500 http://ftp.fr.debian.org/debian/ squeeze/main i386 Packages
     release v=6.0.4,o=Debian,a=stable,n=squeeze,l=Debian,c=main
     origin ftp.fr.debian.org
Paquets étiquetés :


J'ai bien mon dépot backport à 100.

C'est le mozilla debian qui est à 500, voila le fin mot. C'est pouquoi j'ai du forcé l'installation sur le backport.
En théori si j'avai priorisé les backport je n'aurai pas eu ce problème, je vais essayer.

Re Re correction, au moment ou j'ai écrit ces lignes j'avais pas vu la réponce de captnfab ci dessous... Je doit aller dormir.

Dernière modification par huit (03-03-2012 17:32:49)

Hors ligne

#10 03-03-2012 16:29:45

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] PB mise à jour iceweasel 3.5 ver 10 depot mozilla.debain bpo

$ aptitude versions libpixman-1-0
i A 0.16.4-1               stable                                               500
p A 0.24.0-1~bpo60+1       squeeze-backports                                    100


En l'absence du -t squeeze-backports, la résolution de dépendances ignorait les basses priorités.
Le paquet iceweasel du dépôt des mainteneurs mozilla a peut-être une priorité 500 (alors qu'il serait plus raisonnable de lui mettre une priorité 100), mais ses dépendances qui sont dans le dépôt officiel des backports avaient une priorité moindre: 100.

C'est pour cela que je te faisais installer la dépendance à part. smile

Il y a aussi une confusion due au fait que les deux dépôts mozilla et officiel sont tous les deux nommés « squeeze-backports »... Du coup, avec le "-t" tu indiquais d'aller chercher les dépendances dans les deux dépôts...


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#11 03-03-2012 17:11:31

tetrix
Invité

Re : [Résolu] PB mise à jour iceweasel 3.5 ver 10 depot mozilla.debain bpo

Debian....Que du bonheur, smile

Moi, j'ai jamais eu de chocolat frelaté.....mais je vais me méfier à l'avenir wink

A+

#12 03-03-2012 17:37:39

huit
Membre
Distrib. : Satable + Dépots Backport & Multimédia main
Noyau : 2.6.32-5-686
(G)UI : KDE 4.4.5
Inscription : 01-03-2012

Re : [Résolu] PB mise à jour iceweasel 3.5 ver 10 depot mozilla.debain bpo

Ok merci pour les explication, je vais continuer mes test et a éplucher le wiki et bientôt je vais surement migrer.

tetrix a écrit :

Debian....Que du bonheur, smile

Moi, j'ai jamais eu de chocolat frelaté.....mais je vais me méfier à l'avenir wink

A+


A mon avis il a ces chouchou...

Hors ligne

#13 03-03-2012 21:34:15

tetrix
Invité

Re : [Résolu] PB mise à jour iceweasel 3.5 ver 10 depot mozilla.debain bpo

huit a écrit :

A mon avis il a ces chouchou...


Ô l'autre hein !...</joke>

Pied de page des forums