Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 15-03-2012 13:43:20

tos69400
Membre
Distrib. : Wheezy
Noyau : 3.2.0-1-amd64
(G)UI : Gnome-shell
Inscription : 25-07-2011

Latence démarrage gnome-shell

Bonjour,
Je me permet de venir vers vous car voici mon gros souci.
J'ai un temps de latence énorme entre la connexion gdm3 et la mise à disposition du bureau.

Je ne sais pas ce qui se passe et je n'arrive pas à lancer une analyse avec bootchart2 de la séquence de boot.
J'ai fait l'achat d'un i5 en pensant que ma machine sera ultra-puissante : c'est bien le cas mais pas au démarrage.

A l'aide !!!

Edit : j'ai enfin réussi à lancer une visualisation de la séquence de boot à l'aide de bootchart (pas bootchart2)
Voici le lien vers l'image : http://imagepaste.nullnetwork.net/viewimage.php?id=3332
Je ne comprend pas d'où viens le temps de latence !?!

Hors ligne

#2 17-03-2012 02:14:02

arkim
Membre
Lieu : Montpellier, France.
Distrib. : Wheezy
Noyau : 3.0 amd64
(G)UI : Gnome 3.0.2
Inscription : 04-12-2011

Re : Latence démarrage gnome-shell

Bonjour,

Cela pourrait venir d'un problème dans la gestion du northbrige intégré au processeur, non? Notamment le graphisme.

Hors ligne

#3 17-03-2012 03:33:57

tos69400
Membre
Distrib. : Wheezy
Noyau : 3.2.0-1-amd64
(G)UI : Gnome-shell
Inscription : 25-07-2011

Re : Latence démarrage gnome-shell

Merci de ta réponse mais pourrais-tu être plus précis stp car je ne comprend pas tout.

Hors ligne

#4 17-03-2012 07:43:35

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Latence démarrage gnome-shell

Salut !

Moi non plus j'y pigeais rien, mais en tapant :

northbrige intégré au processeur


Dans le moteur de recherche libre :
https://startpage.com/fra/

J'ai trouvé cette explication avec shéma sur wikipedia là :
https://fr.wikipedia.org/wiki/Northbridge

Ce qui est un renseignement nouveau pour beaucoup, merci de ce post ouvert et de la réponse fournie !

Moi j'dis que l' net, nous n'en sommes cérébralement qu'au balbutiement encore !

Amitié, Joel smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#5 17-03-2012 11:45:34

tos69400
Membre
Distrib. : Wheezy
Noyau : 3.2.0-1-amd64
(G)UI : Gnome-shell
Inscription : 25-07-2011

Re : Latence démarrage gnome-shell

Je sais pas si cela pourra aider, mais voici le retour d'infos sur les CPU.

nicolas@debian:~$ cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family  : 6
model   : 42
model name  : Intel(R) Core(TM) i5-2430M CPU @ 2.40GHz
stepping  : 7
microcode : 0x1b
cpu MHz   : 2401.000
cache size  : 3072 KB
physical id : 0
siblings  : 4
core id   : 0
cpu cores : 2
apicid    : 0
initial apicid  : 0
fpu   : yes
fpu_exception : yes
cpuid level : 13
wp    : yes
flags   : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid
bogomips  : 4789.06
clflush size  : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 1
vendor_id : GenuineIntel
cpu family  : 6
model   : 42
model name  : Intel(R) Core(TM) i5-2430M CPU @ 2.40GHz
stepping  : 7
microcode : 0x1b
cpu MHz   : 800.000
cache size  : 3072 KB
physical id : 0
siblings  : 4
core id   : 1
cpu cores : 2
apicid    : 2
initial apicid  : 2
fpu   : yes
fpu_exception : yes
cpuid level : 13
wp    : yes
flags   : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid
bogomips  : 4788.90
clflush size  : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 2
vendor_id : GenuineIntel
cpu family  : 6
model   : 42
model name  : Intel(R) Core(TM) i5-2430M CPU @ 2.40GHz
stepping  : 7
microcode : 0x1b
cpu MHz   : 800.000
cache size  : 3072 KB
physical id : 0
siblings  : 4
core id   : 0
cpu cores : 2
apicid    : 1
initial apicid  : 1
fpu   : yes
fpu_exception : yes
cpuid level : 13
wp    : yes
flags   : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid
bogomips  : 4788.90
clflush size  : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 3
vendor_id : GenuineIntel
cpu family  : 6
model   : 42
model name  : Intel(R) Core(TM) i5-2430M CPU @ 2.40GHz
stepping  : 7
microcode : 0x1b
cpu MHz   : 800.000
cache size  : 3072 KB
physical id : 0
siblings  : 4
core id   : 1
cpu cores : 2
apicid    : 3
initial apicid  : 3
fpu   : yes
fpu_exception : yes
cpuid level : 13
wp    : yes
flags   : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid
bogomips  : 4788.89
clflush size  : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

Hors ligne

#6 17-03-2012 11:57:18

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : Latence démarrage gnome-shell

Yep!

Ton bootchart ne nous sera d'aucune aide, puisqu'il s'arrête, dans la configuration pas defaut, dés l'appel au demarrage du gestionnaire d'affichage.

Ton problème est relativement singulier. Ta latence, tu l'estimes à combien ? 2 secondes ? 3 secondes ?

Habituellement, les latences les plus longues sont dues au demarrage des réseaux ou à une mise en forme tros lourdes (icônes, image de fond, themes).

Je procéderais par déductions en installant par exemple un gestionnaire d'affichage different, fluxbox, openbox, etc.
Si la latence persiste, il faudra observer les services ou routines de démarrage.
Si elle disparait, c'est que gnome est à suspecter.

@+

Zoroastre.

Hors ligne

#7 17-03-2012 12:52:06

tos69400
Membre
Distrib. : Wheezy
Noyau : 3.2.0-1-amd64
(G)UI : Gnome-shell
Inscription : 25-07-2011

Re : Latence démarrage gnome-shell

zoroastre74 a écrit :

Yep!

Ton bootchart ne nous sera d'aucune aide, puisqu'il s'arrête, dans la configuration pas defaut, dés l'appel au demarrage du gestionnaire d'affichage.

Ton problème est relativement singulier. Ta latence, tu l'estimes à combien ? 2 secondes ? 3 secondes ?

Habituellement, les latences les plus longues sont dues au demarrage des réseaux ou à une mise en forme tros lourdes (icônes, image de fond, themes).

Je procéderais par déductions en installant par exemple un gestionnaire d'affichage different, fluxbox, openbox, etc.
Si la latence persiste, il faudra observer les services ou routines de démarrage.
Si elle disparait, c'est que gnome est à suspecter.

@+

Zoroastre.


La latence est d'environ 15 à 20 secondes. Je suspecte en effet gnome-shell car cette latence n'apparait pas une xfce par exemple.

Hors ligne

#8 17-03-2012 14:56:52

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : Latence démarrage gnome-shell

Yep!

La latence est d'environ 15 à 20 secondes.


Ouch !!! Cà fait mal sad

Je suspecte en effet gnome-shell car cette latence n'apparait pas une xfce par exemple.


On ne partira pas sur des hypothèses à base de pont nord et autres cochonneries.

Je ne peux pas plus t'aider, n'étant pas un afficionados de Gnome.
Il faudrait voir si tu peux démarrer sur un shell plutôt que sur Gnome, et ensuite faire appel à ton gestionnaire d'affichage manuellement. La partie bloquante apparaitra peut-être dans le shell.

startx

ou

gnome-session


@+

Zoroastre.

Dernière modification par zoroastre74 (17-03-2012 14:59:23)

Hors ligne

#9 17-03-2012 16:05:20

tos69400
Membre
Distrib. : Wheezy
Noyau : 3.2.0-1-amd64
(G)UI : Gnome-shell
Inscription : 25-07-2011

Re : Latence démarrage gnome-shell

zoroastre74 a écrit :

Yep!

La latence est d'environ 15 à 20 secondes.


Ouch !!! Cà fait mal sad

Je suspecte en effet gnome-shell car cette latence n'apparait pas une xfce par exemple.


On ne partira pas sur des hypothèses à base de pont nord et autres cochonneries.

Je ne peux pas plus t'aider, n'étant pas un afficionados de Gnome.
Il faudrait voir si tu peux démarrer sur un shell plutôt que sur Gnome, et ensuite faire appel à ton gestionnaire d'affichage manuellement. La partie bloquante apparaitra peut-être dans le shell.

startx

ou

gnome-session


@+

Zoroastre.


Ok, je veux bien tenter le coup afin d'identifier le problème.
Peux-tu m'indiquer comment démarrer sur un shell plutôt qu'en mode graphique.

Hors ligne

#10 17-03-2012 16:25:27

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Latence démarrage gnome-shell

Salut,

On appelle le mode recovery :
http://debian-facile.org/doc:systeme:recovery

smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#11 17-03-2012 16:49:10

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : Latence démarrage gnome-shell

Yep!

On appelle le mode recovery


Ouép ! Mais le mode recovery va désactiver plein de truc, non ???

J'aurais plutôt démarrer un shell à partir du gestionnaire de session gdm. L'option existe dans la liste deroulante.
Si notre amis a démarrer xfce lors de ses tests, je suppose qu'il a accés à cette liste déroulante wink

En plus, gdm et X sont de facto en service, çà évite des tracasseries genre comment on fait ceci ou cela.

Aprés, les deux méthodes sont valables, celle proposée par smolski a au moins le mérite de se passer de toute une interfaçe graphique qui pourrait masquer ce que nous cherchons avec ma méthode.
L'autre possibilité est de demarrer sur gnome normalement, d'accéder à tty1 (CTRL+ALT+F1), de killer gnome et de le relancer en restant sur le tty en cours. (retour à l'interface grace à CTRL+ALT+F7)

Si tu démarres en mode recovery, essayes les deux commandes précitées, l'une puis l'autre.
Y-a t'il un specialiste de Gnome dans la salle ???
gnome-shell --replace ???

@+

Zoroastre.

Dernière modification par zoroastre74 (17-03-2012 17:34:48)

Hors ligne

#12 17-03-2012 19:04:01

tos69400
Membre
Distrib. : Wheezy
Noyau : 3.2.0-1-amd64
(G)UI : Gnome-shell
Inscription : 25-07-2011

Re : Latence démarrage gnome-shell

Merci de m'épauler.

En démarrant en mode rescue, il faut se connecter en tant que root.
La séssion graphique est donc root (gnome3 en mode restreint) mais j'ai déconnecté de suite.

En démarrant normalement, puis en tuant le service X (passage en TTY1 puis /etc/init.d/gdm3 stop).
A la commande startx, l'affichage bascule en TTY7 ou TTY8 (j'ai testé à plusieurs reprises).
Si je reviens en TTY1, je vois que l'affichage n'a pas bougé.
Deux erreurs dans TTY1 :
  - erreur concernant xkbcomp => problème de reconnaissance du clavier (certainement en lien avec mes touches fn de luminosité qui ne fonctionnent pas)
  - erreur concernant ma souris sans fil => impossible de réinitialiser l'axe (l'adaptateur est branché mais la souris est éteinte).

J'ai remarqué que si je ferme la session (depuis gnome-shell), l'affichage de gdm3 est assez long (environ 10 secondes) mais la reconnexion (avec passage en TTY9) est super rapide => environ 5 secondes.

Merci encore de votre aide.

Hors ligne

#13 24-03-2012 18:43:08

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : Latence démarrage gnome-shell

Yep!

Afin d'ecarter tout problème relatif au clavier ou à la souris, pourrais-tu tester en remplacant un à un ces péripheriques ???

Même si au demeurant, je ne pense pas que le problème réside ici, il est bon de faire l'essai tout de même...

@+

Zoroastre.

Hors ligne

#14 24-03-2012 18:52:15

tos69400
Membre
Distrib. : Wheezy
Noyau : 3.2.0-1-amd64
(G)UI : Gnome-shell
Inscription : 25-07-2011

Re : Latence démarrage gnome-shell

zoroastre74 a écrit :

Yep!

Afin d'ecarter tout problème relatif au clavier ou à la souris, pourrais-tu tester en remplacant un à un ces péripheriques ???

Même si au demeurant, je ne pense pas que le problème réside ici, il est bon de faire l'essai tout de même...

@+

Zoroastre.


Salut, il s'agit d'un PC portable alors je ne peux pas pratiquer ce que tu demandes.

Merci de m'aider.

Hors ligne

#15 24-03-2012 18:54:45

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : Latence démarrage gnome-shell

Ooopss !!!

Hors ligne

#16 24-03-2012 18:58:55

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : Latence démarrage gnome-shell

Yep!

As-tu pensé à remplacer gdm par slim ou kdm ???

aptitude remove gdm

aptitude install slim


A ce stade, nous nous orientons plutôt vers un problème lié à gnome-shell ou à une étape entre gdm et gnome-shell.

L'installation d'un gestionnaire de démarrage différent nous permettra d'en conclure. Nous savons déjà que tout autre gestionnaire d'affichage fonctionne normalement.

@+

Zoroastre.

Dernière modification par zoroastre74 (24-03-2012 19:02:26)

Hors ligne

#17 25-03-2012 01:43:36

tos69400
Membre
Distrib. : Wheezy
Noyau : 3.2.0-1-amd64
(G)UI : Gnome-shell
Inscription : 25-07-2011

Re : Latence démarrage gnome-shell

zoroastre74 a écrit :

Yep!

As-tu pensé à remplacer gdm par slim ou kdm ???

aptitude remove gdm

aptitude install slim


A ce stade, nous nous orientons plutôt vers un problème lié à gnome-shell ou à une étape entre gdm et gnome-shell.

L'installation d'un gestionnaire de démarrage différent nous permettra d'en conclure. Nous savons déjà que tout autre gestionnaire d'affichage fonctionne normalement.

@+

Zoroastre.


J'ai réalisé ces essais en machine virtuelle.
Un bénéfice non négligeable est à constater, deux soucies subsistent cependant :
   - lightdm n'est pas suffisamment configurable à mon sens
   - slim => le bouton redémarrer ou éteindre n'est plus accessible, ce qui est très embêtant

Merci de m'aider car c'est super saoulant.

Hors ligne

Pied de page des forums