Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-03-2012 19:30:44

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

pas de son sortie HDMI Nvidia

Bonjour,

Je viens d'installer Squeeze, les drivers Nvidia mais je n'arrive pas à avoir de son.

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: HDA Generic [HDA Generic]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


cat /proc/asound/modules
 0 snd_hda_intel


lsmod | grep snd_
snd_hda_codec_realtek   235698  0
snd_hda_intel          20051  1
snd_hda_codec          54244  2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               5380  1 snd_hda_codec
snd_pcm                60487  2 snd_hda_intel,snd_hda_codec
snd_seq                42913  0
snd_timer              15598  2 snd_pcm,snd_seq
snd_seq_device          4493  1 snd_seq
snd                    46542  10 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_seq,snd_timer,snd_seq_device
snd_page_alloc          6265  2 snd_hda_intel,snd_pcm


sous Fedora j'avais modifier /etc/modprobe.d/alsa-base.conf

options snd-hda-intel probe_mask=0xffff,0xfff2

Hors ligne

#2 29-03-2012 19:52:21

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : pas de son sortie HDMI Nvidia

Bonjour nIQnutn et bienvenue sur df !

As-tu consulté le tuto concernant le son ici :
http://debian-facile.org/doc:materiel:c … :depannage

roll

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 29-03-2012 21:51:23

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : pas de son sortie HDMI Nvidia

merci j'ai déjà regardé.
la carte nvidia ne semble pas être reconnu mais je sais pas pourquoi.

Hors ligne

#4 29-03-2012 21:53:33

frenesik
Invité

Re : pas de son sortie HDMI Nvidia

tiens regarde ça si cela peut t'aider: ftp://download.nvidia.com/XFree86/gpu-h … audio.html

#5 29-03-2012 22:12:54

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : pas de son sortie HDMI Nvidia

visiblement ma carte n'est pas reconnu.

 cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xfa600000 irq 22


dans l'exemple

 cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xfa600000 irq 22


aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
default:CARD=PCH
    HDA Intel PCH, HDA Generic
    Default Audio Device
front:CARD=PCH,DEV=0
    HDA Intel PCH, HDA Generic
    Front speakers
surround40:CARD=PCH,DEV=0
    HDA Intel PCH, HDA Generic
    4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
    HDA Intel PCH, HDA Generic
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
    HDA Intel PCH, HDA Generic
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH,DEV=0
    HDA Intel PCH, HDA Generic
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH,DEV=0
    HDA Intel PCH, HDA Generic
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers


dans l'exemple

hw:CARD=NVidia,DEV=3
   HDA NVidia, NVIDIA HDMI
   Direct hardware device without any conversions
hw:CARD=NVidia,DEV=7
   HDA NVidia, NVIDIA HDMI
   Direct hardware device without any conversions
hw:CARD=NVidia,DEV=8
   HDA NVidia, NVIDIA HDMI
   Direct hardware device without any conversions
hw:CARD=NVidia,DEV=9
   HDA NVidia, NVIDIA HDMI
   Direct hardware device without any conversions
plughw:CARD=NVidia,DEV=3
   HDA NVidia, NVIDIA HDMI
   Hardware device with all software conversions
plughw:CARD=NVidia,DEV=7
   HDA NVidia, NVIDIA HDMI
   Hardware device with all software conversions
plughw:CARD=NVidia,DEV=8
   HDA NVidia, NVIDIA HDMI
   Hardware device with all software conversions
plughw:CARD=NVidia,DEV=9
   HDA NVidia, NVIDIA HDMI
   Hardware device with all software conversions


je sais pas si j'ai mal installé les drivers ou s'il manque qqchose

Dernière modification par nIQnutn (29-03-2012 22:22:00)

Hors ligne

#6 30-03-2012 15:46:44

davy
Membre
Lieu : Grenoble
Distrib. : squeeze
Noyau : 3.2
(G)UI : Gnome
Inscription : 25-11-2011

Re : pas de son sortie HDMI Nvidia

Salut,
Ma GT430 me pose aussi pas mal de problème, impossible d'obtenir le son en 5.1. C'est à en perdre son latin !

A vrai dire j'ai pour l'instant lâché l'affaire car suis obligé d'utiliser Ubuntu pour d'autres raisons...

Bref, je peux tout de même suggérer 2 pistes pour aller de l'avant :

- Activer le deuxième écran dans nvidia-settings > redémarrer (bien penser à allumer l'appareil audio avant le PC, ou sinon se reconnecter)

- Si ça ne marche toujours pas, essayer de passer à une version supérieure du noyau via les dépots backport


N'hésites pas à donner des nouvelles, j'aimerais bien tordre le coup à ces histoires de son HDMI sous debian...

PS : quelle est ta configuration matérielle ?

L'économie de la connaissance EST la crise du capitalisme.
Ecologica, André Gorz, 2008
                                                              VIVE LE LIBRE !

Hors ligne

#7 31-03-2012 10:14:05

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : pas de son sortie HDMI Nvidia

Ma config:
MSI P67GD65
Intel i5 2500k
MSI GTX 460
8 Go (2x4Go) DDR3-1333 G.Skill
écran LG M2262D

j'ai installé les drivers en suivant le wiki

apt-get install nvidia-kernel-dkms nvidia-settings nvidia-xconfig


je vais essayer en faisant une mise à jour.

Hors ligne

#8 31-03-2012 11:45:44

davy
Membre
Lieu : Grenoble
Distrib. : squeeze
Noyau : 3.2
(G)UI : Gnome
Inscription : 25-11-2011

Re : pas de son sortie HDMI Nvidia

En effet la version des dépots non-free de base du driver nvidia est la 195.36.31-6 et semble être antérieure à ta carte. Une mise à jour s'impose et tu devrais pouvoir passer à la version 280.13.really.275.36-1~bpo60+1 via les dépôts backports :

- Ajoutes les backports à tes dépots :

sudo nano /etc/apt/sources.list


-Ajoute au fichier la ligne suivante :

deb http://backports.debian.org/debian-backports squeeze-backports main contrib non-free


- Mets à jour ta liste de paquets :

sudo aptitude update


- Passes à une nouvelle version des drivers :

sudo aptitude -t squeeze-backports install nvidia-kernel-dkms nvidia-settings nvidia-xconfig


- Il t'est de même possible de passer à la version 3.2 du noyau :

sudo aptitude -t squeeze-backports install linux-headers-3.2.0-0.bpo.2-all-amd64 linux-image-amd64


A adapter en fonction de ton architecture (ici pour un 64bit)) voir ici les paquets disponibles.


En espérant que cela puisse t'aider...
Bon courage !

PS : Je crois me souvenir que le son n'avait marché chez moi qu'à partir du moment où j'avais activé l'écran HDMI via nvidia-settings puis redémarrer. Il m'a également fallut activer les sorties via alsamixer (appuyer sur m pour passer de "MM" -mute- à "00").

Dernière modification par davy (31-03-2012 19:52:26)


L'économie de la connaissance EST la crise du capitalisme.
Ecologica, André Gorz, 2008
                                                              VIVE LE LIBRE !

Hors ligne

#9 01-04-2012 12:16:55

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : pas de son sortie HDMI Nvidia

Ok, je vais tester ça.

Hors ligne

#10 03-04-2012 11:51:29

davy
Membre
Lieu : Grenoble
Distrib. : squeeze
Noyau : 3.2
(G)UI : Gnome
Inscription : 25-11-2011

Re : pas de son sortie HDMI Nvidia

Alors, le verdict. Cela t'a-t-il permis la détection de ton matériel ?

Une petite question qui m'intéresse particulièrement : réussis-tu à sortir du 5.1 ?

@+

L'économie de la connaissance EST la crise du capitalisme.
Ecologica, André Gorz, 2008
                                                              VIVE LE LIBRE !

Hors ligne

#11 17-07-2012 19:13:46

Berillions
Membre
Distrib. : Squeeze
Noyau : 2.6.39-bpo2
(G)UI : Xfce 4.6
Inscription : 02-05-2009

Re : pas de son sortie HDMI Nvidia

Pour ma part, j'essai également d'avoir le son par la carte Nvidia mais rien à faire. J'ai l'image mais le son reste sur le PC...

Hors ligne

#12 20-07-2012 13:50:41

frenesik
Invité

Re : pas de son sortie HDMI Nvidia

http://www.debian-fr.org/nvidia-chip-mc … 38208.html

Bien c'est pas comme un vendredi soir et j'ai fini toutefois par trouver tout seul :dance:
Sources:
http://www.debian-fr.org/pas-de-son-hdm … 32696.html
http://www.debian-fr.org/son-sur-sortie … 31099.html //tout est dit dans cet html wink .
http://www.debian-fr.org/pas-de-son-par … 31335.html

1er fichier à créer :
#$ sudo gedit /etc/modprobe.d/sound.conf
Citation:
options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2


2nd fichier à créer :
#$ sudo gedit /etc/asound.conf
Citation:
pcm.!default hdmi:NVidia
pcm:iec958 hdmi:NVidia


Dernier fichier à créer :
#$ sudo gedit /home/<user>/.asoundrc
Citation:
pcm.!default
{ type hw
card 0
device 3
}


Puis faire un : sudo /etc/init.d/alsa-utils restart

Et là j'ai du son :violin:

@+

Pied de page des forums