Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-04-2012 19:46:37

BrunoL
Membre
Distrib. : 6.0.4
Noyau : 2.6.32-5-amd64
(G)UI : Gnome 2.30.2
Inscription : 26-02-2012

aptitude : propose mais n'installe pas

Bonjour,

pour compiler un soft j'ai besoin de la libgtk2.0-dev donc
---------------------------------------------------------------------------------------
# aptitude install libgtk2.0-dev
Les NOUVEAUX paquets suivants vont être installés :
  autopoint{a} debhelper{a} gettext{a} html2text{a} intltool-debian{a}
[...]
  x11proto-xext-dev{a} x11proto-xinerama-dev{a} xtrans-dev{a}
0 paquets mis à jour, 50 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 15,0 Mo d'archives. Après dépaquetage, 44,5 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
  libcairo2-dev: Dépend: libcairo2 (= 1.8.10-6) mais 1.10.2-7~bpo60+1 est installé.
  libpixman-1-dev: Dépend: libpixman-1-0 (= 0.16.4-1) mais 0.24.0-1~bpo60+1 est installé.
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     libcairo2-dev [Non installé]                             
2)     libgtk2.0-dev [Non installé]                             
3)     libpango1.0-dev [Non installé]                           
4)     libpixman-1-dev [Non installé]                           

Accepter cette solution ? [Y/n/q/?]

--------------------------------------------------------------------------------------
Je réponds Y et ça produit :

----------------------------------------------------------------------------------

Accepter cette solution ? [Y/n/q/?] Y
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.

---------------------------------------------------------------------------------
Pour info j'ai installé iceweasel 11.0 et je crois avoir vu passé des ~bpo60+1

Comment faire pour qu'aptitude tienne ses promesse smile

Merci.

Hors ligne

#2 02-04-2012 22:01:03

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : aptitude : propose mais n'installe pas

Salut

Tu as des versions plus récentes que celles qui se trouvent dans le dépôt stable pour les paquets libcairo2 et libpixman-1-0. Plus précisément, tu as celles présentes dans squeeze-backports. D'où les problèmes de dépendances non satisfaites. Si tu installes la version de libgtk2.0-dev qui se trouve dans ce même dépôt cela devrait aller.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

Pied de page des forums