Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 12-04-2012 08:20:36

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : installer un driver nvidia pour 2.6 : où trouver les bons paquets ?

tetrix a écrit :

...Ta carte a besoin du 295.33 ...
Oupps ! http://www.nvidia.fr/Download/indexsg.aspx?lang=fr


C'est le 295.40 qui convient.
Mais cette manip ne changera strictement rien pour le noyau 2.6.39 rien puis-qu’à l'installation du pilote, il va lancer le .run qui a besoin des sources du noyau et de ses headers pour compiler.

La seule possibilité d'utiliser cette méthode serait de l'appliquer au noyau 3.2 depuis une console, bien sûr.

Guppy88 a écrit :

Quant à l'autre version, ben j'hésite aussi à la casser encore une fois...


Tu as bien fait une troisième installation pour les essais ?

Dernière modification par paskal (12-04-2012 11:17:53)


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#27 12-04-2012 09:19:50

tetrix
Invité

Re : installer un driver nvidia pour 2.6 : où trouver les bons paquets ?

Je veux bien mais :

NVIDIA's Linux team this morning announced the immediate release of the 295.40 Linux driver. There aren't many changes for this release compared to the recent 295.33 driver release, but it does address a high-risk security vulnerability.

The official changes for the NVIDIA 295.40 Linux stable driver release include closing a security vulnerability where attackers could reconfigure GPUs to gain access to arbitrary system memory, fixes a bug causing DisplayPort devices to occasionally fail after suspend-and-resume, a new "AllowNon3DVisionModes" X configuration option, and support for two new GPUs. The newly-supported GPUs is the GeForce GT 610 and GeForce GT 635M.

The high-risk security vulnerability that was recently discovered is described in CVE-2012-0946. This issue came down to an issue whereby arbitrary system memory could be accessed because the default file permissions on the NVIDIA GPU device nodes allows for read/write access to all users. NVIDIA classified this issue as high-risk since the read/write access is needed in order to leverage NVIDIA GPU hardware acceleration whether it be for OpenGL, OpenCL, or VDPAU. Fortunately, NVIDIA quickly identified the root cause of the vulnerability and released this new driver.


http://www.phoronix.com/scan.php?page=n … px=MTA4NTk

http://nvidia.custhelp.com/app/answers/detail/a_id/3109

#28 12-04-2012 10:00:43

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : installer un driver nvidia pour 2.6 : où trouver les bons paquets ?

Oui, et après ?

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#29 12-04-2012 18:13:36

tetrix
Invité

Re : installer un driver nvidia pour 2.6 : où trouver les bons paquets ?

Et puis non.

#30 12-04-2012 21:24:26

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : installer un driver nvidia pour 2.6 : où trouver les bons paquets ?

Ce que je veux dire : 295.40 ou 295.33 ou n'importe quel autre, il faut bien au moins les headers, non ?
Ou Sean Connery ?

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#31 12-04-2012 22:30:09

tetrix
Invité

Re : installer un driver nvidia pour 2.6 : où trouver les bons paquets ?

#32 12-04-2012 23:07:19

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : installer un driver nvidia pour 2.6 : où trouver les bons paquets ?

tetrix a écrit :


Tu veux parler de la méthode indiquée ici ? hmm


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#33 12-04-2012 23:08:02

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Stretch 64 bits (en rade) +Jessie (en secours)
Noyau : Linux 4.2.0-1-amd64 + Linux 3.16.0-4-amd64
(G)UI : Gnome 3.18.2
Inscription : 07-01-2012

Re : installer un driver nvidia pour 2.6 : où trouver les bons paquets ?

tetrix a écrit :


tetrix tu peux écrire feignant ou fainéant, mais un mixte des deux ça n'existe pas

Ces trois lignes de code, elles sont au début de mon cahier , sur la deuxième page, et en face  il ya un commentaire ne fonctionne pas .
et une autre ligne 00 paquets installés. c'est donc une de mes premières tentatives.

Paskal
Oui, j'ai quatre install, dont deux cassées. Deux sur chaque disque.

Il me semble que j'ai réussi une fois à installer le noyau 3.2, mais je l'ai aussi cassé, tout comme actuellement, en essayant
ce que je croyais être une variante , mais au final c'est la même.
aptitude install nvidia-kernel-dkms nvidia-glx nvidia settings
puis aptitude install nvidia-xconfig
modifier le etc/X11/xprg.conf avec nano

et à la fin aptitude install linux headers-$(uname-r)

Ce que je n'arrive pas à comprendre c'est que la même install ne donne pas toujours le même résultat j'ai par exemple noté que  le nombre de fichiers chargés n'était jamais le même et à la fin d'une de mes installations je me suis même retrouvé avec un affichage  en 1980 X1080, qui n'a pas duré... au re-démarrage suivant l’affichage se faisait de nouveau en 1280 X1080
Je ré essaierai ce week end.
Guppy

Hors ligne

#34 12-04-2012 23:13:39

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : installer un driver nvidia pour 2.6 : où trouver les bons paquets ?

Oui c'est très déroutant, ces "variantes".
Mais il me semble que le noyau 3.2 est peut-être la meilleure piste pour progresser.

et à la fin aptitude install linux headers-$(uname-r)


Je verrai cette ligne plutôt au début (avant l'install de nvidia)


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#35 13-04-2012 08:34:54

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : installer un driver nvidia pour 2.6 : où trouver les bons paquets ?

Guppy88 a écrit :

Oui, j'ai quatre install, dont deux cassées. Deux sur chaque disque.


As-tu encore la version "custom" fonctionnelle, ou alors la possibilité de la réinstaller ?
As-tu la possibilité d'être sur IRC en parallèle à des essais en console (un autre PC serait commode) ?

Pour moi, ce week-end et la semaine suivante vont être un peu difficiles mais le week-end d'après, ça devrait aller pour te filer un coup de main.


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#36 13-04-2012 08:45:27

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Stretch 64 bits (en rade) +Jessie (en secours)
Noyau : Linux 4.2.0-1-amd64 + Linux 3.16.0-4-amd64
(G)UI : Gnome 3.18.2
Inscription : 07-01-2012

Re : installer un driver nvidia pour 2.6 : où trouver les bons paquets ?

@ paskal

Edit: j'ai oublié de te répondre, oui bien sûr que j'ai conservé le CD "Debian Bpo noyau 2.6.39.bpo.2-amd64". Tu penses bien c'est la seule qui aboutit à une confige fonctionnelle, avec un écran réduit certs, mais elle est parfaitement fonctionnelle sous ses autres aspects. C'est le CD que je réutilise comme base de départ.

Les autres version testing entre autres, ainsi que l'installation du noyau 3.2.0-0 bpo2-amd64 (souvent mais pas toujours pour lui) aboutissent au message 
INIT version 2.88 booting
starting the hotplug events dispatcher :udevd
synthesizing initial hotplugs envent ... done
Waiting for /dev to be fully populated


Après tout mes essais, je suis convaincu que tu as saisi dès le début  où se situait vraiment le problème, il est uniquement du à la disparition des headers pour la 2.6.39 etc...

J'ai d'ailleurs noté(c'est sur mon cahier) que l'une de mes tentatives faite avec module assistant, abouti en clair à
paquets binaires pour le(s) noyau(x) + 2.6.39-bpo.2-amd64 : non trouvé
et la commande search que j'ai tenté retourne  : Paquet ignoré. vous devez peut être ajouter quelque chose à sources list, comme "contrib" ou "non free"
Or elle(source-list) était bien configurée avec contrib et non free.

Il me faudrait le bon noyau avec les bons headers ; et c'est pour cela que je pense qu'une version Wheezy ou SID qui posséderait l'intégralité de ses paquets devrait fonctionner.
Je commence  même a douter qu'il soit possible de faire du pinning en mélangeant les paquets headers des versions 3.2 avec un noyau 2.6....

Je vais quand même tenter une réinstall en mod expert, avec un source.elist pré-configuré (en fait deux install l'une derrière l'autre), parce que j'ai vu quelque part que ce mode expert propose de choisir sa source... c'est peut être une idée bête! qu'en pensez vous ? Car cela va me prendre entre  45 et 50 minutes. je ne voudrais pas le faire pour rien.
Guppy

Dernière modification par Guppy88 (13-04-2012 09:04:14)

Hors ligne

#37 13-04-2012 16:53:29

misaine
Membre
Lieu : sables d'olonne
Distrib. : Antergos (Archlinux)
Noyau : 4.3.3
(G)UI : gnome-shell 3.18.2
Inscription : 29-07-2007

Re : installer un driver nvidia pour 2.6 : où trouver les bons paquets ?

j'utilise la méthode dkms depuis un bon moment sans souci
mais lors de la dernière maj il n'a pas été chercher le bon header (686-pae au lieu de 486)
de plus quand j'ai trouvé la solution je n'avais comme choix d'affichage que 640x480 (pas résolu) sad

amd phenom 7650 , 4 Go DDR2 ,GeForce N210

Hors ligne

#38 13-04-2012 19:51:55

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : installer un driver nvidia pour 2.6 : où trouver les bons paquets ?

misaine a écrit :

mais lors de la dernière maj il n'a pas été chercher le bon header (686-pae au lieu de 486)


Peut-être qu'ils étaient censés convenir ?

Guppy88 a écrit :

Les autres version testing entre autres, ainsi que l'installation du noyau 3.2.0-0 bpo2-amd64 (souvent mais pas toujours pour lui) aboutissent au message 
I[i]NIT version 2.88 booting
starting the hotplug events dispatcher :udevd
synthesizing initial hotplugs envent ... done
Waiting for /dev to be fully populated[/i


Oui, si il y a un problème à l'installation d'un périphérique, tu peux attendre jusqu'à dix minutes !
On peut tenter de contourner ça pour terminer le boot sans attendre.

Il faut d'abord, en root, faire une copie de sauvegarde de /etc/init.d/udev : # cp /etc/init.d/udev /etc/init.d/udev.bck
Puis modifier ce fichier udev : # nano /etc/init.d/udev
le bloc à partir de la ligne 274 chez moi :

    # wait for the udevd childs to finish
    log_action_begin_msg "Waiting for /dev to be fully populated"
    if udevadm settle; then
  log_action_end_msg 0
    else
  log_action_end_msg 0 'timeout'
    fi
    ;;


en ajoutant une tempo timeout=3

# wait for the udevd childs to finish
  log_action_begin_msg "Waiting for /dev to be fully populated"
  if udevadm settle --timeout=3 ; then
  log_action_end_msg 0
  else
  log_action_end_msg 0 'timeout'
  fi
  ;;


Mais jamais testé. neutral


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#39 14-04-2012 23:44:24

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Stretch 64 bits (en rade) +Jessie (en secours)
Noyau : Linux 4.2.0-1-amd64 + Linux 3.16.0-4-amd64
(G)UI : Gnome 3.18.2
Inscription : 07-01-2012

Re : installer un driver nvidia pour 2.6 : où trouver les bons paquets ?

Guppy88 a écrit :

Les autres version testing entre autres, ainsi que l'installation du noyau 3.2.0-0 bpo2-amd64 (souvent mais pas toujours pour lui) aboutissent au message 
......
Waiting for /dev to be fully populated|


paskal  arépondu |

Oui, si il y a un problème à l'installation d'un périphérique, tu peux attendre jusqu'à dix minutes !
On peut tenter de contourner ça pour terminer le boot sans attendre.|


Je l'ai laissé plus d'une heure et il attendais toujours.....
Ben oui, mais comme cette version ne veut pas s'ouvrir, coment fait on pour  modifier ses fichiers ?
En mode réparation ?
J'ai préparé le fichier  pour le pining et construit le fichier préférences pour une autre version encore en état
En tout cas le aptitude update  effctué juste après a déjà installé un paquets de paquets supplémentaires.
Mais  j'hésite encore à lancer la modif.

Alors pour passer le temps, j'ai tenté de graver un disque Wheezy,  ultra long 50 minutes de téléchargement et 7 minutes de gravure , pour aboutir au message... Il  y a eu une erreur sur le disque, j'ai quand même essayé, mais il ne fonctionne pas.
J'ai alors essayé avec un petit, pour une net install, à peine une seconde de téléchargement , bien plus long pour graver et message il y a eu une erreur sur le disque. Il est dit que je n'y arriverais pas...
Guppy

PS j'ai vu, dans ce forum, qu'il ya un magazine DEbain  qui venait de sortir avec un CD ou DVD pour installer une des dernières versions,  Y aurait il des chances pour que le CD possède les fameux headers ?

Dernière modification par Guppy88 (14-04-2012 23:45:42)

Hors ligne

#40 16-04-2012 18:44:35

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : installer un driver nvidia pour 2.6 : où trouver les bons paquets ?

Oui, tu pourras modifier le fichier en mode réparation si tu arrives jusqu'à la console.
Ou sinon en bootant sur un noyau  2.6., si tu en as un disponible.

Pour le pinning, je ne peux t'être d'aucun secours car je n'ai pas encore pratiqué ce sport là. smile

Avant de graver un disque, n'oublie pas de vérifier les sommes de contrôle du fichier téléchargé : md5sum ou sha1 par exemple.

Je ne suis pas au courant de ce qui sort en magazine prochainement.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#41 16-04-2012 20:39:03

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Stretch 64 bits (en rade) +Jessie (en secours)
Noyau : Linux 4.2.0-1-amd64 + Linux 3.16.0-4-amd64
(G)UI : Gnome 3.18.2
Inscription : 07-01-2012

Re : installer un driver nvidia pour 2.6 : où trouver les bons paquets ?

tetrix a écrit :

Si tu fais la modif de ton sources.list, tu fais un fichier préférences, tu installes (aptitude install -t ) tu auras le paquet (les paquets) dont tu as besoin sans passé par une autre version...


Mon fichier sources list est modifié et j'ai recopié ligne par ligne, le fichier préférences. Les sources ont été mises à jour.

J'ai essayé aptitude install -t, mais cela n'a pas fonctionné, les instructions de cette commande, indiquent que pour l'argument -t[dis] il faut indiquer la distribution pour laquelle le paquet doit être installé.

Je ne comprends pas pourquoi il faut construire un fichier préférence, s'il faut lui passer un argument précisant la distribution. J'avais cru comprendre que c'était précisément le rôle du fichier préférences de choisir automatiquement.

Il me reste donc encore à choisir ce que je vais mettre au bout de la commande aptitude install, il lui faut le nom du fichier ?

J'essaye et je reviens donner des nouvelles.

Guppy

Hors ligne

#42 16-04-2012 20:56:11

bel@mi
Membre
Distrib. : Stable (bpo)
Inscription : 14-04-2012

Re : installer un driver nvidia pour 2.6 : où trouver les bons paquets ?

Hors ligne

#43 16-04-2012 21:34:47

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : installer un driver nvidia pour 2.6 : où trouver les bons paquets ?

Guppy88 a écrit :

Il me reste donc encore à choisir ce que je vais mettre au bout de la commande aptitude install, il lui faut le nom du fichier ?


Comme dirait un gourmet connu :
C'est pas dans le wiki ? Nan ? Et si ! http://debian-facile.org/manuel:commande_aptitude

L'est pas belle la vie ?

Tchibaaaaaaaaaaaaaaaaaa big_smile

Heu ? Copyleft ? tongue


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#44 19-04-2012 10:53:28

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : installer un driver nvidia pour 2.6 : où trouver les bons paquets ?

Guppy88 a écrit :

Les autres version testing entre autres, ainsi que l'installation du noyau 3.2.0-0 bpo2-amd64 (souvent mais pas toujours pour lui) aboutissent au message 
I[i]NIT version 2.88 booting
starting the hotplug events dispatcher :udevd
synthesizing initial hotplugs envent ... done
Waiting for /dev to be fully populated[/i


Une autre idée : à l'installation du noyau, tu n'as pas eu un message du genre W: Possible missing firmware ...  ?


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#45 22-04-2012 09:24:44

frenesik
Invité

Re : installer un driver nvidia pour 2.6 : où trouver les bons paquets ?

Salut Guppy88,
Où en es tu alors dans cette installation du driver nvidia? La version 295.40 du pilote est sorti, et après installation cela à l'air bien fonctionner. Tiens nous au jus pour savoir ou tu en es wink et si tu as besoin d'aide.

#46 24-04-2012 17:38:00

Guppy88
Membre
Lieu : Rambervillers Vosges
Distrib. : Stretch 64 bits (en rade) +Jessie (en secours)
Noyau : Linux 4.2.0-1-amd64 + Linux 3.16.0-4-amd64
(G)UI : Gnome 3.18.2
Inscription : 07-01-2012

Re : installer un driver nvidia pour 2.6 : où trouver les bons paquets ?

Je crois que je suis saturé, je n'ai rien tenté depuis mon dernier message. C'est abandonné pour l'instant.
J'en suis arrêté à la création d'un fichier préférence comme tu me l'avais proposé et je ne sais plus quel autre fichier.
Guppy

Hors ligne

Pied de page des forums