Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-04-2012 02:52:56

aramis_qc
Membre
Lieu : Québec, Canada
Distrib. : JESSIE
Noyau : Linux 3.16.0-4-amd64
(G)UI : GNOME 3.14.1
Inscription : 09-06-2007
Site Web

Impossible installer SID... debootstrap error (libept1)

Le tout est dû à libept1 qui dépend de libapt-pkg4.10 (4.12 aussi).

Comment fait-on pour suivre le développement de la solution ? Dois-je télécharger à l'infini business.card tant et aussi longtemps que le problème n'est pas corrigé ?

Hors ligne

#2 27-04-2012 08:43:26

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : Impossible installer SID... debootstrap error (libept1)

-1- Installer Wheezy
-2- Upgrader vers sid.

Vouloir installer sid directement, c'est de la grande voltige, on maximise les chances que ça ne fonctionne pas.

À l'upgrade, garder les sources des 2, comme ça s'il y a un soucis, on ne casse pas de dépendance.

Une fois bien installée, utiliser 2 versions : sid+experimental ou sid+wheezy, comme ça on est moins planté quand il manque quelque chose.

Après c'est au cas par cas, toujours faire "safe-upgrade" (j'utilise aptitude) et réserver "full-upgrade" à chaque paquet au cas par cas après avoir bien lu les messages et en n'hésitant pas à tester avant d'installer ( -s ).

Sid tourne très vite, inutile de s'enquiquiner à résoudre des choses qui vont avoir changé dans les quelques heures ou jours qui suivent. Forcer les installation apporte plus d'ennuis que de solutions.

Avec ça c'est très utilisable pour un usage personnel, sauf avec une mauvaise connexion à cause de la quantité de mises à jour.

« Un optimiste, explique Raymond Aubrac, n’est pas un être satisfait, content de la situation actuelle. C’est quelqu’un qui pense qu’il peut faire quelque chose qui servira. »

Hors ligne

#3 27-04-2012 08:54:17

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Impossible installer SID... debootstrap error (libept1)

Ah trop bien tout ça, c'est mis dans le wiki pour sid là :
http://debian-facile.org/doc:systeme:ap … stallation

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#4 27-04-2012 13:46:08

aramis_qc
Membre
Lieu : Québec, Canada
Distrib. : JESSIE
Noyau : Linux 3.16.0-4-amd64
(G)UI : GNOME 3.14.1
Inscription : 09-06-2007
Site Web

Re : Impossible installer SID... debootstrap error (libept1)

Merci à vous deux. C'est bien ce à quoi j'avais pensé. Je cherchais à savoir s'il y avait moyen de suivre l'évolution de SID au niveau des correctifs.

Je suis un utilisateur de aptitude. Aucun problème avec ça.

Je remarque que vous recommandez un safe-upgrade et faire du full-upgrade cas par cas. Mais comment applique-t-on un full-upgrade cas par cas ?Il me semble qu'on met tout le système à jour d'un coup avec full-upgrade.

Quand on met un système à jour en restant dans la même version, c'est safe-upgrade... mais pour passer de stable à testing ou de testing à stable, c'est full-upgrade... non ?

Hors ligne

#5 27-04-2012 14:44:54

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Impossible installer SID... debootstrap error (libept1)

comment applique-t-on un full-upgrade cas par cas ?


Avec l'option simuler :

aptitude -s full-upgrade


Puis, en lisant les mises à jour avec safe-upgrade pour tel ou tel et pas tel autre...
Voir :
http://debian-facile.org/manuel:commande_aptitude


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#6 27-04-2012 14:54:06

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : Impossible installer SID... debootstrap error (libept1)

Je remarque que vous recommandez un safe-upgrade et faire du full-upgrade cas par cas. Mais comment applique-t-on un full-upgrade cas par cas ?Il me semble qu'on met tout le système à jour d'un coup avec full-upgrade.


Ben facile :

aptitude full-upgrade le_paquet_a_mettre_a_jour


safe-upgrade préserve un maximum la version installée de la distrib et les paquets fixées, full-upgrade met les paquets et dépendances à jour, même si elles sont fixées ou sont d'une version supérieure (quand on a les sources de plusieurs versions). Ceci est vrai pour les paquets individuellement ou pour tous les paquets à mettre à jours si on ne précise rien.

Dernière modification par Haricophile (27-04-2012 14:54:57)


« Un optimiste, explique Raymond Aubrac, n’est pas un être satisfait, content de la situation actuelle. C’est quelqu’un qui pense qu’il peut faire quelque chose qui servira. »

Hors ligne

#7 27-04-2012 17:03:20

Ghost
Membre
Distrib. : Stable/SID
Noyau : 3.13 Amd 64
(G)UI : Gnome Shell
Inscription : 26-03-2012
Site Web

Re : Impossible installer SID... debootstrap error (libept1)

aramis_qc a écrit :

Le tout est dû à libept1 qui dépend de libapt-pkg4.10 (4.12 aussi).

Comment fait-on pour suivre le développement de la solution ? Dois-je télécharger à l'infini business.card tant et aussi longtemps que le problème n'est pas corrigé ?


Salut, j'ai eu le meme soucis que toi, la seule solution c'est d'installer Whezzy et de modifier ton sources Lists en SID et après un coup de console

apt-get update


apt-get upgrade


et pour finir :

apt-get dist-upgrade


Et tu seras en SID en patientant un tout petit peu cool

Hors ligne

#8 27-04-2012 18:30:58

hector
Membre
Distrib. : Debian Testing/Sid
Noyau : 4.7.0-1-amd64
(G)UI : KDE Plasma 5
Inscription : 13-12-2011

Re : Impossible installer SID... debootstrap error (libept1)

Salut,

A ce propos je me permets de rappeler que pour éviter d'installer un paquet avec un bug grave, ce qui arrive de temps en temps en Sid, il est recommandé et même indispensable d'installer: apt-listbugs.
http://debian-facile.org/doc:systeme:apt:apt-listbugs
cool

Hors ligne

#9 27-04-2012 19:30:49

Ghost
Membre
Distrib. : Stable/SID
Noyau : 3.13 Amd 64
(G)UI : Gnome Shell
Inscription : 26-03-2012
Site Web

Re : Impossible installer SID... debootstrap error (libept1)

Exact , merci d'avoir compléter wink

Hors ligne

#10 27-04-2012 20:16:26

phreg
Membre
Distrib. : Antix MX-15
Noyau : 4.3-0-liquorix-686
(G)UI : Xfce 4.12
Inscription : 02-04-2011

Re : Impossible installer SID... debootstrap error (libept1)

Bonjour et content de voir que ce problème est réglé.
Avec Debian, j'ai toujours suivi la méthode d'install ancienne version mode minimal texte puis passage vers le récent sans problème.
Ça semble confirmer, car la seule fois où j'ai essayé de faire plus vite j'ai aussi vu cette erreur "debootstrap" et dû recommencer pour que ça passe.

Hors ligne

#11 28-04-2012 01:38:52

aramis_qc
Membre
Lieu : Québec, Canada
Distrib. : JESSIE
Noyau : Linux 3.16.0-4-amd64
(G)UI : GNOME 3.14.1
Inscription : 09-06-2007
Site Web

Re : Impossible installer SID... debootstrap error (libept1)

Bon... un peu long comme procédé car il faut analyser la sortie d'une simulation de full-upgrade, mais c'est vraiment sécuritaire. Au final je ne crois pas qu'il y ait tant de paquets à mettre à jour avec le full-upgrade individuel.

Allons voir ce que ça donne !

À bientôt !

Hors ligne

#12 29-04-2012 02:05:09

aramis_qc
Membre
Lieu : Québec, Canada
Distrib. : JESSIE
Noyau : Linux 3.16.0-4-amd64
(G)UI : GNOME 3.14.1
Inscription : 09-06-2007
Site Web

Re : Impossible installer SID... debootstrap error (libept1)

Finalement je n'ai point besoin de SID. En Wheezy, GNOME3.2 est disponible.

J'avais besoin d'une Debian avec cette nouvelle mouture de GNOME afin de démontrer que Unity n'est pas essentiel.

Je n'enlève rien à Canonical et  Ubuntu, mais Debian c'est le nec plus ultra.

Hors ligne

Pied de page des forums