Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-04-2012 08:52:54

wetaskiwin
Membre
Lieu : Ile de France
Distrib. : Sid
(G)UI : KDE
Inscription : 18-03-2012

[Résolu] Problème avec apt-listbugs

Bonjour,

J'ai un souci avec ma Sid KDE Amd64 sur laquelle j'ai installé apt-listbugs. Lors des mises à jour avec aptitude, après le téléchargement des paquets, je ne peux pas aller au delà de

142 Mo téléchargés en 41s (3 411 ko/s)                                                                                      
/usr/lib/ruby/vendor_ruby/locale.rb:239:in `collect_candidates': undefined method `size' for nil:NilClass (NoMethodError)
        from /usr/lib/ruby/vendor_ruby/locale.rb:222:in `candidates'
        from /usr/lib/ruby/1.8/gettext/runtime/textdomain_manager.rb:78:in `each_textdomains'
        from /usr/lib/ruby/1.8/gettext/runtime/textdomain_manager.rb:102:in `translate_singluar_message'
        from /usr/lib/ruby/1.8/gettext.rb:128:in `_'
        from /usr/share/apt-listbugs/apt-listbugs/logic.rb:324
        from /usr/sbin/apt-listbugs:258:in `require'
        from /usr/sbin/apt-listbugs:258
E: Le sous-processus /usr/sbin/apt-listbugs apt || exit 10 a renvoyé un code d'erreur (10)
E: Failure running script /usr/sbin/apt-listbugs apt || exit 10
Échec de l'installation d'un paquet. Tentative de réparation :


J'ai fait un essai avec apt-get update mais ce n'est pas mieux.

Après recherche, j'ai trouvé une solution qui consiste à éditer /etc/apt/apt.conf.d/10apt-listbugs

// Check all packages whether they has critical bugs before they are installed.
// If you don't like it, comment it out.
DPkg::Pre-Install-Pkgs {"/usr/sbin/apt-listbugs apt || exit 10";};
DPkg::Tools::Options::/usr/sbin/apt-listbugs "";
DPkg::Tools::Options::/usr/sbin/apt-listbugs::Version "2";
// AptListbugs::IgnoreRegexp "FTBFS";


et à commenter la ligne  DPkg::Pre-Install-Pkgs {"/usr/sbin/apt-listbugs apt || exit 10";};
Mais, dans ce cas, je perds le bénéfice d'apt-listbugs et j'hésite à me lancer.

Avez-vous déjà eu ce problème et, si oui, y a-t-il un moyen moins radical de m'en sortir ?

Merci

Dernière modification par wetaskiwin (27-04-2012 10:57:17)

Hors ligne

#2 27-04-2012 10:31:44

hector
Membre
Distrib. : Debian Testing/Sid
Noyau : 4.7.0-1-amd64
(G)UI : KDE Plasma 5
Inscription : 13-12-2011

Re : [Résolu] Problème avec apt-listbugs

Bonjour wetaskiwin,

J'ai eu aussi ce problème depuis quelques jours et pas facile de trouver une solution. Mais depuis ce matin c'est réglé par moi.
J'ai pu installer les paquets :

# apt-cache policy ruby-locale
ruby-locale:
  Installé : 2.0.5-4                                                                                                                                  
  Candidat : 2.0.5-4                                                                                                                                  
 Table de version :                                                                                                                                  
 *** 2.0.5-4 0
        500 http://ftp.fr.debian.org/debian/ sid/main amd64 Packages
        100 /var/lib/dpkg/status


et

# apt-cache policy liblocale-ruby1.8
liblocale-ruby1.8:
  Installé : 2.0.5-4
  Candidat : 2.0.5-4
 Table de version :
 *** 2.0.5-4 0
        500 http://ftp.fr.debian.org/debian/ sid/main amd64 Packages
        100 /var/lib/dpkg/status
     2.0.5-2 0
        500 http://ftp.fr.debian.org/debian/ squeeze/main amd64 Packages
        500 http://ftp.fr.debian.org/debian/ wheezy/main amd64 Packages
        500 http://ftp.fr.debian.org/debian/ sid/main amd64 Packages


Si cela ne passe pas il faudrait peut-être regarder dans ton fichier preferences pour vérifier s'il n'y aurait pas des pins à propos de ruby-locale ou liblocale-ruby1.8

@+

Dernière modification par hector (27-04-2012 10:33:09)

Hors ligne

#3 27-04-2012 10:55:09

wetaskiwin
Membre
Lieu : Ile de France
Distrib. : Sid
(G)UI : KDE
Inscription : 18-03-2012

Re : [Résolu] Problème avec apt-listbugs

Même apt-cache policy grognait

apt-cache policy ruby-locale
ruby-locale:
  Installé : 2.0.5-3
  Candidat : 2.0.5-4
 Table de version :
     2.0.5-4 0
        500 http://ftp.fr.debian.org/debian/ sid/main amd64 Packages
 *** 2.0.5-3 0
        100 /var/lib/dpkg/status
N: « 10apt-listbugs.backup » dans le répertoire « /etc/apt/apt.conf.d/ » a été ignoré car il utilise une extension non valable


Même chose pour liblocale-ruby1.8.

J'ai donc commenté la ligne DPkg::Pre-Install-Pkgs {"/usr/sbin/apt-listbugs apt || exit 10";} dans /etc/apt/apt.conf.d/10apt-listbugs, mis à jour seulement ruby-locale et liblocale-ruby1.8 puis remis /etc/apt/apt.conf.d à l'état initial.

J'ai ensuite pu relancer aptitude safe-upgrade qui est passé comme une lettre à la poste et sur des roulettes. Impeccable !
Debian-Facile... le nom est très bien choisi. big_smile

Merci.

Hors ligne

#4 27-04-2012 11:13:57

hector
Membre
Distrib. : Debian Testing/Sid
Noyau : 4.7.0-1-amd64
(G)UI : KDE Plasma 5
Inscription : 13-12-2011

Re : [Résolu] Problème avec apt-listbugs

C'était avec plaisir ! smile
Debian-Facile est un nom très bien choisi, c'est vrai, et d'autant plus quand ce sont des gens aimables et sympathiques qui l'animent !
wink

Hors ligne

#5 27-04-2012 11:23:39

wetaskiwin
Membre
Lieu : Ile de France
Distrib. : Sid
(G)UI : KDE
Inscription : 18-03-2012

Re : [Résolu] Problème avec apt-listbugs

hector a écrit :

C'était avec plaisir ! smile
Debian-Facile est un nom très bien choisi, c'est vrai, et d'autant plus quand ce sont des gens aimables et sympathiques qui l'animent !;)


Je ne suis pas inscrite depuis bien longtemps et je ne suis pas très bavarde mais tu as tout à fait raison. Une pause au calme quand je commence à me perdre dans toutes les questions que je me pose à propos de Debian, ça ne peut pas faire de mal. wink

Hors ligne

Pied de page des forums