Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-05-2012 17:36:37

005flyof
Membre
Distrib. : Debian Sid
Noyau : Linux 4.5.0-2-amd64
(G)UI : Gnome 3.20
Inscription : 21-02-2011

[Résolu] Impossible d'installer gnome-shell-extensions

Bonjour,

Je n'arrive pas à installer gnome-shell-extension :

root@005flyof:/home/005flyof# aptitude install gnome-shell-extensions
Les NOUVEAUX paquets suivants vont être installés :
  gnome-shell-extensions
0 paquets mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o/89,9 ko d'archives. Après dépaquetage, 677 ko seront utilisés.
(Lecture de la base de données... 126730 fichiers et répertoires déjà installés.)
Dépaquetage de gnome-shell-extensions (à partir de .../gnome-shell-extensions_3.2.3-1_all.deb) ...
dpkg : erreur de traitement de /var/cache/apt/archives/gnome-shell-extensions_3.2.3-1_all.deb (--unpack) :
tentative de remplacement de « /usr/share/locale/fr/LC_MESSAGES/gnome-shell-extensions.mo », qui appartient aussi au paquet gnome-shell-extension-common 3.0.2-2
configured to not write apport reports
                                      Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/gnome-shell-extensions_3.2.3-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de réparation :
                                             
root@005flyof:/home/005flyof#


Pouvez-vous m'aider ?

Merci d'avance

Dernière modification par 005flyof (12-05-2012 11:28:34)

Hors ligne

#2 05-05-2012 19:44:06

bract
Modérateur
Lieu : Pays du kiwi
Distrib. : wheezy
Noyau : 3.2.0-3 amd64
(G)UI : gnome 3.4.2 + lxde(eeepc)
Inscription : 05-02-2011

Re : [Résolu] Impossible d'installer gnome-shell-extensions

bonjour 005flyof

regarde ici:
http://doc.ubuntu-fr.org/probleme_apt
chapitre 4

si cela peut résoudre ton problème wink

L'asso est lancée. cool
La connaissance s'acquiert par l'expérience, tout le reste n'est que de l'information.[Albert Einstein]

Hors ligne

#3 06-05-2012 09:12:11

005flyof
Membre
Distrib. : Debian Sid
Noyau : Linux 4.5.0-2-amd64
(G)UI : Gnome 3.20
Inscription : 21-02-2011

Re : [Résolu] Impossible d'installer gnome-shell-extensions

J'ai essayé ça, mais le fichier dont ils parlent n'existe pas !

Une autre idée ?

Hors ligne

#4 06-05-2012 15:39:33

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu] Impossible d'installer gnome-shell-extensions

On dirait bien qu'il y a un bogue avec ce paquet. Des utilisateurs de gnome, ayant une testing ou un sid, pourrait confirmer si c'est le cas ou non.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#5 07-05-2012 18:25:17

misaine
Membre
Lieu : sables d'olonne
Distrib. : Antergos (Archlinux)
Noyau : 4.3.3
(G)UI : gnome-shell 3.18.2
Inscription : 29-07-2007

Re : [Résolu] Impossible d'installer gnome-shell-extensions

gnome-shell-extension-common 3.0.2-2


d'où vient ce paquet qui n'appartient ni a wheezy ni a sid ?
ton installation était-elle a jour avant d'installer un nouveau paquet


amd phenom 7650 , 4 Go DDR2 ,GeForce N210

Hors ligne

#6 07-05-2012 20:36:55

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu] Impossible d'installer gnome-shell-extensions

Il a probablement suivi un tuto quelconque. Si on fait une recherche avec gnome-shell-extension-common 3.0.2-2, on arrive, par exemple, sur cette page qui nous amène vers ce dépôt tiers (à moins que ce soit un .deb pour buntu). Le mieux à faire, selon moi, c'est de ne pas utiliser ce paquet pris ailleurs, donc de le désinstaller, puis d'y aller avec les paquets debian officiels. Les paquets tiers ne doivent pas être empaquetés de la même façon que ceux des dépôts officiels, d'où le problème rencontré.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#7 09-05-2012 20:27:03

005flyof
Membre
Distrib. : Debian Sid
Noyau : Linux 4.5.0-2-amd64
(G)UI : Gnome 3.20
Inscription : 21-02-2011

Re : [Résolu] Impossible d'installer gnome-shell-extensions

Le système était à jour.

J'ai voulu utiliser ce paquet, même si'l n'appartient pas aux dépots officiels de débian, parce que je n'ai pas trouvé l'équivalent dans les dépots officiels...

Quelqu'un a une idée pour pouvoir personnaliser gnome 3 autrement ?

Hors ligne

#8 09-05-2012 23:12:57

misaine
Membre
Lieu : sables d'olonne
Distrib. : Antergos (Archlinux)
Noyau : 4.3.3
(G)UI : gnome-shell 3.18.2
Inscription : 29-07-2007

Re : [Résolu] Impossible d'installer gnome-shell-extensions

oui! en utilisant les extensions compatibles avec ta version de gnome-shell

amd phenom 7650 , 4 Go DDR2 ,GeForce N210

Hors ligne

#9 10-05-2012 07:24:16

005flyof
Membre
Distrib. : Debian Sid
Noyau : Linux 4.5.0-2-amd64
(G)UI : Gnome 3.20
Inscription : 21-02-2011

Re : [Résolu] Impossible d'installer gnome-shell-extensions

Effectivement, je n'avais pas pensé à cela !!

Merci beaucoup !

Je vais chercher ces extensions !

Hors ligne

#10 10-05-2012 13:43:00

misaine
Membre
Lieu : sables d'olonne
Distrib. : Antergos (Archlinux)
Noyau : 4.3.3
(G)UI : gnome-shell 3.18.2
Inscription : 29-07-2007

Re : [Résolu] Impossible d'installer gnome-shell-extensions


amd phenom 7650 , 4 Go DDR2 ,GeForce N210

Hors ligne

#11 10-05-2012 15:08:39

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : [Résolu] Impossible d'installer gnome-shell-extensions

Chez moi le paquet marche en wheezy, mais +1 pour le dépôt
https://extensions.gnome.org/
qui marche parfaitement (contrairement à celui de Fedora qui exige gnome 3.4)

« La religion et l'art sont les luxes des lâches, qui permettent de fuir la réalité quand elle devient trop difficile à affronter. La différence c'est que la religion transforme tout mensonge en vérité alors que l'art transforme toute vérité en mensonge. »

Hors ligne

#12 10-05-2012 16:14:10

misaine
Membre
Lieu : sables d'olonne
Distrib. : Antergos (Archlinux)
Noyau : 4.3.3
(G)UI : gnome-shell 3.18.2
Inscription : 29-07-2007

Re : [Résolu] Impossible d'installer gnome-shell-extensions

c'est le même , mais faut pas brûler les étapes , si tu reste en F16 il fonctionne wink

amd phenom 7650 , 4 Go DDR2 ,GeForce N210

Hors ligne

#13 10-05-2012 18:57:37

bract
Modérateur
Lieu : Pays du kiwi
Distrib. : wheezy
Noyau : 3.2.0-3 amd64
(G)UI : gnome 3.4.2 + lxde(eeepc)
Inscription : 05-02-2011

Re : [Résolu] Impossible d'installer gnome-shell-extensions

Bonjour smile

pour info depuis hier soir c'est gnome 3.4.1 sur wheezy.
le site https://extensions.gnome.org/ reste fonctionnel cool

L'asso est lancée. cool
La connaissance s'acquiert par l'expérience, tout le reste n'est que de l'information.[Albert Einstein]

Hors ligne

#14 10-05-2012 19:20:50

misaine
Membre
Lieu : sables d'olonne
Distrib. : Antergos (Archlinux)
Noyau : 4.3.3
(G)UI : gnome-shell 3.18.2
Inscription : 29-07-2007

Re : [Résolu] Impossible d'installer gnome-shell-extensions

oui mais gnome-shell est toujours en 3.2

amd phenom 7650 , 4 Go DDR2 ,GeForce N210

Hors ligne

#15 10-05-2012 19:30:48

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : [Résolu] Impossible d'installer gnome-shell-extensions

Misaine, ne soit pas trop pressé que ça se plante tongue:P:P

« La religion et l'art sont les luxes des lâches, qui permettent de fuir la réalité quand elle devient trop difficile à affronter. La différence c'est que la religion transforme tout mensonge en vérité alors que l'art transforme toute vérité en mensonge. »

Hors ligne

#16 10-05-2012 19:37:00

bract
Modérateur
Lieu : Pays du kiwi
Distrib. : wheezy
Noyau : 3.2.0-3 amd64
(G)UI : gnome 3.4.2 + lxde(eeepc)
Inscription : 05-02-2011

Re : [Résolu] Impossible d'installer gnome-shell-extensions

Précision importante, on fait trop facilement l'amalgame entre gnome et gnome-shell
merci misaine;)

L'asso est lancée. cool
La connaissance s'acquiert par l'expérience, tout le reste n'est que de l'information.[Albert Einstein]

Hors ligne

#17 10-05-2012 20:23:27

misaine
Membre
Lieu : sables d'olonne
Distrib. : Antergos (Archlinux)
Noyau : 4.3.3
(G)UI : gnome-shell 3.18.2
Inscription : 29-07-2007

Re : [Résolu] Impossible d'installer gnome-shell-extensions

Haricophile a écrit :

Misaine, ne soit pas trop pressé que ça se plante tongue:P:P


je risque rien, je suis sur CUT cool


amd phenom 7650 , 4 Go DDR2 ,GeForce N210

Hors ligne

#18 10-05-2012 22:51:04

Blacksad
Membre
Lieu : Le Havre gris
Distrib. : Stable
Inscription : 03-05-2012

Re : [Résolu] Impossible d'installer gnome-shell-extensions

misaine a écrit :

Haricophile a écrit :

Misaine, ne soit pas trop pressé que ça se plante tongue:P:P


je risque rien, je suis sur CUT cool


Ha cool smile

Est-ce que tu parles de ton expérience sous CUT quelque part sur ce forum ou sur le net ? (je suis nouveau ici et tu te doutes bien que je n'ai pas lu tout l'historique du forum ^^)

J'ai découvert il y'a quelque temps et ça me dépanne bien quand je recherche une version précise d'un paquet mais pour ce qui es de l'usage quotidien je n'ai jamais testé.

Dernière modification par Blacksad (10-05-2012 22:52:57)

Hors ligne

#19 11-05-2012 06:22:57

misaine
Membre
Lieu : sables d'olonne
Distrib. : Antergos (Archlinux)
Noyau : 4.3.3
(G)UI : gnome-shell 3.18.2
Inscription : 29-07-2007

Re : [Résolu] Impossible d'installer gnome-shell-extensions

je fais court pour ne pas polluer , c'est un snapshot de wheezy où on est a l'abri de la casse et où on a pas à faire les maj tous les matins .j'en suis très satisfait.

Dernière modification par misaine (11-05-2012 06:26:40)


amd phenom 7650 , 4 Go DDR2 ,GeForce N210

Hors ligne

#20 11-05-2012 07:38:45

005flyof
Membre
Distrib. : Debian Sid
Noyau : Linux 4.5.0-2-amd64
(G)UI : Gnome 3.20
Inscription : 21-02-2011

Re : [Résolu] Impossible d'installer gnome-shell-extensions

Alors, j'ai essayé d'aller voir sur le site dont vous m'avez parlé, j'y arrive, mais aucune extensions ne s'affiche (compatible avec ma version)...
J'ai alors essayé de l'ajouter au fichier

comment faut-il faire ?

désolé, mais je ne fais que commencer à utiliser debian !

Hors ligne

#21 11-05-2012 20:01:48

Blacksad
Membre
Lieu : Le Havre gris
Distrib. : Stable
Inscription : 03-05-2012

Re : [Résolu] Impossible d'installer gnome-shell-extensions

A ce stade, donnes nous les versions de tes paquets avec un:

apt-cache policy gnome-shell
apt-cache policy gnome-shell-extensions


Si tu as toujours ton gnome-shell-extension-common 3.0.2-2, commences par un remove de ce paquet.

Hors ligne

#22 12-05-2012 11:25:31

005flyof
Membre
Distrib. : Debian Sid
Noyau : Linux 4.5.0-2-amd64
(G)UI : Gnome 3.20
Inscription : 21-02-2011

Re : [Résolu] Impossible d'installer gnome-shell-extensions

Alors, j'ai les versions à jour !

En fait, je suis un vrai andouille : toutes les extensions sont installées, c'est juste que j'avais pas démarré le gnome 3, j'étais en gnome classic !

Voici ce que me donne les commandes demandées :

root@005flyof:/home/005flyof# apt-cache policy gnome-shell
gnome-shell:
  Installé : 3.2.2.1-2
  Candidat : 3.2.2.1-2
Table de version :
*** 3.2.2.1-2 0
        500 http://ftp.fr.debian.org/debian/ wheezy/main amd64 Packages
        100 /var/lib/dpkg/status
root@005flyof:/home/005flyof# apt-cache policy gnome-shell-extensions
gnome-shell-extensions:
  Installé : 3.2.3-1
  Candidat : 3.2.3-1
Table de version :
*** 3.2.3-1 0
        500 http://ftp.fr.debian.org/debian/ wheezy/main amd64 Packages
        100 /var/lib/dpkg/status


En fait, je n'arrivait pas à le démarrer (pilote de la CG libre) et depuis que je l'ai installé (le pilote non-libre), tout marche à merveille !

Merci à tous !

Dernière modification par 005flyof (12-05-2012 11:28:13)

Hors ligne

Pied de page des forums