Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 15-05-2012 11:46:14

aticus
Membre
Distrib. : Debian squeeze 32 bits.
Inscription : 12-05-2012

Affichage large | Que faire?

Je viens d'installer Debian Squeeze en dual boot avec Windows7.
Mon problème et que j'ai une résolution assez large avec le pilote par défaut qui est nouveau si j'ai bien compris.

Je vous mets un aperçu :

1337074710.png

Je précise que j'ai déjà été voir dans configuration du système / affichage / taille : 1280 * 1024.

Donc mes question sont les suivantes :

Que dois-je faire pour régler cela ?

Faut-il envisager d'installer le pilote propriétaire de la carte graphique ?

Si oui quel démarche je dois adopter sachant que ma carte graphique est une intel?

Je vous mets le détails ci-dessous.

1337074485.png

Merci d'avance de votre aide.

Hors ligne

#2 15-05-2012 12:38:52

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Affichage large | Que faire?

Bonjour,
Tu peux installer xrandr pour tester les différentes résolutions et choisir celle qui te convient.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#3 15-05-2012 12:54:56

aticus
Membre
Distrib. : Debian squeeze 32 bits.
Inscription : 12-05-2012

Re : Affichage large | Que faire?

Bonjour paskal

Je ne trouve pas comment installer xandr :

root@aticus-pc:/home/aticus# apt-get install xrandr
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Aucune version du paquet xrandr n'est disponible, mais il existe dans la base                                                                                                      
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète                                                                                          
ou qu'il n'est disponible que sur une autre source                                                                                                                                  
Cependant les paquets suivants le remplacent :                                                                                                                                      
  x11-xserver-utils                                                                                                                                                                
                                                                                                                                                                                   
E: Le paquet « xrandr » n'a pas de version susceptible d'être installée


Il y a un truc particulier à faire ?

Hors ligne

#4 15-05-2012 13:01:08

aticus
Membre
Distrib. : Debian squeeze 32 bits.
Inscription : 12-05-2012

Re : Affichage large | Que faire?

En fait il est installé :

cela me renvoit c'est différentes résolutions.

aticus@aticus-pc:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1280 x 1024, maximum 1280 x 1024
default connected 1280x1024+0+0 0mm x 0mm
   1280x1024       0.0*
   1024x768        0.0  
   800x600         0.0  
   640x480         0.0


Cependant je ne sais pas quoi ajouter comme résolution et comment le faire ?

Hors ligne

#5 15-05-2012 13:01:23

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Affichage large | Que faire?

Effectivement plus de xrandr non plus pour moi :

$ apt-cache show xr
xracer        xrdp          xringd        xrsh          
xracer-tools  xrestop       xrootconsole


roll


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#6 15-05-2012 13:21:48

aticus
Membre
Distrib. : Debian squeeze 32 bits.
Inscription : 12-05-2012

Re : Affichage large | Que faire?

Un peut plus de détails sur la carte graphique :

aticus@aticus-pc:~$ lspci -nn | egrep "VGA|Display"
00:02.0 VGA compatible controller [0300]: Intel Corporation Sandy Bridge Integrated Graphics Controller [8086:0102] (rev 09)


aticus@aticus-pc:~$ grep Chipset /var/log/Xorg.0.log
(II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
(II) VESA(0): VESA VBE OEM: Intel(R)Sandybridge Desktop Graphics Chipset Accelerated VGA BIOS
(II) VESA(0): VESA VBE OEM: Intel(R)Sandybridge Desktop Graphics Chipset Accelerated VGA BIOS


aticus@aticus-pc:~$ dmesg | grep agp
[    0.904157] Linux agpgart interface v0.103


Je me permet de mettre cela que j'ai vu sur ubuntu-fr :

[q]Les cartes Intel fonctionnent (en 2D et en 3D) avec les pilotes suivants :

      i810

      vesa
   
      intel

Ces trois pilotes sont inclus dans le paquet xserver-xorg-video-intel. Le pilote correspondant à la carte graphique utilisé est installé automatiquement.
[/q]

Dernière modification par aticus (15-05-2012 13:23:48)

Hors ligne

#7 15-05-2012 16:07:01

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Affichage large | Que faire?

Et ton xorg.conf donne quoi ?

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#8 15-05-2012 16:09:14

aticus
Membre
Distrib. : Debian squeeze 32 bits.
Inscription : 12-05-2012

Re : Affichage large | Que faire?

J'ai été dans

etc/X11 (et je ne trouve pas xorg.conf)



et dans

usr/share/X11/ (et j'ai un dossier xorg.conf.d mais pas de fichier xorg.conf)



Donc du coup le trouve ou le fichier xorg.conf ?
S'il te plaît.

Dernière modification par aticus (04-01-2013 14:58:35)

Hors ligne

#9 15-05-2012 16:22:47

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Affichage large | Que faire?

De nos jours, le xorg.conf n'est plus forcément généré à l'installation car, en principe, la détection automatique du hardware fonctionne sans trop de problèmes.

Sauf que pour moi, ça fonctionne bien sur une distribution mais ça ne fonctionne plus sur ma Squeeze. sad

Il se peut aussi que tu en aies besoin.
Consulte le wiki :  http://debian-facile.org/ et reposte si tu souhaite des précisions.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#10 15-05-2012 17:05:20

Blacksad
Membre
Lieu : Le Havre gris
Distrib. : Stable
Inscription : 03-05-2012

Re : Affichage large | Que faire?

Je te conseil le script sgfxi 

Sur un tty (ctrl_alt_F1), tu prends les droits root tu lances:

cd /usr/local/bin && wget -Nc smxi.org/sgfxi && chmod +x sgfxi && sgfxi


Pour une carte intel peut-etre qu'il n'accepte que le commutateur -N -> sgfxi -N

Ce script t'installera les drivers s'ils manquent, le xorg.conf s'il faut, bref: le pied.

Hors ligne

#11 16-05-2012 08:27:20

aticus
Membre
Distrib. : Debian squeeze 32 bits.
Inscription : 12-05-2012

Re : Affichage large | Que faire?

Blacksad je viens de tester ta méthode.
Ça ma tout installer seul hic! je n'ai plus de session graphique.
Avez vous une idée car startx ne fonctionne pas.
Que faire ?

Hors ligne

#12 16-05-2012 08:49:15

aticus
Membre
Distrib. : Debian squeeze 32 bits.
Inscription : 12-05-2012

Re : Affichage large | Que faire?

Je vous poste mon xorg.conf :

Section "ServerLayout"
  Identifier     "X.org Configured"
  Screen      0  "Screen0" 0 0
  InputDevice    "Mouse0" "CorePointer"
  InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
  ModulePath   "/usr/lib/xorg/modules"
  FontPath     "/usr/share/fonts/X11/misc"
  FontPath     "/usr/share/fonts/X11/cyrillic"
  FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
  FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
  FontPath     "/usr/share/fonts/X11/Type1"
  FontPath     "/usr/share/fonts/X11/100dpi"
  FontPath     "/usr/share/fonts/X11/75dpi"
  FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
  FontPath     "built-ins"
EndSection

Section "Module"
  Load  "glx"
  Load  "record"
  Load  "extmod"
  Load  "dbe"
  Load  "dri"
  Load  "dri2"
EndSection

Section "InputDevice"
  Identifier  "Keyboard0"
  Driver      "kbd"
EndSection

Section "InputDevice"
  Identifier  "Mouse0"
  Driver      "mouse"
  Option      "Protocol" "auto"
  Option      "Device" "/dev/input/mice"
  Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
  Identifier   "Monitor0"
  VendorName   "Monitor Vendor"
  ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "DRI"                 # [<bool>]
        #Option     "ColorKey"            # <i>
        #Option     "VideoKey"            # <i>
        #Option     "FallbackDebug"       # [<bool>]
        #Option     "Tiling"              # [<bool>]
        #Option     "Shadow"              # [<bool>]
        #Option     "SwapbuffersWait"     # [<bool>]
        #Option     "XvMC"                # [<bool>]
        #Option     "XvPreferOverlay"     # [<bool>]
        #Option     "DebugFlushBatches"   # [<bool>]
        #Option     "DebugFlushCaches"    # [<bool>]
        #Option     "DebugWait"           # [<bool>]
  Identifier  "Card0"
  Driver  "intel"
  VendorName  "Intel Corporation"
  BoardName   "Sandy Bridge Integrated Graphics Controller"
  BusID       "PCI:0:2:0"
EndSection

Section "Screen"
  Identifier "Screen0"
  Device     "Card0"
  Monitor    "Monitor0"
  SubSection "Display"
    Viewport   0 0
    Depth     1
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     4
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     8
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     15
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     16
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     24
  EndSubSection
EndSection



Section "Extensions"
# Option      "Composite" "disable"
# Option      "RENDER"  "disable"
EndSection

Dernière modification par aticus (04-01-2013 14:59:08)

Hors ligne

#13 16-05-2012 08:52:03

aticus
Membre
Distrib. : Debian squeeze 32 bits.
Inscription : 12-05-2012

Re : Affichage large | Que faire?

Et mon xorg .conf-bu-2012-05-16-08:19:14 :

Section "ServerLayout"
  Identifier     "X.org Configured"
  Screen      0  "Screen0" 0 0
  InputDevice    "Mouse0" "CorePointer"
  InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
  ModulePath   "/usr/lib/xorg/modules"
  FontPath     "/usr/share/fonts/X11/misc"
  FontPath     "/usr/share/fonts/X11/cyrillic"
  FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
  FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
  FontPath     "/usr/share/fonts/X11/Type1"
  FontPath     "/usr/share/fonts/X11/100dpi"
  FontPath     "/usr/share/fonts/X11/75dpi"
  FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
  FontPath     "built-ins"
EndSection

Section "Module"
  Load  "glx"
  Load  "record"
  Load  "extmod"
  Load  "dbe"
  Load  "dri"
  Load  "dri2"
EndSection

Section "InputDevice"
  Identifier  "Keyboard0"
  Driver      "kbd"
EndSection

Section "InputDevice"
  Identifier  "Mouse0"
  Driver      "mouse"
  Option      "Protocol" "auto"
  Option      "Device" "/dev/input/mice"
  Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
  Identifier   "Monitor0"
  VendorName   "Monitor Vendor"
  ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "AccelMethod"         # [<str>]
        #Option     "DRI"                 # [<bool>]
        #Option     "ColorKey"            # <i>
        #Option     "VideoKey"            # <i>
        #Option     "FallbackDebug"       # [<bool>]
        #Option     "Tiling"              # [<bool>]
        #Option     "Shadow"              # [<bool>]
        #Option     "SwapbuffersWait"     # [<bool>]
        #Option     "XvMC"                # [<bool>]
        #Option     "XvPreferOverlay"     # [<bool>]
        #Option     "DebugFlushBatches"   # [<bool>]
        #Option     "DebugFlushCaches"    # [<bool>]
        #Option     "DebugWait"           # [<bool>]
  Identifier  "Card0"
  Driver      "intel"
  VendorName  "Intel Corporation"
  BoardName   "Sandy Bridge Integrated Graphics Controller"
  BusID       "PCI:0:2:0"
EndSection

Section "Screen"
  Identifier "Screen0"
  Device     "Card0"
  Monitor    "Monitor0"
  SubSection "Display"
    Viewport   0 0
    Depth     1
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     4
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     8
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     15
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     16
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     24
  EndSubSection
EndSection

Hors ligne

#14 16-05-2012 09:47:17

aticus
Membre
Distrib. : Debian squeeze 32 bits.
Inscription : 12-05-2012

Re : Affichage large | Que faire?

Bon j'ai supprimer les deux fichiers xorg.conf et cela refonctionne.
Seul problème toujours pas d'amélioration dans ma résolution .
Qu'est qui provoque donc ce problème avec mon xorg.conf?
Et comment le renseigner correctement?

Hors ligne

#15 16-05-2012 19:39:15

Blacksad
Membre
Lieu : Le Havre gris
Distrib. : Stable
Inscription : 03-05-2012

Re : Affichage large | Que faire?

Seul le xorg.conf est utilisé, l'autre est une sauvegarde, tu n'as pas à le virer quand tu ne t'en sert plus, juste à renommer le xorg.conf d'une autre manière genre xorg.conf."date du jour".

C'est un peu vague "je n'ai plus de session graphique", il nous faudrait connaitre ce que disent tes logs quand ça plante.
Donc les logs sont toujours dans /var/log/
Et dans notre cas précis regardes en premier lieu ce que te raconte Xorg.0.log

as-tu lu les différentes option possible du script ?
Personnellement quand j'avais une ATI j'avais plein de façon d'installer les drivers: les libres, les proprio des depots, les proprio téléchargé et compilé, en spécifiant une version spécifique etc...
L’intérêt est justement de jongler rapidement et sans avoir à trop réfléchir d'une version à une autre mais le script qui teste quel est la meilleur solution selon le poste, selon l'humeur et les goûts de l'utilisateur reste à inventer, dsl
Après, avec une Intel les choix sont peut-etre limité, je n'ai pas regardé dans le détail, mais il suffit de savoir lire wink

Sinon je vois qu'il y'a pas mal de module d'activé, tu peux commencer par commenter toute la section en mettant des # devant chaque ligne pour voir si c'est mieux.
Puis si c'est ok, les réactiver un a un jusqu'à trouver celui qui fait foirer le lancement d'X

Dernière modification par Blacksad (16-05-2012 19:44:56)

Hors ligne

Pied de page des forums