Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-04-2008 09:22:34

Druviel
Membre
Inscription : 10-04-2008

Problême avec Compiz Fuzion

Bonjour à tous,

Suite à l'installation il y a peu de Compiz-Fusion, je me suis rendu compte que mon pc avait beaucoup de mal :s

Je lance donc Compiz-Fusion grâce à la commande

compiz-manager


, le shell reste bloqué à un certain moment, et si je ferme la fenêtre de la console, je ne peux plus en rouvrir enfin elle deviennent toutes blanches. Au bout d'un moment le systême ne répond limite plus, il bloque. Il faut que j'étire les applications en avant plan pour la resélectionné et au bout de 4sec maximum sa replante.

C'est vraiment énervant, savez vous que faire?

Merci D'avance


C'est parce que la vitesse de la lumière est supérieure à celle du son, que tant de gens paraissent brillant avant d'avoir l'air con.

Hors ligne

#2 25-04-2008 10:21:28

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : Problême avec Compiz Fuzion

Salut
Quand tu le lances, il y a un autre WM qui tourne avant (Métacity ? kwm? xfwm4?)
Pas de message d'erreur dans la console au lancement ?

Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#3 25-04-2008 10:27:01

Druviel
Membre
Inscription : 10-04-2008

Re : Problême avec Compiz Fuzion

J'ai gnome par default

J'ai une erreur quand j'éteind le pc seulement avec GDM

C'est parce que la vitesse de la lumière est supérieure à celle du son, que tant de gens paraissent brillant avant d'avoir l'air con.

Hors ligne

#4 25-04-2008 12:03:16

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : Problême avec Compiz Fuzion

si tu fais un killall métacity avant de lancer compiz-fusion ?

Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#5 25-04-2008 12:07:16

Druviel
Membre
Inscription : 10-04-2008

Re : Problême avec Compiz Fuzion

Je fais killall metacity et le shell ne me renvois rien plus de prompt non plus :s

Edit : Aaaah obligé de taper sur return pour avoir quelque chose

j'ai refait un petit

compiz-manager


et en tapant sur return je n'ai rien je fais simplement un retour à la ligne. je tape donc sur ctrl+c et j'ai :

/usr/bin/compiz: line 775: 12016 Erreur de segmentation  $*
Avertissement du gestionnaire de fenêtres : Impossible de charger le thème « Clearlooks » : Impossible de trouver un fichier valide pour le thème Clearlooks


Ce n'est pas normal à mon avis :s
Que dois-je faire?

Je vais quand même essayer de redésinstaller Compiz-fuzion avec l'option --purge
et le réinstaller correctement on va voir ce que sa donne.

edit2 :
Voici ce que j'ai exactement :

$ compiz-manager
Checking for Xgl: not present.
Detected PCI ID for VGA: 01:00.0 0300: 10de:0427 (rev a1) (prog-if 00 [VGA controller])
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1280x800) to maximum 3D texture size (8192): Passed.
Checking for nVidia: present.
Checking for FBConfig: present.
Checking for Xgl: not present.
Starting emerald
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32
/usr/bin/compiz.real (core) - Warn: No GLXFBConfig for depth 32

Dernière modification par Druviel (25-04-2008 12:44:26)


C'est parce que la vitesse de la lumière est supérieure à celle du son, que tant de gens paraissent brillant avant d'avoir l'air con.

Hors ligne

#6 25-04-2008 15:01:23

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : Problême avec Compiz Fuzion

essai de passer la valeur depth de 32 a 24 dans le /etc/X11/xorg.conf

Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#7 25-04-2008 15:49:24

Druviel
Membre
Inscription : 10-04-2008

Re : Problême avec Compiz Fuzion

Justement je n'ai pas de valeur à 32, sa s'arrête à 24 :s

voilà mon fichier xorg.conf

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
        FontPath        "/usr/share/fonts/X11/misc"
        FontPath        "/usr/X11R6/lib/X11/fonts/misc"
        FontPath        "/usr/share/fonts/X11/cyrillic"
        FontPath        "/usr/X11R6/lib/X11/fonts/cyrillic"
        FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath        "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath        "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/share/fonts/X11/Type1"
        FontPath        "/usr/X11R6/lib/X11/fonts/Type1"
        FontPath        "/usr/share/fonts/X11/100dpi"
        FontPath        "/usr/X11R6/lib/X11/fonts/100dpi"
        FontPath        "/usr/share/fonts/X11/75dpi"
        FontPath        "/usr/X11R6/lib/X11/fonts/75dpi"
        # path to defoma fonts
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection
Section "Module"
        Load    "bitmap"
        Load    "ddc"
        Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "vbe"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "fr"
        Option          "XkbVariant"    "latin9"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
        Option          "Emulate3Buttons"       "true"
EndSection

Section "InputDevice"
        Identifier      "Synaptics Touchpad"
        Driver          "synaptics"
        Option          "SendCoreEvents"        "true"
        Option          "SendCoreEvents"        "true"
        Option          "Device"                "/dev/psaux"
        Option          "Protocol"              "auto-dev"
        Option          "HorizScrollDelta"      "0"
EndSection

Section "Device"
        Identifier      "nVidia Corporation NVIDIA Default Card"
        Driver          "nvidia"
        BusID           "PCI:1:0:0"
EndSection

Section "Monitor"
        Identifier      "Écran générique"
        Option          "DPMS"
        HorizSync       28-50
        VertRefresh     43-75
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "nVidia Corporation NVIDIA Default Card"
        Monitor         "Écran générique"
        DefaultDepth    16
        SubSection "Display"
                Depth           1
                Modes           "1920x1440" "1920x1200" "1856x1392" "1792x1344" "1680x1050" "1600x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x$
        EndSubSection
        SubSection "Display"
                Depth           4
                Modes           "1920x1440" "1920x1200" "1856x1392" "1792x1344" "1680x1050" "1600x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x$
        EndSubSection
        SubSection "Display"
                Depth           8
                Modes           "1920x1440" "1920x1200" "1856x1392" "1792x1344" "1680x1050" "1600x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x$
                Modes           "1920x1440" "1920x1200" "1856x1392" "1792x1344" "1680x1050" "1600x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x$
        EndSubSection
        SubSection "Display"
                Depth           15
                Modes           "1920x1440" "1920x1200" "1856x1392" "1792x1344" "1680x1050" "1600x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x$
        EndSubSection
        SubSection "Display"
                Depth           16
                Modes           "1920x1440" "1920x1200" "1856x1392" "1792x1344" "1680x1050" "1600x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x$
        EndSubSection
        SubSection "Display"
                Depth           24
                Modes           "1920x1440" "1920x1200" "1856x1392" "1792x1344" "1680x1050" "1600x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x$
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
        InputDevice     "Synaptics Touchpad"
EndSection

Section "DRI"
        Mode    0666
EndSection


C'est parce que la vitesse de la lumière est supérieure à celle du son, que tant de gens paraissent brillant avant d'avoir l'air con.

Hors ligne

#8 26-04-2008 00:06:31

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : Problême avec Compiz Fuzion

Oui, mais il est en default 16, passe le a 24

Voici le miens

Section "Files"
EndSection

Section "Module"
    Load           "bitmap"
    Load           "dbe"
    Load           "ddc"
    Load           "extmod"
    Load           "freetype"
    Load           "glx"
    Load           "record"
    Load           "type1"
    Load           "v4l"
    Load           "vbe"
    Load     "dri"
    Load           "GLcore"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "fr"
# Option    "XkbVariant"  "latin9"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ImPS/2"
    Option         "Emulate3Buttons" "true"
#    Option         "SWCursor" "true"
EndSection

Section "Monitor"
    Identifier     "NEC C LC17M"
    HorizSync       50.0 - 90.0
    VertRefresh     50.0 - 160.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "nVidia Corporation C51 [GeForce 6150 LE]"
    Driver         "nvidia"
    Option  "AddARGBGLXVisuals" "true"
    Option  "XAANoOffscreenPixmaps" "true" 
EndSection

Section "Screen"
    Identifier     "Default screen"
    Device         "nVidia Corporation C51 [GeForce 6150 LE]"
    Monitor        "NEC C LC17M"
    DefaultDepth    24
   SubSection     "Display"
        Depth       24
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "enable"


sauf erreur de ma part l'option composite "enable" est importante ainsi que les options "AddARGBGLXVisuals" "True"
"XAANoOffscreenPixmaps" "true"


Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#9 26-04-2008 16:08:57

Druviel
Membre
Inscription : 10-04-2008

Re : Problême avec Compiz Fuzion

arf, en fait du coup j'ai passé ma Debian en Version stable (Etch) à la place de Sid. Merci Freddec je vous tiens au courant.

C'est parce que la vitesse de la lumière est supérieure à celle du son, que tant de gens paraissent brillant avant d'avoir l'air con.

Hors ligne

Pied de page des forums