Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 26-05-2012 19:59:41

playgeek
Membre
Inscription : 11-05-2012

Re : comment installer le kernel le plus recent ?

DosXX a écrit :

martin_mtl a écrit :

aptitude -t squueeze-backports install linux-image-3.2.0-0.bpo.2-686-pae


On retrouve ces explications dans le wiki à cette page

À la prochaine
Martin


heu je dirais plutôt :
aptitude -t squeeze-backports install linux-image-3.2.0-0.bpo.2-686-pae


houaaaaa!!! alors là que moi je reprenne martin_mtl trop fort lol:lol::lol: comment j'me la raconte!!!
j'ai droit a un carré de choco??? wink
bonjour martin_mtl. smile


salut :

j'ai ca :

linux-base (3) unstable; urgency=low

  * Some HP Smart Array controllers are now handled by the new 'hpsa'
    driver, rather than the 'cciss' driver.

    While the cciss driver presented disk device names beginning with
    'cciss/', hpsa makes disk arrays appear as ordinary SCSI disks and
    presents device names beginning with 'sd'.  In a system that already
    has other SCSI or SCSI-like devices, names may change unpredictably.

    During the upgrade from earlier versions, you will be prompted to
    update configuration files which refer to device names that may
    change.  You can choose to do this yourself or to follow an automatic
    upgrade process.  All changed configuration files are backed up with
    a suffix of '.old' (or '^old' in one case).

-- Ben Hutchings <ben@decadent.org.uk>  Wed, 16 Mar 2011 13:19:34 +0000
/tmp/tmpWYpXYj  (END)

je fais quoi ?

Hors ligne

#27 26-05-2012 20:03:05

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : comment installer le kernel le plus recent ?

@ martin_mtl
oui, mais je voudrais voir les p, les i et les A après sa tentative d'install.

@ DosXX
l'argument -t spécifie le dépôt pour le paquet et ses dépendances (si j'ai bonne mémoire)

@ playgeek
tu es sûr d'avoir seulement stable dans ton sources.list ?

Dernière modification par paskal (26-05-2012 20:05:36)


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#28 26-05-2012 20:06:18

DosXX
Membre
Distrib. : Squeeze 6.0.7 + Backports
Noyau : 2.6.32-5-amd64 /3.2.0-0.bpo.4-amd64 /2.6.32-5-686
(G)UI : Gnome 2.30.2 /Gnome-Fluxbox / LXDE
Inscription : 10-03-2012

Re : comment installer le kernel le plus recent ?

paskal a écrit :

@ DosXX
l'argument -t spécifie le dépôt pour le paquet et ses dépendances (si j'ai bonne mémoire)


ok, donc la totale. pas juste la cible. cool merci


# >_Znort !!!

Hors ligne

#29 26-05-2012 20:08:13

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : comment installer le kernel le plus recent ?

@ playgeek
As-tu une carte RTL8191 Wireless ?

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#30 26-05-2012 20:08:50

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : comment installer le kernel le plus recent ?

playgeek a écrit :

j'ai ca :

linux-base (3) unstable; urgency=low

  * Some HP Smart Array controllers are now handled by the new 'hpsa'
    driver, rather than the 'cciss' driver.

    While the cciss driver presented disk device names beginning with
    'cciss/', hpsa makes disk arrays appear as ordinary SCSI disks and
    presents device names beginning with 'sd'.  In a system that already
    has other SCSI or SCSI-like devices, names may change unpredictably.

    During the upgrade from earlier versions, you will be prompted to
    update configuration files which refer to device names that may
    change.  You can choose to do this yourself or to follow an automatic
    upgrade process.  All changed configuration files are backed up with
    a suffix of '.old' (or '^old' in one case).

-- Ben Hutchings <ben@decadent.org.uk>  Wed, 16 Mar 2011 13:19:34 +0000
/tmp/tmpWYpXYj  (END)

je fais quoi ?


Tu appuis sur Q (pour quitter).


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#31 27-05-2012 09:24:45

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : comment installer le kernel le plus recent ?

DosXX a écrit :

paskal a écrit :

@ DosXX
l'argument -t spécifie le dépôt pour le paquet et ses dépendances (si j'ai bonne mémoire)


ok, donc la totale. pas juste la cible. cool merci


J'ai quand même un doute :
- si le paquet a besoin d'une version de dépendance présente dans les backports, ce sera le cas ;
- mais si la version ordinaire est suffisante, elle sera installée car prioritaire (niveau 500 par défaut) sur celle des backports (niveau 100 par défaut).
Je pense que c'est le cas d'une bonne partie des librairies :

Backports are recompiled packages from testing (mostly) and unstable (in a few cases only, e.g. security updates) in a stable environment so that they will run without new libraries (whenever it is possible) on a Debian stable distribution


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#32 27-05-2012 09:48:51

playgeek
Membre
Inscription : 11-05-2012

Re : comment installer le kernel le plus recent ?

paskal a écrit :

playgeek, peux-tu poster la sortie de :

# aptitude search linux-image


voila

root@debian:/home/seb# aptitude search linux-image
v   linux-image                     -                                          
v   linux-image-2.6                 -                                          
p   linux-image-2.6-486             - Linux for older PCs (dummy package)      
i   linux-image-2.6-686             - Linux for modern PCs (dummy package)      
p   linux-image-2.6-686-bigmem      - Linux for PCs with 4GB+ RAM (dummy package
p   linux-image-2.6-686-pae         - Linux for modern PCs (dummy package)      
p   linux-image-2.6-amd64           - Linux for 64-bit PCs (dummy package)      
p   linux-image-2.6-openvz-686      - Linux 2.6 for modern PCs (meta-package), O
p   linux-image-2.6-vserver-686     - Linux 2.6 for modern PCs (meta-package), L
p   linux-image-2.6-vserver-686-big - Linux 2.6 for PCs with 4GB+ RAM (meta-pack
p   linux-image-2.6-xen-686         - Linux 2.6 for modern PCs (meta-package), X
p   linux-image-2.6.32-5-486        - Linux 2.6.32 for old PCs                  
i A linux-image-2.6.32-5-686        - Linux 2.6.32 for modern PCs              
p   linux-image-2.6.32-5-686-bigmem - Linux 2.6.32 for PCs with 4GB+ RAM        
p   linux-image-2.6.32-5-686-bigmem - Debugging infos for Linux 2.6.32-5-686-big
p   linux-image-2.6.32-5-amd64      - Linux 2.6.32 for 64-bit PCs              
p   linux-image-2.6.32-5-openvz-686 - Linux 2.6.32 for modern PCs, OpenVZ suppor
p   linux-image-2.6.32-5-openvz-686 - Debugging infos for Linux 2.6.32-5-openvz-
p   linux-image-2.6.32-5-vserver-68 - Linux 2.6.32 for modern PCs, Linux-VServer
p   linux-image-2.6.32-5-vserver-68 - Linux 2.6.32 for PCs with 4GB+ RAM, Linux-
p   linux-image-2.6.32-5-vserver-68 - Debugging infos for Linux 2.6.32-5-vserver
p   linux-image-2.6.32-5-xen-686    - Linux 2.6.32 for modern PCs, Xen dom0 supp
p   linux-image-2.6.32-5-xen-686-db - Debugging infos for Linux 2.6.32-5-xen-686
p   linux-image-3.2.0-0.bpo.1-486   - Linux 3.2 for older PCs                  
p   linux-image-3.2.0-0.bpo.1-686-p - Linux 3.2 for modern PCs                  
p   linux-image-3.2.0-0.bpo.1-686-p - Debugging infos for Linux 3.2.0-0.bpo.1-68
p   linux-image-3.2.0-0.bpo.1-amd64 - Linux 3.2 for 64-bit PCs                  
p   linux-image-3.2.0-0.bpo.2-486   - Linux 3.2 for older PCs                  
pB  linux-image-3.2.0-0.bpo.2-686-p - Linux 3.2 for modern PCs                  
p   linux-image-3.2.0-0.bpo.2-686-p - Debugging infos for Linux 3.2.0-0.bpo.2-68
p   linux-image-3.2.0-0.bpo.2-amd64 - Linux 3.2 for 64-bit PCs                  
p   linux-image-3.2.0-0.bpo.2-rt-68 - Linux 3.2 for modern PCs, PREEMPT_RT      
p   linux-image-3.2.0-0.bpo.2-rt-68 - Debugging infos for Linux 3.2.0-0.bpo.2-rt
p   linux-image-486                 - Linux for older PCs (meta-package)        
p   linux-image-686                 - Linux for modern PCs (dummy package)      
p   linux-image-686-bigmem          - Linux for PCs with 4GB+ RAM (dummy package
p   linux-image-686-pae             - Linux for modern PCs (meta-package)      
p   linux-image-amd64               - Linux for 64-bit PCs (meta-package)      
p   linux-image-openvz-686          - Linux for modern PCs (meta-package), OpenV
p   linux-image-rt-686-pae          - Linux for modern PCs (meta-package), PREEM
p   linux-image-vserver-686         - Linux for modern PCs (meta-package), Linux
p   linux-image-vserver-686-bigmem  - Linux for PCs with 4GB+ RAM (meta-package)
p   linux-image-xen-686             - Linux for modern PCs (meta-package), Xen d
root@debian:/home/seb#

Hors ligne

#33 27-05-2012 10:21:44

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : comment installer le kernel le plus recent ?

Le paquet linux-image-3.2.0-0.bpo.2-686-pae est cassé (ou a des dépendances cassées ?) sad
Je ne vais pas pouvoir te dépanner.
Poste quand même le résultat de :

# aptitude why linux-image-3.2.0-0.bpo.2-686-pae


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#34 27-05-2012 10:36:31

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : comment installer le kernel le plus recent ?

Après, une simulation de mise-à-jour donne quoi ?

# aptitude -s safe-upgrade


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#35 27-05-2012 14:10:05

playgeek
Membre
Inscription : 11-05-2012

Re : comment installer le kernel le plus recent ?

j'ai ca


seb@debian:~$ su
Mot de passe :
root@debian:/home/seb# aptitude -s safe-upgrade
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.
Charger/installer/enlever des paquets.
root@debian:/home/seb#

Hors ligne

#36 27-05-2012 14:11:15

playgeek
Membre
Inscription : 11-05-2012

Re : comment installer le kernel le plus recent ?

ah j'oubliais l'autre question :


seb@debian:~$ su
Mot de passe :
root@debian:/home/seb# aptitude why linux-image-3.2.0-0.bpo.2-686-pae
E: dpkg a été interrompu. Il est nécessaire d'utiliser « dpkg --configure -a » pour corriger le problème.
W: Impossible de verrouiller le fichier cache : cela est en général dû à une installation simultanée de paquets avec dpkg ou un autre outil comme APT. Ouverture en mode lecture seule : AUCUNE des modifications de l'état des paquets que vous pourrez faire ne sera conservée.
i   xorg                              Dépend     xserver-xorg                   
i A xserver-xorg                      Dépend     xserver-xorg-video-all | xserve
                                                 r-xorg-video-6                 
p   virtualbox-guest-x11              Fournit    xserver-xorg-video-6           
p   virtualbox-guest-x11              Dépend     virtualbox-guest-utils (= 4.0.1
                                                 0-dfsg-1~bpo60+1)             
p   virtualbox-guest-utils            Recommande virtualbox-guest-dkms (= 4.0.10
                                                 -dfsg-1~bpo60+1) | virtualbox-g
                                                 uest-source (= 4.0.10-dfsg-1~bp
                                                 o60+1)                         
p   virtualbox-guest-dkms             Dépend     dkms (>= 2.1.0.0)             
p   dkms                              Recommande linux-image                   
pB  linux-image-3.2.0-0.bpo.2-686-pae Fournit    linux-image                   
root@debian:/home/seb#

Hors ligne

#37 27-05-2012 14:28:10

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : comment installer le kernel le plus recent ?

Bien. Alors tente la réparation :

# dpkg --configure -a


Bon courage.

Et n'oublie pas le post #30 de martin_mtl (appuyer sur Q si tu as un avertissement)

Dernière modification par paskal (28-05-2012 07:35:31)


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#38 27-05-2012 15:56:22

playgeek
Membre
Inscription : 11-05-2012

Re : comment installer le kernel le plus recent ?

merci a tous ca a enfin marcher et encore merci a vous tous  big_smile

d'aileur je suis desus en ce moment et je vois déjà la difference merci a tous big_smile

Hors ligne

#39 27-05-2012 19:03:39

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : comment installer le kernel le plus recent ?

Content pour toi smile
Un p'tit résolu dans l'titre ?
Fait chaud pour le choco, mais enfin bon ...

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#40 28-05-2012 01:19:15

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : comment installer le kernel le plus recent ?

Tu risques en effet d'avoir du choco fondant paskal smile

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#41 28-05-2012 07:38:56

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : comment installer le kernel le plus recent ?

Bonjour martin_mtl, smile

Oui, ici on est passé directement de l'hiver doux à l'été orageux.
Je propose que l'on remplace les points chocolat par des points glace. big_smile

C'est l'ami Jojo qui va faire une drole de tête ! lol

Dernière modification par paskal (28-05-2012 07:42:16)


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#42 29-05-2012 02:57:19

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : comment installer le kernel le plus recent ?

Ou des points cubes de glace lol

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

Pied de page des forums