Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-06-2012 09:16:33

DreamOn
Membre
Distrib. : Sid
Noyau : 3.2.0-2-amd64
(G)UI : XFCE 4.8
Inscription : 24-03-2012

[Résolu] Problème démarrage interface graphique

Bonjour à tous smile

Depuis que j'ai installé Debian, j'utilise les pilotes propriétaires fglrx de ATI sans aucun souci. Depuis que j'ai fait une mise à jour du système via aptitude safe-upgrade, rien ne va plus...

Au démarrage du PC après le grub et le chargement de tous les modules, j'ai un écran noir avec le curseur qui clignote. Je suis donc allé dans une console via Ctrl+Alt+F1 en essayant de reconfigurer le fichier xorg.conf avec la commande : aticonfig --initial et voilà ce que cela me donne :

aticonfig --initial
aticonfig: No supported adapters detected


Donc j'essaie avec les pilotes libres en faisant X -configure et voilà ce que j'ai :

[...]
(II) [KMS] No DRICreatePCIBusID symbol, no kernel modesetting.
Number of created screens does not match number of detected devices.
Configuration failed.
Server terminated with error (2). Closing log file.


Qui me crée le fichier /root/xorg.conf.new suivant :

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    Screen      2  "Screen2" RightOf "Screen1"
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection
[...]


La seule solution que j'ai trouvée pour démarrer mon interface graphique et d'éditer le fichier /root/xorg.conf.new en supprimant les lignes qui indiquent deux moniteurs inconnus (j'en ai bien un seul) et de le copier vers /etc/X11/xorg.conf. Une fois la copie faite je peux lancer l'interface graphique via invoke-rc.d lightdm start.

Je dois à chaque fois faire ça car même en redémarrant le PC avec les pilotes libres et le fichier xorg.conf configuré pour ne spécifier qu'un seul moniteur, j'arrive à l'écran noir avec le curseur..

Je ne sais plus quoi faire.. J'aimerai retrouver ma config avec les pilotes fglrx. Si quelqu'un a une solution, merci !

Dernière modification par DreamOn (12-06-2012 14:12:12)


Debian Sid
XFCE

Hors ligne

#2 12-06-2012 10:07:53

DreamOn
Membre
Distrib. : Sid
Noyau : 3.2.0-2-amd64
(G)UI : XFCE 4.8
Inscription : 24-03-2012

Re : [Résolu] Problème démarrage interface graphique

Je viens de voir sur la page des modifications de fglrx de Debian que les anciennes cartes Radeon HD ne sont plus supportées... http://packages.debian.org/changelogs/p … /changelog

Pour info, ce sont celles-là :
- RadeonHD 2000
- RadeonHD 3000
- RadeonHD 4000

Je vais essayer de retrouver les anciens pilotes.

Debian Sid
XFCE

Hors ligne

#3 12-06-2012 11:56:15

DreamOn
Membre
Distrib. : Sid
Noyau : 3.2.0-2-amd64
(G)UI : XFCE 4.8
Inscription : 24-03-2012

Re : [Résolu] Problème démarrage interface graphique

J'ai essayé d'installer les drivers dispos sur le site de AMD : http://support.amd.com/us/gpudownload/l … linux.aspx

Mais ça ne marche pas, écran noir lors du lancement de l'interface graphique...

Si quelqu'un peut m'aider smile

Debian Sid
XFCE

Hors ligne

#4 12-06-2012 14:11:53

DreamOn
Membre
Distrib. : Sid
Noyau : 3.2.0-2-amd64
(G)UI : XFCE 4.8
Inscription : 24-03-2012

Re : [Résolu] Problème démarrage interface graphique

Bon la seule solution que j'ai trouvée est de tout désinstaller xorg + fglrx + librairies mesa puis réinstaller xorg et cela remarche smile

Debian Sid
XFCE

Hors ligne

Pied de page des forums