Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-06-2012 16:25:53

koff75
Membre
Inscription : 15-06-2012

Problème : fuse

Bonjour à tous,

j'ai un soucis avec un script shell, je suis sous un noyau 3.0, mon script nécessite de monter un répertoire sur le réseau, seulement, il a besoin de fuse et me renvoie :

fuse: device not found, try 'modprobe fuse' first
umount: /mnt/dossier: not mounted


j'ai donc lancé :
lsmod |grep fuse : sans résultat
modprobe fuse : FATAL: Module fuse not found

Puis, j'ai ré-installer fuse avec les sources : ./configure && make && make install

Je suis ensuite allé dans /etc/init.d :
./fuse start : Loading fuse module/usr/local/bin/fusermount  failed !
./fuse status : Checking fuse filesystem not available


Si vous avez une piste, ça m'aiderai vraiment !
Merci d'avance

Hors ligne

#2 20-06-2012 17:44:36

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : Problème : fuse

Yep!

Avant d'attaquer les sources, il aurait fallu interroger les dépots :

aptitude search fuse


Pour le partage réseau, on utilise quelque soit le système d'exploitation la sur-couche SMB (alias SAMBA). Tu devras donc installer fuse :

aptitude install fuse


et peut être,

aptitude install fusesmb


Pour supprimer l'installation des sources, un make uninstall ou make remove (je ne sais plus trop bien, pas toujours prévus également) dans le répertoire de la source (là où tu as fait make && make install) devrait remettre ta config d'équèrre.

@+

Zoroastre.

Hors ligne

#3 22-06-2012 11:21:58

koff75
Membre
Inscription : 15-06-2012

Re : Problème : fuse

J'ai installé tout ce qui est nécéssaire mais je n'ai toujours pas de module lancé ...

root@ion:/# mount | grep fuse
root@ion:/# ls -l /dev/fuse
crw-rw-rw- 1 root root 10, 229 Jun 22 08:04 /dev/fuse
root@ion:/# dpkg -l | grep fuse
ii  fuse-utils                         2.8.4-1.1                    Filesystem in USErspace (utilities)
ii  fusesmb                            0.8.7-1.1                    filesystem client based on the SMB file transfer protocol
ii  gvfs-fuse                          1.6.4-3                      userspace virtual filesystem - fuse server
ii  libconfuse0                        2.7-1                        Library for parsing configuration files
ii  libfuse-dev                        2.8.4-1.1                    Filesystem in USErspace (development files)
ii  libfuse2                           2.8.4-1.1                    Filesystem in USErspace library
root@ion:/# cat

Hors ligne

#4 23-06-2012 22:06:02

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : Problème : fuse

Peut être qu'il faut ajouter fuse dans le fichier /etc/modules  pour qu'il se lance au démarrage?

En ligne

Pied de page des forums