Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-06-2012 17:55:55

mtiburs
Membre
Lieu : Besançon
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : gnome / lxde
Inscription : 28-03-2012

[résolu] pb de variable DISPLAY en ssh -X

Bonjour à tous,

Je viens de finir d'installer mes 3 serveurs de machines virtuelles (virtualbox) de la même façon (64 bits/squeeze, je les installe avec lxde et ensuite je supprime gdm3 pour qu'ils restent en mode texte, je rajoute xrdp pour éventuellement pouvoir les utiliser à ma guise).

Je voudrais utiliser certains programmes sous X depuis un vieux PC qui est lent, le problème c'est que je peux aller sur un des serveurs mais pas les autres, cependant, ils ont tous été fait pareil !

Voici les messages (après l'authentification) de celui qui fonctionne (serveur3: 192.168.1.213):
debug1: Authentication succeeded (password).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug1: Requesting X11 forwarding with authentication spoofing.
debug1: Sending environment.
debug1: Sending env LANG = fr_FR.utf8
debug1: Sending command: xterm
debug1: client_input_channel_open: ctype x11 rchan 3 win 65536 max 16384
debug1: client_request_x11: request from 127.0.0.1 50318
debug1: channel 1: new [x11]
debug1: confirm x11
debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
debug1: client_input_channel_req: channel 0 rtype eow@openssh.com reply 0
debug1: channel 1: FORCE input drain
debug1: channel 0: free: client-session, nchannels 2
debug1: channel 1: free: x11, nchannels 1
Transferred: sent 3198216, received 15160 bytes, in 5.5 seconds
Bytes per second: sent 581664.1, received 2757.2
debug1: Exit status 0

Voici celui du serveur1:
debug1: Authentication succeeded (password).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug1: Requesting X11 forwarding with authentication spoofing.
debug1: Sending environment.
debug1: Sending env LANG = fr_FR.utf8
debug1: Sending command: xterm
xterm Xt error: Can't open display:
xterm:  DISPLAY is not set
debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
debug1: client_input_channel_req: channel 0 rtype eow@openssh.com reply 0
debug1: channel 0: free: client-session, nchannels 1
Transferred: sent 1576, received 2056 bytes, in 0.2 seconds
Bytes per second: sent 7958.8, received 10382.8
debug1: Exit status 1

et celui du 2:
debug1: Authentication succeeded (password).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug1: Requesting X11 forwarding with authentication spoofing.
debug1: Sending environment.
debug1: Sending env LANG = fr_FR.utf8
debug1: Sending command: xterm
debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
debug1: client_input_channel_req: channel 0 rtype eow@openssh.com reply 0
xterm Xt error: Can't open display:
xterm:  DISPLAY is not set
debug1: channel 0: free: client-session, nchannels 1
Transferred: sent 1576, received 2056 bytes, in 0.2 seconds
Bytes per second: sent 7439.9, received 9705.8
debug1: Exit status 1

J'ai cherché toute la journée ce que je pouvais trouver là-dessus mais je n'y comprends plus rien !
J'ai regardé les fichiers de config, ils sont identiques.

J'ai essayé avec un autre PC fraichement installé, c'est exactement pareil: j'ai accès au 3 mais pas au 1 et 2.

Si certaines personnes ont quelques idées ou une explication, je suis preneur ;-)

Cordialement.

Dernière modification par mtiburs (26-06-2012 18:38:34)

Hors ligne

#2 26-06-2012 18:36:44

mtiburs
Membre
Lieu : Besançon
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : gnome / lxde
Inscription : 28-03-2012

Re : [résolu] pb de variable DISPLAY en ssh -X

J'ai trouvé et je réponds à mon post.
(je pourrais supprimer le message mais ça peut avoir son utilité).

En fait, j'avais oublié une petite configuration que je n'avais pas faite sur le serveur 3 (celui qui fonctionne) et quand je l'ai faite ... et bien ... ça marche plus !

Voici les parties qui ont mis "la cabane sur le chien":

ajout de commentaires dans /etc/hosts
# The following lines are desirable for IPv6 capable hosts
#::1     ip6-localhost ip6-loopback
#fe00::0 ip6-localnet
#ff00::0 ip6-mcastprefix
#ff02::1 ip6-allnodes
#ff02::2 ip6-allrouters

dans /etc/sysctl.conf
#disable ipv6
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

dans /etc/modprobe.d/blacklist.conf ajouter à la fin du fichier:
blacklist ipv6

J'avais vu ça à l'époque sur un forum Ubuntu pour optimiser le système (en fait supprimer l'ipv6 quand on s'en sert pas), et là, le fait d'enlever l'ipv6 empêche la connection ssh avec X

Si un "connaisseur" pouvait me donner une explication à cela, j'en serais râvi ;-)

Hors ligne

Pied de page des forums