Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-07-2012 15:59:09

Bruno10
Membre
Lieu : Rennes
Distrib. : Wheezy/Sid
Noyau : 3.2 amd64
(G)UI : XFCE 4.10
Inscription : 25-03-2010

[Résolu] Problème update après migration

Bonjour,

Je viens de terminer la migration de squeeze vers wheezy. Quelle galère, mais quelle galère ! dépendances en vrac, pilote nVidia en vrac, et moi-même un peu en vrac aussi... et je n'y pensais plus, mais fini gdm (que j'aimais bien, voilà).

C'est bien beau de mettre une jolie phrase dans ma signature, j'aurais mieux fait de me l'appliquer à moi-même.

Bref, ma bécane remarche mais j'ai encore 2-3 problèmes. Notamment quand je fais aptitude update ou apt-get update, voilà ce que j'ai à la fin.

61,2 ko téléchargés en 3s (15,9 ko/s)                                                                                                                                                 
W: impossible de récupérer http://http.debian.net/debian/dists/wheezy/InRelease : Impossible de trouver l'entrée « main/binary-cups-dbg/Packages » attendue dans le fichier « Release » : ligne non valable dans sources.list ou fichier corrompu                                                                                                                             
W: impossible de récupérer http://security.debian.org/dists/wheezy … InRelease : Impossible de trouver l'entrée « main/binary-cups-dbg/Packages » attendue dans le fichier « Release » : ligne non valable dans sources.list ou fichier corrompu                                                                                                                         
W: impossible de récupérer http://http.debian.net/debian/dists/sid/InRelease : Impossible de trouver l'entrée « main/binary-cups-dbg/Packages » attendue dans le fichier « Release » : ligne non valable dans sources.list ou fichier corrompu
W: impossible de récupérer http://http.debian.net/debian/dists/exp … InRelease : Impossible de trouver l'entrée « main/binary-cups-dbg/Packages » attendue dans le fichier « Release » : ligne non valable dans sources.list ou fichier corrompu
W: impossible de récupérer http://www.deb-multimedia.org/dists/wheezy/Release : Impossible de trouver l'entrée « main/binary-cups-dbg/Packages » attendue dans le fichier « Release » : ligne non valable dans sources.list ou fichier corrompu
W: impossible de récupérer http://www.deb-multimedia.org/dists/sid/Release : Impossible de trouver l'entrée « main/binary-cups-dbg/Packages » attendue dans le fichier « Release » : ligne non valable dans sources.list ou fichier corrompu
E: Some index files failed to download. They have been ignored, or old ones used instead.
E: Impossible de reconstruire le cache des paquets



J'ai enlevé, réinstallé etc... cups-dbg, walou, je ne vois pas le problème. Mon sources.list:

## wheezy
deb http://http.debian.net/debian/ wheezy main contrib non-free
deb-src http://http.debian.net/debian/ wheezy main contrib non-free

## wheezy multimedia
deb http://www.deb-multimedia.org wheezy main non-free
deb-src http://www.deb-multimedia.org/ wheezy main non-free

## wheezy security
deb http://security.debian.org/ wheezy/updates main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free


## sid
deb http://http.debian.net/debian/ sid main contrib non-free
deb-src http://http.debian.net/debian/ sid main contrib non-free

## sid multimedia
deb http://www.deb-multimedia.org/ sid main non-free

#Experimental
deb http://http.debian.net/debian/ experimental main contrib non-free



et mon fichier preferences:

Package: *
Pin: release a=testing
Pin-Priority: 990


Package: *
Pin: release a=unstable
Pin-Priority: 80


Package: *
Pin: release a=experimental
Pin-priority: 1



Voilà, si quelqu'un voit où est l'os,merci...

Dernière modification par Bruno10 (15-07-2012 13:22:02)


If it ain't broke, don't fix it.

Hors ligne

#2 13-07-2012 16:21:12

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Problème update après migration

Il me semble que pour migrer vers testing ou sid tout en maintenant son pc fonctionnel il est officiellement recommandé de maintenir actives  les sources stables car elles maintiennent opérationnels les paquets stables sur les paquets momentanément cassés en testing ou en sid simplement en les réinstallant.
smile

Voir là :
http://debian-facile.org/manuel:sources … on_testing

Dernière modification par smolski (13-07-2012 16:22:08)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 14-07-2012 11:04:31

Bruno10
Membre
Lieu : Rennes
Distrib. : Wheezy/Sid
Noyau : 3.2 amd64
(G)UI : XFCE 4.10
Inscription : 25-03-2010

Re : [Résolu] Problème update après migration

Oui merci smolski, j'avais imprudemment omis cette étape.
J'ai remis les dépôts squeeze, mais cela ne change rien à mon problème.

If it ain't broke, don't fix it.

Hors ligne

#4 14-07-2012 15:02:57

Ghost
Membre
Distrib. : Stable/SID
Noyau : 3.13 Amd 64
(G)UI : Gnome Shell
Inscription : 26-03-2012
Site Web

Re : [Résolu] Problème update après migration

Salut, à tu essayer de changer de mirroir pour l'installation des paquets?
J'ai eu également des soucis pour installer une testing dernièrement, un problème de mirroir avec également des erreurs lors de l'installation des paquets.

-C'est peut être du au gel de wheezy, en ce moment il y a pas mal de chose qui plante.Je ne t'explique même pas si je dois installer une Sid yikes

Hors ligne

#5 15-07-2012 13:21:14

Bruno10
Membre
Lieu : Rennes
Distrib. : Wheezy/Sid
Noyau : 3.2 amd64
(G)UI : XFCE 4.10
Inscription : 25-03-2010

Re : [Résolu] Problème update après migration

Bon alors:

J'ai changé de miroir et mis ftp://ftp.debian.org.
Cela n'a rien changé.
J'ai cherché le nom du paquet qui m'emm...nuyait dans /var en faisant:
grep -nri 'cups-dbg'
et suis tombé sur un fichier /var/lib/dpkg/arch qui contenait amd64 (logique) et cups-dbg.
Je l'ai modifié, puis supprimé, refait aptitude update, walou.
Puis j'ai remis mon ancien miroir http.debian. net.
Et aptitude tourne comme une horloge.
Résolu mais je n'ai pas compris pourquoi.

Suivi le sage conseil de smolski, qui m'a permis de réinstaller "mon" gdm, en attendant mieux (mieux, c'est-à-dire pas gdm3).

Plus qu'à résoudre mon problème de mise en veille décrit dans un autre post.

Merci à tous smile

If it ain't broke, don't fix it.

Hors ligne

#6 15-07-2012 14:13:25

mortalius
Membre
Distrib. : Debian GNU/Linux stretch/sid
Noyau : Linux 4.0.0-2-amd64
(G)UI : Xfce 4.12
Inscription : 27-02-2012

Re : [Résolu] Problème update après migration

Bonjour Bruno10,

A propos d'une alternative à gdm3, tu peux tester lightdm. C'est certes un produit canonical, mais semble être un bon successeur à gdm2. Sinon, il y a toujours slim, même si j'ai l'impression qu'il soit pas ou peu maintenu. (en même temps lorsque ca fonctionne ...)

Hors ligne

#7 28-04-2015 20:27:50

Spirale21
Membre
Distrib. : Jessie 8.4
Noyau : Linux 3.16.0-4-amd64
(G)UI : i3 version 4.8
Inscription : 26-02-2013

Re : [Résolu] Problème update après migration

Bonjour,
J'ai Wheezy en 64 bits et je devais installer mon imprimante. Un paquet était pré requis mais il n'existe que pour l'architecture i386 (ia32-libs). J'ai ajouter l'architecture mais en la notant j'ai mis i356!!!! et j'avais donc des problèmes (même que ceux de bruno10 à quelque détails près) et le fichier:

/var/lib/dpkg/arch

m'a permis de corriger mon erreur.
Donc un grand merci à Bruno10


RTFM ça ct avant....

Hors ligne

Pied de page des forums