Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#51 15-09-2012 19:45:30

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] debian sid instable

captnfab a écrit :

J'espère que le processus d'installation/mise à jour sera tellement bien rodé qu'il n'y en aura pas vraiment besoin ! big_smile


lol

captnfab a écrit :

Mais bon, sauf fin du monde, le wiki, le salon irc et leurs helpeurs seront toujours là en cas de pépins lors de la mise à jour wink


Merci à tous pour votre disponibilité. cool


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#52 15-09-2012 21:53:10

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu] debian sid instable

jeanmarc1 a écrit :

# AutomaticLoginEnable = true
# AutomaticLogin = user1
 



Avais tu bien modifier ces deux lignes comme ça

AutomaticLoginEnable = true
AutomaticLogin = ton_login



en prenant bien soins de supprimer les # au début de chaque ligne ?


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#53 16-09-2012 06:40:11

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu] debian sid instable

bendia a écrit :

Avais tu bien modifier ces deux lignes comme ça

AutomaticLoginEnable = true
AutomaticLogin = ton_login


en prenant bien soins de supprimer les # au début de chaque ligne ?



bonjour ben,

merci pour ton aide.

voici le nouveau fichier daemon.conf :

# GDM configuration storage
# See /usr/share/gdm/gdm.schemas for a list of available options.
[daemon]
Enabling automatic login
AutomaticLoginEnable = true
AutomaticLogin = jm

# Enabling timed login
# TimedLoginEnable = true
# TimedLogin = user1
# TimedLoginDelay = 10

# Reserving more VTs for test consoles (default is 7)
#  FirstVT = 9

[security]
[xdmcp]
[greeter]
# Only include selected logins in the greeter
# IncludeAll = false
# Include = user1,user2
[chooser]
[debug]
# More verbose logs
# Additionally lets the X server dump core if it crashes
#  Enable = true



cela ne change rien. toujours la demande du nom d'utilisateur et mot de passe au redémarrage.


"Being is not doing"

Hors ligne

#54 16-09-2012 08:41:58

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu] debian sid instable

Bonjour

Je pense qu'il faut garder le # sur la première  ligne

# Enabling automatic login


mais pas sur les deux suivante comme tu l'as fait.
J'ai fait l'essai sous Sid ça fonctionne. A voir sous Wheezy


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#55 16-09-2012 08:56:02

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu] debian sid instable

bendia a écrit :

Bonjour
Je pense qu'il faut garder le # sur la première  ligne

# Enabling automatic login


mais pas sur les deux suivante comme tu l'as fait.
J'ai fait l'essai sous Sid ça fonctionne. A voir sous Wheezy



oui, cela marche maintenant !

voici le code que j'ai mis :

[daemon]
# Enabling automatic login
AutomaticLoginEnable = true
AutomaticLogin = jm



je n'ai pas encore bien l'habitude de l'écriture en ligne. "commenter", veut dire qu'on retire le # et la ligne devient active. "décommenter", veut dire qu'on laisse le  # et la ligne est inactive. est-ce bien cela ?

merci encore pour ton aide.


"Being is not doing"

Hors ligne

#56 16-09-2012 09:02:12

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] debian sid instable

Dans beaucoup de fichiers de configuration, les lignes commençant par # sont ignoréesl'application chargeant son fichier de configuration.
Elles permettent donc d'une part de rajouter des commentaires (d'où le nom « commenter » ou « passer en commentaire » pour « rajouter le # », et inversement).
Ainsi, on trouve souvent des exemples de morceaux de configuration « en commentaire », et donc désactivées mais dont l'administrateur peut s'inspirer.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#57 16-09-2012 09:06:32

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu] debian sid instable

captnfab a écrit :

Dans beaucoup de fichiers de configuration,....



merci ++ une ligne sans  # est donc dite "décommentée" et devient active, si je comprends bien.


"Being is not doing"

Hors ligne

#58 16-09-2012 09:10:25

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] debian sid instable

oui smile
C'est pour ça qu'il ne faut pas « décommenter » une ligne contenant un vrai commentaire comme « # Enabling automatic login »

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#59 16-09-2012 09:13:18

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu] debian sid instable

captnfab a écrit :

oui smile
C'est pour ça qu'il ne faut pas « décommenter » une ligne contenant un vrai commentaire comme « # Enabling automatic login »



ok. je comprends. "enabling automatic login" n'est qu'un commentaire, qui désigne les lignes qui le suivent, afin d'en faciliter la compréhension.


"Being is not doing"

Hors ligne

#60 16-09-2012 09:21:52

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu] debian sid instable

je n'ouvre pas de nouveaux fils de discussion, car on peut dire que tout cela concerne la mise à jour wheezy. une question concernant la gestion des périphériques usb. j'ai deux disques durs usb. ils sont bien montés avec leurs noms au démarrage. mais dans media, ils apparaissent avec les noms de usb0 et usb1. dans la colonne de gauche de nautilus, on a les deux disques montés avec leurs noms d'origine + usb0 et usb1 non montés ou considérés comme déjà montés. peu pratique, car par exemple pour utiliser luckybackup superuser pour copier un disque sur l'autre, on a accès uniquement aux dénominations usb0 et usb1, et non aux noms d'origine, ce qui peut engendrer des erreurs.

"Being is not doing"

Hors ligne

#61 16-09-2012 11:18:10

Switch
Membre
(G)UI : XFCE !
Inscription : 17-06-2012
Site Web

Re : [Résolu] debian sid instable

Je ne sais pas si tes clés ont déja un nom ou "label" ?:

L'option -l de mount affiche en plus des partitions montées, leur "étiquette" ou surnom. Cherches dedans à quel périphérique et partition correspond ton usb0.

mount -l


Exemple chez moi pour voir à quel périphérique correspond ma clée USB dont la partition unique, nommée BLANCHE dans nautilus.
Elle a déja une étiquette et n'est pas  nommée usb0 comme pour toi.
Je peux filtrer la sortie de mount grâce à grep en demandant de voir que la ligne contenant le mot que je cherche:

$ mount -l | grep BLANCHE
/dev/sdg1 on /media/BLANCHE type vfat  (...etc...) [BLANCHE]


Je vois ici que la clé montée dans le dossier /media/BLANCHE correspond au périphérique /dev/sdg et partition 1.
L'outil permettant de lire/définir le "label" des partitions sous Linux est généralement

e2label


Mais ici la clé USB on voir que la partition de la clé est formatée en VFAT (systeme FAT32 de Windows ). C'est fait pour que ma clé soit lisible sur les pc des windoziens.
Du coup je dois trouver la commande qui permet de lire le label des partitions au format  windows/DOS.
J'utilise la commande "apropos" et cherche le mot "label":

apropos label


je vois ce résultat qui semble parler d'une commande qui peut lire et modifier le label:

dosfslabel (8)       - set or get a MS-DOS filesystem label


Je test sur la clé:

# dosfslabel /dev/sdg1


Ca affiche bien le label de ma clé : "BLANCHE".
Je peux aussi modifier le label ainsi:

# dosfslabel /dev/sdg1 JEANMARC


Puis vérifier avec la commande précédente.

Tout ceci est faisable avec l'outil graphique des partitionnement Gparted évidement.
Pour les systèmes de fichiers linux (ext2,3 ...) utilises e2label.

man e2label
man dosfslabel
...



En espérant que nommer tes clés fera que ton nautilus les affichera avec ce nom ?

Au passage je crois que le vrai identifiant unique d'une clé c'est le numérro UUID.
La commande blkid (IDentité des BLocKs):
Exemple en filtrant la sortie avec grep pour voir que ma clé:

# blkid | grep BLANCHE
/dev/sdg1: LABEL="BLANCHE" UUID="7834-850E" TYPE="vfat"

Dernière modification par Switch (16-09-2012 11:31:01)

Hors ligne

#62 16-09-2012 17:53:36

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu] debian sid instable

merci beaucoup, switch, pour ton aide.
en utilisant mount -l, je trouve mes deux disques durs usb :

/dev/sde1 on /media/usb0 type ext4 (rw,nosuid,nodev,noexec,relatime,user_xattr,acl,barrier=1,data=ordered,user=jm) [icybox]

/dev/sdd1 on /media/usb1 type ext4 (rw,nosuid,nodev,noexec,relatime,user_xattr,barrier=1,data=ordered,user=jm) [samsung 3]



d'après ce que je comprends, usb0 et usb1 sont les points de montage. j'ai l'impression qu'on ne peut pas les modifier. les noms icybox et samsung 3 sont les étiquettes. on peut les modifier en effet avec gparted ou la commande que tu indiques.

en fait, ils apparaissent dans la colonne de gauche de nautilus, à la rubrique "périphériques", comme s'ils étaient non montés. ainsi qu'apparaissent aussi les étiquettes des deux disques durs montés. soit je laisse tomber, et repère définitivement les équivalences entre les points de montage et les étiquettes, pour ne pas inverser la sauvegarde d'un disque dur sur l'autre, soit je trouve un moyen de modifier le nom de montage, qui devrait alors devenir /media/icybox et /media/samsung3.


"Being is not doing"

Hors ligne

#63 16-09-2012 21:17:42

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu] debian sid instable

Bonsoir

Ce qui est étrange, c'est que chez moi, les périphériques de stockage USB amovibles montent systématiquement selon les étiquettes. S'il n'y en a pas c'est Système de fichiers taille !!

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#64 16-09-2012 22:06:27

Switch
Membre
(G)UI : XFCE !
Inscription : 17-06-2012
Site Web

Re : [Résolu] debian sid instable

je ne sais pas quel et comment est configurer le système de montage automatique chez toi.
Comme Bendia, chez moi les CLé USB sont montées dans /media/LABEL et pas /media/usbX hmm
Probablement qu'avec des disques dur et pas de simples clé USB ca change de règles?
Bref, essayes de voir quel système monte tes disques automatiquement voir si tu peux le configurer; ou
Configurer toi même le montage de ces 2 disques, avec fstab (ou udev ? ).
Chaque lien de fstab dit ou monter quoi. Tu peux identifier définir précisement le  périphérique à monter avec son identifiant unique UUID dasn la ligne fstab; et dire ou le monter et avec quels options (lecture ecriture etc).
Je ne confirme rien, je n'ai jamais utilisé de disque durs USB .

Edit: jai pas testé mais cette personne donne un exemlpe pour que udev gere quand il branche un disque dur extrene, exprès pour utiliser la sauvegarde. (c'est de 2009 ):
http://www.ubbdf.fr/pmwiki/Deb/Udev

Dernière modification par Switch (16-09-2012 23:50:24)

Hors ligne

#65 17-09-2012 05:36:33

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu] debian sid instable

bendia a écrit :

Bonsoir
Ce qui est étrange, c'est que chez moi, les périphériques de stockage USB amovibles montent systématiquement selon les étiquettes. S'il n'y en a pas c'est Système de fichiers taille !!



oui, c'est curieux. par exemple, là je me sers du même portable sans les disques usb. dans nautilus, il a gardé non monté usb0 et usb1.


"Being is not doing"

Hors ligne

#66 17-09-2012 05:38:36

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu] debian sid instable

Switch a écrit :

je ne sais pas quel et comment est configurer le système de montage automatique chez toi.
Comme Bendia, chez moi les CLé USB sont montées dans /media/LABEL et pas /media/usbX hmm
Probablement qu'avec des disques dur et pas de simples clé USB ca change de règles?
Bref, essayes de voir quel système monte tes disques automatiquement voir si tu peux le configurer; ou
Configurer toi même le montage de ces 2 disques, avec fstab (ou udev ? ).
Chaque lien de fstab dit ou monter quoi. Tu peux identifier définir précisement le  périphérique à monter avec son identifiant unique UUID dasn la ligne fstab; et dire ou le monter et avec quels options (lecture ecriture etc).
Je ne confirme rien, je n'ai jamais utilisé de disque durs USB .
Edit: jai pas testé mais cette personne donne un exemlpe pour que udev gere quand il branche un disque dur extrene, exprès pour utiliser la sauvegarde. (c'est de 2009 ):
http://www.ubbdf.fr/pmwiki/Deb/Udev



merci pour les suggestions. bon, je vais voir cela sans urgence, car ce n'est pas un problème majeur. mais il faut tout de même regarder cela. la solution udev a l'air intéressante. j'ai d'ailleurs renoncé à l'utilisation des nas, à cause de la mauvaise gestion par les logiciels de sauvegarde type luckybackup. j'utilise des disques usb accessibles dans le réseau par samba.


"Being is not doing"

Hors ligne

#67 17-09-2012 06:01:41

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu] debian sid instable

si je voulais installer une wheezy, sur une partition libre de mon second ordi, qui tourne sous squeeze, quelle est la meilleure méthode ?

"Being is not doing"

Hors ligne

#68 17-09-2012 08:25:58

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] debian sid instable

Salut jeanmarc1,

Ta question est intéressante, pourrais-tu la reformuler à l'identique dans une nouvelle discussion, section installation.

Yep ! smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#69 17-09-2012 08:27:08

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu] debian sid instable

smolski a écrit :

Salut jeanmarc1,
Ta question est intéressante, pourrais-tu la reformuler à l'identique dans une nouvelle discussion, section installation.
Yep ! smile



ok ++


"Being is not doing"

Hors ligne

#70 18-09-2012 08:26:52

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu] debian sid instable

captnfab a écrit :

Cool, c'est le cas le plus simple.
Il te suffit (en root) d'arrêter network-manager

invoke-rc.d network-manager stop


Puis de lancer la connexion automatique:

dhclient


Si cela ne fonctionne toujours pas, il suffit de régler les DNS en mettant (toujours en root), par exemple, ceux d'opendns:

nameserver 208.67.222.222


dans le fichier /etc/resolv.conf
Une fois le réseau fonctionnel:

aptitude update
aptitude full-upgrade



bonjour,
sur le second wheezy que j'ai installé sur une partition libre d'un autre ordi à partir de l'image iso que tu m'avais transmise, je débouche toujours sur une interface de terminal. j'ai pu mettre une connexion internet en changeant les dns de resolv.conf. startx ne fonctionne pas.
j'ai fait un aptitude-update. dois-je faire un aptitude upgrade ou full-upgrade pour accéder à un wheezy fonctionnel ?


"Being is not doing"

Hors ligne

#71 18-09-2012 10:28:44

bel@mi
Membre
Distrib. : Stable (bpo)
Inscription : 14-04-2012

Re : [Résolu] debian sid instable

As-tu installé un gestionnaire de bureau ?

Hors ligne

#72 18-09-2012 10:30:48

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu] debian sid instable

Galandou a écrit :

As-tu installé un gestionnaire de bureau ?



non. dois-je faire un aptitude install gdm3 ?


"Being is not doing"

Hors ligne

#73 18-09-2012 11:18:57

bel@mi
Membre
Distrib. : Stable (bpo)
Inscription : 14-04-2012

Re : [Résolu] debian sid instable

Je te renvoie sur cette page http://wiki.debian.org/fr/DesktopEnvironment  Tu auras tout à loisir de voir les différents de gestionnaires de bureau, au gestionnaire de fenêtres....Tu suis les liens, il y a les explications, les méthodes d'installation.

Hors ligne

#74 18-09-2012 11:28:14

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu] debian sid instable

Galandou a écrit :

Je te renvoie sur cette page http://wiki.debian.org/fr/DesktopEnvironment  Tu auras tout à loisir de voir les différents de gestionnaires de bureau, au gestionnaire de fenêtres....Tu suis les liens, il y a les explications, les méthodes d'installation.



merci ++ si par ex on installe kde, peut-on repasser ensuite à gnome ?


"Being is not doing"

Hors ligne

#75 18-09-2012 12:05:23

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] debian sid instable

oui en désinstallant proprement kde (ah le syndrome captnfab m'a frappé !) et en installant proprement un autre environnement...

En remarque, je sais qu'en installant lxde sur une squeeze, sans désinstaller gnome, je passe à l'environnement lxde sans problème. roll

Dernière modification par smolski (18-09-2012 12:09:13)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums