Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-09-2012 19:19:46

asnow
Membre
Inscription : 20-09-2012

[Résolu]Montage auto DD au demarrage

Bonsoir,

Je suis un nouvel utilisateur et après la lecture de kilomètre de forum, je ne parviens toujours pas à faire un truc tout bête je suppose:(:.

Voila j'essaye en vain de monter mon dd (Hdd 1.2 To) automatiquement au démarrage, dans le fstab :

  GNU nano 2.2.4             Fichier : /etc/fstab                      Modifié 

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sda1 during installation
UUID=a43bd9a8-c641-4cb7-a3f3-9c612b5e9f03 /               ext3    errors=remoun$
# swap was on /dev/sda5 during installation
UUID=f0807075-b2a0-481a-b2b1-594b45ebcdde none            swap    sw           $
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/scd1       /media/cdrom1   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
/dev/sda        /media/Hdd 1.2 To auto defaults,umask=777        0       0




^G Aide      ^O Écrire    ^R Lire fich.^Y Page préc.^K Couper    ^C Pos. cur.
^X Quitter   ^J Justifier ^W Chercher  ^V Page suiv.^U Coller    ^T Orthograp.


Si quelqu'un aurai la gentillesse de me donner un coup de pouce.

Merci.

Dernière modification par asnow (30-09-2012 14:25:17)


Mon petit Jo, tu termine ce que tu as commencé et tu dégage de chez moi !

www.youtube.com/watch?v=k1jjjNTJqvQ (très con, mais j'adore)

Hors ligne

#2 20-09-2012 19:36:39

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu]Montage auto DD au demarrage

Salut asnov et bienvenue sur df !

Alors, il faut connaître l'UUID de ton disque.
Passe en terminal et tape :

ls -lh /dev/disk/by-uuid


Tu obtiens la liste des UUID présents sur tes disques.
Voir le tuto là :
http://debian-facile.org/doc:systeme:ls … sk_by-uuid
Fait une copie de sauvegarde de ton fichier fstab actuel par un terminal root en tapant :

cp -r /etc/fstab /etc/fstab-sav


Maintenant, tu peux monter la partition de ce disque dans le fstab par son UUID.

Prends exemple de ce qui est rédigé pour ton /home en le copiant/collant à la suite puis en le rédigeant correctement pour ton propre disque.

Tu peux aussi lister la présence de ton disque avec la commande fdisk en tapant dans un terminal root :

fdisk -l


http://debian-facile.org/doc:systeme:fdisk#option_-l

Et même en déterminer le système de fichier dans lequel il est formaté en utilisant la commande df dans un terminal user ainsi :

df -hT


http://debian-facile.org/doc:systeme:df#option_-ht

N'hésite pas à nous demander si tu as des difficultés de compréhension des tutos comme de cette réponse.

Yep ! big_smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 20-09-2012 20:42:02

asnow
Membre
Inscription : 20-09-2012

Re : [Résolu]Montage auto DD au demarrage

Salut Smolski,

Merci de ton intérêt.
Mais j'ai tenté de suivre tes conseil et j'ai du faire une bêtise. Car maintenant la machine ne redémarre plus et failed apparaisse apres plusieurs lignes au démarrage.

J'ai sauvegarder le fichier fstab comme tu me la suggérer mais comment le restaurer, car je peux seulement lire le fichier.

Au secours !!!

Merci d'avance!

Mon petit Jo, tu termine ce que tu as commencé et tu dégage de chez moi !

www.youtube.com/watch?v=k1jjjNTJqvQ (très con, mais j'adore)

Hors ligne

#4 20-09-2012 21:14:52

asnow
Membre
Inscription : 20-09-2012

Re : [Résolu]Montage auto DD au demarrage

Non c'est bon en farfouillant j'ai trouvé mount / -o remount,rw qui ma permis de modifier fstab et de redémarrer normalement.
J'ai réparer ma bêtise tout seul. OUFF.

Mon petit Jo, tu termine ce que tu as commencé et tu dégage de chez moi !

www.youtube.com/watch?v=k1jjjNTJqvQ (très con, mais j'adore)

Hors ligne

#5 20-09-2012 21:44:24

asnow
Membre
Inscription : 20-09-2012

Re : [Résolu]Montage auto DD au demarrage

En faites je me suis trompé dans la syntaxe. par contre j'ai corrigé, mais ça ne marche. Je recapitule :

root@asnowdebian:/home/asnow# blkid
/dev/sdb1: LABEL="Hdd 500G" UUID="44DB71A03CBC120F" TYPE="ntfs"
/dev/sda1: UUID="a43bd9a8-c641-4cb7-a3f3-9c612b5e9f03" TYPE="ext3"
/dev/sda3: LABEL="Hdd 1.2 To" UUID="a9effa81-cbaf-42d9-8e57-d86965d537f9" TYPE="ext2"
/dev/sda5: UUID="f0807075-b2a0-481a-b2b1-594b45ebcdde" TYPE="swap"
root@asnowdebian:/home/asnow#

A la 3ème ligne j'obtient le UUID de HDD 1.2 To.

Dans fsatb, je crée la dernière ligne :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sda1 during installation
UUID=a43bd9a8-c641-4cb7-a3f3-9c612b5e9f03 /               ext3    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=f0807075-b2a0-481a-b2b1-594b45ebcdde none            swap    sw              0       0



/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/scd1       /media/cdrom1   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
/dev/sda        /media/Hdd 1.2 To auto defaults,umask=777        0       0
UUID=a9effa81-cbaf-42d9-8e57-d86965d537f9 /               ext2    errors=remount-ro 0       1

UUID correspond au numéro recueillis tout à l'heure et je met ext2, car c'est le type donné plus haut.

Mais ça ne marche pas !

Suis je bête ou quelque chose m'échappe.

Merci à toi d'avance.
C'est pas évident de passer de windows à ça !

Mon petit Jo, tu termine ce que tu as commencé et tu dégage de chez moi !

www.youtube.com/watch?v=k1jjjNTJqvQ (très con, mais j'adore)

Hors ligne

#6 20-09-2012 22:33:51

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu]Montage auto DD au demarrage

/dev/sda        /media/Hdd 1.2 To auto defaults,umask=777        0       0


Encore une fois, /dev/sda est le disque tout entier, pas la partition que tu veux monter. smile

Peux-tu nous donner copie de la commande en terminal root :

fdisk -l


Et pareil pour ton fstab :
dans un terminal user :

cat /etc/fstab


et copie du fichier.
NOTA : Utilise les CODE pour encadrer le résultat de tes copies de configuration, c'est plus lisible.

Tu peux modifier le label de ton disque aussi, voir la commande :
http://debian-facile.org/doc:systeme:e2label

Afin de lui donner un nom sans espace et plus commode à reproduire.
Perso, je label disk-1 disk-2 disk-3 etc...

Pourquoi as-tu formaté en ext2 ?

Hop hop hop ! big_smile

Edit : voici mon fstab :

cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sda2 during installation
UUID=b9caae12-b938-4e38-b210-0d69613e5ecf /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda1 during installation
UUID=801d6e5c-a630-4548-bd1a-2ff802027b0f /boot           ext2    defaults        0       2
# /home was on /dev/sda9 during installation
UUID=fe1b0f96-c597-450c-9974-d2555fd988eb /home           ext4    defaults        0       2
# /tmp was on /dev/sda8 during installation
UUID=358423e4-7497-430e-9478-4a5f4d88e7aa /tmp            ext4    defaults        0       2
# /usr was on /dev/sda6 during installation
UUID=34adbdb3-2ce3-40ab-95c0-79d2cd4be73a /usr            ext4    defaults        0       2
# /var was on /dev/sda7 during installation
UUID=40a72011-1574-402f-a08b-c232566d3245 /var            ext4    defaults        0       2
# swap was on /dev/sda5 during installation
UUID=5c349945-0b2b-4143-a5f3-23a02516e27b none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0

# stock was on /dev/sda4 during installation
UUID=3eac5a2f-ca7a-4051-b49f-5151bc9977e9 /media/stock           ext3    defaults        0       2
# site was on /dev/sdb1 during installation
UUID=70d23a97-36fa-4196-a64c-5aae38a7cb91 /media/disk-11           ext4    defaults        0       2
# disk-2 was on /dev/sdc1 during installation
UUID=5c12329b-c041-435d-b2eb-baebdaf2033d /media/disk-2           ext4    defaults        0       2
# disk-3 was on /dev/sdd1 during installation
UUID=99ee1b3f-0f0e-4d8b-89a8-2af1848cf2fd /media/disk-3           ext3    defaults        0       2
# disk_ext was on /dev/sde1 during installation
UUID=4e71b4c9-2d39-410b-bf4a-babac5bfeb23 /media/disk_ext           ext3    defaults        0       2

 


Visite le tuto concernant fstab aussi :
http://debian-facile.org/manuel:config:fstab


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#7 21-09-2012 03:28:49

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu]Montage auto DD au demarrage

Salut

/dev/sda3: LABEL="Hdd 1.2 To" UUID="a9effa81-cbaf-42d9-8e57-d86965d537f9" TYPE="ext2"



/dev/sda3, la partition a monter. C'est l'info que voulait Jojo smile.

Une remarque en passant. Pour ma part, je préférerais avoir une point de montage simple comme /media/Hdd1.2To (ou juste Hdd par ex.), ou un truc de genre, au lieu d'avoir un dossier avec des espaces. Le /Hdd 1.2 To ne sera pas être pris en compte correctement s'il est écrit comme ça. Il faudrait plutôt écrire /media/Hdd\ 1.2\ To/ pour protéger les espaces. Tu pourrais mettre aussi /media/Hdd_1.2_To si tu tiens à tout garder

En passant, ton disque "Hdd 1.2 To", c'est un disque USB ou non ?

Dernière modification par martinux_qc (21-09-2012 03:41:03)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#8 29-09-2012 15:00:22

asnow
Membre
Inscription : 20-09-2012

Re : [Résolu]Montage auto DD au demarrage

Bonjour,

Merci à tous pour vos précieux conseil. Grace à vous j'ai enfin réussis.
(c'est un dd interne pas usb).

Mon petit Jo, tu termine ce que tu as commencé et tu dégage de chez moi !

www.youtube.com/watch?v=k1jjjNTJqvQ (très con, mais j'adore)

Hors ligne

#9 29-09-2012 22:55:04

asnow
Membre
Inscription : 20-09-2012

Re : [Résolu]Montage auto DD au demarrage

Bonsoir,

Suite à toutes ces manip, depuis peu mon bureau à distance activé dans debian ne fonctionne plus que quand j'ai un écran de connecté à mon serveur. Avant je pouvais y accéder depuis mon ipad avec vnc, également depuis mon pc. Maintenant quand je débranche l'écran, après une minute mon accès vnc ce coupe et plus de connections possible jusqu’à ce que je rebranche l'écran sur le serveur.

En espérant m'être exprimer corectement, j'espère que quelqu'un pourra m'aider.

Merci

Mon petit Jo, tu termine ce que tu as commencé et tu dégage de chez moi !

www.youtube.com/watch?v=k1jjjNTJqvQ (très con, mais j'adore)

Hors ligne

#10 30-09-2012 02:32:05

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu]Montage auto DD au demarrage

Salut asnow

1) Il est bon de mettre un [Résolu] devant le titre de son sujet, lorsque le problème est résolu, pour indiquer que l'on a trouvé une réponse satisfaisante à sa question.

Il serait bien aussi que tu indiques exactement comment tu as résolu le problème. Cela pourrait être utile à d'autres qui seraient dans ta situation.

2) Une autre règle importante à suivre est : un fil de discussion, un problème. C'est plus facile, lorsqu'on fait une recherche sur un problème donné, de tomber sur une solution. De plus, en voyant le titre de ton sujet, tu auras plus de chance que des gens répondent à ta question. Là, le titre de ce fil n'a pas de rapport avec ton dernier problème.

Je t'invite donc à ouvrir un nouveau fil de discussion où tu reprendra ton problème. Tu pourras toujours mettre un lien vers ce fil si tu le juge nécessaire.

Dernière modification par martinux_qc (30-09-2012 02:35:55)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#11 30-09-2012 14:21:42

asnow
Membre
Inscription : 20-09-2012

Re : [Résolu]Montage auto DD au demarrage

Bonjour,

Suite à la réflexion de Martinux_qc concernant les règles, je vais préciser comment j'ai résolu mon problème.

En faites il fallait tout simplement ajouter :

# / was on /dev/sda3 during installation
UUID=a9effa81-cbaf-42d9-8e57-d86965d537f9 /media/Hdd1.2               ext2    defaults          0       2



à mon fichier fstab.

Ont peut voir que j'ai suivis les conseil concernant les espaces.

Merci encore pour votre aide !!!!!!!


Mon petit Jo, tu termine ce que tu as commencé et tu dégage de chez moi !

www.youtube.com/watch?v=k1jjjNTJqvQ (très con, mais j'adore)

Hors ligne

#12 30-09-2012 15:12:00

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu]Montage auto DD au demarrage

Merci, sympa le retour !
Cela pourra certainement servir à des visiteurs ainsi.

Remarque :
Ça :

//media/Hdd1.2



Ne devrait pas avoir un double slash devant mais un simple, comme ceci :

/media/Hdd1.2



Pour que la ligne soit parfaitement écrite !

Car ici le slash (/) indique la racine du système,
media le répertoire contenu dans cette racine
Hdd1.2 le répertoire contenu dans le répertoire media et contenant les données de ton disque.

Voir le tuto des répertoires et leurs chemins :
http://debian-facile.org/doc:programmat … epertoires

wink


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#13 30-09-2012 15:22:56

asnow
Membre
Inscription : 20-09-2012

Re : [Résolu]Montage auto DD au demarrage

Oui tu as raison petite faute frappe !

Mon petit Jo, tu termine ce que tu as commencé et tu dégage de chez moi !

www.youtube.com/watch?v=k1jjjNTJqvQ (très con, mais j'adore)

Hors ligne

#14 30-09-2012 17:11:50

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu]Montage auto DD au demarrage

Merci pour le retour asnow.

Comme le mentionne Jojo, c'est toujours apprécié et utile. Cela permet de confirmer la méthode utilisée pour résoudre le problème.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

Pied de page des forums