Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#76 11-01-2013 11:14:12

vince06fr
Membre
Distrib. : Debian Sid/experimental
Noyau : Linux 3.7-trunk-amd64
(G)UI : gnome-shell (gnome 3.6)
Inscription : 29-10-2012

Re : Gnome 3.6 out

Utiliser gnome-shell sans utiliser les bureaux multiples alors que les bureaux dynamique s sont une vrai tuerie(bon c'est juste mon avis).
Et pourquoi ne plus utiliser Alt-tab alors qu'il est toujours la?
Ctrl supr au lieu de juste supr c'est pas trop dur non plus et si vraiment tu veux un navigateur qui se comporte comme l'ancien naitilus, installe thunar
Quand a l'obligation d'avoir un dock alors que tu le fais apparaître juste avec la touche super ou par activité,  c'est juste encombrer ton bureau
J'accéder au bureau exactement comme avant, je comprend pas quel est ton problème
Bon encore une fois ce n'est que mon avis vis a vis de mon expérience gnome+shell

Dernière modification par vince06fr (11-01-2013 11:17:20)

Hors ligne

#77 11-01-2013 16:07:28

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : Gnome 3.6 out

vince06fr a écrit :

Utiliser gnome-shell sans utiliser les bureaux multiples alors que les bureaux dynamique s sont une vrai tuerie(bon c'est juste mon avis).


C'est beaucoup trop long, il faut rentrer/sortir du dash systématiquement, il n'y a pas de bascule à la souris rapide.

vince06fr a écrit :

Et pourquoi ne plus utiliser Alt-tab alors qu'il est toujours la?


En fait je l'utilise mais avec une extension, sinon l'original oblige à utiliser les deux mains quand il y a plusieurs fenêtre d'une même application.
https://extensions.gnome.org/extension/ … s-alt-tab/

vince06fr a écrit :

Ctrl supr au lieu de juste supr c'est pas trop dur non plus


Oui mais ça sert à rien, la sécurité est assuré par la corbeille.

vince06fr a écrit :

et si vraiment tu veux un navigateur qui se comporte comme l'ancien naitilus, installe thunar


Pas convaincu par Xfce, trop jeune et je crois pas qu'il prennent en charge les nautilus script.

vince06fr a écrit :

Quand a l'obligation d'avoir un dock alors que tu le fais apparaître juste avec la touche super ou par activité,  c'est juste encombrer ton bureau


Tu veux me faire vomir avec ces allez retour, je sais pas toi, mais j'ai un écran de 24" et l'effet de vomissement est proportionnel à la taille de l'écran.
De plus la position des applications évoluent constamment en fonction de l'ouverture des fenêtres, pas moyen de savoir ou une appli va se trouver, alors qu'avec un dock ça ne bouge pas.

vince06fr a écrit :

J'accéder au bureau exactement comme avant, je comprend pas quel est ton problème


Je parle du bureau, l'espace de travail derrière les applications, pas moyen d'y accéder facilement, pas moyen de minimiser les applications non plus.

vince06fr a écrit :

Bon encore une fois ce n'est que mon avis vis a vis de mon expérience gnome+shell


Regarde le nombre d'extension installé par utilisateur et par Gnome-Shell, tu verra qu'il y a un problème.
Une bonne interface ne nécessite pas autant de customisation et de patch bizarres pour arriver à être convenable.

Personnellement, je suis de prés le progrès de Gnome, et trouve dommage que cette période de flottement s'éternise.
Pour avoir des news fraîches de Gnome je vous conseille ce site:
http://worldofgnome.org/

Hors ligne

#78 11-01-2013 17:17:05

misaine
Membre
Lieu : sables d'olonne
Distrib. : Antergos (Archlinux)
Noyau : 4.3.3
(G)UI : gnome-shell 3.18.2
Inscription : 29-07-2007

Re : Gnome 3.6 out

C'est beaucoup trop long, il faut rentrer/sortir du dash systématiquement, il n'y a pas de bascule à la souris rapide.


la bascule au clavier est bien plus rapide voir instantanée. il faut comprendre que gnome-shell produit tous ses avantages par l'utilisation du clavier.ce qui prouve bien qu'il n'est pas conçu pour les tablettes.
pour ma part je n'utilise pas d'extension , il y a déjà tout smile

Dernière modification par misaine (11-01-2013 17:21:48)


amd phenom 7650 , 4 Go DDR2 ,GeForce N210

Hors ligne

#79 11-01-2013 18:19:42

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : Gnome 3.6 out

Bon, c'est bien parce que vous insistez, je vais retester Gnome-Shell sans extension, en gardant la philo de départ.
Je sais que c'est un peu maso mais je vais essayer de tenir la distance.
Je garde juste l'extension qui remet le shut down.(faut pas exagérer non plus).
J'ai viré l'affichage du bureau aussi.

Sinon, on a toujours pas la possibilité d'installer Gnome 3.6 dans Wheezy?

Hors ligne

#80 11-01-2013 18:40:31

misaine
Membre
Lieu : sables d'olonne
Distrib. : Antergos (Archlinux)
Noyau : 4.3.3
(G)UI : gnome-shell 3.18.2
Inscription : 29-07-2007

Re : Gnome 3.6 out

Sinon, on a toujours pas la possibilité d'installer Gnome 3.6 dans Wheezy?


il est dans experimental donc ce doit être possible.
d'ailleurs d'après son info-distri , vince06fr est en 3.6 wink

edit : j'essaierai ce soir sur ma siduction

Dernière modification par misaine (11-01-2013 18:43:26)


amd phenom 7650 , 4 Go DDR2 ,GeForce N210

Hors ligne

#81 11-01-2013 18:55:31

vince06fr
Membre
Distrib. : Debian Sid/experimental
Noyau : Linux 3.7-trunk-amd64
(G)UI : gnome-shell (gnome 3.6)
Inscription : 29-10-2012

Re : Gnome 3.6 out

Oui-oui, gnome-shell 3.6 est dans experimental, attention, il y a encore du changement avec 3.4, il m'a fallut un peu de temps pour m'y habituer
De même nautilus 3.6 est dans experimental et là aussi il y a encore du changement, notament le retour des emblemes

juste pour revenir sur le ctrl-supr à la place de supr, ce n'est pas pour la sécurité mais pour plus de cohérence avec les raccourcis du genre ctrl-C ctrl-V, etc..

un tres bon article sur le futur de gnome :
https://linuxfr.org/news/gnome-3-6-en-r … -gnome-4-0

Dernière modification par vince06fr (12-01-2013 01:35:49)

Hors ligne

#82 11-01-2013 18:57:46

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : Gnome 3.6 out

vince06fr a écrit :

Oui-oui, gnome-shell 3.6 est dans experimental, attention, il y a encore du changement avec 3.4, il m'a fallut un peu de temps pour m'y habituer
De même nautilsu 3.6 est dans experimenta et là aussi il y a encore du changement, notament le retour des emblemes

juste pour revenir sur le ctrl-supr à la place de supr, ce n'est pas pour la sécurité mais pour plus de cohérence avec les raccourcis du genre ctrl-C ctrl-V, etc..

un tres bon article sur le futur de gnome :
https://linuxfr.org/news/gnome-3-6-en-r … -gnome-4-0


Tu aurais pas une procédure pour l'installer par hasard?

Hors ligne

#83 11-01-2013 19:18:53

vince06fr
Membre
Distrib. : Debian Sid/experimental
Noyau : Linux 3.7-trunk-amd64
(G)UI : gnome-shell (gnome 3.6)
Inscription : 29-10-2012

Re : Gnome 3.6 out

Je suis en Sid mais quel que soit la version de debian le dépôt experimental est automatiquement en priorité 1, il n'y a donc même pas besoin de faire de pinning pour l'installer donc allons-y :

édite le fichier /etc/apt/sources.list avec ton éditeur préféré et rajoute les lignes suivantes

## experimental
deb http://ftp.fr.debian.org/debian/ experimental main contrib non-free
#deb-src http://ftp.fr.debian.org/debian/ experimental main contrib non-free
 


enregistre et ferme l'editeur puis fais un update

#apt-get update


utilise aptitude si tu preferes

avant de faire quoi que ce soit on va vérifier que la priorité du dépot est bien à 1

$ apt-cache policy


dans le retour de la commande tu dois trouvé les lignes suivantes

 500 http://ftp.fr.debian.org/debian/ experimental/non-free Translation-en
 500 http://ftp.fr.debian.org/debian/ experimental/main Translation-en
 500 http://ftp.fr.debian.org/debian/ experimental/contrib Translation-en
   1 http://ftp.fr.debian.org/debian/ experimental/non-free amd64 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=non-free
     origin ftp.fr.debian.org
   1 http://ftp.fr.debian.org/debian/ experimental/contrib amd64 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=contrib
     origin ftp.fr.debian.org
   1 http://ftp.fr.debian.org/debian/ experimental/main amd64 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=main
     origin ftp.fr.debian.org


Ca veux dire que c'est bon, tu ne risque pas de passer tout ton système en experimental
Tu peux aussi installer apt-listbugs pour être prévenu des bogues non corrigés des paquets que tu installes, ça peux t'éviter d'installer un paquet contenant un bug critique provenant du dépot experimental mais c'est pas obligatoire car avec un pinning à 1 il faut que tu explique à apt que le paquet doit venir d'experimental(par contre en Sid ou en wheezy c'est vraiment recommandé)

Bon pour installer gnome-shell depuis experimental il faut faire

# apt-get update
# apt-get install -t experimental gnome-shell  nautilus


les paquets nautilus et gnome-shell comprennent de nombreux bugs serieux mais pas de bugs critiques, ils sont donc utilisables

!! Attention s'il t'est proposé de mettre à jour libc6 refuse car libc6 est un paquet essentiel et en Squeeze, je ne suis pas sûr que ça passe sans mise à jour de ce paquet


Bon maintenant si tu laisse le dépôt experimental activé, chaque fois que tu voudras installer un paquet et ses dépendances depuis ce dépôt il te suffit de taper

#apt-get update
# apt-get install -t experimental [paquet à installer]




attention les paquets experimental installé de cette maniere ne seront pas mis à jour automatiquement vers une nouvelles versions d'experimental, il faut mettre à jour en relançant la commande

# apt-get update
# apt-get -t experimental install [paquet]


si tu veux suivre les mises à jours d'un paquet installé depuis experimental il faut faire du pining sur ce paquet
http://wiki.debian.org/DebianExperiment … al_package


Edit : correction pour correction d'une commande et rajout d'un avertissement

Dernière modification par vince06fr (13-01-2013 09:31:28)

Hors ligne

#84 11-01-2013 19:41:06

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : Gnome 3.6 out

Merci pour la doc
J'ai ajouté le dépôt mais ça bloque au niveau des en-têtes

Ign http://security.debian.org wheezy/updates/non-free Translation-ca
Ign http://security.debian.org wheezy/updates/non-free Translation-ru
Ign http://security.debian.org wheezy/updates/non-free Translation-id
89% [Attente des fichiers d'en-tête]
 


C'est peut être un probléme de disponibilité serveur, je retenterais plus tard.

Hors ligne

#85 12-01-2013 10:58:28

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : Gnome 3.6 out

Je pense que ce n'est pas encore possible avec Wheezy.

sudo apt-get install -t experimental task-gnome-desktop gnome-shell  nautilus
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
task-gnome-desktop est déjà la plus récente version disponible.
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 gnome-shell : Dépend: libgstreamer1.0-0 (>= 1.0.0) mais il n'est pas installable
               Dépend: libtelepathy-logger3 (>= 0.2.0) mais il n'est pas installable
               Dépend: gir1.2-gnomebluetooth-1.0 (>= 3.6.0) mais 3.4.2-1 devra être installé
               Casse: gdm3 (< 3.5.90) mais 3.4.1-5 devra être installé
 task-gnome-desktop : Dépend: gnome-core mais ne sera pas installé
                      Recommande: gnome mais ne sera pas installé
                      Recommande: libreoffice-gcj mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
 


Trop de dépendance pas satisfaite.
Faut que je réfléchisse à un dual boot avec Sid peut être.


En attendant la design team de Gnome bosse sur les settings.
http://afaikblog.wordpress.com/2013/01/11/settings/
Ils vont essayer de les faire rentrer dans Gnome 3.8

Il y a aussi un accès au git de l'équipe pour explorer les captures:
https://github.com/gnome-design-team

Hors ligne

#86 12-01-2013 19:20:30

vince06fr
Membre
Distrib. : Debian Sid/experimental
Noyau : Linux 3.7-trunk-amd64
(G)UI : gnome-shell (gnome 3.6)
Inscription : 29-10-2012

Re : Gnome 3.6 out

Non, je crois qu'il y a eu des mises à jours importante dans experimental et que comme précisé dans le message certains paquets ne sont pas sorti d'incoming rendant la version de gnome d'incoming incompatible avec les anciennes versions de debian , je viens de casser ma sid en tentant d'upgrader dconf ( lol j'y suis enfin arrivé)

Dernière modification par vince06fr (12-01-2013 20:57:49)

Hors ligne

#87 12-01-2013 21:21:05

misaine
Membre
Lieu : sables d'olonne
Distrib. : Antergos (Archlinux)
Noyau : 4.3.3
(G)UI : gnome-shell 3.18.2
Inscription : 29-07-2007

Re : Gnome 3.6 out

rien n'est plus instable qu'une sid en période de gel de testing lol

amd phenom 7650 , 4 Go DDR2 ,GeForce N210

Hors ligne

#88 13-01-2013 09:29:22

vince06fr
Membre
Distrib. : Debian Sid/experimental
Noyau : Linux 3.7-trunk-amd64
(G)UI : gnome-shell (gnome 3.6)
Inscription : 29-10-2012

Re : Gnome 3.6 out

Oui enfin, en fait le probleme a été résolu avec un

# apt-get purge dconf gnome*
# apt-get update && apt-get upgrade
#apt-get install -t experimental gnome-shell nautilus


Si c'est que ça tu appelles instable hmm bref toujours pas réussis à casser ma Sid, pourtant j'y travaille lol

@kao
En fait il ne faut pas installer le paquet task-gnome-desktop (les paquets nautilus et gnome-shell comprennent de nombreux bugs serieux mais pas de critiques, ils sont donc utilisable) ,je corrige donc mon post
par contre d'apres mes tests en VM ça passe avec Sid mais pas avec squeeze ni avec wheezy

Dernière modification par vince06fr (13-01-2013 14:48:11)

Hors ligne

#89 13-01-2013 19:32:00

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : Gnome 3.6 out

Le problème de dépendance avec Wheezy provient bien de Gnome-Shell lui même.
Il semble possible d'installer Nautilus sans problème mais je préfère le faire en même temps que Gnome-Shell.
Pensez vous qu'il faut attendre, pour que ce soit résolu, ou que c'est mort et les dev préparent déjà Jessie à partir de Sid?

Sinon, Gnome planche sur le design d'un Software Center pour Gnome 3.10.
http://worldofgnome.org/installing-soft … ning-next/
Je trouve l'idée intéressant d'avoir un outil pour installer les applications avec un design cohérent au projet Gnome.

Après ce sera sûrement aux distributions de choisir si elle veulent l'utiliser ou pas.
software-new.png

Hors ligne

Pied de page des forums