Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-09-2012 05:43:31

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

[Résolu] pavé numérique inactif dans wheezy

bonjour,
sur une des deux wheezy que j'ai installées, sur deux ordis différents, impossible de faire fonctionner le pavé numérique d'un clavier usb filaire. il fonctionne bien sur l'autre wheezy. j'ai trouvé dans les forums le moyen d'activer le verrouillage numérique au démarrage du système, mais le pavé numérique reste toujours muet. j'ai cherché dans les paramètres clavier et souris, mais rien ne bouge. suggestion ? merci par avance ++

Dernière modification par jeanmarc1 (29-11-2012 19:11:51)


"Being is not doing"

Hors ligne

#2 27-11-2012 22:42:46

ostyll
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.0.0-1-amd64
(G)UI : Gnome 2.30.2
Inscription : 13-05-2010

Re : [Résolu] pavé numérique inactif dans wheezy

Bonjour,

Je voulais plus de précision sur votre problème vous cherchez a activer le pavé numérique au démarrage de wheezy ou il ne fonctionne pas du tout meme quand la session est ouverte.

Hors ligne

#3 27-11-2012 23:18:08

frenesik
Invité

Re : [Résolu] pavé numérique inactif dans wheezy

plop

Regarde si tu as le paquet numlock d'installé

# aptitude search numlock



si il est installé et que malgré l'installation le pavé ne marche pas il faut l'activer dès le lancement de X. Pour l'activer manuellement tape

numlockx on



ou ajoute dans tes fichier de lancement ( .xinitrc ou autres )

numlockx on &



comme ça à chaque lancement de X ton pavé sera activé

#4 28-11-2012 16:38:46

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu] pavé numérique inactif dans wheezy

ostyll a écrit :

Bonjour,
Je voulais plus de précision sur votre problème vous cherchez a activer le pavé numérique au démarrage de wheezy ou il ne fonctionne pas du tout meme quand la session est ouverte.


bonjour, le pavé numérique ne fonctionne pas du tout quand la session est ouverte. le numlock a l'air de bien s'activer au démarrage. mais le pavé numérique est muet. bien sûr, le clavier lui même fonctionne bien, y compris les chiffres en haut du clavier.


"Being is not doing"

Hors ligne

#5 28-11-2012 16:46:13

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu] pavé numérique inactif dans wheezy

frenesik a écrit :

plop
Regarde si tu as le paquet numlock d'installé

# aptitude search numlock


si il est installé et que malgré l'installation le pavé ne marche pas il faut l'activer dès le lancement de X. Pour l'activer manuellement tape

numlockx on


ou ajoute dans tes fichier de lancement ( .xinitrc ou autres )

numlockx on &


comme ça à chaque lancement de X ton pavé sera activé



merci pour ton message. oui, numlock est bien installé.
après avoir fait

numlockx on

, cela ne change rien. le pavé ne fonctionne toujours pas.

je vais essayer de trouver le fichier de lancement dont tu parles. je ne sais pas où le trouver pour l'instant.


"Being is not doing"

Hors ligne

#6 28-11-2012 16:54:04

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu] pavé numérique inactif dans wheezy

frenesik a écrit :


ou ajoute dans tes fichier de lancement ( .xinitrc ou autres )

numlockx on &


comme ça à chaque lancement de X ton pavé sera activé



voici le contenu du fichier xinitrc :

#!/bin/sh
# /etc/X11/xinit/xinitrc
#
# global xinitrc file, used by all X sessions started by xinit (startx)
# invoke global X session script
. /etc/X11/Xsession
numlockx on &



mais après avoir redémarré le système, le pavé numérique est toujours muet, que j'active ou non la touche Verr Num. celle-ci allume un voyant vert au-dessus du pavé numérique, mais il reste toujours muet.


"Being is not doing"

Hors ligne

#7 28-11-2012 16:57:29

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu] pavé numérique inactif dans wheezy

j'ai aussi essayé d'ajouter un # sur la dernière ligne

# numlockx on &

, cela active le verrouillage num au démarrage, mais le pavé est toujours muet...


"Being is not doing"

Hors ligne

#8 29-11-2012 08:10:11

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu] pavé numérique inactif dans wheezy

peut-être devrais-je réinstaller gnome ? il se peut qu'il y ait des paquets manquants. je ne suis pas sûr, mais on doit pouvoir le faire par un

aptitude reinstall gdm3

?


"Being is not doing"

Hors ligne

#9 29-11-2012 18:13:17

lorus
Modérateur
Lieu : /var/log/snort/alert
Distrib. : Debian Squeeze/Wheezy/Freebsd amd64
Noyau : 2.6.32 / 3.2/
(G)UI : Gnome 2.30.2 / 3.2.4 / (bsd)2.32.1
Inscription : 25-07-2010

Re : [Résolu] pavé numérique inactif dans wheezy

Bonjour

Que revoie

gnome-keyboard-properties

? Voir agencement -> modèle de clavier

As-tu essayé

# dpkg-reconfigure keyboard-configuration

?

À tout hasard smile


Si vous êtes fan du « Si ce n’est pas cassé, ne le corrigez pas » , vous serez un grand fan de BSD. Mais si vous êtes du genre à avoir besoin que tout soit le plus récent possible, vous feriez mieux de migrer vers Linux aussi vite que possible histoire de ne pas être à la traîne.BSD a un système de base comprenant de nombreux outils, ils sont tous développés et packagés ensemble pour être cohésif.

Hors ligne

#10 29-11-2012 18:38:38

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu] pavé numérique inactif dans wheezy

Bonjour,

lorus a écrit :

Bonjour
Que revoie

gnome-keyboard-properties

? Voir agencement -> modèle de clavier



voici :

# gnome-keyboard-properties
bash: gnome-keyboard-properties : commande introuvable
 



dans les paramètres du clavier, j'avais essayé de modifier les agencements, mais cela n'a rien donné. le clavier par défaut est français latin 9. j'ai essayé le français tout court, mais c'est idem.

lorus a écrit :


As-tu essayé

# dpkg-reconfigure keyboard-configuration

?



je viens d'essayer. j'ai laissé le clavier par défaut int 105 touches, et les options par défaut. pavé numérique toujours muet.


"Being is not doing"

Hors ligne

#11 29-11-2012 19:11:20

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu] pavé numérique inactif dans wheezy

ça y est. j'ai trouvé. dans les paramètres système / accès universel / pointage et clic de souris, le contrôle du pointeur à l'aide du pavé numérique était sur "on". en le mettant sur "off", le pavé numérique fonctionne. j'avais vu dans les forums anglophones, qu'il fallait aller dans les paramètres du clavier et désactiver cette fonction. mais dans wheezy, elle se trouve dans "accès universel" et non dans "paramètres du clavier". il fallait le savoir. merci à tous pour votre aide. je mets "résolu".

"Being is not doing"

Hors ligne

#12 30-11-2012 16:28:49

lorus
Modérateur
Lieu : /var/log/snort/alert
Distrib. : Debian Squeeze/Wheezy/Freebsd amd64
Noyau : 2.6.32 / 3.2/
(G)UI : Gnome 2.30.2 / 3.2.4 / (bsd)2.32.1
Inscription : 25-07-2010

Re : [Résolu] pavé numérique inactif dans wheezy

Merci du retour jeanmarc1 smile

Si vous êtes fan du « Si ce n’est pas cassé, ne le corrigez pas » , vous serez un grand fan de BSD. Mais si vous êtes du genre à avoir besoin que tout soit le plus récent possible, vous feriez mieux de migrer vers Linux aussi vite que possible histoire de ne pas être à la traîne.BSD a un système de base comprenant de nombreux outils, ils sont tous développés et packagés ensemble pour être cohésif.

Hors ligne

#13 30-11-2012 18:48:17

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu] pavé numérique inactif dans wheezy

lorus a écrit :

Merci du retour jeanmarc1 smile



merci aussi pour ton aide ++


"Being is not doing"

Hors ligne

Pied de page des forums