Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-10-2012 16:43:58

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Sorties hdmi et vga sur eeepc R051CX

Bonjour à toutes et à tous,

J'ai installé Debian testing avec un noyau custom sur mon netbook Asus eeepc R051CX, initialement équipé d'Ubuntu. J'ai placé il y a quelques jours un post à ce sujet dans la section Installation. Je dispose donc maintenant sur mon netbook d'un dual boot Ubuntu Debian.

Ayant pu disposer d'un téléviseur avec entrées vga et hdmi, j'ai pu essayer les sorties correspondantes de mon netbook. Sous Ubuntu, çà marche (enfin l'image au moins, je n'ai pas testé la sortie du son par hdmi). Il faut presser les touches Fonction et F8 en même temps pour envoyer l'image soit sur l'écran du netbook, soit sur le téléviseur. Avec la sortie vga on a soit l'une, soit l'autre mais pas les deux en même temps tandis qu'avec la sortie hdmi on peut avoir les deux en même temps.

Par contre sous Debian je ne suis pas encore parvenu à faire marcher ces sorties hdmi et vga. L'écran du téléviseur reste noir, les touches de fonction ont l'air totalement inopérantes.

Existe-t-il un moyen d'activer ces sorties, peut-être en installant quelque chose pour rendre opérationnelles les touches de fonction?

Merci d'avance pour tout renseignement.

Bien cordialement,

C.-M. M.

Hors ligne

#2 04-10-2012 11:04:58

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : Sorties hdmi et vga sur eeepc R051CX

Bonjour,

Je n'ai pas beaucoup progressé depuis mon dernier message. Sous Ubuntu les sorties vga et hdmi marchent, xrandr voit parfaitement l'écran externe lorsque je le connecte. Sous Debian, rien à faire, l'écran externe branché à la sortie vga ou à la sortie hdmi est ignoré, et xrandr ne voit que l'écran interne à la résolution 1024 x 600.

Quant aux touches de fonction, il y en a qui fonctionnent aussi bien sous Debian que sous Ubuntu. Ce sont les touches:

  Fn + F1 qui met en veille (sous Debian, pas moyen de sortir de veille un fois qu'on y est! sous ubuntu çà marche un peu mieux mais il arrive aussi qu'on n'arrive pas à sortir de veille),

  Fn + F2 qui coupe ou remet le wifi,

  Fn + F3 qui déconnecte ou reconnecte le touchpad (très utile quand on tape du texte),

  Fn + F10 qui coupe ou remet le son,

  Fn + F11 qui diminue le volume sonore,

  Fn + F12 qui augmente le volume sonore.

Les autres touches de fonction qui marchent sous Ubuntu mais pas sous Debian sont

Fn + F4 qui affiche l'utilitaire de réglage de l'affichage (résolution de l'écran, rotation, ...),

  Fn + F5 qui diminue la luminosité de l'écran,

  Fn + F6 qui l'augmente,

  Fn + F7 qui éteint ou rallume l'écran,

  Fn + F8 qui fait passer de l'écran interne à l'écran externe ou inversement (parfois on arrive à avoir les deux en même temps, je n'ai pas encore compris exactement ce qu'il faut faire pour avoir ce résultat).

  Fn + F9 qui affiche le moniteur système.

J'ai essayé de copier certains fichiers du dossier /etc/acpi de la partition Ubuntu dans le dossier de même nom (initialement presque vide) de la partition Debian en espérant que cela ferait marcher sous Debian les sorties vga et hdmi, sans aucun succès.

Je pense maintenant que le non-fonctionnement des sorties vga et hdmi sous Debian ne vient pas d'une insuffisance des touches de fonction, mais de l'absence de certains pilotes pour la partie graphique du processeur Atom N2600. Ces pilotes doivent exister dans la distribution Ubuntu d'origine, mais pas dans la distribution Debian que j'ai installée, ce qui expliquerait que Debian n'exploite pas toutes les fonctions du processeur. J'ai regardé les dossiers /lib/firmware des partitions Ubuntu et Debian, il n'y a pratiquement rien dans le dossier de la partition Debian et un tas de choses dans le dossier de la partition Ubuntu.
J'ignore lesquelles il faudrait installer sous Debian pour exploiter toutes les possibilités graphiques du processeur, et je me doute que pour installer ces firmwares il ne suffit pas de copier les fichiers de la partition Ubuntu!

Je me demande s'il ne serait pas plus sage de me contenter d'Ubuntu sur ce netbook. A bien regarder, Ubuntu n'est pas si mal et ressemble beaucoup à Debian ...même si on a avec cette distribution pas mal d'ennuis avec le son. Au début, sous Ubuntu, le son marchait tant sur les haut-parleurs internes que sur des écouteurs externes et depuis hier, je ne sais pourquoi, il marche uniquement sur écouteurs externes. Alors que sous Debian il marche parfaitement sur les haut-parleurs internes et sur les écouteurs externes!

Bonne journée à toutes et à tous,

Ajouté le 5 octobre:

1. J'ai corrigé quelques erreurs sur l'effet des touches de fonction.

2. Je vois un peu plus précisément l'origine des problèmes de son sous ubuntu que j'ai mentionnés. Ilsont lieu avec le noyau qui s'est installé après mise à jour,

   3.2.0-31-generic-pae.

Avec le noyau présent à la première mise en route du netbook,

  3.2.0-25-generic-pae,

le son marche toujours très bien. Je pense donc que c'est la mise à jour qui a détraqué le son.

3. J'ai vérifié que l'accélération matérielle fonctionnait, sous Debian comme sous Ubuntu. Le problème des sorties vga et hdmi sous Debian  n'est donc peut-être pas dû à l'absence de pilote pour la partie  graphique du processeur.

C.-M. M.

Dernière modification par cmm (05-10-2012 18:26:23)

Hors ligne

#3 04-10-2012 18:39:31

phreg
Membre
Distrib. : Antix MX-15
Noyau : 4.3-0-liquorix-686
(G)UI : Xfce 4.12
Inscription : 02-04-2011

Re : Sorties hdmi et vga sur eeepc R051CX

Bonjour,
pour commencer, je vérifieraisavec xev dans une console les retours des ces combinaisons de touches.
Ça renvoie des infos du genre :

KeyRelease event, serial 32, synthetic NO, window 0x3400001,
    root 0x1ad, subw 0x0, time 1265733, (230,492), root:(239,567),
    state 0x50, keycode 134 (keysym 0xffec, Super_R), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyPress event, serial 32, synthetic NO, window 0x3400001,
    root 0x1ad, subw 0x0, time 1269733, (230,492), root:(239,567),
    state 0x10, keycode 96 (keysym 0xffc9, F12), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyRelease event, serial 32, synthetic NO, window 0x3400001,
    root 0x1ad, subw 0x0, time 1269797, (230,492), root:(239,567),
    state 0x10, keycode 96 (keysym 0xffc9, F12), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyPress event, serial 32, synthetic NO, window 0x3400001,
    root 0x1ad, subw 0x0, time 1271837, (230,492), root:(239,567),
    state 0x10, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

C'est les lignes du stype "keycode 134 (keysym 0xffec, Super_R)" qui comptent, là j'ai tapé la touche Win de droite. 
Ensuite, j'irais voir si les définitions de clavier sont similaires (là, il faut que je révise un peu roll) .

Hors ligne

#4 04-10-2012 20:07:24

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : Sorties hdmi et vga sur eeepc R051CX

Merci Phreg, je vais essayer!

Cordialement,

C.-M. M.

Hors ligne

#5 07-10-2012 19:26:48

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : Sorties hdmi et vga sur eeepc R051CX

Bonjour à toutes et à tous,

Toujours pas de progrès. xev montre que sous ubuntu et sous debian les touches se comportent de la même manière. Cependant, sous Ubuntu toutes les touches de fonction marchent, ainsi que les sorties vga et hdmi (cette dernière envoie bien au téléviseur à la fois l'image et le son, je l'ai vérifié). Tandis que sous Debian çà ne marche pas.

J'ai installé le paquet eeepc-acpi-scripts, sans succès. Mais depuis j'ai un message "warning" au démarrage signalant un conflit avec le module pciehp. Je vais lire plus attentivement la page

http://wiki.debian.org/fr/EeePC/HowTo/C … AOk-ciales

pour essayer de comprendre ce qui se passe.

En attendant je m'habitue à Ubuntu qui marche très bien sur ce netbook, dont je ne regrette pas l'achat.

Bien cordialement,

C.-M. M.

Hors ligne

Pied de page des forums