Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-05-2008 16:27:53

kamcsa83
Membre
Inscription : 26-05-2008

Probleme de lancement de Xorg

Bonjour,

    Je sait que ce sujet a était souvent traité mais je n'ai pas trouvé de solution. Au 1er démarage de debian j'avai ce message d'erreur :

Module Loader present
Markers: (--) probeb, (**) from config file, (=smile default setting,
             (++) from command line, (!!) notice, (II) Informational,
             (ww) warning, (EE) error, (NI) not implemented, (??)unknown.
(=smile Log file: "/var/log/Xorg.0.log", Time:Thu Apr 10 12:57:20 2008
(=smile Using config file: "/etc/X11/xorg.conf"
(EE) No devices detected.

Fatal server error:
no screens found


puis j'ai fait un dpkg-reconfigure xserver-xorg en choisissant comme driver nv ( je ne l'ai pas changer il avait deja reconnu que ma carte graphique qui est une geforce 8600GTS), j'ai ce message :

Fatal server error:
no screens found
XI0: fatal I0 error 104 (connection reset by peer) on X server "0.0"
       after 0 requests (0 know processed) with 0 events remaining.


J'i vu dans un autre post qu quelqu'un avait resolu le probleme, mais j'ai pas compris comment il a fait voila ce qu'il dit :

Bon mon problème est réglé, j'ai simplement fait une Mise à Jour de Etch vers Sid d'abord, modification dans les dépôts, ensuite un peit dist-upgrade.


Si quelqu'un pourrait m'éclairer...


Je viens de refaire un dpkg-reconfigure, et j'ai choisi vesa sa marche parfaitement mais j'ai lu qu'avec ce driver on utiliser pas le potentiel de la carte graphique ( ce qui est pas grave pour ce que je vais faire ) mais j'aimerais quand meme revenir sur le driver nv.

Config : MSI GeForce 8600GTS
            ecran LCD 20' samsung syncmaster 206BW

Dernière modification par kamcsa83 (27-05-2008 16:35:06)

Hors ligne

#2 27-05-2008 16:54:56

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : Probleme de lancement de Xorg

Tu as quelle version de Debian ? Si tu as Etch, la version stable actuelle (celle que tu télécharges par défaut sur le site officiel), et le pilote nv intégré est peut-être un peu vieillot pour une 8600GTS. C'est peut-être pour ça que ça a marché pour l'autre personne en upgradant vers Sid, la version unstable mais beaucoup plus à jour.

Tu peux essayer d'utiliser le driver officiel pour voir ce que ça donne. Il se trouve dans la section non-free des dépôts (voir par ici pour l'activer). Chez moi j'installe :

apt-get install nvidia-kernel-'uname -r' nvidia-kernel-common nvidia-glx


Et remplace 'nv' ou 'vesa' par 'nvidia' dans le xorg.conf.

Attention, cette méthode n'est pas valable pour Lenny, la version testing !


« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#3 27-05-2008 17:03:54

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : Probleme de lancement de Xorg

Salut
Or donc, merci d'avoir ouvert un nouveau topic wink

Commençons par le début
Sur Debian il existe trois branche concomitante, toute affublées d'un nom de code (issue des personnage du film toys story pour info).

1 - La Branche Unstable toujours appelée SID (pour Still In Devellopment, et qui corresponds au voisin qui casse ses jouets).
Cette branche reçois tout les nouveau paquets dans les version les plus a jour et les bugs qui vont avec, elle est tres performante récente, mais peux parfois casser en raison des bugs . Elle s'adresse surtout a des testeurs et développeurs

2- La branche Testing, son nom actuelle est Lenny : cette branche reçois en seconde intention les paquets aprè leur passge dans SID où ils ont été relativement bien debbugé mais parfois  pas entièrement.
Le délai de passage de SId vers testing est d'environ 15 jours pour un paquet sans alerte de bug. Cela en fait une branche embarquant des paquets récents, et d'une stabilité très bonne. On estime que c'est la branche adéquate pour du desktop a titre privé.
Après quelques temps (plusieus mois) cette branche est figée et plus aucun paquets en provenace de sid n'y entre. Elle est alors débugguée a fond, et une fois cette dernière étape terminée elle remplace la stable actuelle et une nouvelle branche testing est ouverte avec un nouveau nom de code
A terme Lenny deviendra la Stable en remplacement de Etch (voir ci dessous), Etch passera aux archives et une nouvelle testing sera lancée (j'ignore son future nom de code)
3 - La version Stable dont le nom de code actuel est Etch , elle est figée depuis environ 1an 1/2 et n'évolue plus (sauf trou de sécurité).
Elle est d'une stabilité remarquable, mais un peu ancienne déjà. On estime classiquement qu'elle est idéale pour du desktop en environnement professionnel et pour des serveurs tres fiable/stable, mais également pour installer en remplacement d'un $utre OS sur des machine un peu ancienne (mais pas trop quand meme !).

Je pense que ton problème viens de là, tu as du installé Etch (Stable) mais le pilote qui existe pour les cartes nvidia n'embarque pas le code pour une carte récente.
Ce qui explique qu'un passage vers une branche plus réactive (Testing / Unstable) ai réglè le soucis de la personne dont tu parles. --> pilote nvi plus récent

Un passage vers unstable pour un grand débutant me semble prématuré (mais pas impossible, et idéale si tu souhiate apprendre vite et que tu as du temps et pas peur de tout casser --> rare).
En revanche un passage vers testing est sans trop de risque et t'ammenra des version plus récents de bien des logiciels.

Pour ne pas te macher le travail, je te donne quelques pistes et te laisse chercher un peu.
Le fichier qui gère ta branche est le fichier /etc/apt/sources.list
Les commandes a connaitres sont apt-get update, apt-get dist-upgrade

A bientot

Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#4 27-05-2008 17:22:39

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : Probleme de lancement de Xorg

Salut

Pour donner un petit complément de l'excellente explication de freddec wink, bjm nous à fait une petite doc à ce sujet --> http://debian-facile.org/wiki/doku.php? … g:unstable

Il faut que j'y colle des exemples de sources.list mais ca pourra aussi t'aiguiller smile

@+

PS: n'hésite pas à recréer un autre post si tu ne t'en sors pas

Hors ligne

#5 27-05-2008 17:27:58

kamcsa83
Membre
Inscription : 26-05-2008

Re : Probleme de lancement de Xorg

effectivement j'ai pris une version stable, l'image CD s'appelle : debian-40r3-i386-CD-1.

Tout d'abord merci pour ton explication freddec, et en ce qui concerne linux sa va faire 2 ans que je me suis mis "vite fait "a l'utiliser, suite a mes cours en DUT reseaux é telecom. Et actuellement en stage je peux dire que "j'en bouffe" et j'en apprend tous les jours.

Pour revenir a mon probleme, je vais essayer dés que je le temp la technique de mani et si besoin je passerai a une version unstable. Mais quand tu parle de "tout casser", tu veux parler du materiel informatique (carte mere...) parce que si c'est le cas je la mettrai sur un des vieux PC que j'ai en stock et non mon PC actuel.

merci encore pour vos réponse

Hors ligne

#6 28-05-2008 09:28:07

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : Probleme de lancement de Xorg

Non ton matériel ne risque rien a ma connaissance
Par tout casser j'entends le système pas le matos , mais rassures toi cela est rarissimes.
Sous Linux/Debian depuis 2003 cela m'est arrivé une fois de devoir réinstaller a cause d'un système de fichier tout casser, irrécupérable.  Et le seul responsable se trouvais être entre la chaise et le clavier sad

Mais avant d'envisager une Sid, je te suggère de tester lenny/Testing d'autant plus qu'au jours d'aujourd'hui le paquet xserver-xorg-video-nv est dans la même version sur les deux branches (1:2.1.9-1).
Toutefois , rappel toi qu'il s'agit des pilotes libres pas des pilotes officiels de nvidia et qu'a ce titre ils ne présentent pas toutes les fonctionnalités des pilotes officiels (en terme de 3D surtout)

Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

Pied de page des forums