Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-06-2008 12:56:45

jul
Membre
Distrib. : sid
Noyau : 2.6.32
(G)UI : gnome
Inscription : 01-06-2008

[ RESOLU] pas d'eth1

Bonjour a tous


C'est mon premier post sur ce forum qui m'est par ailleurs souvent très utile...

Je me résous à poster car je galère un peu : fraichement passé sous debian (après ubuntu, fedora), je n'arrive pas à connecter mon pc à internet. je m'explique:

j'ai un mini réseau local (2PC) relié grace au routeur freebox sans dhcp.

L'installation de debian se passe sans soucis, ma carte réseau est reconnue (controleur intégré nvidia) mais :

- au premier boot : pas de serverX donc je passe en version sid (carte graphique récente)
- Lorsque ma sid est installé, miracle j'ai une interface graphique mais plus aucune connexion internet
- après avoir farfouillé un peu, je m'aperçois que : j'ai eth0 (boucle local), eth2 (firewire), mais plus de eth1 (dans les outils réseau) et mon pc se connecte automatiquement à eth2
- la commande lspci voit bien ma carte réseau intégré pourtant

Comment corriger ce problème ? Debian sans internet c'est pas gagné !!!!


Merci, a+

Dernière modification par jul (18-06-2008 19:31:39)

Hors ligne

#2 01-06-2008 15:15:03

Thom1
Membre
Inscription : 29-11-2007
Site Web

Re : [ RESOLU] pas d'eth1

Salut,

Ceci vient de udev, voici ce qu'il faut faire :

- edites /etc/udev/rules.d/z25_persistent-net.rules
- remplace pour la ligne eth2 : DRIVERS=="?*" par DRIVERS=="nom_du_module_nvidia" et évidemment le "eth2" par "eth1"
- enregistres et quittes ton fichier
- relance udev : /etc/init.d/udev reload (sinon avec stop et start, mais pas restart)

Hors ligne

#3 01-06-2008 20:08:31

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : [ RESOLU] pas d'eth1

j'ai eth0 (boucle local),


En général la boucle locale c'est "lo", tu es sur que ta carte n'est pas sur eth0


Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#4 11-06-2008 13:27:58

jul
Membre
Distrib. : sid
Noyau : 2.6.32
(G)UI : gnome
Inscription : 01-06-2008

Re : [ RESOLU] pas d'eth1

Bonjour, merci pour ta réponse, et désolé pour le retard (je me suis absenté)

Dans ce fichier j'ai :

#firewire device
eth0

#PCI device (forcedeth)
eth1

#PCI device (forcedeth)
eth2

Je comprends pas pourquoi j'ai deux devices pci ?
quel nom du module nvidia dois-je mettre ?

merci a+

Dernière modification par jul (11-06-2008 13:36:28)

Hors ligne

#5 11-06-2008 15:10:33

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : [ RESOLU] pas d'eth1

Salut

De quel fichier parle tu ?

Voici le contenu de mon /etc/udev/rules.d/z25_persistent-net.rules

# This file was automatically generated by the /lib/udev/write_net_rules
# program run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single line.

# PCI device 0x10de:0x0269 (forcedeth)
SUBSYSTEM=="net", DRIVERS=="?*", ATTR{address}=="00:19:db:43:0c:ea", NAME="eth0"


A savoir: ATTR{address}=="00:19:db:43:0c:ea" correspond a l'adresse mac du controleur (unique pour chaque carte réseau)

Pour info: j'ai également un contrôleur nvidia utilisant le module forcedeth et le module en question apparait bien dans lsmod

Je te suggère donc de nous passer copie:
1- du contenu du fichier : /etc/udev/rules.d/z25_persistent-net.rules
   --> ce qui nous permettra de vérifier comment tes cartes réseaux sont nommées par udev

2- de la sortie de ifconfig
  --> qui nous permettra de voir quelles sont les interfaces actives

3- de la sortie de ifconfig -a
  --> ce qui nous permettra de voir toutes les interfaces (y compris celles inatcives)
  -->de s'assurer de la mac adress de ton controleur réseau pour, le cas échéant, adapter le nommage de udev en modifiant le fichier z25_persistent...

4- de la sortie de lsmod |grep force
  --> on vérifiera ainsi que le module forcedeth est bien chargé

Et ajoutes 'y tant qu'on y est la sortie de cat /etc/network/interface
  --> histoire de vérifier ce qui est activé au lancement de la machine

Yapluka wink


Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#6 11-06-2008 15:40:21

jul
Membre
Distrib. : sid
Noyau : 2.6.32
(G)UI : gnome
Inscription : 01-06-2008

Re : [ RESOLU] pas d'eth1

ok merci pour ton aide

/etc/udev/rules.d/z25_persistent-net.rules
This file was automatically generated by the /lib/udev/write_net_rules
# program, probably run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single line.
# MAC addresses must be written in lowercase.

# Firewire device 00eb3dcc00001d7d (ohci1394)
SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:eb:3d:cc:00:00:1d:7d", NAME="eth0"

# PCI device 0x10de:0x0450 (forcedeth)
SUBSYSTEM=="net", DRIVERS=="", ATTRS{address}=="f0:d7:c0:7d:1d:00", NAME="eth1"

# PCI device 0x10de:0x0450 (forcedeth)
SUBSYSTEM=="net", DRIVERS=="?*", ATTR{address}=="00:1d:7d:c0:d7:f0", NAME="eth2"


ifconfig

eth2      Link encap:Ethernet  HWaddr 00:1d:7d:c0:d7:f0 
          inet adr:169.254.203.22  Bcast:169.254.255.255  Masque:255.255.0.0
          adr inet6: fe80::21d:7dff:fec0:d7f0/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3 errors:0 dropped:0 overruns:0 frame:0
          TX packets:90 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:186 (186.0 B)  TX bytes:13770 (13.4 KiB)
          Interruption:253 Adresse de base:0x8000

lo        Link encap:Boucle locale 
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:210 errors:0 dropped:0 overruns:0 frame:0
          TX packets:210 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:15664 (15.2 KiB)  TX bytes:15664 (15.2 KiB)

ifconfig -a
eth2      Link encap:Ethernet  HWaddr 00:1d:7d:c0:d7:f0 
          inet adr:169.254.203.22  Bcast:169.254.255.255  Masque:255.255.0.0
          adr inet6: fe80::21d:7dff:fec0:d7f0/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3 errors:0 dropped:0 overruns:0 frame:0
          TX packets:90 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:186 (186.0 B)  TX bytes:13770 (13.4 KiB)
          Interruption:253 Adresse de base:0x8000

lo        Link encap:Boucle locale 
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:210 errors:0 dropped:0 overruns:0 frame:0
          TX packets:210 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:15664 (15.2 KiB)  TX bytes:15664 (15.2 KiB)


lsmod |grep force
i2c_nforce2            11392  0
i2c_core               30752  1 i2c_nforce2
forcedeth              55692  0


/etc/network/interface

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth1
iface eth1 inet static
    address 192.168.0.1
    netmask 255.255.255.0
    network 192.168.0.0
    broadcast 192.168.0.255
    gateway 192.168.0.100
    # dns-* options are implemented by the resolvconf package, if installed
    dns-nameservers 212.27.53.252 212.27.54.252



Voilà !!!!!! merci

Dernière modification par jul (11-06-2008 15:47:37)

Hors ligne

#7 11-06-2008 21:20:58

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [ RESOLU] pas d'eth1

Bonjour,

Que donne un

ifup eth1


Si après ça un ifconfig montre bien l'eth1, je suggère de remplacer dans /etc/network/interfaces

 allow-hotplug eth1


par

 auto eth1


Ça devrait le faire.

Hors ligne

#8 11-06-2008 22:20:47

jul
Membre
Distrib. : sid
Noyau : 2.6.32
(G)UI : gnome
Inscription : 01-06-2008

Re : [ RESOLU] pas d'eth1

ca change rien désolé...
merci de te pencher sur mon problème...

Hors ligne

#9 11-06-2008 23:34:18

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [ RESOLU] pas d'eth1

J'ai entendu parler d'un paquet qui s'appelle resolvconf. Est-ce que ça pourrait t'aider ? (Si tu peux le récupérer par une connexion sur une autre machine par exemple)

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#10 11-06-2008 23:55:21

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [ RESOLU] pas d'eth1

Oups! Au temps pour moi, je me suis fait piéger par les adresses MAC différentes sur eth1 et eth2; j'ai conclu faussement à la présence de 2 interfaces eth dans la machine. En fait la MAC de l'un correspond à l'autre lue à l'envers (a.b.c.d.e.f -> f.e.d.c.b.a).
eth1 et eth2 semblent donc représenter le même interface réseau.

En regardant de plus prêt, eth2 est en 169.254.x.y, ce qui correspond sauf erreur à de la configuration automatique (zeroconf est-il installé?).

Je suppose que ce qui est souhaité est d'avoir la configuration en 192.168.0.1 déclarée pour eth1 dans le fichier interfaces.
Dans ce cas, j'essaierai de mettre en commentaire la ligne du eth2 dans persistent-net.rules pour ne pas avoir eth2 (je ne suis pas certain que ça marche, ni que ça soit la bonne méthode).
je remplacerai ensuite le allow-hotplug par auto pour eth1 dans interfaces comme mentionné dans mon post précédent afin d'activer automatiquement eth1.
Il ne devrait plus ensuite y avoir qu'à relancer le réseau pour tester:

# invoke-rc.d networking restart


Si ça ne fonctionne pas, merci de nous copier les messages renvoyés par la commande et le résultat d'un ifconfig.

PS: Il est toujours utile de copier les résultats fournis par les commandes qu'il t'es demandé d'exécuter, même lorsque cela "ne change rien"; les messages renvoyés par les commandes donnent souvent de précieuses indications à celui qui essaie de t'aider. C'est pour cela d'ailleurs qu'ils sont demandés.  wink

Hors ligne

#11 12-06-2008 00:05:06

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [ RESOLU] pas d'eth1

Mélodie est passée le temps que je rédige le post précédent. (j'suis lent je sais...)

resolvconf permet simplement d'utiliser les options dns-* (dns-nameservers ...) dans le fichier interfaces au lieu de déclarer les DNS dans le /etc/resolv.conf. C'est une facilité permettant de regrouper les paramètres dans le fichier interfaces, et ça ne concerne que la résolution des noms.
Aucune incidence donc sur la configuration des interfaces réseau.


édit:

Extrait de aptitude show zeroconf:
Description : IPv4 link-local address allocator
zeroconf is an implementation of IPv4 link-local addresses (RFC3927) which can be used for ad-hoc networks.  Addresses are allocated from the 169.254.0.0/16 range semi-randomly.

That means making it possible to take two laptop computers, and connect them with a crossover Ethernet cable, and have them communicate usefully using IP, without needing a man in a white lab coat to set it all up for you.


Désinstaller zeroconf me paraît de plus en plus être la bonne solution au problème.

Dernière modification par tux12 (12-06-2008 00:48:03)

Hors ligne

#12 12-06-2008 10:08:25

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : [ RESOLU] pas d'eth1

yep

Je rejoins Tux12 sur les adress mac inversées eth1 eth2 , ça m'a sauté au yeux (ca peux venir d'ou ?) c'est bizarre non !

En dehors de zéroconf j'aurai une autre suggestion pour que l'on retombe sur une structure plus "classique"


1- Faire une copie de sauvegarde du z25_persistent-net.rules par prudence
2- puis le modifier ainsi:

# PCI device 0x10de:0x0450 (forcedeth)
SUBSYSTEM=="net", DRIVERS=="", ATTRS{address}=="f0:d7:c0:7d:1d:00", NAME="eth0"

# PCI device 0x10de:0x0450 (forcedeth)
#SUBSYSTEM=="net", DRIVERS=="?*", ATTR{address}=="00:1d:7d:c0:d7:f0", NAME="eth1"

# Firewire device 00eb3dcc00001d7d (ohci1394)
SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:eb:3d:cc:00:00:1d:7d", NAME="eth2"


Ainsi la carte firewire devrait passer en eth2 et la carte ethernet en eth0 (j'ai diésé la eth1 avec mac inversée pour qu'elle ne vienne pas compliquer les choses)

Modifier en suite le /etc/network/interfaces ainsi

# The primary network interface
allow-hotplug eth0
iface eth0 inet static
    address 192.168.0.1
    netmask 255.255.255.0
    network 192.168.0.0
    broadcast 192.168.0.255
    gateway 192.168.0.100
    # dns-* options are implemented by the resolvconf package, if installed
    dns-nameservers 212.27.53.252 212.27.54.252


ou bien passer le static en DHCP en fonction de la méthode de connexion (box, serveur dhcp, connexion directe via modem adsl ?)

Relancer udev et le network et vérifier a nouveau le ifconfig


qu'en pense tu TUX12 ?

NOTA: si je comprends bien l'anglais zéronconf sert donc a connecter deux PC via un cable croisé sans avoir besoin d'utiliser un accessoire type hub ?


Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#13 12-06-2008 16:35:28

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [ RESOLU] pas d'eth1

Salut Freddec,

zeroconf permet de configurer automatiquement les deux machines en l'absence de serveur DHCP pour faire le boulot. C'est zeroconf qui crée les interfaces d'adresse 169.254.x.y qui permettent aux deux machines de communiquer.
Ceci n'est utile que dans le cas ou les machines attendent une config par DHCP et que celle-ci ne se fait pas (absence ou indisponibilité du serveur DHCP, ou plus d'IPs à distribuer). D'où la référence au réseau le plus simple possible (câble croisé entre deux clients), le hub permettant d'imaginer que l'on dispose de plus d'une machine faisant office de serveur dhcp (il faut envisager un contexte de clients M$ - voir plus bas).

J'ai un peu cherché moi aussi car j'avais viré zéroconf dès le passage à Etch (ça me mettait mes configs statiques en vrac) sans chercher plus loin.
Pour confirmation voir par exemple http://www.frameip.com/nntp/fr-comp-res … nsible.htm (la première réponse de Xavier Roche)
et pour APIPA http://msdn.microsoft.com/en-us/library/aa505918.aspx (eh oui, il semblerait que ça soit du M$) ou ici en français (plus ou moins, c'est traduit par gougeul).
Désolé pour les liens pourris, si vous trouvez mieux je suis preneur.

La MAC inversée est à mon avis générée par ce système, c'est un moyen simple d'avoir des adresses MAC uniques sur le réseau concerné.


Sinon, concernant la modif du persistent-net.rules, je n'y crois pas car nous ne sommes pas dans le cas ou deux cartes "s'échangent" les IP entre elles et se retrouvent sur un réseau inadéquat (la carte connecté au réseau A est configurée pour le réseau B et vice-versa). Si j'ai bien compris (rien n'est moins sûr) le persistent-net.rules sert à cela (?).

Passer en DHCP (avec un serveur DHCP) devrait éliminer le problème, puisque zéroconf intervient quand la config par DHCP à échoué (donc dans le cas de deux clients M$ - en DHCP par défaut - reliés entre eux directement par un câble croisé).

Je persiste à croire que pour un réseau configuré en statique, le mieux/plus simple est de virer zeroconf. smile

Hors ligne

#14 12-06-2008 22:07:21

jul
Membre
Distrib. : sid
Noyau : 2.6.32
(G)UI : gnome
Inscription : 01-06-2008

Re : [ RESOLU] pas d'eth1

bon rebonjour et encore merci.....

Zeroconf n'est pas installé sur mon pc !!!!! (je viens d'aller voir avec synaptic)


Concernant la manip de freddec : une nouvelle interface eth3 est crée dans z25_persistent.rules identique à la eth1 diesée !!!
nm_applet indique une connection avec une ip "self assigned" sur eth3 192.254.203.22

le ifconfig donne :
bureau:/home/jul# ifconfig
eth3      Link encap:Ethernet  HWaddr 00:1d:7d:c0:d7:f0 
          inet adr:169.254.203.22  Bcast:169.254.255.255  Masque:255.255.0.0
          adr inet6: fe80::21d:7dff:fec0:d7f0/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:18 errors:0 dropped:0 overruns:0 frame:0
          TX packets:83 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:1116 (1.0 KiB)  TX bytes:12803 (12.5 KiB)
          Interruption:253 Adresse de base:0xc000

lo        Link encap:Boucle locale 
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:82 errors:0 dropped:0 overruns:0 frame:0
          TX packets:82 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:6160 (6.0 KiB)  TX bytes:6160 (6.0 KiB)

Hors ligne

#15 12-06-2008 22:16:03

jul
Membre
Distrib. : sid
Noyau : 2.6.32
(G)UI : gnome
Inscription : 01-06-2008

Re : [ RESOLU] pas d'eth1

tux12 a écrit :

Dans ce cas, j'essaierai de mettre en commentaire la ligne du eth2 dans persistent-net.rules pour ne pas avoir eth2 (je ne suis pas certain que ça marche, ni que ça soit la bonne méthode).
je remplacerai ensuite le allow-hotplug par auto pour eth1 dans interfaces comme mentionné dans mon post précédent afin d'activer automatiquement eth1.
Il ne devrait plus ensuite y avoir qu'à relancer le réseau pour tester:

# invoke-rc.d networking restart


Si ça ne fonctionne pas, merci de nous copier les messages renvoyés par la commande et le résultat d'un ifconfig.

PS: Il est toujours utile de copier les résultats fournis par les commandes qu'il t'es demandé d'exécuter, même lorsque cela "ne change rien"; les messages renvoyés par les commandes donnent souvent de précieuses indications à celui qui essaie de t'aider. C'est pour cela d'ailleurs qu'ils sont demandés.  wink


Voici les messages d'erreur :
bureau:/home/jul# invoke-rc.d networking restart
Reconfiguring network interfaces...SIOCSIFADDR: No such device
eth1: ERROR while getting interface flags: No such device
SIOCSIFNETMASK: No such device
SIOCSIFBRDADDR: No such device
eth1: ERROR while getting interface flags: No such device
eth1: ERROR while getting interface flags: No such device
Failed to bring up eth1.

Hors ligne

#16 12-06-2008 22:38:25

jul
Membre
Distrib. : sid
Noyau : 2.6.32
(G)UI : gnome
Inscription : 01-06-2008

Re : [ RESOLU] pas d'eth1

bon du nouveau...

j'accède à Internet en mettant mes dns dans /etc/resolv.conf

bon je vais m'attaquer à mon réseau samba car j'ai un beau bugbuddy qui s'ouvre quand je veux accèder à mes fichiers paratagés !!!!

Dernière modification par jul (12-06-2008 22:38:55)

Hors ligne

#17 13-06-2008 00:54:39

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [ RESOLU] pas d'eth1

Bonsoir tout le monde,

jul a écrit :

Zeroconf n'est pas installé sur mon pc


Ok.

jul a écrit :

nm_applet indique une connection avec une ip "self assigned" sur eth3 192.254.203.22


nm -> network-manager. Je l'avais oublié celui-là. Encore un truc de configuration automatique qui n'existe pas chez moi. hmm

On voit que l''interface eth3 est lui aussi auto-configuré (IP en 169.254.x.y)

jul a écrit :

j'accède à Internet en mettant mes dns dans /etc/resolv.conf


Donc par le réseau 169.254.0.0. J'en conclue que le modem/routeur sait utiliser cette méthode de configuration (APIPA). Par contre, comme la configuration n'est dans ce cas pas faite à partir du fichier interfaces, il semble normal qu'il faille définir les DNS dans le resolv.conf. Donc en fait il ne te manquais que cela depuis le début de ce fil.

MAIS, ça veut dire que ton réseau local est le 169.254.0.0 et non 192.168.0.0 comme défini dans le fichier interfaces pour eth1. Il faudra sans doute en tenir compte pour les prochains problèmes de communication réseau. Par exemple, peux tu accéder à l'interface de gestion de ton modem/routeur?

Ce qui m'intrigue, c'est pourquoi l'interface eth1 tel que défini dans le fichier interfaces ne peut pas être configuré mais eth[23] définis par l'autoconf le sont, alors que si je me réfère à ce que proposait Thom1 - ajouter le nom du module dans persistent-net.rules -, il n'y à pas actuellement de différence entre eth1 et eth2 dans ce fichier. Ça me laisse penser que le chargement du module forcedeth est effectué par [udev? | nm?].

Bon donc ça fonctionne, mais c'est pas très propre comme configuration.
Jul peux bien entendu en rester là, mais il me semble qu'il aurait intérêt à partir sur des bases saines et mieux comprises. Donc un interface eth1, sur un réseau genre 192.168.0.0 comme défini dans le fichier interfaces.
Pour cela je suggère à Jul d'essayer la manip proposée par Thom1, en mettant "forcedeth" comme nom de  module. On doit si j'ai bien compris aussi pouvoir arriver au même résultat en chargeant ce module au démarrage (ajouter une ligne avec "forcedeth" dans le fichier /etc/modules).

Après, c'est lui qui décide. wink

Allez, promis, sur Samba je serais moins bavard. big_smile

Hors ligne

#18 13-06-2008 09:40:30

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : [ RESOLU] pas d'eth1

Allez, promis, sur Samba je serais moins bavard.


Quand le bavardage atteint ce niveau qualitatif on le lis avec plaisir.

Je pencjerai avec toi pour obtenir un reseau plus conventionnel en192.168.x.x.
Mais pourquoi eth1 plus que eth0 ?
Je plussise donc avec l'idée de forcer le driver via le z_25TrucMuche sur eth1 ou eth0


Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#19 13-06-2008 14:39:42

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [ RESOLU] pas d'eth1

Euh... merci freddec :confused:

Pourquoi eth1? Parce que j'en étais resté à la configuration initiale de Jul avec le firewire en eth0, pour ne pas embrouiller le fil.

Hors ligne

#20 13-06-2008 16:53:53

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : [ RESOLU] pas d'eth1

pas embrouiller le fil.


Une raison qui en vaut bien d'autres wink

Ce qui est bizarre c'est cette mani qu'a udev de coller parfois les firewire en etho alors que ce ne sont pas (à mas connaissance des interfaces réseau !).


Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#21 13-06-2008 19:14:10

jul
Membre
Distrib. : sid
Noyau : 2.6.32
(G)UI : gnome
Inscription : 01-06-2008

Re : [ RESOLU] pas d'eth1

Rebonjour,

J'ai été un peu rapide sur mon post précédent, désolé :

jul a écrit :

bon du nouveau...

j'accède à Internet en mettant mes dns dans /etc/resolv.conf

bon je vais m'attaquer à mon réseau samba car j'ai un beau bugbuddy qui s'ouvre quand je veux accèder à mes fichiers paratagés !!!!


J'ai réussi en configurant comme ceci :


/etc/udev/rules.d/z25_persistent-net.rules

# This file was automatically generated by the /lib/udev/write_net_rules
# program, probably run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single line.
# MAC addresses must be written in lowercase.

# PCI device 0x10de:0x0450 (forcedeth)
SUBSYSTEM=="net", DRIVERS=="?*", ATTR{address}=="00:1d:7d:c0:d7:f0", NAME="eth0"

# Firewire device 00eb3dcc00001d7d (ohci1394)
SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:eb:3d:cc:00:00:1d:7d", NAME="eth1"


/etc/network/interfaces

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
    address 192.168.0.1
    netmask 255.255.255.0
    network 192.168.0.0
    broadcast 192.168.0.255
    gateway 192.168.0.100
    # dns-* options are implemented by the resolvconf package, if installed
    dns-nameservers 212.27.53.252 212.27.54.252


Plus : installation de resolconf !!!!!  (n'est-ce pas Melod)y wink



mon ifconfig
bureau:/home/jul# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1d:7d:c0:d7:f0 
          inet adr:192.168.0.1  Bcast:192.168.0.255  Masque:255.255.255.0
          adr inet6: fe80::21d:7dff:fec0:d7f0/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:901 errors:0 dropped:0 overruns:0 frame:0
          TX packets:800 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:1126531 (1.0 MiB)  TX bytes:80483 (78.5 KiB)
          Interruption:253 Adresse de base:0xc000

lo        Link encap:Boucle locale 
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:95 errors:0 dropped:0 overruns:0 frame:0
          TX packets:95 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:6321 (6.1 KiB)  TX bytes:6321 (6.1 KiB)



Cependant tout ça me paraît un peu bancal ?!

- Network manager (et son applet nm_applet) reste toujours avec sa f****** croix rouge. Il indique "aucune connexion réseau" et décocher activer le réseau n'a aucune incidence hmm

- Iceweasel et evolution s'ouvre toujours en mode "off line" (mais cela n'a peut-être rien à voir...)

Je comprends pas et ça m'énerve !!!!!!!!!!! Puis-je virer network-manager si il sert à rien ?

En tout cas merci à vous, l'essentiel est là. Quant à ces "bavardages" j'appelle plutot cela de la pédagogie bien utile aux amateurs comme moi.

Merci de votre accueil sur ce forum.

Dernière modification par jul (13-06-2008 19:22:10)

Hors ligne

#22 13-06-2008 19:39:16

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : [ RESOLU] pas d'eth1

Cependant tout ça me paraît un peu bancal ?!


Bah non, moi ça ma parait tiptop (a confirmer par tux12 qui connait ça mieux que moi)

Voici mon ifconfig

eth0      Link encap:Ethernet  HWaddr 00:19:db:43:0c:ea  
          inet adr:181.x.x.x  Bcast:181.x.x.x  Masque:255.255.0.0
          adr inet6: fe80::219:dbff:fe43:cea/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10522402 errors:2 dropped:0 overruns:0 frame:2
          TX packets:1779471 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:2065946107 (1.9 GiB)  TX bytes:197815494 (188.6 MiB)
          Interruption:16 Adresse de base:0x6000

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:717152 errors:0 dropped:0 overruns:0 frame:0
          TX packets:717152 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:68722704 (65.5 MiB)  TX bytes:68722704 (65.5 MiB)


Ne tiens pas compte des adresses en 181.x.x.x, il s'agit d'un réseau un peu particulier pour cette tranche d'adresse (pas cachère !)

Pour ce qui est de Network-manager, tu peux le virer je pense, pour ma part il n'est pas installé.


Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#23 14-06-2008 00:40:36

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [ RESOLU] pas d'eth1

Bonsoir,

Merci tout d'abord à Jul de nous avoir collé une version à jour de sa config, et plus globalement pour la clarté de son retour. Un beau geste qu'on aimerait voir plus souvent. wink

Donc c'est soit l'inversion des déclarations dans le persistent-net.rules proposé par Freddec au #12, soit le auto dans interfaces qui résoud le Pb.

freddec a écrit :

Bah non, moi ça ma parait tiptop (a confirmer par tux12 qui connait ça mieux que moi)


N'exagérons rien. Moi je n'utilise que des IP cachères. big_smile
Sinon, oui c'est tiptop pour ce qui est de la config, mais je crois que Jul faisait allusion à network-manager.
Il est bien entendu possible de se passer de ce dernier dès lors que l'on est prêt à se faire une config manuellement (c'est chose faite maintenant) et à se passer de la petite icône de nm-applet.

Concernant Iceweasel, ne suffit-il pas de positionner dans Edition/Préférences/onglet Géneral/Démarrage l'option "Au démarrage de Iceweasel" sur "Afficher les derniers onglets et fenêtres utilisés" pour obtenir le fonctionnement désiré?

Concernant l'interface firewire et la remarque du #20 (Freddec), pour ce que je souviens de mes lectures (un vieux MISC je crois) on peut l'utiliser comme interface réseau, mais ce n'est pas conçu spécifiquement pour cela et peut poser de sérieux problèmes de sécurité car le firewire écrit directement en mémoire (je ne sais si cela reste vrai lorsqu'il est géré en tant qu'interface ethernet).

Pour udev, euh... comme pour Samba. tongue

Hors ligne

Pied de page des forums