Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-10-2012 19:11:22

Tribalmazoot
Membre
Inscription : 01-04-2012

Désactiver le clic du touchpad

Bonjour,

Je rencontre encore une fois ce problème du touchpad dont je ne parviens pas à désactiver le clic. Je prend des notes à la fac avec mon netbook et donc autant dire tout de suite qu'à cause du clic du touchpad c'est impossible d'écrire quoi que ce soit à moins de maintenir sa main droite en l'air pendant qu'on écrit, ce qui n'est vraiment pas génial quand on doit écrire pendant 4 heures non stop. Si vous ne connaissez pas ce problème, il s'agit du fait que lorsqu'on écrit au clavier et qu'on appuie sur la barre espace, si la main est posée confortablement sur le côté bas droit de l'ordinateur portable, alors notre pouce éfleurera fatalement le touchpad pendant l'enfoncement de la barre espace. Et ducoup ça clic là ou se trouve le curseur donc à un endroit aléatoire dans le haut du texte et on se retrouve avec des bouts de phrase au beau milieu d'un mot, bref ça rend tout le texte illisible et ça donne une folle envie de jeter l'ordinateur par la fenêtre.

Des suggestions pour désactiver ce fichu clic du touchpad qui m'en aura toujours fait bavé? Sur ubuntu j'avais réussi à résoudre le problème après pas mal de recherche. Mais sur debian je n'ai toujours pas trouvé. Gpointing ne permet pas de désactiver le clic du touchpad sur debian visiblement alors qu'il permet bien de le faire sur ubuntu.

Dernière modification par Tribalmazoot (22-10-2012 19:13:19)

Hors ligne

#2 23-10-2012 08:24:36

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Désactiver le clic du touchpad

Salut,
Désactiver le "clic" du touchpad:

synclient TapButton1=0


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 23-10-2012 21:57:02

Tribalmazoot
Membre
Inscription : 01-04-2012

Re : Désactiver le clic du touchpad

merci captnfab. Cependant :

root@lowdrainpc:/home/lowdrain# synclient TapButton1=0
Couldn't find synaptics properties. No synaptics driver loaded?

Hors ligne

#4 23-10-2012 22:15:24

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Désactiver le clic du touchpad

À faire en user smile

Dans une session X, lance un émulateur de terminal et tape simplement la commande dedans.

Si tu as le même résultat, c'est que ton touchpad est reconnu comme une souris, ce qui serait étrange et te pousserait probablement à faire un xorg.conf pour préciser quel type de périphérique tu utilises et forcer l'utinisation de synaptics (xserver-xorg-input-synaptics est bien installé ?)

Si au contraire ça marche et désactive le "tap" du touchpad, il te faudra lancer le script à chaque démarrage ou modifier le xorg.conf pour que la conf soit appliquée par défaut.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#5 23-10-2012 23:16:11

Tribalmazoot
Membre
Inscription : 01-04-2012

Re : Désactiver le clic du touchpad

lowdrain@lowdrainpc:~$ synclient TapButton1=0
Couldn't find synaptics properties. No synaptics driver loaded?



xserver-xorg.... est bien installé je viens de vérifier dans le gestionnaire de paquet synaptic. Par contre je n'ai pas de fichier xorg.conf, ça peut venir de là?

Hors ligne

#6 24-10-2012 22:59:40

Tribalmazoot
Membre
Inscription : 01-04-2012

Re : Désactiver le clic du touchpad

UP

si y'en a d'autres qui galèrent avec ça j'ai une solution de secours : mettre une règle ou une carte dure sur le touchpad pendant qu'on écrit. ça évide de clicker tout le temps sans faire exprès. En attendant une solution pour désactiver le clic. PS : il faut vraiment que ça soit un matériaux dur, si c'est juste une feuille ou un truc cartonné trop fin, le clic va quand même fonctionner malheuresement. Ce qui marche le mieux visiblement c'est la règle posée en longueur parallèle au clavier, sur le touchpad.

Dernière modification par Tribalmazoot (24-10-2012 23:01:49)

Hors ligne

#7 24-10-2012 23:07:27

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Désactiver le clic du touchpad

Essaye de te faire un fichier xorg.conf et de spécifier que le driver à utiliser pour ton touchpad est synaptics.

Tu peux regarder dans le wiki comment générer un fichier xorg.conf de base avec Xorg -configure.

Une fois que tu l'auras, je ou qqn d'autre d'aidera à le modifier de manière idoine.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#8 24-10-2012 23:15:20

Tribalmazoot
Membre
Inscription : 01-04-2012

Re : Désactiver le clic du touchpad

Ok. j'avais essayé de créer un fichier xorg déjà mais ça n'avais pas fonctionné contrairement à sur mon pc fixe. mais je vais réessayer. ça m'avais dit un truc du style :

Fatal server error:
Server is already active for display 0


mais bon j'avais peut etre oublié de faire un truc. je vais voir ça.

Hors ligne

#9 24-10-2012 23:18:51

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Désactiver le clic du touchpad

Il faut fermer le serveur X en cours avant de lancer le X -configure. Sinon tu as cette erreur.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#10 25-10-2012 16:18:34

Tribalmazoot
Membre
Inscription : 01-04-2012

Re : Désactiver le clic du touchpad

Je l'ai fais en mode recovery mode, donc en console, pas sous X, voici ce que ça m'a dit :

fatal server error
caught signal 11



hmm

Hors ligne

#11 25-10-2012 17:28:54

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Désactiver le clic du touchpad

Je ne pense pas que ça marche en mode recovery puisque la majorité des services sont éteints…

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#12 25-10-2012 18:06:38

Tribalmazoot
Membre
Inscription : 01-04-2012

Re : Désactiver le clic du touchpad

Salut,

En fait, j'ai un peu peur de stopper X en session normal, c'est surement totalement idiot mais j'ai peur de pas réussir à relancer X après (je sais qu'il faut faire startx mais c'est à peu près tout...). C'est pour ça que je l'ai fait en recovery, là où on est que en mode console.

Hors ligne

#13 25-10-2012 20:05:30

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Désactiver le clic du touchpad

smile

Si tu redémarres, ton serveur X essayera de se relancer tout seul.

S'il n'y arrive pas, il te suffit de supprimer le xorg.conf (par exemple depuis le mode recovery), pour qu'il se relance au démarrage suivant.

Pour arrêter Xorg pendant une session, tu peux sois couper gdm / gdm3 / kdm / xdm / lightdm (je ne sais pas lequel tu utilises) avec l'habituelle « invoke-rc.d gdm3 stop ».

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#14 25-10-2012 20:29:27

Tribalmazoot
Membre
Inscription : 01-04-2012

Re : Désactiver le clic du touchpad

lowdrain@lowdrainpc:~$ /etc/init.d/gdm stop
bash: /etc/init.d/gdm: No such file or directory
lowdrain@lowdrainpc:~$ /etc/init.d/gdm3 stop
Stopping GNOME Display Manager: gdm3.
lowdrain@lowdrainpc:~$ /etc/init.d/kdm stop
bash: /etc/init.d/kdm: No such file or directory
lowdrain@lowdrainpc:~$ /etc/init.d/xdm stop
bash: /etc/init.d/xdm: No such file or directory
lowdrain@lowdrainpc:~$ cd /etc/X11/
lowdrain@lowdrainpc:/etc/X11$ Xorg -configure

Fatal server error:
Server is already active for display 0
  If this server is no longer running, remove /tmp/.X0-lock
  and start again.


Please consult the The X.Org Foundation support
   at http://wiki.x.org
 for help.

lowdrain@lowdrainpc:/etc/X11$ invoke-rc.d gdm3 stop
bash: invoke-rc.d: command not found
lowdrain@lowdrainpc:/etc/X11$ su
Password:
root@lowdrainpc:/etc/X11# invoke-rc.d gdm3 stop
Stopping GNOME Display Manager: gdm3.
root@lowdrainpc:/etc/X11# Xorg -configure

Fatal server error:
Server is already active for display 0
  If this server is no longer running, remove /tmp/.X0-lock
  and start again.


Please consult the The X.Org Foundation support
   at http://wiki.x.org
 for help.



Visiblement gdm3 ne veut pas se stopper. Etant donné que ça ne me met pas en console (ne ferme pas X)

Hors ligne

#15 26-10-2012 15:20:12

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Désactiver le clic du touchpad

Mhh, tu dois pouvoir le tuer avec ctrl + alt + backspace aussi

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#16 26-10-2012 17:03:56

Tribalmazoot
Membre
Inscription : 01-04-2012

Re : Désactiver le clic du touchpad

ctrl alt backspace ne fait rien sad

Hors ligne

#17 26-10-2012 19:11:22

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Désactiver le clic du touchpad

C'est abandonné, il me semble, non ?
Pour le retrouver, essaye d'ajouter dans le xorg.conf

Section "ServerFlags"
     Option "DontZap" "False"
EndSection


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#18 26-10-2012 21:09:58

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : Désactiver le clic du touchpad

Et qu'est-ce que ça dirait avec


# killall gdm3
 


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#19 27-10-2012 07:57:33

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Désactiver le clic du touchpad

As-tu essayé de suivre la consigne ?

remove /tmp/.X0-lock



captnfab a écrit :

Je ne pense pas que ça marche en mode recovery puisque la majorité des services sont éteints…


Peut-on redémarrer les services nécessaires à ce point là ?

Dernière modification par paskal (27-10-2012 07:59:13)


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#20 27-10-2012 10:38:20

Tribalmazoot
Membre
Inscription : 01-04-2012

Re : Désactiver le clic du touchpad

lowdrain@lowdrainpc:~$ killall gdm3
gdm3: no process found
lowdrain@lowdrainpc:~$ su
Password:
root@lowdrainpc:/home/lowdrain# killall gdm3
gdm3: no process found
root@lowdrainpc:/home/lowdrain#



C'est abandonné, il me semble, non ?
Pour le retrouver, essaye d'ajouter dans le xorg.conf


bin justement le problème là c'est que je ne peux pas créer de Xorg.conf

lowdrain@lowdrainpc:~$ remove /tmp/.X0-lock
bash: remove: command not found
lowdrain@lowdrainpc:~$ su
Password:
root@lowdrainpc:/home/lowdrain# remove /tmp/.X0-lock
bash: remove: command not found
root@lowdrainpc:/home/lowdrain#
 

Hors ligne

#21 27-10-2012 11:24:08

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Désactiver le clic du touchpad

Et comme ça ?

# nano /etc/X11/xorg.conf



et pour supprimer le fichier, c'est en root avec la commande rm

# rm  /tmp/.X0-lock

Dernière modification par paskal (27-10-2012 11:28:39)


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#22 27-10-2012 22:33:02

Lætitia
Modette
Lieu : Normandie du Nord
Distrib. : Stretch
Noyau : 4.6.0-1-amd64
(G)UI : Xfce4
Inscription : 14-04-2010
Site Web

Re : Désactiver le clic du touchpad

salut,
et que donne

cat /proc/bus/input/devices | grep -i touchpad


Des fois que le touchpad serait reconnu comme une souris. Mais si synaptics ne se lance pas, ça va pas être simple. sad

Bon courage smile


<titia> pas assez cuit; µonde  -> explosion
<captnfab> ^^
<captnfab> s/µ/bl/ wink

Hors ligne

#23 27-10-2012 22:44:16

sechanbask
Membre
Inscription : 14-10-2009

Re : Désactiver le clic du touchpad

j'ai un problème avec mon touchpad sur mon portable fujitsu simens amilo pi 2530 :

j'ai suivi le tuto http://wiki.debian.org/SynapticsTouchpad à partir Debian squeeze, kernel 2.6.30-1, Xorg 7.4

et après la configuration de gnome marchait, alors si ça peut t'aider...

Hors ligne

#24 28-10-2012 02:29:38

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Désactiver le clic du touchpad

Salut sechanbask,

Afin que chaque solution trouvée puisse être partagée, il est de coutume sur df d'ouvrir sa propre discussion plutôt que de bernacler celle de quelqu'un d'autre, même avec un problème similaire.
Ouvre ta propre discussion en mentionnant un lien vers celle-ci si tu le désires...

Voir le tuto des bernacles là :
http://debian-facile.org/atelier:bernacle et Plop !

Edit :
Ah oui j'avais point vu que c'était une solution !
Pardon sechanbask et merci de ton intervention. big_smile

Dernière modification par smolski (28-10-2012 11:19:31)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#25 28-10-2012 07:37:59

imaginasys
Membre
Inscription : 15-07-2011

Re : Désactiver le clic du touchpad

Bonjour,

Personnellement j'utilise :  /usr/bin/synaptic TouchpadOff=1

Cela désactive complètement le touchpad et me permet de taper sans avoir le pointeur de la souris qui semble perdre les pédales et mon historique défiler dans l'écran lorsque je suis dans un terminal.

Si tu veux voir les possibilités, essaie :  /usr/bin/synaptic -l

Il va lister la config au complet.

Et en passant, je suis pas sûr avec Debian, mais chez moi (gentoo) c'est xdm qui démarre le gestionnaire de connection.  Que ce soit kdm,gdm, lightdm, lxdm, et peu importe.  Désolé d'avoir mentionné une autre distro que Debian!  Mais Debian m'intéresse aussi!

Salutations,

               BT

Dernière modification par imaginasys (28-10-2012 07:39:10)

Hors ligne

Pied de page des forums