Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-10-2012 15:28:54

ptilou
Membre
Distrib. : Squeeze, Ubuntu studio 12.04
(G)UI : Gnome, E17, XFCE
Inscription : 08-01-2010

Plus d'image avec VLC

Bonjour
Il y a peu, j'ai installé pour ma belle sœur une machine avec Squeeze sous Gnome. Je voulais quelque chose de simple et stable. Elle vient de Windows et n'a rien du geek. Après tests à la maison tout fonctionnait nickel.
Machine envoyée à destination (loin de chez moi) tout fonctionne.
Après quelques jours, coup de fil de la miss qui m'informe de divers problèmes.
Une connerie avec le flash dans Iceweasel (résolu) et VLC qui n'affiche plus qu'un écran noir en lecture de quelque vidéo que ce soit. Le son est là mais plus l'image.
J'ai d'abord pensé à un problème de pilote graphique. Mais apparement non; glxinfo renvoie un "direct rendering yes" et GoogleEearth fonctionne sans problème.
(Carte graphique nvidia 210 et le pilote est le pilote par défaut de l'install: nv ou nouveau sait plus )
J'ai tenté de lui faire faire une modif de la sortie vidéo dans VLC et de choisir X11: cela s'avère sans effet.
Suis un peu à cours d'idées, si quelqu'un en a une je suis preneur.
Merci

Il y a pire que le bruit des bottes: le silence des pantoufles

Hors ligne

#2 23-10-2012 17:34:02

eliohann
Membre
Lieu : Montpellier
Distrib. : Debian SID
(G)UI : Gnome Shell
Inscription : 23-09-2012

Re : Plus d'image avec VLC

Histoire d'incriminer VLC ou autre chose :

Totem donne quoi ?

Hors ligne

#3 23-10-2012 17:55:33

ptilou
Membre
Distrib. : Squeeze, Ubuntu studio 12.04
(G)UI : Gnome, E17, XFCE
Inscription : 08-01-2010

Re : Plus d'image avec VLC

Incrimine, incrimine  wink
Moi je crois que c'est un problème VLC ou de manip faites sur VLC. Encore que la réinitialisation de ses paramètres reste sans effet...
Pour ce qui est de l'image Totem fonctionne mais apparemment il a des soucis pour la lecture de certaine pistes son. Notamment quand il y en a plusieurs.
Mais je dis bien apparemment car la machine est loin et je n'ai que les commentaire de l'utilisatrice qui comme je l'ai dit est loin d'être un geek.

Il y a pire que le bruit des bottes: le silence des pantoufles

Hors ligne

#4 23-10-2012 20:41:57

eliohann
Membre
Lieu : Montpellier
Distrib. : Debian SID
(G)UI : Gnome Shell
Inscription : 23-09-2012

Re : Plus d'image avec VLC

sans accès à la machine ça pas être facile ...

Déjà tu peux tenter un

#aptitude purge vlc


suivi de

#aptitude install vlc

Hors ligne

#5 23-10-2012 21:20:33

wlourf
Membre
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : awesome
Inscription : 19-07-2010

Re : Plus d'image avec VLC

Si la belle soeur a bidouilé dans les préférences de vlc, ce serait pas mal de les rétablir : Menu Outils/Préférences, Cliquer sur Rétablir les Préférences.
Si le problème persiste, il faudrait coller ici ce qui s'affiche dans la fenêtre message : Faire Menu Outils/Messages puis ensuite lancer la lecture d'un film (et non l'inverse).

Hors ligne

#6 23-10-2012 22:03:06

seb95deMLO
Invité

Re : Plus d'image avec VLC

j'ai eu un soucis comme ça et j'ai mis linux firmware non free, je sais ça n'a rien a voir mais essaye

#7 23-10-2012 22:38:56

ptilou
Membre
Distrib. : Squeeze, Ubuntu studio 12.04
(G)UI : Gnome, E17, XFCE
Inscription : 08-01-2010

Re : Plus d'image avec VLC

Merci les gars.
Je lui ai déjà fait rétablir les préférences: sans succès.
Je vais lui faire tenter le #aptitude purge vlc et #aptitude install vlc.
Puis si ça ne fonctionne pas je verrais/posterais les messages.
Je vous tiens au courant.

Il y a pire que le bruit des bottes: le silence des pantoufles

Hors ligne

#8 24-10-2012 08:40:52

KDP
Membre
Lieu : Savoie
Distrib. : Jessie
Noyau : linux 3.16
(G)UI : LXQT
Inscription : 26-12-2011
Site Web

Re : Plus d'image avec VLC

Tu peux peut-être vérifier, dans Préférences->Vidéo, si l'option "Activer la vidéo" est cocher.

Hors ligne

#9 24-10-2012 12:38:01

seb95deMLO
Invité

Re : Plus d'image avec VLC

as tu comme je te l'ai di mis firmware-nonfee?
car chez moi sur un vieu coucou, j'avais les videos, puis en mettant en plein ecran ou en touchant a la taille de la fenetre que ça soit sous vlc ou autre la video etait simplement devenu du noir. J'ai mis les firmwares non free et hop revoilou l'image...

#10 24-10-2012 15:51:53

ptilou
Membre
Distrib. : Squeeze, Ubuntu studio 12.04
(G)UI : Gnome, E17, XFCE
Inscription : 08-01-2010

Re : Plus d'image avec VLC

Je n'ai pas encore réussit à joindre l'utilisatrice au tel mais quelques précisions.
L'option "activer la vidéo" est cochée.
Au sujet des firmware. VLC a fonctionné sans. J'ai jeté un œil dessus et je n'ai rien vu qui concerne la config en question. En plus c'est pas un vieux coucou mais une machine neuve avec rien d'exotique dessus.  Mais bon Si la manip "#aptitiude  purge vlc #aptitude install vlc" ne fonctionne pas et que je vois rien dans les messages je tenterais. Il n'y a pas beaucoup de risques.
La suite sûrement ce soir après mon coup de fil "hot line"

Dernière modification par ptilou (24-10-2012 15:54:20)


Il y a pire que le bruit des bottes: le silence des pantoufles

Hors ligne

#11 29-10-2012 12:33:12

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : Plus d'image avec VLC

j'ai eu le même problême sur deux squeeze , avec deux environements différents , une simple mise à jour à résolu le pb pour les deux :

 # aptitude update



puis

 # aptitude upgrade

Dernière modification par bundy (29-10-2012 12:33:55)

Hors ligne

#12 29-10-2012 16:35:15

ptilou
Membre
Distrib. : Squeeze, Ubuntu studio 12.04
(G)UI : Gnome, E17, XFCE
Inscription : 08-01-2010

Re : Plus d'image avec VLC

Bon . Après avoir joint la miss quelques infos complémentaires.
- aptitude purge vlc, aptitude install vlc: ne change rien
- aptitude update, aptitude upgrade: rien non plus (le système est à jour)
Les messages dans vlc: 1 seul:
"swscale error: could not init SwScaler and/or allocate memory"
Une rapide recherche sur internet ne m'a pas donné de solution.Sauf un vieux truc (2008) dans un forum Debian... http://forums.debian.net/viewtopic.php? … 31#p235682 Pas la même version du noyau, des drivers, de vlc.....
Peut-être un problème avec le driver nouveau ou nv (je sais plus lequel est installé par défaut). j'avoue que l'install du driver proprio par téléphone me fait un peu peur.

Il y a pire que le bruit des bottes: le silence des pantoufles

Hors ligne

Pied de page des forums