Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-11-2012 12:24:52

Franz
Membre
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 08-05-2012

chmod inopérant sur dd externe

Bonjour à tous smile

Le problème est simple je n'arrive pas à rendre exécutable mon script d'encodage mp3 (un grand merci pour l'aide) que j:ai copié dans un répertoire sur un disque externe. Sur mon disque interne il n'y a pas de problème.


Bien sûr j'ai essayé sur le terminal en root  avec chmod u+x fichier.
En mode graphique également (propriétés/permissions/exécution) la case à cocher se décoche  toute seule. sad


Je ne saisis pas très bien les droits concernant les disques durs eux-même. Je suppose que c'est de ce côté que ça coince et je n'ose pas trop bricoler ???


Voilà !  Merci d'avance.

Vieux processeur amd sempron 3000+ cadencé à 2 Gz

Hors ligne

#2 02-11-2012 18:08:16

stopher
Membre
Lieu : lille
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : Gnome
Inscription : 03-10-2008
Site Web

Re : chmod inopérant sur dd externe

Salut ,

Quel est le type de ton système de fichier du DD externe ?

Ch.

Hors ligne

#3 02-11-2012 18:45:13

Franz
Membre
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 08-05-2012

Re : chmod inopérant sur dd externe

Salut Stopher

C'est un iomega acheté déjà formaté,  windows w95  fat32 d'après mon utilitaire de disque sous gnome.

Les opérations sur les fichiers se font normalement lecture et écriture.


Par contre quand je fais propriété sur l'icone iomega les indications sont:


Propriétaire: Création et suppression des fichîers

Groupe: accès aux dossiers aucun

Autre: accès aux dossiers aucun

La case Execution indique le signe "moins"

Dernière modification par Franz (02-11-2012 18:53:38)


Vieux processeur amd sempron 3000+ cadencé à 2 Gz

Hors ligne

#4 02-11-2012 19:09:12

vince06fr
Membre
Distrib. : Debian Sid/experimental
Noyau : Linux 3.7-trunk-amd64
(G)UI : gnome-shell (gnome 3.6)
Inscription : 29-10-2012

Re : chmod inopérant sur dd externe

le fat32 ne gere pas les droits.
C'est donc au niveau de l'os que le probleme des droits est réglé. Par defaut les OS Debian like ne donne pas de droits en execution au peripherique.
Si tu tiens absolument à avoir des droits en execution sur ton disque dur il va falloir modifier ton fstab

http://linux.developpez.com/guide/x5324.html a écrit :

Si vous disposez de systèmes de fichiers FAT ou FAT32, vous pourrez monter ces partitions automatiquement lors du démarrage du système. Comme les systèmes de fichiers basés sur la FAT ne peuvent pas gérer les droits des utilisateurs, vous allez devoir faire un choix pour fixer ces droits à une valeur raisonnable. Vous pouvez par exemple donner le droit de lecture à tous les utilisateurs, mais le droit d'écriture uniquement à l'administrateur système. La ligne à ajouter dans le fichier /etc/fstab sera alors la suivante :

/dev/partition  répertoire  vfat  auto,exec,codepage=cp850,iocharset=iso8859-1  0  0

où partition est la partition contenant le système de fichiers FAT, et répertoire est le répertoire servant de point de montage pour cette partition. Cette ligne permettra de monter automatiquement ce système de fichiers en tant que FAT32 au démarrage du système. Les fichiers binaires seront exécutables, bien qu'ils ne soient pas stockés sur un système de fichiers EXT2. Si vous voulez laisser les droits d'écriture aux utilisateurs, vous pouvez utiliser la ligne suivante à la place de celle indiquée ci-dessus :

/dev/partition  répertoire  vfat  auto,codepage=cp850,iocharset=iso8859-1,umask=0  0  0



http://formation-debian.via.ecp.fr/fstab.html
http://debian-facile.org/manuel:config:fstab
http://doc.ubuntu-fr.org/mount_fstab

Dernière modification par vince06fr (02-11-2012 19:29:33)

Hors ligne

#5 02-11-2012 19:38:26

stopher
Membre
Lieu : lille
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : Gnome
Inscription : 03-10-2008
Site Web

Re : chmod inopérant sur dd externe

Réponse de vince06fr

Ba voilà .. c'est là ou je voulais en venir tongue

La gestion des droits n'est pas la même, donc dans ton cas pour résumer, l'option de montage qui t'intéresse le plus est : exec

Pour tester rapidement, tu peux entrer ce genre de commande :

sudo mount -t vfat /dev/hdX /chemin/vers/ton/point/de/montage -o rw,exec



hdX étant le fichier représentant ton périphérique ( disque externe ) qd tu le branches, fait un df -h pour voir ces infos et le monter de nouveau.

/chemin/vers/ton/point/de/montage étant un répertoire ( vide de préférence, mais ce n'est pas obligé ) sur lequel sera monté ton disque avec les options spécifiées .

Voilà, après si seul ton système linux accède à ce disque, formate le en ext3 ou 4 pour être tranquille sur ce point .

Bonne soirée ,
Ch.

Hors ligne

#6 02-11-2012 20:01:27

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : chmod inopérant sur dd externe

Il n'y aurait pas un petit bouton pour permettre l'écriture sur cette cle usb une fois ? roll

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#7 02-11-2012 20:31:09

Franz
Membre
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 08-05-2012

Re : chmod inopérant sur dd externe

Je patauge un peu mais vous me donnez les bonnes directions pour résoudre cette affaire.


Merci  pour vos réponses et votre attention   smile

Vieux processeur amd sempron 3000+ cadencé à 2 Gz

Hors ligne

#8 21-12-2012 00:08:47

david96
Invité

Re : chmod inopérant sur dd externe

Le plus simple est de le formater en ext4, là tu n'as plus de problème de droit. wink

#9 21-12-2012 05:01:59

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : chmod inopérant sur dd externe

david96 a écrit :

Le plus simple est de le formater en ext4, là tu n'as plus de problème de droit. wink


Pas uniquement en ext4, le ext3 ou ext2 même (pas besoin de journalisation si c'est juste pour des données) fait aussi très bien l'affaire.


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#10 21-12-2012 05:03:31

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : chmod inopérant sur dd externe

martinux_qc a écrit :

david96 a écrit :

Le plus simple est de le formater en ext4, là tu n'as plus de problème de droit. wink


Pas uniquement en ext4, le ext3 ou ext2 même (pas besoin de journalisation si c'est juste pour des données) fait aussi très bien l'affaire.



Et si il utilise le disque sur windows ????, attention avant de dire ça smile


\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#11 21-12-2012 05:19:54

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : chmod inopérant sur dd externe

Bien sûr Matt, mais ça on ne le saura probablement jamais puisque Franz n'est pas repassé par ici.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#12 21-12-2012 05:21:24

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : chmod inopérant sur dd externe

Ah je sais pas moi, je réponds à tes ***** lol <--- CENSURÉ

Dernière modification par MaTTuX_ (21-12-2012 05:49:53)


\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#13 21-12-2012 08:43:35

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : chmod inopérant sur dd externe

MaTTuX_ a écrit :

***** lol <--- CENSURÉ


Oh ! yikes

Au fait, est-ce que Ext2Fsd conviendrait dans ce cas ?


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

Pied de page des forums