Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-11-2012 20:25:31

cris2029
Membre
Lieu : Marseille
Distrib. : Debian Wheezy
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome
Inscription : 04-11-2012

Cartes Graphiques INTEL / ATI commutable

Bonjour à tous,

Je suis sous Debian Wheezy et j'ai un problème avec ma carte graphique.

uname :


Linux Chris-Vaio 3.2.0-4-amd64 #1 SMP Debian 3.2.32-1 x86_64 GNU/Linux
 



lspci | grep VGA :


00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Whistler [AMD Radeon HD 6600M Series]
 




Jusqu'à présent, j'utilisais la méthode vga_switcheroo http://doc.ubuntu-fr.org/vga_switcheroo pour utiliser tout le temps la carte Intel.

J'aimerais utiliser les pilotes proprio désormais car j'ai vu que sur ubuntu la gestion du changement de carte s'était nettement amélioré  http://forum.ubuntu-fr.org/viewtopic.php?id=924311&p=1.

J'ai donc installé les pilotes proprio  fglrx-driver, fglrx-control ... J'ai utilisé ensuite aticonfig --initial -f pour écrire le xorg.conf de manière automatique.


  1 Section "ServerLayout"
  2         Identifier     "aticonfig Layout"
  3         Screen      0  "aticonfig-Screen[0]-0" 0 0
  4 EndSection
  5
  6 Section "Module"
  7 EndSection
  8
  9 Section "Monitor"
 10         Identifier   "aticonfig-Monitor[0]-0"
 11         Option      "VendorName" "ATI Proprietary Driver"
 12         Option      "ModelName" "Generic Autodetecting Monitor"
 13         Option      "DPMS" "true"
 14 EndSection
 15
 16 Section "Device"
 17         Identifier  "aticonfig-Device[0]-0"
 18         Driver      "fglrx"
 19         BusID       "PCI:1:0:0"
 20 EndSection
 21
 22 Section "Screen"
 23         Identifier "aticonfig-Screen[0]-0"
 24         Device     "aticonfig-Device[0]-0"
 25         Monitor    "aticonfig-Monitor[0]-0"
 26         DefaultDepth     24
 27         SubSection "Display"
 28                 Viewport   0 0
 29                 Depth     24
 30         EndSubSection
 31 EndSection

 




Du coup, la carte discrete (ATI) fonctionne bien mais lorsque je veux utiliser la carte graphique intégrée à l'aide de aticonfig --px-igpu, j'ai une erreur bête au redémarrage de X "No screen found" qui vient du fait que X cherche à recharger le module fglrx alors qu'il devrait utilisé les pilotes intel.

Je ne suis pas trop familier avec l'écriture de xorg.conf, je vais continuer de chercher de ce coté là, mais si vous avez des idées, je suis preneur.


Merci d'avance.

Le log correspondant :


[   253.647]
X.Org X Server 1.12.4
Release Date: 2012-08-27
[   253.647] X Protocol Version 11, Revision 0
[   253.647] Build Operating System: Linux 3.2.0-4-amd64 x86_64 Debian
[   253.647] Current Operating System: Linux Chris-Vaio 3.2.0-4-amd64 #1 SMP Debian 3.2.32-1 x86_64
[   253.647] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-4-amd64 root=UUID=18e82d4d-ed4b-40cc-98cb-3aef14f43382 ro quiet
[   253.648] Build Date: 30 September 2012  10:53:24AM
[   253.648] xorg-server 2:1.12.4-1 (Julien Cristau <jcristau@debian.org>)
[   253.648] Current version of pixman: 0.26.0
[   253.648]  Before reporting problems, check http://wiki.x.org
  to make sure that you have the latest version.
[   253.648] Markers: (--) probed, (**) from config file, (==) default setting,
  (++) from command line, (!!) notice, (II) informational,
  (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   253.648] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Nov  4 18:31:45 2012
[   253.648] (==) Using config file: "/etc/X11/xorg.conf"
[   253.648] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   253.648] (==) ServerLayout "aticonfig Layout"
[   253.648] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[   253.648] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[   253.648] (**) |   |-->Device "aticonfig-Device[0]-0"
[   253.648] (==) Automatically adding devices
[   253.648] (==) Automatically enabling devices
[   253.648] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   253.648]  Entry deleted from font path.
[   253.648] (==) FontPath set to:
  /usr/share/fonts/X11/misc,
  /usr/share/fonts/X11/100dpi/:unscaled,
  /usr/share/fonts/X11/75dpi/:unscaled,
  /usr/share/fonts/X11/Type1,
  /usr/share/fonts/X11/100dpi,
  /usr/share/fonts/X11/75dpi,
  /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
  built-ins
[   253.648] (==) ModulePath set to "/usr/lib/xorg/modules"
[   253.648] (II) The server relies on udev to provide the list of input devices.
  If no devices become available, reconfigure udev or disable AutoAddDevices.
[   253.648] (II) Loader magic: 0x7fe468661ae0
[   253.648] (II) Module ABI versions:
[   253.648]  X.Org ANSI C Emulation: 0.4
[   253.648]  X.Org Video Driver: 12.1
[   253.648]  X.Org XInput driver : 16.0
[   253.648]  X.Org Server Extension : 6.0
[   253.649] (--) PCI:*(0:0:2:0) 8086:0116:104d:907b rev 9, Mem @ 0xc0000000/4194304, 0xb0000000/268435456, I/O @ 0x00008000/64
[   253.649] (--) PCI: (0:1:0:0) 1002:6741:104d:907b rev 0, Mem @ 0xa0000000/268435456, 0xc8400000/131072, I/O @ 0x00007000/256, BIOS @ 0x????????/131072
[   253.649] (II) Open ACPI successful (/var/run/acpid.socket)
[   253.649] (II) "extmod" will be loaded by default.
[   253.649] (II) "dbe" will be loaded by default.
[   253.649] (II) "glx" will be loaded by default.
[   253.649] (II) "record" will be loaded by default.
[   253.649] (II) "dri" will be loaded by default.
[   253.649] (II) "dri2" will be loaded by default.
[   253.649] (II) LoadModule: "extmod"
[   253.650] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[   253.650] (II) Module extmod: vendor="X.Org Foundation"
[   253.650]  compiled for 1.12.4, module version = 1.0.0
[   253.650]  Module class: X.Org Server Extension
[   253.650]  ABI class: X.Org Server Extension, version 6.0
[   253.650] (II) Loading extension SELinux
[   253.650] (II) Loading extension MIT-SCREEN-SAVER
[   253.650] (II) Loading extension XFree86-VidModeExtension
[   253.650] (II) Loading extension XFree86-DGA
[   253.650] (II) Loading extension DPMS
[   253.650] (II) Loading extension XVideo
[   253.650] (II) Loading extension XVideo-MotionCompensation
[   253.650] (II) Loading extension X-Resource
[   253.650] (II) LoadModule: "dbe"
[   253.650] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[   253.650] (II) Module dbe: vendor="X.Org Foundation"
[   253.650]  compiled for 1.12.4, module version = 1.0.0
[   253.650]  Module class: X.Org Server Extension
[   253.650]  ABI class: X.Org Server Extension, version 6.0
[   253.650] (II) Loading extension DOUBLE-BUFFER
[   253.650] (II) LoadModule: "glx"
[   253.650] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   253.650] (II) Module glx: vendor="X.Org Foundation"
[   253.650]  compiled for 1.12.4, module version = 1.0.0
[   253.651]  ABI class: X.Org Server Extension, version 6.0
[   253.651] (==) AIGLX enabled
[   253.651] (II) Loading extension GLX
[   253.651] (II) LoadModule: "record"
[   253.651] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[   253.651] (II) Module record: vendor="X.Org Foundation"
[   253.651]  compiled for 1.12.4, module version = 1.13.0
[   253.651]  Module class: X.Org Server Extension
[   253.651]  ABI class: X.Org Server Extension, version 6.0
[   253.651] (II) Loading extension RECORD
[   253.651] (II) LoadModule: "dri"
[   253.651] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[   253.651] (II) Module dri: vendor="X.Org Foundation"
[   253.651]  compiled for 1.12.4, module version = 1.0.0
[   253.651]  ABI class: X.Org Server Extension, version 6.0
[   253.651] (II) Loading extension XFree86-DRI
[   253.651] (II) LoadModule: "dri2"
[   253.651] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[   253.651] (II) Module dri2: vendor="X.Org Foundation"
[   253.651]  compiled for 1.12.4, module version = 1.2.0
[   253.651]  ABI class: X.Org Server Extension, version 6.0
[   253.651] (II) Loading extension DRI2
[   253.651] (II) LoadModule: "fglrx"
[   253.651] (WW) Warning, couldn't open module fglrx
[   253.651] (II) UnloadModule: "fglrx"
[   253.651] (II) Unloading fglrx
[   253.651] (EE) Failed to load module "fglrx" (module does not exist, 0)
[   253.651] (EE) No drivers available.
[   253.652]
Fatal server error:
[   253.652] no screens found
[   253.652]
Please consult the The X.Org Foundation support
   at http://wiki.x.org
 for help.
[   253.653] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   253.654]
 

Hors ligne

Pied de page des forums