Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-11-2012 17:28:11

trogloman
Membre
Distrib. : debian squeeze
Noyau : 3.2.0-0.bpo.3-amd64
(G)UI : KDE4
Inscription : 06-11-2012
Site Web

[Résolu] carte son intégré CM Asus P8B75-M LX sous debian squeeze

On passe donc de l'image au son, avec mon dernier pb sur la 3° machine...

carte son "non reconnu" ? enfin, pas de son en tout cas...

Si je clic sur le sélecteur de volume, j'ai le droit à un "aucun greffon de contrôle de volume GStreamer et/ou périphériques trouvés"

Il s'agit d'une carte son intégrée à la CM ASUS P8B75-M LX, chipstet asustek 8415 d'après ce que j'ai pu trouver...

Dessus tourne une debian squeeze

J'ai essayé le passage en kernel 3.2, résultat positif pour le son, sauf qu'avec ce noyau, plus d'image dans vlc (contenu de la fenêtre noir) et au bout de quelques instant, l'écran/ordi se figent complètement, demandant l'usage du bouton power pour éteindre (pas bien!)
Je suis donc repasser à l'ancien noyau


uname -r
2.6.32-5-amd64
 



Pour le détail sur la Carte: lspci -v donne


00:1b.0 Audio device: Intel Corporation Device 1e20 (rev 04)
  Subsystem: ASUSTeK Computer Inc. Device 8415
  Flags: bus master, fast devsel, latency 0, IRQ 14
  Memory at f7c10000 (64-bit, non-prefetchable) [size=16K]
  Capabilities: [50] Power Management version 2
  Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
  Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
  Capabilities: [100] Virtual Channel
  Capabilities: [130] Root Complex Link

 



J'ai essayé pas mal de bidouilles trouvées sur le net sans succès, la dernière en date est le téléchargement des dernières version de alsa-lib alsa-driver alsa-firmware, sauf qu'en béotien que je suis, je ne sais pas quoi faire de mes jolis dossier pour les installer ou les faire prendre en compte par le système...

au plaisir de vous lire wink

Dernière modification par trogloman (13-11-2012 08:59:33)

Hors ligne

#2 10-11-2012 21:04:30

lorus
Modérateur
Lieu : /var/log/snort/alert
Distrib. : Debian Squeeze/Wheezy/Freebsd amd64
Noyau : 2.6.32 / 3.2/
(G)UI : Gnome 2.30.2 / 3.2.4 / (bsd)2.32.1
Inscription : 25-07-2010

Re : [Résolu] carte son intégré CM Asus P8B75-M LX sous debian squeeze

Salut smile

Bon c'est du Intel et j'ai eu le même souci! Question as-tu quand même du son à la prise casque ou micro?

Dans tous les cas, j'ai résolu mon souci avec cette commande :

# dpkg-reconfigure alsa-base && reboot


sinon essaye ça:

# alsactl init && reboot



Il semble que Alsa se configure mal surtout avec squeeze 64 bits lors de l'installation... !

smile


Édit: Je précise que stable est stable avec des paquets issuent de la branche stable (squeeze en l'occurence). Si tes paquets sont des .deb, fais pour les installer:

# dpkg -i le nom du paquet


Si vous êtes fan du « Si ce n’est pas cassé, ne le corrigez pas » , vous serez un grand fan de BSD. Mais si vous êtes du genre à avoir besoin que tout soit le plus récent possible, vous feriez mieux de migrer vers Linux aussi vite que possible histoire de ne pas être à la traîne.BSD a un système de base comprenant de nombreux outils, ils sont tous développés et packagés ensemble pour être cohésif.

Hors ligne

#3 11-11-2012 11:11:27

trogloman
Membre
Distrib. : debian squeeze
Noyau : 3.2.0-0.bpo.3-amd64
(G)UI : KDE4
Inscription : 06-11-2012
Site Web

Re : [Résolu] carte son intégré CM Asus P8B75-M LX sous debian squeeze

Bonjour lorus et merci de te pencher sur mon pb

Je n'ai pas testé les autres prises que la sortie son, mais vu que la carte son n'est reconnu nul part, je sais pas si c'est la peine de tester.

Là j'ai juste droit à des bip au démarrage, et j'ai eu du son lors du passage en 3.2, mais avec le petit inconvénient exposé au premiers post...

Tes 2 commandes n'ont rien donné, si ce n'est pour la dernière:

# alsactl init && reboot
alsactl: init:1743: No soundcards found...
 



Et d'ailleurs, c'est comme si alsa n'était pas installé neutral

e# cat /proc/asound/version
cat: /proc/asound/version: Aucun fichier ou dossier de ce type



Une autre idée ??? car je suis sur le point de rechercher une vieille carte son dans mon stock pour résoudre ce pb à la punk tongue

Hors ligne

#4 11-11-2012 14:15:33

lorus
Modérateur
Lieu : /var/log/snort/alert
Distrib. : Debian Squeeze/Wheezy/Freebsd amd64
Noyau : 2.6.32 / 3.2/
(G)UI : Gnome 2.30.2 / 3.2.4 / (bsd)2.32.1
Inscription : 25-07-2010

Re : [Résolu] carte son intégré CM Asus P8B75-M LX sous debian squeeze

Et bien je n'ai plus de piste. On dirait que ton matériel n'est pas reconnu... Le noyau 3.2 est dépourvu de blob propriétaire!
Essayes d'installer les firmwares linux nonfree... Peut-être que ton matériel à besoin de pilote proprio pour être correctement reconnu sad

Amitiés.

Lorus.

Si vous êtes fan du « Si ce n’est pas cassé, ne le corrigez pas » , vous serez un grand fan de BSD. Mais si vous êtes du genre à avoir besoin que tout soit le plus récent possible, vous feriez mieux de migrer vers Linux aussi vite que possible histoire de ne pas être à la traîne.BSD a un système de base comprenant de nombreux outils, ils sont tous développés et packagés ensemble pour être cohésif.

Hors ligne

#5 11-11-2012 15:15:34

trogloman
Membre
Distrib. : debian squeeze
Noyau : 3.2.0-0.bpo.3-amd64
(G)UI : KDE4
Inscription : 06-11-2012
Site Web

Re : [Résolu] carte son intégré CM Asus P8B75-M LX sous debian squeeze

il n'est pas reconnu par le noyau 2.6 mais reconnu par le 3.2
Par contre sous le 3.2 c'est l'écran qui reste noir en balançant un film, puis l'ensemble de la machine qui crampe...

Est ce que je n'aurais pas une porte de sortie avec le noyau 3.2 et en cherchant a mettre a jour les drivers vidéo ?

Hors ligne

#6 12-11-2012 21:01:30

trogloman
Membre
Distrib. : debian squeeze
Noyau : 3.2.0-0.bpo.3-amd64
(G)UI : KDE4
Inscription : 06-11-2012
Site Web

Re : [Résolu] carte son intégré CM Asus P8B75-M LX sous debian squeeze

Bon ben ça c'est fait, je me suis auto-dépanné en suivant ma piste smile.

J'ai donc installé linux-image-amd64 et xserver-xorg-video-intel + une petite réinstall de vlc entre les deux (mais que je pense sans influence...) Tous a partir du backport, et j'ai le son ET l'image, ce qui va être quand même plus sympa pour se faire un film ;-)

Il reste un truc étrange sur cette machine (quoi que je n'ai pas fait l'essai après cette mise a jour): c'est lors de la copie sur une clef usb (en fat32) d'un film, le début de la copie se passe normalement, et à la fin, ça crampe sur "temps restant 1s ou 0s" mais genre plus longtemps que la copie en elle même !
Est ce que ça peut être une histoire de cache d'écriture ?? en même temps faut que je re-teste...

et merci pour les pistes ;-)

Hors ligne

#7 13-11-2012 07:29:34

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] carte son intégré CM Asus P8B75-M LX sous debian squeeze

Merci du retour trogloman !

Alors, il suffisait des backports !
C'est souvent le cas en stable, surtout après les premiers temps de mise à disposition.

Peux-tu ajouter [Résolu] dans le titre, cela facilitera la découverte de ta solution pour les visiteurs intéressés !

Amitié, Joel smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#8 13-11-2012 09:00:50

trogloman
Membre
Distrib. : debian squeeze
Noyau : 3.2.0-0.bpo.3-amd64
(G)UI : KDE4
Inscription : 06-11-2012
Site Web

Re : [Résolu] carte son intégré CM Asus P8B75-M LX sous debian squeeze

Et de réinstaller la partie vidéo a partir des backports surtout, car sinon c'était grand malheur aussi big_smile
!!

Hors ligne

Pied de page des forums