Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-11-2012 18:10:23

manu67a
Membre
Inscription : 26-11-2012

upgrade: Lenny -> Squeeze - php 5.2 et 5.3

Bonjour à tous,

j'ai un serveur qui est encore sous lenny que je souhaite mettre à jour mais voilà certaines applications ne fonctionne que sur php 5.2 et pas de dev sous la main pour mettre à jour.

Auriez-vous un système sous Squeeze qui fonctionne avec php 5.3 en standard mais également avec une version 5.2 pour que vos dev. restent fonctionnels ?
Si oui, comment avez-vous fait ?

Merci d'avance pour votre aide.

Manuel

Hors ligne

#2 26-11-2012 20:55:48

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : upgrade: Lenny -> Squeeze - php 5.2 et 5.3

Salut Manu,

Bon, alors déjà, la première réponse que je dois te faire, c'est que lenny est bientôt old-old-stable, et qu'il serait temps de passer en squeeze, qui sera de toute façon un point de passage nécessaire pour passer en wheezy dans quelques mois.

Mais si tu as vraiment de bonnes raisons de rester en lenny (ce qui mine de rien serait quand même inquiétant), tu peux toujours essayer les backports de lenny (ils sont dans les archives maintenant qu'ils ne sont plus maintenus : deb http://archive.debian.org/backports.org/ lenny-backports main contrib non-free

[Edit: je viens de vérifier, en fait il n'y a pas de php5 dans les backports]

Du coup, il reste une mauvaise solution : récupérer le paquet et le recompiler pour ton serveur, et une bonne solution : migrer smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 27-11-2012 10:17:17

manu67a
Membre
Inscription : 26-11-2012

Re : upgrade: Lenny -> Squeeze - php 5.2 et 5.3

Bonjour captnfab,

merci pour ta réponse.

En fait le but est bien de passer à la version standard de la distribution mais d'y inclure en plus php 5.2.

Le but étant d'avoir la distribution à jour et en plus une version de php5.2 pour les sites sur le serveur qui ne sont pas compatibles 5.3.

Manu

Hors ligne

#4 28-11-2012 15:02:04

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : upgrade: Lenny -> Squeeze - php 5.2 et 5.3

Ok, j'avais lu trop vite.

Je n'ai jamais fait ça encore, mais de la même manière, je doute que ce soit recommandé smile
L'idée sera sans doute de demander à ce que les .php d'une arborescence soient interprétés via un interpréteur particulier, qu'il t'aura fallu installer/compiler d'une manière non orthodoxe smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

Pied de page des forums