Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-01-2013 18:45:55

tetiti20
Membre
Inscription : 20-01-2013

[Résolu] Problème de configuration samba

Bonjour,

Je viens d'investir dans un HP proliant microserveur dans le but de me faire un petit serveur à la maison big_smile
Voilà je souhaite que ce serveur me serve à deux choses:
=> Serveur de fichier (genre NAS) => accès libre par tous les PC (sous windows7) de mon réseau.
=> 3 disques dur pour un RAID5 pour faire un backup de mes documents, photos...
=> Fonction de PVR avec TVheadhend

Le gros problème je suis débutant dans le monde linux (quand même quelques connaissances roll)

Pour le moment j'ai déjà installé debian de base (brut de décoffrage, avec rien) jusque là c'est bon.
J'ai mis ce qu'il faut pour une connection en ssh => c'est bon ça marche
Installation de webmin => cela fonctionne aussi

Là ou je bloque actuellement c'est pour le partage de fichier avec samba (aussi installer sans problème).
Je souhaiterais en fait avoir en gros un disque réseau accessible par tout mes pc. Mais surtout sans login ni mot de passe à entrer. Evidemment je n'y arrive pas cela fait 2 jours que je cherche un tuto complet mais a chaque fois cela ne fonctionne pas.

Actuellement depuis un PC sous W7 je vois bien le serveur mais dès que je souhaite y rentrer il me demande login et mot de passe mad en entrant login et mdp j'ai bian accès.

Bref comment dois-je faire pour enlever login et mot de passe? Quelqu'un peut-il m'aider?

Merci

Dernière modification par tetiti20 (21-01-2013 20:27:58)

Hors ligne

#2 20-01-2013 21:54:12

ostyll
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.0.0-1-amd64
(G)UI : Gnome 2.30.2
Inscription : 13-05-2010

Re : [Résolu] Problème de configuration samba

Bonjour,

Alors pour t'aider je voudrais voir ton fichier conf samba pour voir ce qui cloche !

Hors ligne

#3 21-01-2013 08:13:32

tetiti20
Membre
Inscription : 20-01-2013

Re : [Résolu] Problème de configuration samba

Et voilà:

tet@homeserver: cat /etc/samba/smb.conf
[global]
server string = Mon Super Serveur Sous Linux
workgroup = HOMENET
netbios name = HOMESERVER
public = yes
encrypt passwords = true
log file = /var/log/samba/log.%m
syslog = 0
panic action = /usr/share/samba/panic-action %d
dns proxy = no
security = domain
invalid users = root
socket options = TCP_NODELAY
guest account = nobody
share modes = yes

[test]
path = /media/usb0
read only = no
writeable = yes
public = yes
 



Merci de ton aide smile

Hors ligne

#4 21-01-2013 09:14:18

ostyll
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.0.0-1-amd64
(G)UI : Gnome 2.30.2
Inscription : 13-05-2010

Re : [Résolu] Problème de configuration samba

voila je pense comme ca sa ira mieux !


[global]
server string = Mon Super Serveur Sous Linux
workgroup = HOMENET
netbios name = HOMESERVER
encrypt passwords = true
log file = /var/log/samba/log.%m
syslog = 0
panic action = /usr/share/samba/panic-action %d
dns proxy = no
security = user
socket options = TCP_NODELAY
guest account = nobody
map to guest = bad user

[test]
path = /media/usb0
read only = no
writeable = yes
public = yes

Hors ligne

#5 21-01-2013 20:27:10

tetiti20
Membre
Inscription : 20-01-2013

Re : [Résolu] Problème de configuration samba

C'est bon ça marche! un grand merci big_smile
En attendant de recevoir mes autres disques durs pour le RAID5, je vais essayé de faire fonctionné ma carte DVB-T.
C'est pas gagné ! yikes

Hors ligne

Pied de page des forums