Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-01-2013 04:38:53

guyjapon
Membre
Lieu : Sainte-Rose
Distrib. : wheezy et Jessie
Noyau : 3.2.0-4-amd64 et 3.16.0-4
(G)UI : Kde4.8.4 Gnome, Mate
Inscription : 01-12-2010

[Résolu] Firefox: librairies manquantes (pas sur)

Comme je le fais toujours j'ai installé FIREFOX dans /usr/local/bin. Mais il ne démarre pas

un ldd me donne ceci

#ldd /usr/local/bin/firefox/firefox
    linux-gate.so.1 =>  (0xf775b000)
    libpthread.so.0 => /lib32/libpthread.so.0 (0xf7730000)
    libdl.so.2 => /lib32/libdl.so.2 (0xf772c000)
    libstdc++.so.6 => not found
    libm.so.6 => /lib32/libm.so.6 (0xf7705000)
    libgcc_s.so.1 => not found
    libc.so.6 => /lib32/libc.so.6 (0xf75be000)
    /lib/ld-linux.so.2 (0xf775c000)



Mais aprés recherche libstdc++.so.6 et libgcc_s.so.1 sont respectivement bien dans /lib et /usr/lib

r# ls -l $(locate libstdc++.so.6)
lrwxrwxrwx 1 root root      19 14 oct.  15:21 /usr/lib/libstdc++.so.6 -> libstdc++.so.6.0.13
-rw-r--r-- 1 root root 1043976 14 nov.   2010 /usr/lib/libstdc++.so.6.0.13
r# ls -l $(locate libgcc_s.so.1)
-rw-r--r-- 1 root root 90504 14 nov.   2010 /lib/libgcc_s.so.1



voilà, je ne vois pas ce qui ne colle pas. Merci pour l'aide

Linux 2.6.32-5-amd64

Dernière modification par guyjapon (30-01-2013 07:32:04)

Hors ligne

#2 29-01-2013 05:29:02

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Firefox: librairies manquantes (pas sur)

Salut guyjapon

Je vais un peu botter en touche mais pourquoi tu n'actualises pas iceweasel comme indiquer dans ce tuto :
Actualiser iceweasel plutôt que d'utiliser firefox. C'est ici !
wink

Et peut-être aussi que tu y découvrirais ce qui ne se passe pas bien pour FF ? roll

Dernière modification par smolski (29-01-2013 05:29:26)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#3 29-01-2013 08:51:56

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] Firefox: librairies manquantes (pas sur)

@  guyjapon

J'ai ceci :

# ldd /opt/firefox/firefox
    linux-gate.so.1 =>  (0xf779c000)
    libpthread.so.0 => /lib32/libpthread.so.0 (0xf7763000)
    librt.so.1 => /lib32/librt.so.1 (0xf775a000)
    libdl.so.2 => /lib32/libdl.so.2 (0xf7755000)
    libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf7660000)
    libm.so.6 => /lib32/libm.so.6 (0xf763a000)
    libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf761c000)
    libc.so.6 => /lib32/libc.so.6 (0xf74d5000)
    /lib/ld-linux.so.2 (0xf779d000)



Je suppose donc que tes /usr/lib/libstdc++.so.6 et /lib/libgcc_s.so.1 sont les versions en 64 bits.
Tu as juste décompressé dans /usr/local/bin ?

@ jojo
ben on n'est pas libre d'installer ff, ici ? mad => -1 point choco tongue


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#4 29-01-2013 09:50:23

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Firefox: librairies manquantes (pas sur)

Plutôt que d'installer avec difficulté un FF la configuration de Iceweasel peut être une solution alternative.

paskal tu me fends le cœur là... Oui, tu entends ? Tu me fends le cœur !
Et moi qui aie crû un instant que ce coup matutinal passerait totalement inaperçu, zut alors ! tongue

Dernière modification par smolski (30-01-2013 07:29:08)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#5 29-01-2013 17:19:16

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] Firefox: librairies manquantes (pas sur)

smolski a écrit :

tu me fend le cœur là... Oui, tu entends ? Tu me fends le cœur !


Allons Jojo, ne prends pas ça au tragique !
avé l'assent  big_smile

Ben je n'avais eu aucune difficulté pour installer FF et aucun problème avec flash ou autres.

Par contre, j'ai zieuté la procédure pour Iceweasel et je le sens moyen (elle date de 2011, il faut supprimer le français etc)
Je vais la tenter un de ces quatre sur mon portable car la version pour squeeze n'est vraiment pas terrible.
Gare si ça se passe mal ! wink


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#6 29-01-2013 23:19:50

guyjapon
Membre
Lieu : Sainte-Rose
Distrib. : wheezy et Jessie
Noyau : 3.2.0-4-amd64 et 3.16.0-4
(G)UI : Kde4.8.4 Gnome, Mate
Inscription : 01-12-2010

Re : [Résolu] Firefox: librairies manquantes (pas sur)

@smolski
effectivement pourquoi ne pas faire une mise à jour de iceweasel.
J'ai souhaité installer firefox juste parce qu'a premier vu je ne pouvais pas installer l'addition sync des favoris sur iceweasel.
merci
@paskal
comme je l'ai déja fait au moins une douzaine de fois sur d'autre machines j'ai décompréssé dans /usr/local/bin/ sans problème.
sur mon portable noyau 32 bits j'ai ça:
   

linux-gate.so.1 =>  (0xb77ac000)
    libpthread.so.0 => /lib/i686/cmov/libpthread.so.0 (0xb7781000)
    libdl.so.2 => /lib/i686/cmov/libdl.so.2 (0xb777d000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7687000)
    libm.so.6 => /lib/i686/cmov/libm.so.6 (0xb7661000)
    libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7643000)
    libc.so.6 => /lib/i686/cmov/libc.so.6 (0xb74fc000)
    /lib/ld-linux.so.2 (0xb77ad000)



je vais aussi essayer d'intaller dans /opt

Hors ligne

#7 29-01-2013 23:46:14

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] Firefox: librairies manquantes (pas sur)

guyjapon a écrit :

je vais aussi essayer d'intaller dans /opt


Je crains que ça ne résolve rien.

Je me demande si les libstdc++.so.6 et libgcc_s.so.1 auraient pu être désinstallées suite à une mise-à-jour, par exemple.


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#8 30-01-2013 06:31:02

guyjapon
Membre
Lieu : Sainte-Rose
Distrib. : wheezy et Jessie
Noyau : 3.2.0-4-amd64 et 3.16.0-4
(G)UI : Kde4.8.4 Gnome, Mate
Inscription : 01-12-2010

Re : [Résolu] Firefox: librairies manquantes (pas sur)

j'ai installé les 2 librairies en 32 bits et ça donne ça (sauf que ça marche pas mieux)

ldd /opt/firefox/firefox
    linux-gate.so.1 =>  (0xf76e4000)
    libpthread.so.0 => /lib32/libpthread.so.0 (0xf76b9000)
    libdl.so.2 => /lib32/libdl.so.2 (0xf76b5000)
    libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf75bf000)
    libm.so.6 => /lib32/libm.so.6 (0xf7599000)
    libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf757b000)
    libc.so.6 => /lib32/libc.so.6 (0xf7434000)
    /lib/ld-linux.so.2 (0xf76e5000



Mais j'ai le message d'erreur en lançant Firefox

XPCOMGlueLoad error for file /opt/firefox/libxpcom.so:
libxul.so: cannot open shared object file: No such file or directory
Couldn't load XPCOM.

Hors ligne

#9 30-01-2013 07:18:07

guyjapon
Membre
Lieu : Sainte-Rose
Distrib. : wheezy et Jessie
Noyau : 3.2.0-4-amd64 et 3.16.0-4
(G)UI : Kde4.8.4 Gnome, Mate
Inscription : 01-12-2010

Re : [Résolu] Firefox: librairies manquantes (pas sur)

@smolski
J'ai suivi le tuto pour ICEWEASEL : impeccable, j'ai ce que je veux. Merci:)

Hors ligne

#10 30-01-2013 07:27:16

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Firefox: librairies manquantes (pas sur)

Mettre [résolu] dansl 'titre tu dois guyapon. Le tuto en chocolat est là :
Tuto tout t'en chocolat pour résolu ! Hop !

paskal blblblblblblbl tongue

Dernière modification par smolski (30-01-2013 07:27:30)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#11 30-01-2013 08:49:27

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] Firefox: librairies manquantes (pas sur)

guyjapon a écrit :

Mais j'ai le message d'erreur en lançant Firefox

XPCOMGlueLoad error for file /opt/firefox/libxpcom.so:
libxul.so: cannot open shared object file: No such file or directory
Couldn't load XPCOM.


Pour rester conforme au titre du topic, installer le paquet libdbus-glib-1-2

smolski a écrit :

paskal blblblblblblbl tongue


Je sens que je vais me fâcher tout rouge ! lol


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

Pied de page des forums