Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-02-2013 15:36:52

eliohann
Membre
Lieu : Montpellier
Distrib. : Debian SID
(G)UI : Gnome Shell
Inscription : 23-09-2012

Configuring network interface long

Bonjour,

Malgré mes recherches ici et sur le net en général, je ne trouve pas de solution à mon problème, certes mineur mais agaçant :
Lors du boot de la machine, le système s'arrête sur "Configuring network interface" pendant plusieurs secondes, une bonne dizaine je dirai, puis repart.

Voici le contenu de mon fichier /etc/network/interfaces :

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
#NetworkManager#iface eth0 inet dhcp
# This is an autoconfigured IPv6 interface
#NetworkManager#iface eth0 inet6 auto
 



Evidement j'ai bien accès au net (car connexion géré par NetworkManager), en filaire direct sur la freebox.
Je ne comprends pas ce qui mets autant de temps à s'activer dans le "Configuring ..."

Quelqu'un aurait une idée ?
C'est pas que ce soit super super gênant mais je tourne sur ssd et c'est la seule chose qui ralentisse le boot.

Merci.

Hors ligne

#2 03-02-2013 18:12:52

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Configuring network interface long

Bonjour,

A prendre avec réserves : j'ai peut-être eu ce problème dans le passé sur un client qui attendait des infos d'un serveur qui n'était pas encore connecté à ce moment.
Puis il continuait au bout d'un time out.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#3 03-02-2013 19:38:56

eliohann
Membre
Lieu : Montpellier
Distrib. : Debian SID
(G)UI : Gnome Shell
Inscription : 23-09-2012

Re : Configuring network interface long

Le truc c'est que c'est un pc familial, connecté à une freebox.
Donc le pc n'attends absolument rien.
Ce qui me dit que ce n'est pas normal, c'est que j'ai un netbook sous debian aussi et il n'y a aucun lag sur le configuring network... alors qu'il est en wifi.
Bref je chercherai plus tard ... ou alors, vu que je vais probablement bientot changer de pc, ne pas me prendre la tête avec ... sauf si ça se produit avec le nouveau aussi...

Hors ligne

#4 03-02-2013 20:37:59

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : Configuring network interface long

Commente la ligne allow-hotplug pour eth0. Tu n'en as pas besoin si network manager s'occupe de la connexion smile

YA3HGA-H

Hors ligne

#5 03-02-2013 22:23:50

eliohann
Membre
Lieu : Montpellier
Distrib. : Debian SID
(G)UI : Gnome Shell
Inscription : 23-09-2012

Re : Configuring network interface long

Fait ... absolument rien changé ...

Quelqu'un aurait-il une autre idée ?

Hors ligne

#6 04-02-2013 12:48:46

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Configuring network interface long

Bjr,
Oui, virer Network bidule et dé-commenter la ligne qui va bien.

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#7 04-02-2013 23:50:45

eliohann
Membre
Lieu : Montpellier
Distrib. : Debian SID
(G)UI : Gnome Shell
Inscription : 23-09-2012

Re : Configuring network interface long

Salut

Oui mais si je ne me trompe pas la connexion ne sera plus gérée par network manager?

Hors ligne

#8 05-02-2013 00:03:13

Dohri
Membre
Lieu : /home/dohri/canapé
Distrib. : Sid
Noyau : 3.10.1 amd64
Inscription : 19-12-2010
Site Web

Re : Configuring network interface long

network manager c'est pratique pour du wifi si tu bouge pas mal, là en filaire rien de bien gênant à t'en passer au contraire.
dans ton fichier interfaces tu modifie la ligne eth0 comme ça:

auto eth0
iface eth0 inet dhcp



tu peux ensuite stopper nm et redémarrer le service réseau

service networking restart



ça devrait marcher sans soucis wink

si ta carte n’apparaît plus quand tu fais ifconfig c'est que udev en a perdu son latin (ça arrive parfois en fonction des conf) dans ce cas il suffit de supprimer le fichier qui va bien:

rm /etc/udev/rules.d/70-persistent-net.rules


et de redémarrer le service à nouveau wink


Asus Zenbook ux32vd > Sid   |   eeepc 1215 > Sid + gnome  |   eeepc 1015 > Squeeze + gnome   |   sony vaio > Squeeze CLI   |   serveur home made > debian squeeze CLI

Hors ligne

#9 06-02-2013 22:19:11

eliohann
Membre
Lieu : Montpellier
Distrib. : Debian SID
(G)UI : Gnome Shell
Inscription : 23-09-2012

Re : Configuring network interface long

Bien alors voilà mes essais :

1) Configurer /etc/network/interfaces en dhcp
2) Configurer /etc/network/interfaces en static
3) supprimer le 70-persistent-net.rules
4) Configuer la freebox pour que le bail dhcp soit fixe pour mon adresse mac

Evidement un reboot entre chaque essai.
J'ai même combiné, pour être sur :
DHCP + Suppr 70-p...
STATIC + Supp 70-p etc...

Et UNE FOIS, UNE SEULE ça a booté sans s'arrêter sur Configuring network interfaces, j'en perds mon latin ...

Mon controleur ethernet est un marvell si ça peut aider (j'ai tenté l'install de firmware-nonfree aussi)

Hors ligne

Pied de page des forums