Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-06-2008 16:08:39

Eliness
Membre
Lieu : Strasbourg
Inscription : 28-06-2008

[Résolu]Derniers drivers ATI du dépôt : souci en utilisant de la 3D...

Bonjour à tous !

Possédant fièrement un ordinateur fraîchement passé d'Ubuntu à une Debian Sid, j'ai réussi sans soucis à installer les derniers drivers ATI des dépôts (fglrx) pour ma carte HD 2600.

Souci, dès que je désire jouer (à Warcraft 3 pour ne pas le citer, lancé en mode OpenGL), l'affichage change en ceci, qui est ma foi fort laid et surtout totalement inutilisable :

[img align=C]http://img294.imageshack.us/img294/3203/warcraftpourrifg2.jpg[/img]

Lorsque je quitte le jeu, l'écran reste ainsi "déchiré", la souris suivant le sens diagonal alors que je trace un trait vertical, bref, je dois redémarrer X.

Pas de soucis dans le /var/log/Xorg.0.log, voilà ce qu'il me dit pour fglrx :

(II) LoadModule: "fglrx"
(II) Loading /usr/lib/xorg/modules/drivers//fglrx_drv.so
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
        compiled for 7.1.0, module version = 8.50.3
        Module class: X.Org Video Driver


glxgears fonctionne sans soucis (les roues sont affichées normalement, ce qui me laisse supposer que le problème n'est pas tant inhérent à mon installation qu'à la compatibilité entre cette version de drivers et le jeu ?) Il me donne des scores plus qu'acceptables :

eliness@biquette:~$ glxgears
27614 frames in 5.0 seconds = 5522.717 FPS


eliness@biquette:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon HD 2600
OpenGL version string: 2.1.7659 Release


Voici un extrait de mon xorg.conf avec les parties qui me semblent relevantes (bien que je n'y touche pas trop à cette bestiole, elle m'est bien obscure...) :

Section "ServerLayout"
        Identifier     "aticonfig-Layout[all]"
        Screen      0  "aticonfig-Screen[0]" 0 0
EndSection

Section "Module"
        # direct rendering infrastructure which makes opengl go fast
        Load    "dri"
        # glx and glcore implement opengl
        Load    "glx"
        Load    "GLcore"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

Section "Device"
        Identifier  "Configured Video Device"
EndSection

Section "Device"
        # Quelques options un peu exotiques, je crains ne pas tout y comprendre...
        Identifier  "aticonfig-Device[0]"
        Driver      "fglrx"
        Option      "backingstore" "true"
        Option      "AllowGLXWithComposite" "true"
        Option      "UseInternalAGPGART" "no"
        Option      "KernelModuleParm" "agplock=0"
EndSection

Section "Screen"
        Identifier "Default Screen"
        Monitor    "Configured Monitor"
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]"
        Device     "aticonfig-Device[0]"
        Monitor    "aticonfig-Monitor[0]"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection


Ma résolution est du 1680x1050, j'ai essayé de changer de résolution dans Warcraft, de passer à 16 ou 32 bits, rien à faire, j'ai toujours le même résultat.

Quelqu'un aurait-il une idée d'autres programmes à tester, pour voir si le problème vient de Warcraft ou semble plus général à une gestion de la 3D ? Ou mieux, quelqu'un aurait-il une solution pour que je puisse jouer à nouveau sans problèmes ?

Merci par avance smile

Dernière modification par Eliness (29-06-2008 11:59:31)

Hors ligne

#2 28-06-2008 22:08:04

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [Résolu]Derniers drivers ATI du dépôt : souci en utilisant de la 3D...

Je ne vois pas de section DRI dans le xorg.conf que tu nous montres (mets-le complet tant qu'à faire).

Quand j'avais ATI j'avais ça dans la section Screen:

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        DefaultDepth    24
        SubSection "Display"
                Modes   "1280x1024"
        EndSubSection
EndSection

Section "DRI"
        Group "users"
        Mode   0660
EndSection

Section "Extensions"
        Option "Composite" "Enable"
        Option "RENDER"    "Enable"
        Option "DAMAGE"    "Enable"
EndSection


Lances aussi en root la commande:

cat /var/log/xorg.0.log | grep EE


et donnes-nous le résultat s'il te plaît.

Je vois ça dans ton xorg.conf:

  Driver      "fglrx"


C'est venu là comment ? (D'habitude on écrit "ati" à cet endroit, c'est pour ça que je te poses la question).

Pour savoir si la 3D est activée, en mode utilisateur:

glxinfo | grep rendering


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#3 28-06-2008 22:21:22

Eliness
Membre
Lieu : Strasbourg
Inscription : 28-06-2008

Re : [Résolu]Derniers drivers ATI du dépôt : souci en utilisant de la 3D...

Bonjour Melodie !
Merci de te pencher sur mon problème smile

Alors, l'ajout de la section DRI et des Extensions ne change rien, on dirait...

Pour les éventuelles erreurs dans le log par ta commande, rien à signaler, il me donne juste la "légende"
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

Pour le driver, "ati" est pour utiliser le driver libre, et "fglrx" pour le driver propriétaire (c'est le xorg.conf généré en lançant la commande aticonfig --initial après avoir installé les drivers)

Et la 3D est bien activée, il me renvoie Yes dans le direct rendering du glxinfo !

Pour le xorg.conf complet :

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
  Identifier     "aticonfig-Layout[all]"
  Screen      0  "aticonfig-Screen[0]" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
  # direct rendering infrastructure which makes opengl go fast
  Load    "dri"
  # glx and glcore implement opengl
  Load    "glx"
  Load    "GLcore"
EndSection

Section "InputDevice"
  Identifier  "Generic Keyboard"
  Driver      "kbd"
  Option      "XkbRules" "xorg"
  Option      "XkbModel" "pc105"
  Option      "XkbLayout" "fr"
  Option      "XkbVariant" "latin9"
  Option      "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
  Identifier  "Configured Mouse"
  Driver      "mouse"
EndSection

Section "Monitor"
  Identifier   "Configured Monitor"
EndSection

Section "Monitor"
  Identifier   "aticonfig-Monitor[0]"
  Option      "VendorName" "ATI Proprietary Driver"
  Option      "ModelName" "Generic Autodetecting Monitor"
  Option      "DPMS" "true"
EndSection

Section "Device"
  Identifier  "Configured Video Device"
EndSection

Section "Device"
  Identifier  "aticonfig-Device[0]"
  Driver      "fglrx"
  Option      "backingstore" "true"
  Option      "AllowGLXWithComposite" "true"
        Option      "UseInternalAGPGART" "no"
        Option      "KernelModuleParm" "agplock=0"
EndSection

Section "Screen"
  Identifier "Default Screen"
  Monitor    "Configured Monitor"
EndSection

Section "Screen"
  Identifier "aticonfig-Screen[0]"
  Device     "aticonfig-Device[0]"
  Monitor    "aticonfig-Monitor[0]"
  DefaultDepth     24
  SubSection "Display"
    Viewport   0 0
    Depth     24
  EndSubSection
EndSection

Section "DRI"
        Group "users"
        Mode   0660
EndSection

Section "Extensions"
        Option "Composite" "Enable"
        Option "RENDER"    "Enable"
        Option "DAMAGE"    "Enable"
EndSection

Dernière modification par Eliness (28-06-2008 22:23:38)

Hors ligne

#4 28-06-2008 23:14:41

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [Résolu]Derniers drivers ATI du dépôt : souci en utilisant de la 3D...

Essaie d'installer Driconf, et de voir quelles options de réglages il propose.

C'est quoi Warcraft 3 comme jeu ? Ce n'est pas un de ces jeux qui se jouent à partir de l'installation faite avec Playonlinux par hasard ?

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#5 29-06-2008 11:45:21

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : [Résolu]Derniers drivers ATI du dépôt : souci en utilisant de la 3D...

Salut

Longtemps que je ne me suis pas penché sur les driver ATI (qui n'ont pas bonne réputation soit dit en passant)
Mais je lis ceci dans ton premier post:

Module fglrx: vendor="FireGL - ATI Technologies Inc."
        compiled for 7.1.0, module version = 8.50.3
        Module class: X.Org Video Driver


Hors sauf erreur de ma part Xorg dans Sid et Lenny est en 7.3, conclusion le module n'est pas compilé pour ta version

Sinon tu as essayé avec le nouveau driver libre xserver-video-radeonhd


Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#6 29-06-2008 11:59:13

Eliness
Membre
Lieu : Strasbourg
Inscription : 28-06-2008

Re : [Résolu]Derniers drivers ATI du dépôt : souci en utilisant de la 3D...

Melodie > Driconf ne semble pas pouvoir fonctionner avec les drivers fglrx, dommage, ça a l'air d'être un très bon outil ! Quant à Warcraft 3, c'est un jeu que j'ai réussi à faire tourner avec Wine sans soucis, mais il existe un script Playonlinux également il me semble.

freddec > C'était cela ! Je ne savais pas que cette ligne référait au Xorg, et effectivement de là vient l'erreur puisque ça marche sans souci sur une Ubuntu que j'avais gardée de côté sur une autre partition, et qui utilise la version inférieure. Je suis donc passée à la version précédente en attendant que le module soit compilé dans ma version. Merci beaucoup smile Quant au driver libre, je suis avec assiduité son évolution (en effet, les drivers proprios n'ont pas bonne réputation à juste titre), mais il ne semble pas encore fonctionner chez moi, peut-être à cause de ma résolution d'écran atypique !

Hors ligne

#7 29-06-2008 15:51:39

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : [Résolu]Derniers drivers ATI du dépôt : souci en utilisant de la 3D...

Heureux que ça marche wink
Tu as donc downgrader xorg dse 7.3 vers 7.1  et ca roule ?

Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#8 29-06-2008 15:58:25

Eliness
Membre
Lieu : Strasbourg
Inscription : 28-06-2008

Re : [Résolu]Derniers drivers ATI du dépôt : souci en utilisant de la 3D...

Exactement smile

Hors ligne

Pied de page des forums