Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-06-2008 11:47:42

mecanotox
Membre
Distrib. : Ubuntu 12.10 Quantal
Noyau : 3.5.0-21-generic
(G)UI : XFCE 4.10 + Thunar 1.6
Inscription : 04-06-2008

Partition FAT32

Salut @ tous.

Etant encore en Dual-Boot, j'ai une partition d'échange FAT 32.

Son point de montage:

/echange


je n'arrive pas a autoriser l'écriture sur cette partition. (J'ai essayer en mode graphique sous Gnome mais on me demande les privilèges ROOT).

Comment effectuer cette manoeuvre en mode console ?

Hors ligne

#2 30-06-2008 12:03:40

Thom1
Membre
Inscription : 29-11-2007
Site Web

Re : Partition FAT32

il faut la monter soit avec l'option "umask=000" soit "users" dans ton fstab ou sur ta ligne de commande

Hors ligne

#3 30-06-2008 13:16:02

kinroux
Membre
Lieu : Boulogne/mer
Distrib. : Squeeze
Noyau : 2.6.32-5-amd64
(G)UI : Gnome
Inscription : 27-06-2008

Re : Partition FAT32

J'avais le même problème que toi, je l'avais résolu en utilisant la commande chmod.

Je crois que ça revient au même que la solution proposée par Thom1.

Hors ligne

#4 30-06-2008 13:41:26

mecanotox
Membre
Distrib. : Ubuntu 12.10 Quantal
Noyau : 3.5.0-21-generic
(G)UI : XFCE 4.10 + Thunar 1.6
Inscription : 04-06-2008

Re : Partition FAT32

Quels sont les commandes a faire dans ma console Thom1

Hors ligne

#5 30-06-2008 13:52:54

Thom1
Membre
Inscription : 29-11-2007
Site Web

Re : Partition FAT32

Si tu veux monter ta partoche depuis root :

mount -o umask=000 /dev/<ta_partition> <ton_rep_de_montage>


sinon il faut que tu mettes l'option 'users' dans ton fstab

Hors ligne

#6 30-06-2008 14:41:44

christophehanon
Membre
Lieu : Molenbaix
Inscription : 27-09-2007

Re : Partition FAT32

Hello tout le monde,

Je ne sais pas si le problème est déjà résolu ou non mais vous devez absolument suivre les indication de "thom1"...

Edition du fstab (avec un éditeur de texte) et ajout d'une ligne pour la partition d'échange et son point de montage.

KiwiV, Debian user smile

Hors ligne

#7 30-06-2008 15:54:40

kinroux
Membre
Lieu : Boulogne/mer
Distrib. : Squeeze
Noyau : 2.6.32-5-amd64
(G)UI : Gnome
Inscription : 27-06-2008

Re : Partition FAT32

christophehanon a écrit :

vous devez absolument suivre les indication de "thom1"...


J'avais eu le même problème et avais eu du mal à le résoudre.
Dans de mémoire (mauvaise?) j'avais utilisé chmod, mais je me rappelle aussi avoir vu des discussions sur fstab.

Pouvez vous me dire quelles différences il y a entre ces deux méthodes ?

Désolé pour ma fausse solution mecanotox.

Hors ligne

#8 30-06-2008 16:12:37

mecanotox
Membre
Distrib. : Ubuntu 12.10 Quantal
Noyau : 3.5.0-21-generic
(G)UI : XFCE 4.10 + Thunar 1.6
Inscription : 04-06-2008

Re : Partition FAT32

Ce n'est rien, merci quand même des réponse je vais voir ce que je peus déjà faire.

Ma partition est déjà montée: Je peu y accédé, lire les donnée, mais pas ecrire de données dessus ni en supprimées.

Dernière modification par mecanotox (30-06-2008 16:13:35)

Hors ligne

#9 30-06-2008 18:39:34

Thom1
Membre
Inscription : 29-11-2007
Site Web

Re : Partition FAT32

J'ai oublié de te dire un détail : si tu as modifié ton fstab avec l'option 'users', il faudra monter ta partition avec ton user et non en root

Hors ligne

Pied de page des forums