Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-04-2013 08:48:19

CWI13
Membre
Inscription : 03-04-2013

Impression soffice xls avec crontab

Bonjour,
Malgre le parcourt d'un certain nombre de forum je n'arrive pas a faire fonctionner mon script ci dessous qui fonctionne en ligne de commande :

En fait, j'essaie d'imprimer un fichier xls depuis crontab
Cela marche donc avec :
PrintXls2ps.sh
#!/bin/sh
/usr/lib/openoffice/program/soffice -p PSPRINTER /home/ftp/export/Excel/simple.xls

Si je fais crontab -e (comme root)
SHELL=/bin/sh
PATH=/bin:/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/sbin:/sbin
30 * * * * /usr/bin/PrintXls2ps.sh >>/home/frp/export/Excel/FileLog.txt 2>&1

J'ai l'erreur
/usr/lib/openoffice.org/program/soffice.bin X11 error: Can't open display:
Set DISPLAY environment variable, use -display option
or check permissions of your X-Server
(See "man X" resp. "man xhost" for details)

J'ai essaye avec
1- 30 * * * * /bin/sh /usr/bin/PrintXls2ps.sh >>/home/frp/export/Excel/FileLog.txt 2>&1
2- /usr/lib/openoffice/program/soffice -headless -p PSPRINTER /home/ftp/export/Excel/simple.xls
3- using source /home/"username"/.bash_profile dans le sh script
4- export DISPLAY:=0:0 dans le sh script
5- 30 * * * * root /bin/sh /usr/bin/PrintXls2ps.sh >>/home/frp/export/Excel/FileLog.txt 2>&1
6- 30 * * * * export DISPLAY=:0 /bin/sh /usr/bin/PrintXls2ps.sh >>/home/frp/export/Excel/FileLog.txt 2>&1

Et rien ne marche

Quelqu'un a une piste ?

J'utilise etch with ooo 2.0.3

Merci par avance

Hors ligne

#2 03-04-2013 11:08:06

stopher
Membre
Lieu : lille
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : Gnome
Inscription : 03-10-2008
Site Web

Re : Impression soffice xls avec crontab

Salut ,

Pour utiliser la session X d'un autre utilisateur ( ce qui est la cas ici ), il me semble qu'il faille regarder du coté de "xhost"

http://www.xfree86.org/current/xhost.1.html

qui s'utilise donc comme ceci :

#Pour donner un acces au serveur X par tt le monde
xhost +

#Pour retirer cet acces
xhost -



Après , pour y accéder tu peux peut-être essayer ceci

#!/bin/bash
export DISPLAY=127.0.0.1:0$
/usr/lib/openoffice/program/soffice -p PSPRINTER /home/ftp/export/Excel/simple.xls



A tester smile

Après si vraiment ça ne fonctionne pas, peut être utiliser une session SSH avec l'option -X peut résoudre ce problème d'accès au serveur X

Good luck ,

Ch.



[HS]

Débian Etch

Il y a pire que moi ...

image018.gif

[/HS]

Dernière modification par stopher (03-04-2013 11:10:57)

Hors ligne

Pied de page des forums