Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-04-2013 12:41:24

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

utiliser un serveur postfix+dovecot depuis l'extérieur.

bonjour,

j'ai un serveur mail sous squeeze. apache2 avec postfix, dovecot .tout marche impec sauf que je ne trouve pas comment configurer ni postfix ni dovecot pour pouvoir les utiliser avec depuis une autre machine avec un client de messagerie quand je suis en dehors de mon reseau. j'ai esayé plein de conf glanées sur le net mais ça ne marche pas. Probablement car j'écris des choses qui se contrdisent las les fichiers de conf.Je suis un peu largué.
Je contourne le truc en utilisant le web mail squirrell mail, ça depanne, mais c'est beaucoup moin confortable qu'un vrai client sur un laptop.

le main.cf de mon postfix:



smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no


append_dot_mydomain = no

readme_directory = no

# TLS parameters
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
#smtpd_sasl_auth_enable = yes


myhostname = xxxx.xxxx.fr
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = xxxxx.fr, xxxx.xxxx.fr, localhost.xxxxx.fr, localhost
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128 192.168.10.101 192.168.10.103
#mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
home_mailbox = Maildir/
message_size_limit = 31457280



mon dovecot.conf



 
auth default {

  mechanisms = plain


  passdb pam {
   
  }

 
  }

 
}



dict {
  #quota = mysql:/etc/dovecot/dovecot-dict-quota.conf
  #expire = db:/var/lib/dovecot/expire.db
}



plugin {
 
}

 

Hors ligne

#2 09-04-2013 20:12:12

stopher
Membre
Lieu : lille
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : Gnome
Inscription : 03-10-2008
Site Web

Re : utiliser un serveur postfix+dovecot depuis l'extérieur.

Salut,

Si en local ta conf fonctionne , elle doit fonctionner depuis l'extérieur .
Par contre as-tu correctement "natter" le ports correspondants aux services mis en place sur ton routeur/firewall ?

Ch.

Hors ligne

#3 10-04-2013 16:13:21

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : utiliser un serveur postfix+dovecot depuis l'extérieur.

stopher a écrit :


Par contre as-tu correctement "natter" le ports correspondants aux services mis en place sur ton routeur/firewall ?



je pense oui, aprés j'ai fait ça de façon empirique mais en tous cas je recoit de l'exterieur et j'envoi vers l'exterieur sans pb

natval.png


.Ce qui me fait dir que c'est mon main.cf qui ne vas pas, c'est que seul peuvent utiliser le serveur les machine dont l'ip est mentionnée dans le chan "my_networks". Je pense qu'il doit y avoir une option pour que tous ceux qui donne le bon mdp aient le droit de se connecter.J'ai d'ailleur trouvé plusieur réponse sur le net mais ça ne marche jamais. dernier tuto en date que j'ai consulté:

http://www.linuxmail.info/smtp-authenti … -centos-5/

typiquement ce que je cherche à fair, je met exactement les même rêgles que lui, mais ça marche pas.

Dernière modification par bundy (10-04-2013 16:20:47)

Hors ligne

#4 10-04-2013 17:13:19

stopher
Membre
Lieu : lille
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : Gnome
Inscription : 03-10-2008
Site Web

Re : utiliser un serveur postfix+dovecot depuis l'extérieur.

C'est normal que les gens de l'extérieurs ne puissent utiliser ton serveur pour envoyer des mails .. sinon ce serait un "open relais"

il te faut activer l'authentification smtpd.

Ca date un peu, ( peut être que certains paquets ont changés de nom ) mais ça fonctionne toujours .

Sasl postfix

Regarde la conf de postfix dans le wiki ,

surtout au niveau de :


smtpd_recipient_restrictions=
      permit_mynetworks,
      permit_sasl_authenticated,
      reject_unauth_destination,
      reject_non_fqdn_recipient,
      reject_unknown_sender_domain,
      reject_non_fqdn_sender,
      reject_unknown_recipient_domain,
      reject_invalid_helo_hostname,
      reject_unlisted_recipient,
      reject_unlisted_sender,
      reject_non_fqdn_helo_hostname,
      reject_rbl_client list.dsbl.org,
      reject_rhsbl_sender dsn.rfc-ignorant.org
 




Dans ton cas, tu n'autorise que les ips déclarées dans mynetworks

Avec l'authentification SASL on autorise aussi les clients authentifiés

smtpd_recipient_restrictions=
      permit_mynetworks,
      permit_sasl_authenticated,




Good luck ,
Ch.

Hors ligne

#5 11-04-2013 16:49:01

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : utiliser un serveur postfix+dovecot depuis l'extérieur.

mon pb c'est dés que je met ceci :

smtpd_recipient_restrictions=
      permit_mynetworks,
      permit_sasl_authenticated



dans le main.cf , quand j'essais d'envoyer un mail, le "sablier" d'evolution tourne indefiniment, je ne peut pas me connecter.

je lis plein de choses sur le net mais bon, vu que chaque conf est différente j'ai peur de fair plus de mal que de bien.
par exemple : je n'ai pas de

/etc/postfix/sasl/smtpd.conf


et je ne suis pas sûr de devoir le créer.

aussi ma clef et le certificat sont dans

/etc/ssl/certs/




dans toutes les conf que je vois c'est ici

/etc/postfix/ssl/

Hors ligne

#6 11-04-2013 18:59:46

stopher
Membre
Lieu : lille
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : Gnome
Inscription : 03-10-2008
Site Web

Re : utiliser un serveur postfix+dovecot depuis l'extérieur.

peux tu poster le retour de la commande suivante :

postconf -n



pour info :


man postconf
       -n     Print  parameter  settings  that  are not left at their built-in
              default value, because they are explicitly specified in main.cf.

Hors ligne

#7 13-04-2013 15:38:49

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : utiliser un serveur postfix+dovecot depuis l'extérieur.

voila :

postconf -n
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
config_directory = /etc/postfix
home_mailbox = Maildir/
inet_interfaces = all
mailbox_size_limit = 0
message_size_limit = 31457280
mydestination = xxxxxx.fr, xxxxxx.xxxx.fr, localhost.xxxxxx.fr, localhost
myhostname = xxxxx.xxxxx.fr
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128 192.168.10.101 192.168.10.103
myorigin = /etc/mailname
readme_directory = no
recipient_delimiter = +
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
 



comme je le disai, les paramettres de "smtpd_recipient_restrictions=" ne s'y trouvent pas, car si je les met, je suis rejeté du serveur et je ne peux l'utiliser.

Dernière modification par bundy (13-04-2013 15:40:17)

Hors ligne

#8 14-04-2013 18:52:24

stopher
Membre
Lieu : lille
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : Gnome
Inscription : 03-10-2008
Site Web

Re : utiliser un serveur postfix+dovecot depuis l'extérieur.

oui mais,
lorsque tu te fais jeter, que disent les logs ?

Hors ligne

#9 14-04-2013 19:08:11

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : utiliser un serveur postfix+dovecot depuis l'extérieur.

le dernier log :

# cat  /var/log/mail.err
Apr 14 11:11:22 debian postfix/smtpd[8519]: fatal: parameter "smtpd_recipient_restrictions": specify at least one working instance of: check_relay_domains, reject_unauth_destination, reject, defer or defer_if_permit
Apr 14 11:12:23 debian postfix/smtpd[8521]: fatal: parameter "smtpd_recipient_restrictions": specify at least one working instance of: check_relay_domains, reject_unauth_destination, reject, defer or defer_if_permit
Apr 14 11:13:24 debian postfix/smtpd[8523]: fatal: parameter "smtpd_recipient_restrictions": specify at least one working instance of: check_relay_domains, reject_unauth_destination, reject, defer or defer_if_permit
Apr 14 11:14:25 debian postfix/smtpd[8525]: fatal: parameter "smtpd_recipient_restrictions": specify at least one working instance of: check_relay_domains, reject_unauth_destination, reject, defer or defer_if_permit
Apr 14 11:15:26 debian postfix/smtpd[8528]: fatal: parameter "smtpd_recipient_restrictions": specify at least one working instance of: check_relay_domains, reject_unauth_destination, reject, defer or defer_if_permit
 

Hors ligne

#10 14-04-2013 20:25:46

stopher
Membre
Lieu : lille
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : Gnome
Inscription : 03-10-2008
Site Web

Re : utiliser un serveur postfix+dovecot depuis l'extérieur.

Tu mets quoi exactement dans "smtpd_recipient_restrictions" ?

Par défaut, ( si tu ne le surcharges pas dans le main.cf ) la valeur est la suivante :

smtpd_recipient_restrictions=
      permit_mynetworks,
      reject_unauth_destination



Tu peux le mettre tel quel dans ton main, ça devrait toujours fonctionner ...


Le miens par exemple :


smtpd_recipient_restrictions = permit_mynetworks,
        permit_sasl_authenticated,
        reject_unauth_destination,
        reject_non_fqdn_recipient,
        reject_unknown_sender_domain,
        reject_non_fqdn_sender,
        reject_unknown_recipient_domain,
        reject_invalid_helo_hostname,
        reject_unlisted_recipient,
        reject_unlisted_sender,
        reject_non_fqdn_helo_hostname,
        reject_rbl_client list.dsbl.org,
        reject_rhsbl_sender dsn.rfc-ignorant.org,
        permit
 




D’après la Doc :
IMPORTANT : si vous changez la valeur de ce paramètre, vous devez indiquer au moins une des restrictions suivantes, sinon Postfix refusera de recevoir du courrier :

reject, defer, defer_if_permit, reject_unauth_destination

Hors ligne

#11 14-04-2013 21:18:18

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : utiliser un serveur postfix+dovecot depuis l'extérieur.

en rmetant la valeur par défaut je n'ai plus de probême en local, mais si je met comme toi la restriction "permit_sasl_authenticated" elle n'à aucun effet ,c'est à dire que je ne peux toujour pas me connecter au smtp avec un client qui n'est pas listé dans my networks.
voila ce que me dit thunder bird sur un client non listé dans mynetworks:

An error occurred while sending mail. The mail server responded:  5.7.1 <xxxxxx.xxxxx@gmail.com>: Relay access denied. Please check the message recipient xxxx.xxxxxx@gmail.com and try again



PS : bizzare mais je n'ai pas eu de nouveau log dans postfix cette fois ci

Dernière modification par bundy (15-04-2013 01:01:20)

Hors ligne

#12 08-05-2013 10:45:09

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : utiliser un serveur postfix+dovecot depuis l'extérieur.

bon je reprend un peu,

j'ai donc éditer le main.cf au niveau de smtpd_recipient_restrictions. Mais au moment de la connection le mdp est refusé.
dans les log j'ai ça:

# cat /var/log/mail.log

May  8 09:49:16 debian postfix/smtpd[10970]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: No such file or directory
May  8 09:49:16 debian postfix/smtpd[10970]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: No such file or directory
May  8 09:49:16 debian postfix/smtpd[10970]: warning: unknown[192.168.10.101]: SASL LOGIN authentication failed: authentication failure

Hors ligne

#13 08-05-2013 12:31:28

stopher
Membre
Lieu : lille
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : Gnome
Inscription : 03-10-2008
Site Web

Re : utiliser un serveur postfix+dovecot depuis l'extérieur.

Salut,

une piste wink : http://serverfault.com/questions/163777 … -directory

le process smtps est chrooté par defaut sur les paquets debian ( ce n'était pas le cas avant Lenny en tt cas ).

Deux possibilités , désactiver le chroot du process ( dans master.cf, remplacer le y de la colonne "chroot" par "-" ou "n" )

ou copier /etc/sasldb2 dans le chroot du process ( /var/spool/postfix/etc )

Ch.

Hors ligne

#14 08-05-2013 13:08:03

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : utiliser un serveur postfix+dovecot depuis l'extérieur.

Salut,

j'ai fait:

 #cp  /etc/sasldb2 /var/spool/postfix/etc/sasldb2



et maintenant l'erreur dans les les log à changée on dirai qu'il il voit bien le fichier que j'ai copié dans /var/spool/postfix/etc mais qu'il n'à pas le droit de le lire :

 # cat /var/log/mail.log
May  8 13:00:40 debian postfix/smtpd[12010]: connect from unknown[192.168.10.101]
May  8 13:00:45 debian postfix/smtpd[12010]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: Permission denied
May  8 13:00:45 debian postfix/smtpd[12010]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: Permission denied
May  8 13:00:45 debian postfix/smtpd[12010]: warning: unknown[192.168.10.101]: SASL LOGIN authentication failed: authentication failure
May  8 13:00:47 debian postfix/smtpd[12010]: disconnect from unknown[192.168.10.101]



En plus l'autre truc que je trouve bizzare c'est qu'il dit qu'il ne connait pas 192.168.10.101 alors que ce dérnier est listé dans à la ligne "mynetworks" dans main.cf

Dernière modification par bundy (08-05-2013 13:20:43)

Hors ligne

#15 08-05-2013 17:53:09

stopher
Membre
Lieu : lille
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : Gnome
Inscription : 03-10-2008
Site Web

Re : utiliser un serveur postfix+dovecot depuis l'extérieur.

Quels sont les droits de sasldb2 ?

De mon coté, ( en non root )

-rw-rw---- 1 root sasl 12288 aoû 23  2012 /etc/sasldb2



T'y est presque tongue


Edit :

Le unknown , c'est juste qu'il n'arrive pas à trouver un nom pour l'ip donnée .. donc .. spa grave smile

Dernière modification par stopher (08-05-2013 17:54:54)

Hors ligne

#16 08-05-2013 20:22:07

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : utiliser un serveur postfix+dovecot depuis l'extérieur.

que je sois en root ou simple user stat me repond la même chose :

 $ stat /etc/sasldb2
  File: « /etc/sasldb2 »
  Size: 12288       Blocks: 16         IO Block: 4096   fichier
Device: 801h/2049d  Inode: 2106724     Links: 1
Access: (0660/-rw-rw----)  Uid: (    0/    root)   Gid: (   45/    sasl)
Access: 2013-05-08 12:41:49.000000000 +0200
Modify: 2012-10-10 22:49:16.000000000 +0200
Change: 2012-10-10 22:49:16.000000000 +0200
 

Dernière modification par bundy (08-05-2013 22:42:23)

Hors ligne

#17 09-05-2013 10:03:18

stopher
Membre
Lieu : lille
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : Gnome
Inscription : 03-10-2008
Site Web

Re : utiliser un serveur postfix+dovecot depuis l'extérieur.

oui mais sasldb2 dans ton chroot ? :

ls -la /var/spool/postfix/etc/sasldb2

Hors ligne

#18 09-05-2013 11:40:51

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : utiliser un serveur postfix+dovecot depuis l'extérieur.

stopher a écrit :

oui mais sasldb2 dans ton chroot ? :



Efféctivement, qu' est ce que je suis distrait  roll

 $ ls -la /var/spool/postfix/etc/sasldb2
-rw-r----- 1 root root 12288  8 mai   12:45 /var/spool/postfix/etc/sasldb2



En même temps aurait-il pu y avoir un autre propriétaire des droits sur ce fichiers? Vu que pour copier quelque chose depuis /etc il faut forcément être root.

bref, je doit donc essayer de  donner les droits de lécture à tous les user du systême, c'est ça?
je débute avec chmod, donc est-ce que tu peux me dire si la commande suivante serait la bonne?

 # chmod 640 /var/spool/postfix/etc/sasldb2

Dernière modification par bundy (09-05-2013 11:41:19)

Hors ligne

#19 09-05-2013 11:54:57

stopher
Membre
Lieu : lille
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : Gnome
Inscription : 03-10-2008
Site Web

Re : utiliser un serveur postfix+dovecot depuis l'extérieur.

nop faut mettre les même droits



chown root:sasl /var/spool/postfix/etc/sasldb2
chmod 660 /var/spool/postfix/etc/sasldb2
 




je post depuis mon tel tongue désolé pour la simplicité du MSG


ch

Hors ligne

#20 09-05-2013 13:40:55

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : utiliser un serveur postfix+dovecot depuis l'extérieur.

bon ça ne marche toujours pas, pour dovecot pas de problême le mdp est accépté, mais pour le smtp il en veut toujours pas.
comprend pas neutral

Le dernier log:

 
# nano /var/log/mail.log
May  9 12:51:58 debian postfix/smtpd[13193]: connect from unknown[192.168.10.101]
May  9 12:51:58 debian postfix/smtpd[13193]: warning: unknown[192.168.10.101]: SASL LOGIN authentication failed: authentication failure
May  9 12:51:58 debian dovecot: imap-login: Login: user=<valerian>, method=PLAIN, rip=192.168.10.101, lip=192.168.10.103, TLS
May  9 12:52:03 debian postfix/smtpd[13193]: warning: unknown[192.168.10.101]: SASL LOGIN authentication failed: authentication failure
May  9 12:52:16 debian postfix/smtpd[13193]: warning: unknown[192.168.10.101]: SASL LOGIN authentication failed: authentication failure
May  9 12:52:20 debian postfix/smtpd[13193]: warning: unknown[192.168.10.101]: SASL LOGIN authentication failed: authentication failure
May  9 12:52:29 debian postfix/smtpd[13193]: warning: unknown[192.168.10.101]: SASL LOGIN authentication failed: authentication failure
May  9 12:52:35 debian postfix/smtpd[13193]: warning: unknown[192.168.10.101]: SASL LOGIN authentication failed: authentication failure
May  9 12:52:36 debian postfix/smtpd[13193]: warning: unknown[192.168.10.101]: SASL LOGIN authentication failed: authentication failure
May  9 12:52:37 debian postfix/smtpd[13193]: warning: unknown[192.168.10.101]: SASL LOGIN authentication failed: authentication failure
May  9 12:52:37 debian postfix/smtpd[13193]: warning: unknown[192.168.10.101]: SASL LOGIN authentication failed: authentication failure
May  9 12:52:37 debian postfix/smtpd[13193]: warning: unknown[192.168.10.101]: SASL LOGIN authentication failed: authentication failure
May  9 12:52:40 debian postfix/smtpd[13193]: warning: unknown[192.168.10.101]: SASL LOGIN authentication failed: authentication failure
May  9 12:52:43 debian postfix/smtpd[13193]: disconnect from unknown[192.168.10.101]
 

Dernière modification par bundy (09-05-2013 16:44:48)

Hors ligne

#21 09-05-2013 18:24:00

stopher
Membre
Lieu : lille
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : Gnome
Inscription : 03-10-2008
Site Web

Re : utiliser un serveur postfix+dovecot depuis l'extérieur.

Tu utilises quoi comme login ? "valerian" ?

essaye avec le domaine

login : valerian@tondomaine.fr
mdp: ton mdp

Hors ligne

#22 09-05-2013 20:24:57

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : utiliser un serveur postfix+dovecot depuis l'extérieur.

ha non ça ça ne marche pas, d'ailleur dovecot ne reconnait plus l'utilisateur non plus de cette façon.

d'ailleur  en regardant le message d'erreur dont tu parlais  on voit que la ligne où il y a le login, c'est le log de dovecot et que le mdp  est accépté . Le warning est pour postfix et concerne le fait qu'il ne connait pas la machine qui se connect.

Dernière modification par bundy (10-05-2013 09:45:43)

Hors ligne

Pied de page des forums