Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-04-2013 18:05:07

22decembre
Membre
Lieu : Aarhus, Danemark
Distrib. : Debian, release : testing, codename : jessie
Noyau : Linux 3.14-2-amd64
(G)UI : Kwin (4)
Inscription : 10-03-2013
Site Web

[résolu] plantage NFS foireux

Bonjour

J'ai un problème avec NFS que j'ai un peu mal géré (car il bloquait le boot, j'ai donc dû utiliser la méthode sagouin/bourrin pour l’empêcher de nuire plutôt que réparer la cause sous-jacente).

Je vais décrire le problème chronologiquement :

dimanche 7 avril 2013 :

Installation de nfs suivant la méthode habituelle, configuré le partage dans /etc/exports, fixé les ports pour pouvoir après configurer le pare-feu, relancé le bidule (service nfs-kernel-server restart et aussi rpcbind nfs-common et peut-être d'autres !)
Je constate que l'export ne se fait pas. Donc je relance plusieurs fois comme dit au dessus, je cherche, je bricole (nfs, c'est super, sauf que ça plante rarement, donc aucun message de bug n'est jamais envoyé, va debuguer avec ça !).

Finalement, à la fin de la journée, je comprends que nfsd écoute deux fois (une fois sur l'interface ipv4 et une fois sur la ipv6). Donc il bloque parce que lors de la seconde initialisation, il trouve que son port d'écoute est déjà occupé par la première initialisation (me fais-je bien comprendre ?). Je ne trouve nulle-part comment résoudre ce problème, si ce n'est une référence à un bug portmap, et portmap n'est pas installé sur mon système mais bien rpcbind (le bug est donc résolu et non lié à mon problème à moi). À ce moment de la journée, je m’arrête car il est tard.

mercredi 10 avril 2013 :

Je fais autre chose. Je reboote mon serveur en le branchant en hdmi sur ma tv (pour tenter l'install de xbmc). le boot s’interrompt au bout d'un moment avec des y scintillants sur ma tv (en fait, je pense qu'il y a une boucle infinie quelque part...). Je pense en mode rescue où j'active un par un chacun des services du boot et je découvre que le coupable est le service nfs-common. Je reboote à nouveau et je délink tous les liens sur les scripts de démarrage, ce qui fait que mon serveur peut enfin booter (nfs-common n'est pas invoqué).
Seulement maintenant, apt me demande de finir une install et bloque tout tant que je n'ai pas fais "dpkg --configure -a". Et cette commande provoque à nouveau une boucle infinie (fort heureusement dans une session ssh facile à tuer smile ).

Voila. Que puis-je faire et que puis-je vous indiquer pour que vous m'aidiez (car "aide-toi, le ciel ou la communauté t'aidera !") ?

Dernière modification par 22decembre (14-04-2013 23:17:25)

Hors ligne

#2 10-04-2013 18:32:50

Dohri
Membre
Lieu : /home/dohri/canapé
Distrib. : Sid
Noyau : 3.10.1 amd64
Inscription : 19-12-2010
Site Web

Re : [résolu] plantage NFS foireux

tu as en grande partie résolu ton problème en voyant que cela venait d'ipv4/v6, tu as essayé de desactivé le support ipv6 pour voir si ça améliore les choses??

Asus Zenbook ux32vd > Sid   |   eeepc 1215 > Sid + gnome  |   eeepc 1015 > Squeeze + gnome   |   sony vaio > Squeeze CLI   |   serveur home made > debian squeeze CLI

Hors ligne

#3 10-04-2013 19:14:32

22decembre
Membre
Lieu : Aarhus, Danemark
Distrib. : Debian, release : testing, codename : jessie
Noyau : Linux 3.14-2-amd64
(G)UI : Kwin (4)
Inscription : 10-03-2013
Site Web

Re : [résolu] plantage NFS foireux

comment desactiver le support d'ipv6 dans nfs ?

Hors ligne

#4 10-04-2013 20:20:42

Dohri
Membre
Lieu : /home/dohri/canapé
Distrib. : Sid
Noyau : 3.10.1 amd64
Inscription : 19-12-2010
Site Web

Re : [résolu] plantage NFS foireux

tu peux le désactiver tout court, c'est plus simple et de toute façon pour l'instant ça ne sert pas à grand chose si ce n'est ralentir le démarrage et les différentes applications qui veulent utiliser ipv6 avant ipv4...
pour désactvier ipv6 c'est dans le fichier /etc/sysctl.conf dans lequel il faut mettre les lignes suivantes:


net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1



puis relancer par :

sysctl -p


Asus Zenbook ux32vd > Sid   |   eeepc 1215 > Sid + gnome  |   eeepc 1015 > Squeeze + gnome   |   sony vaio > Squeeze CLI   |   serveur home made > debian squeeze CLI

Hors ligne

#5 10-04-2013 20:35:59

22decembre
Membre
Lieu : Aarhus, Danemark
Distrib. : Debian, release : testing, codename : jessie
Noyau : Linux 3.14-2-amd64
(G)UI : Kwin (4)
Inscription : 10-03-2013
Site Web

Re : [résolu] plantage NFS foireux

Je vais faire ça pour l'instant, mais d'ici quelques temps je devrais trouver autre chose. Mais comme on aura résolu le soucis du nfs.

Je vais bientôt avoir de la connectivité ipv6, d'où ma remarque.

Hors ligne

#6 10-04-2013 21:07:46

Dohri
Membre
Lieu : /home/dohri/canapé
Distrib. : Sid
Noyau : 3.10.1 amd64
Inscription : 19-12-2010
Site Web

Re : [résolu] plantage NFS foireux

il faudrait que l'ipv6 se généralise avant que son utilisation soit réellement utile...mais bon il va bien falloir s'y mettre de toute façon, l'attribution d'adresses ipv4 est de plus en plus surveillée et encadrée:)

Asus Zenbook ux32vd > Sid   |   eeepc 1215 > Sid + gnome  |   eeepc 1015 > Squeeze + gnome   |   sony vaio > Squeeze CLI   |   serveur home made > debian squeeze CLI

Hors ligne

#7 10-04-2013 22:13:34

22decembre
Membre
Lieu : Aarhus, Danemark
Distrib. : Debian, release : testing, codename : jessie
Noyau : Linux 3.14-2-amd64
(G)UI : Kwin (4)
Inscription : 10-03-2013
Site Web

Re : [résolu] plantage NFS foireux

Ce n'est pas le lieu du débat ipv6... smile

Sinon, j'ai donc desactivé au niveau du noyau ipv6 comme tu as dit. Ça change rien (toujours un problème à lancer ou arreter le service, faire une install correcte...).

Et j'ai regardé... rpcbind travaille encore en ipv6 !

root@blackblock:/var/cache/apt/archives# /usr/sbin/rpcinfo
   program version netid     address                service    owner
    100000    4    tcp6      ::.0.111               portmapper superuser
    100000    3    tcp6      ::.0.111               portmapper superuser
    100000    4    udp6      ::.0.111               portmapper superuser
    100000    3    udp6      ::.0.111               portmapper superuser
    100000    4    tcp       0.0.0.0.0.111          portmapper superuser
    100000    3    tcp       0.0.0.0.0.111          portmapper superuser
    100000    2    tcp       0.0.0.0.0.111          portmapper superuser
    100000    4    udp       0.0.0.0.0.111          portmapper superuser
    100000    3    udp       0.0.0.0.0.111          portmapper superuser
    100000    2    udp       0.0.0.0.0.111          portmapper superuser
    100000    4    local     /var/run/rpcbind.sock  portmapper superuser
    100000    3    local     /var/run/rpcbind.sock  portmapper superuser
    100024    1    udp       0.0.0.0.127.253        status     102
    100024    1    tcp       0.0.0.0.127.253        status     102
    100024    1    udp6      ::.127.253             status     102
    100024    1    tcp6      ::.127.253             status     102
 



La moindre invocation du service, ne serait-ce que pour savoir si quelque chose fonctionne (service nfs-common status) envoie cette boucle infinie. Je me demande ce qui se passe.

Hors ligne

#8 10-04-2013 22:25:34

Dohri
Membre
Lieu : /home/dohri/canapé
Distrib. : Sid
Noyau : 3.10.1 amd64
Inscription : 19-12-2010
Site Web

Re : [résolu] plantage NFS foireux

montre nous tes fichiers de conf (exports etc) pour voir

Asus Zenbook ux32vd > Sid   |   eeepc 1215 > Sid + gnome  |   eeepc 1015 > Squeeze + gnome   |   sony vaio > Squeeze CLI   |   serveur home made > debian squeeze CLI

Hors ligne

#9 11-04-2013 13:22:25

22decembre
Membre
Lieu : Aarhus, Danemark
Distrib. : Debian, release : testing, codename : jessie
Noyau : Linux 3.14-2-amd64
(G)UI : Kwin (4)
Inscription : 10-03-2013
Site Web

Re : [résolu] plantage NFS foireux

/etc/default/nfs-common :

# If you do not set values for the NEED_ options, they will be attempted
# autodetected; this should be sufficient for most people. Valid alternatives
# for the NEED_ options are "yes" and "no".

# Do you want to start the statd daemon? It is not needed for NFSv4.
NEED_STATD= yes

# Options for rpc.statd.
#   Should rpc.statd listen on a specific port? This is especially useful
#   when you have a port-based firewall. To use a fixed port, set this
#   this variable to a statd argument like: "--port 4000 --outgoing-port 4001".
#   For more information, see rpc.statd(8) or http://wiki.debian.org/SecuringNFS
STATDOPTS="--port 32765 --outgoing-port 32766"

# Do you want to start the idmapd daemon? It is only needed for NFSv4.
NEED_IDMAPD= no

# Do you want to start the gssd daemon? It is required for Kerberos mounts.
NEED_GSSD= no



/etc/exports :


/home           *(rw)
 

Hors ligne

#10 11-04-2013 16:00:55

22decembre
Membre
Lieu : Aarhus, Danemark
Distrib. : Debian, release : testing, codename : jessie
Noyau : Linux 3.14-2-amd64
(G)UI : Kwin (4)
Inscription : 10-03-2013
Site Web

Re : [résolu] plantage NFS foireux

J'ai trouvé ça aussi :

Apr 11 14:49:02 blackblock kernel: [15238.533143] RPC: Registered named UNIX socket transport module.
Apr 11 14:49:02 blackblock kernel: [15238.533152] RPC: Registered udp transport module.
Apr 11 14:49:02 blackblock kernel: [15238.533157] RPC: Registered tcp transport module.
Apr 11 14:49:02 blackblock kernel: [15238.533162] RPC: Registered tcp NFSv4.1 backchannel transport module.
Apr 11 14:49:02 blackblock kernel: [15238.596444] FS-Cache: Loaded
Apr 11 14:49:02 blackblock kernel: [15238.634337] FS-Cache: Netfs 'nfs' registered for caching
Apr 11 14:49:02 blackblock kernel: [15238.652441] Installing knfsd (copyright (C) 1996 okir@monad.swb.de)



C'est dans les logs et c'est apparu à divers moments quand j'essaye de réinstaller le truc...

Hors ligne

#11 14-04-2013 11:41:08

22decembre
Membre
Lieu : Aarhus, Danemark
Distrib. : Debian, release : testing, codename : jessie
Noyau : Linux 3.14-2-amd64
(G)UI : Kwin (4)
Inscription : 10-03-2013
Site Web

Re : [résolu] plantage NFS foireux

Résolu !

Il ne doit pas y avoir d'espace dans le paramétrage de /etc/default/nfs-common !

NEED_IDMAPD=yes



plutôt que

NEED_IDMAPD= yes



Le truc absurde, improbable et potentiellement invérifiable (car il y a des dizaines d'erreurs à vérifier de ce genre pour chaque logiciel installé !).

Hors ligne

#12 14-04-2013 12:45:07

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [résolu] plantage NFS foireux

Merci du retour 22decembre !

Il te reste à ajouter [Résolu] dans l'titre en éditant ton post1 ! big_smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

Pied de page des forums