Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-04-2013 00:34:06

Luckytfc
Membre
Inscription : 26-04-2013

[Erreur 404 ] FTP non fonctionnel

Bonjour,

J'ai crée un serveur sous debian.
J'ai fait en sorte qu'un site appartiennent a un utilisateur.

J'ai crée un fichier dans sites-availables avec ces caractéristiques

Voila ma config :

<VirtualHost *:80>
    # Adresse email à contacter en cas de problemes
    ServerAdmin g.audouy@gmail.com

    # Nom de domaine avec les www
    ServerName www.audouy.visite.gsb

    # Les différents alias du site, généralement le NDD sans les www
    ServerAlias audouy.visite.gsb

    # La où sont stocké les données du site
    DocumentRoot /home/appli-frais/www

    <Directory />
        # Des options : ici suivre les liens symboliques
        Options FollowSymLinks
        # Autoriser l'override, autrement dit les .htaccess
        AllowOverride All
    </Directory>
    <Directory /home/appli-frais/www>
        # Encore des options : multiviews peut être pratique
        # Si on essaye d'accéder à site.com/index
        # Et que index n'existe pas, le serveur va rechercher index.*
        # Autrement dit : index.php, index.html etc...
        Options FollowSymLinks MultiViews
        # Autorise les htaccess
        AllowOverride All
        Order allow,deny
        allow from all
    </Directory>
    # Log pour les erreurs
    ErrorLog ${APACHE_LOG_DIR}/error.log
    LogLevel warn
    # Log des connexion au site
    CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>
 



Donc quand j'accédes a mon site je tape dans l'url  : www.172.16.0.21/~appli-frais

Mais le probleme c'est que je tombe sur ce type d'erreur :

The requested URL /~appli-frais/

was not found on this server.




Que faire?

Je vous remercie d'avance.


PS: Le serveur est sur un réseau interne [Intranet]

Hors ligne

#2 27-04-2013 17:04:09

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : [Erreur 404 ] FTP non fonctionnel

Pour pouvoir utiliser ~tonuser il faut activer le mode userdir de apache, du coup tu auras un dossier public_html et sa sera beaucoup plus simple pour gerer.

\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#3 16-05-2013 18:22:44

Luckytfc
Membre
Inscription : 26-04-2013

Re : [Erreur 404 ] FTP non fonctionnel

Je m'excuse du retard . J'ai eu des problèmes personnel qui m'ont empêcher de revenir dessus.
Je vais plancher sur cette idée.
Je te remercie de ton aide.

Hors ligne

Pied de page des forums