Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-05-2013 18:45:25

cannard
Membre
Inscription : 09-05-2013

[Résolu] arrêt impossible PII

Bonjour à tous,

après mon problème résolu de carte son, en voilà un autre après lequel je cours depuis un sacré bout de temps : mon ordi se met en "halted" au lieu de s'éteindre hmm

en fait je suis exactement dans le même cas de figure que ce post : http://debian-facile.org/viewtopic.php?pid=27890 sauf que mon ordi est un PII et non un PIII, mais les messages d'erreurs sont les mêmes.

la solution avait été jusque là de rester sur un vieux noyau (qui supporte donc encore apm), de l'activer au démarrage avec "apm  power_off=1" dans /etc/modules et depuis grub2 de personnaliser l'entrée sur laquelle je boot en précisant "linux16" et "initrd16" (pour forcer en 16bit, voir ici).
Et ça marchait, mais avec le passage à wheezy j'ai été obligé d'utiliser un noyau plus récent pour lequel ces techniques ne fonctionnent malheureusement plus...

Du coup je n'ai plus d'autre choix que de corriger les problèmes liés à ACPI (car le bios parle bien d'un support acpi... peut être pas standard par contre).


Ce qui m'amène à utiliser ACPIDUMP, mais là j'avoue que je n'y comprend pas grand chose hmm

Donc si vous avez des idées ou des propositions autres que acpidump, je suis preneur smile

Dernière modification par cannard (10-05-2013 20:42:50)

Hors ligne

#2 10-05-2013 20:42:16

cannard
Membre
Inscription : 09-05-2013

Re : [Résolu] arrêt impossible PII

ça va paraître un peu ridicule, mais je me réponds à moi-même vu que j'ai trouvé la solution lol

déjà le support de apm n'est pas totalement supprimé, on le trouve toujours sous forme de module (pour le noyau 3.2.0 que j'utilise actuellement en tout cas), donc pour le faire fonctionner, il faut :

- l'activer au démarrage avec "apm  power_off=1" dans /etc/modules
- personnaliser l'entrée de grub2 en mettant : "linux16" et "initrd16" pour forcer le démarrage en 16bit (personnellement j'ai rajouté une copie du démarrage de mon noyau modifiée dans la section 40.custom de /etc/grub.d, histoire de faire quelque chose de propre...)

et finalement (et c'est ce qui empêchait que ça marche) :

- démarrer apmd en le rajoutant dans /etc/rc.local : "/etc/init.d/apmd start"

en effet, le simple fait de l'activer au démarrage (en ajoutant la ligne dans /etc/modules) lançait automatiquement le démon avec un noyau en 2.6.26, mais ce n'est plus le cas en 3.2.0 (m'en a fallu du temps avant de comprendre ça roll)

en espérant que ça en aide certains (vu que le problème a l'air d'être le même en PIII en plus...) wink

Hors ligne

#3 10-05-2013 21:24:11

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] arrêt impossible PII

Merci smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#4 13-05-2013 08:40:56

aster37
Membre
Lieu : Touraine
Distrib. : raspbian
Noyau : Linux raspberrypi 3.6.11+
(G)UI : Aucune
Inscription : 19-01-2011
Site Web

Re : [Résolu] arrêt impossible PII

Merci beaucoup pour l'info, personnellement je n'ai plus le problème car je suis passé sous Raspberry_pi
smile

raspberry_pi    512 Mo ram

Hors ligne

Pied de page des forums