Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-05-2013 18:54:47

eggregor
Membre
Lieu : Rouen
Distrib. : Sid amd64 + mint LMDE, et Sid 32/autre machine
Noyau : Linux debian 3.8-1-amd64
(G)UI : Gnome3
Inscription : 23-09-2009

Module acx-mac80211

Bonjour à tous,

J'avais perdu un jour l'usage de ma carte wifi dans des conditions obscures, et je me suis dit il y a quelque temps qu'il fallait remédier à cette situation et me débarrasser du câble éthernet.

J'ai donc installé le firmware ACX111 que je suis allé chercher sur http://acx100.erley.org,
puis le driver acx-mac80211 trouvé sur source-forge et placé comme il faut via dkms, git, et modprobe.

Au point que je m'étais étonné moi-même, vu que çà fonctionnait au poil.

Et puis, j'ai commis une bourde:

J'ai installé une nouvelle version de Linux-Mint sur une partition prévue pour çà, qui comportait une LMDE ancienne, et se satisfaisait d'un HOME commun avec ma SID.

Mais là, patatra, en gardant pour LMDE le même user que pour SID, (ça marchait comme ca avant mais j'aurais pas dû persister)  j'ai organisé une merdier pas piqué des vers, et notamment sur la connection Wlan!

En faisant les manips sous LMDE, j'ai bien la connexion sans fil, mais sous SID, rien à faire, ce qui allait tout seul ne marche pas.

De plus, l'installation de LMDE avec ce home commun, m'a amené sous SID le bureau GNOME3 dont j'avais jusqu'ici évité l'affichage avec un accès à "Gnome classique".
Maintenant plus moyen d'accéder à cette possibilité, mais ce n'est pas le plus embêtant.
(LMDE est toutefois en version Cinnamon)

Bon, je ne veux pas faire trop long:

Avec les récentes mises à jour de Sid, mon problème de module ne s'améliore pas, et comme je ne suis pas devenu un champion de la compile, je vous livre ce que me dit la machine, en comptant bien sur vos conseils pour orienter les manœuvres :

debian:/home/eggregor# tail -20 /var/lib/dkms/acx-mac80211/git/build/make.log
DKMS make.log for acx-mac80211-git for kernel 3.8-2-amd64 (x86_64)
lundi 20 mai 2013, 18:07:54 (UTC+0200)
echo "make is "standalone build""
make is standalone build
make -C /lib/modules/3.8-2-amd64/build M=/var/lib/dkms/acx-mac80211/git/build CONFIG_ACX_MAC80211=m CONFIG_ACX_MAC80211_PCI=y CONFIG_ACX_MAC80211_USB=m CONFIG_ACX_MAC80211_MEM=m EXTRA_CFLAGS=" -DCONFIG_ACX_MAC80211=1  -DCONFIG_ACX_MAC80211_USB=1  -DCONFIG_ACX_MAC80211_MEM=1  -DCONFIG_ACX_MAC80211_PCI=1 -DACX_GIT_VERSION=\\\"v20130127\\\"" modules
make[1]: entrant dans le répertoire « /usr/src/linux-headers-3.8-2-amd64 »
/usr/src/linux-headers-3.8-2-common/arch/x86/Makefile:88: stack protector enabled but no compiler support
  CC [M]  /var/lib/dkms/acx-mac80211/git/build/pci.o
/var/lib/dkms/acx-mac80211/git/build/pci.c:1042:22: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘acxpci_probe’
/var/lib/dkms/acx-mac80211/git/build/pci.c:1295:23: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘acxpci_remove’
/var/lib/dkms/acx-mac80211/git/build/pci.c:1507:12: error: ‘acxpci_probe’ undeclared here (not in a function)
/var/lib/dkms/acx-mac80211/git/build/pci.c:1508:2: error: implicit declaration of function ‘__devexit_p’ [-Werror=implicit-function-declaration]
/var/lib/dkms/acx-mac80211/git/build/pci.c:1508:25: error: ‘acxpci_remove’ undeclared here (not in a function)
cc1: some warnings being treated as errors
make[4]: *** [/var/lib/dkms/acx-mac80211/git/build/pci.o] Erreur 1
make[3]: *** [_module_/var/lib/dkms/acx-mac80211/git/build] Erreur 2
make[2]: *** [sub-make] Erreur 2
make[1]: *** [all] Erreur 2
make[1]: quittant le répertoire « /usr/src/linux-headers-3.8-2-amd64 »
make: *** [all] Erreur 2

Sans doute pas très compliqué  ?
Merci par avance à celui qui s'intéressera à cette affaire.

Hors ligne

#2 27-05-2013 14:30:27

eggregor
Membre
Lieu : Rouen
Distrib. : Sid amd64 + mint LMDE, et Sid 32/autre machine
Noyau : Linux debian 3.8-1-amd64
(G)UI : Gnome3
Inscription : 23-09-2009

Re : Module acx-mac80211

Hello,
ça s'appelle faire un tabac !
Je vais essayer de me débrouiller autrement.

Hors ligne

#3 28-05-2013 19:11:46

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Module acx-mac80211

Bonsoir,

eggregor a écrit :

Sans doute pas très compliqué  ?


Bof, erreur 1, erreur 2 ! Si on n'a pas de doc explicite, c'est la boule de cristal ou le pifomètre sad


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#4 28-05-2013 21:15:11

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Module acx-mac80211

Plop.
Le module n'est pas adapté à la version du noyau, point barre.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#5 29-05-2013 13:47:48

eggregor
Membre
Lieu : Rouen
Distrib. : Sid amd64 + mint LMDE, et Sid 32/autre machine
Noyau : Linux debian 3.8-1-amd64
(G)UI : Gnome3
Inscription : 23-09-2009

Re : Module acx-mac80211

Salut Captain,

Donc eul'module n'est pas adapté !
Je croyais que l'évolution des noyaux allait dans le sens du mieux.
Tu me diras le mieux, des fois, est l'ennemi du bien !

Et le bien mal acquis...

Je garde le câble, en attendant.

Et pataglop. Merci de votre assistance.

Hors ligne

#6 29-05-2013 19:12:01

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Module acx-mac80211

Les anciens modules ne sont pas tout le temps compatibles avec les nouveaux noyaux. Il te faut probablement récupérer une nouvelle version du module, ou attendre qu'elle existe smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#7 30-05-2013 16:04:04

eggregor
Membre
Lieu : Rouen
Distrib. : Sid amd64 + mint LMDE, et Sid 32/autre machine
Noyau : Linux debian 3.8-1-amd64
(G)UI : Gnome3
Inscription : 23-09-2009

Re : Module acx-mac80211

Ah ah Captain, le monde évolue en somme, et ni toi ni moi ne saurons le maîtriser sans faire offense à tes compétences, que je sais bien au delà des normes des individus de mon époque.
Je vais attendre.
Après tout y'a pas l'feu, mais depuis que tu m'as si patiemment aidé à pénétrer le monde Debian j'ai un peu l'impression que ma machine ces derniers mois (une douzaine sans doute) ne tire pas que des bénéfices du progrès.

Mais bon, j'ai la chance de vivre au grand air.
J'espère que tu as fait une belle sortie de la FAC et que tu profites du soleil du grand sud, s'il existe encore.

Hors ligne

#8 30-05-2013 20:57:41

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Module acx-mac80211

@eggregor: Mais pourquoi n'es-tu pas resté avec le noyau 3.2 de Wheezy ? Les modules pour ta carte wifi ne marchaient pas dessus ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#9 31-05-2013 19:24:28

eggregor
Membre
Lieu : Rouen
Distrib. : Sid amd64 + mint LMDE, et Sid 32/autre machine
Noyau : Linux debian 3.8-1-amd64
(G)UI : Gnome3
Inscription : 23-09-2009

Re : Module acx-mac80211

Pataglop,
En fait j'ai toujours la Sid que tu m'avais tant aidé à installer avec un chroot, et j'ai laissé faire simplement une mise à jour, quand ça s'est mis à cartonner ces derniers temps, qui a ramené le noyau 3.8-1 puis le 3.8-2 que j'ai aussi installé parce que je croyais que ça corrigerait le hic sur le 3.8-1.

Alors cela marchait-il avec le noyau 3.2.?..
Oui et non, dans cet ordre c'est pour cette raison que j'ai fait un post long comme un jour sans pain, pour lancer cette discussion.

J'ai créé un merdier en remplaçant mon ancienne LMDE par la dernière sortie et en gardant un /home commun avec Sid, et je te le donne en mille le même utilisateur.

Je ne refais pas le post, c'est le schisme dans la bécane.

Ma session Sid sous cet user commun ne s'ouvre plus, ce qui n'est pas le plus embêtant, et surtout la connexion wifi n'a plus voulu fonctionner et j'étais encore sous le noyau 3.2.
Par contre avec Mint c'est ok.

Raisonnement simpliste, je me suis dit, un autre user, un autre noyau, une recompile et ça va gazer... Et non. Et me voilà sur le forum.

Rien de dramatique, si ce n'est que je me prends parfois les pieds dans la ficelle.

@plus captn.

Hors ligne

Pied de page des forums