Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 31-05-2013 22:29:03

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Problèmes de mises à jour

Bonjour,

Comme Wheezy vient de sortir en stable, il y a eu de nombreuses mises à jour à faire ces derniers temps (notamment sous Sid).
Sur mon ordi, j'ai donc fais les mises à jours, ben chaque jour, et ça s'est plutôt bien passé,
sauf que Debian a une fâcheuse tendance à ne pas installer les headers du noyaux, du coup à chaque mise à jour du noyau j'ai le droit d'utiliser l'ordi en mod terminal pour installer le noyau smile

Je me suis donc dit, je vais mettre l'ordi de mon petit frère (lui aussi sous Sid) à jour dans quelques jours, du temps que tout soit régler.
Ainsi j'avais environ 1000 mises à jours à faire d'un coup.
Mais voilà, il y avait plusieurs paquets qui avaient des dépendances qui cassaient des d'autres paquets ....
J'ai donc fais des
aptitude install paquet
(ce qui m'a pris beaucoup de temps)

Finalement, j'ai presque tout mis à jour sauf quelques paquets:
comme: libsnmp-base libkrb5-dev ...

Le problème, c'est que depuis, sur son ordi, de nombreux logiciels me donnent

erreur de segmentation


par exemple nautilus, transmission .... ne se lancent plus

Quelqu'un peut il m'aider ?

Dernière modification par daufinsyd (31-05-2013 22:29:21)


Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#2 31-05-2013 22:40:46

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Problèmes de mises à jour

Héhé, c'est ça la sid smile

Tu sais, pour garder ton noyau, tu peux faire un « aptitude hold linux-image-blablabla » et il ne le met plus à jour.

L'erreur de segmentation doit venir d'une dépendance qui n'a pas été marquée comme telle et qui cause le problème.

Si tu veux débugguer le truc, installe gdb et lance « gdb nautilus » puis tapes « r » (pour le lancer) puis une fois le segfault atteint, « bt » pour obtenir la backtrace et l'endroit du plantage.

Si tu veux faire marcher le truc, essaye de faire le « hold » puis un « aptitude safe-upgrade ».

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 31-05-2013 22:47:59

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : Problèmes de mises à jour

" pour garder ton noyau"
nan, nan j'ai pas envi d'avoir un vieux noyaux smile je me demandait juste pourquoi le noyau ne recommandait pas les headers ?
je regarde pour gdb smile

Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#4 31-05-2013 22:53:40

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : Problèmes de mises à jour

Chez moi pour software-center

GNU gdb (GDB) 7.6-debian
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
"/usr/share/software-center/software-center": not in executable format: Format de fichier non reconnu
(gdb) r
Starting program:  
No executable file specified.
Use the "file" or "exec-file" command.
(gdb)
 



je suppose que ce que je suis censé voir c'esr

not in executable format


?

Mais que dois-je faire ?

Si non pour nautilus ça me met:

GNU gdb (GDB) 7.6-debian
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/nautilus...(no debugging symbols found)...done.
(gdb) r
Starting program: /usr/bin/nautilus
warning: no loadable sections found in added symbol-file system-supplied DSO at 0x7ffff7ffa000
warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffecf1b700 (LWP 9578)]
[New Thread 0x7fffe7fff700 (LWP 9579)]
[New Thread 0x7fffe77fe700 (LWP 9580)]
[New Thread 0x7fffe6ffd700 (LWP 9581)]

(nautilus:9574): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:90:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9574): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:91:17: Not using units is deprecated. Assuming 'px'.

(nautilus:9574): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:94:8: 'inset' is not a valid property name

(nautilus:9574): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:108:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9574): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:109:17: Not using units is deprecated. Assuming 'px'.

(nautilus:9574): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:112:8: 'inset' is not a valid property name

(nautilus:9574): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:130:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9574): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:131:17: Not using units is deprecated. Assuming 'px'.

(nautilus:9574): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:134:8: 'inset' is not a valid property name

(nautilus:9574): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:439:32: Not using units is deprecated. Assuming 'px'.

(nautilus:9574): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:456:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9574): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:472:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9574): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:488:32: Not using units is deprecated. Assuming 'px'.

(nautilus:9574): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:526:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9574): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:532:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9574): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:548:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9574): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:555:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9574): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:564:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9574): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:571:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9574): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:658:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9574): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:674:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9574): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:221:31: Not using units is deprecated. Assuming 'px'.
[Thread 0x7fffe7fff700 (LWP 9579) exited]
Initializing nautilus-gdu extension
[New Thread 0x7fffe7fff700 (LWP 9582)]
[New Thread 0x7fffbe1fd700 (LWP 9584)]
[New Thread 0x7fffbd9fc700 (LWP 9585)]
[New Thread 0x7fffbd1fb700 (LWP 9586)]

(nautilus:9574): Gtk-WARNING **: Style property "border-top-left-radius" is not gettable

(nautilus:9574): GLib-GObject-WARNING **: /tmp/buildd/glib2.0-2.36.1/./gobject/gtype.c:4239: type id `0' is invalid

(nautilus:9574): GLib-GObject-WARNING **: can't peek value table for type `<invalid>' which is not currently referenced

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff70d0be7 in gtk_style_context_get_valist ()
   from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
(gdb) bt
#0  0x00007ffff70d0be7 in gtk_style_context_get_valist ()
   from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#1  0x00007ffff71187fa in gtk_theming_engine_get ()
   from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#2  0x00007fffe5faef33 in _gtk_rounded_box_apply_border_radius ()
   from /usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/theming-engines/libunico.so
#3  0x00007fffe5fb0c2c in ?? ()
   from /usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/theming-engines/libunico.so
#4  0x00007fffe5fb2548 in ?? ()
   from /usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/theming-engines/libunico.so
#5  0x00007fffe5fb722e in ?? ()
   from /usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/theming-engines/libunico.so
#6  0x00007ffff70d26e6 in gtk_render_background ()
   from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#7  0x00007ffff718e90a in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#8  0x00007ffff7047e1f in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#9  0x00007ffff71739e0 in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#10 0x00007ffff519e8e7 in ?? ()
   from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#11 0x00007ffff51b72b6 in g_signal_emit_valist ()
   from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#12 0x00007ffff51b7f82 in g_signal_emit ()
   from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#13 0x00007ffff717481c in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#14 0x00007ffff717f44c in gtk_widget_send_expose ()
   from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
Cannot access memory at address 0x7fffffffdb48
(gdb)
 



EDIT:
avec nautilus-dbg d'installé:

GNU gdb (GDB) 7.6-debian
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/nautilus...Reading symbols from /usr/lib/debug/usr/bin/nautilus...done.
done.
(gdb) r
Starting program: /usr/bin/nautilus
warning: no loadable sections found in added symbol-file system-supplied DSO at 0x7ffff7ffa000
warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffecf1b700 (LWP 9668)]
[New Thread 0x7fffe7fff700 (LWP 9669)]
[New Thread 0x7fffe77fe700 (LWP 9670)]
[New Thread 0x7fffe6ffd700 (LWP 9671)]

(nautilus:9664): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:90:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9664): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:91:17: Not using units is deprecated. Assuming 'px'.

(nautilus:9664): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:94:8: 'inset' is not a valid property name

(nautilus:9664): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:108:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9664): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:109:17: Not using units is deprecated. Assuming 'px'.

(nautilus:9664): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:112:8: 'inset' is not a valid property name

(nautilus:9664): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:130:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9664): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:131:17: Not using units is deprecated. Assuming 'px'.

(nautilus:9664): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:134:8: 'inset' is not a valid property name

(nautilus:9664): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:439:32: Not using units is deprecated. Assuming 'px'.

(nautilus:9664): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:456:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9664): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:472:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9664): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:488:32: Not using units is deprecated. Assuming 'px'.

(nautilus:9664): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:526:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9664): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:532:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9664): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:548:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9664): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:555:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9664): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:564:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9664): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:571:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9664): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:658:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9664): Gtk-WARNING **: Theme parsing error: gtk-widgets-borders.css:674:31: Not using units is deprecated. Assuming 'px'.

(nautilus:9664): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:221:31: Not using units is deprecated. Assuming 'px'.
Initializing nautilus-gdu extension
[Thread 0x7fffe7fff700 (LWP 9669) exited]
[New Thread 0x7fffe7fff700 (LWP 9672)]
[New Thread 0x7fffbde55700 (LWP 9674)]
[New Thread 0x7fffbd654700 (LWP 9675)]

(nautilus:9664): Gtk-WARNING **: Style property "border-top-left-radius" is not gettable

(nautilus:9664): GLib-GObject-WARNING **: /tmp/buildd/glib2.0-2.36.1/./gobject/gtype.c:4239: type id `0' is invalid

(nautilus:9664): GLib-GObject-WARNING **: can't peek value table for type `<invalid>' which is not currently referenced

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff70d0be7 in gtk_style_context_get_valist () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
(gdb) bt
#0  0x00007ffff70d0be7 in gtk_style_context_get_valist () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#1  0x00007ffff71187fa in gtk_theming_engine_get () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#2  0x00007fffe5faef33 in _gtk_rounded_box_apply_border_radius () from /usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/theming-engines/libunico.so
#3  0x00007fffe5fb0c2c in ?? () from /usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/theming-engines/libunico.so
#4  0x00007fffe5fb2548 in ?? () from /usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/theming-engines/libunico.so
#5  0x00007fffe5fb722e in ?? () from /usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/theming-engines/libunico.so
#6  0x00007ffff70d26e6 in gtk_render_background () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#7  0x00007ffff718e90a in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#8  0x00007ffff7047e1f in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#9  0x00007ffff71739e0 in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#10 0x00007ffff519e8e7 in ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#11 0x00007ffff51b72b6 in g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#12 0x00007ffff51b7f82 in g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#13 0x00007ffff717481c in ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#14 0x00007ffff717f44c in gtk_widget_send_expose () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#15 0x00007ffff7047c18 in gtk_main_do_event () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#16 0x00007ffff6c61b3e in ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
#17 0x00007ffff6c5d7c9 in ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
#18 0x00007ffff6c5da1c in ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
#19 0x00007ffff519e8e7 in ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#20 0x00007ffff51b72b6 in g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#21 0x00007ffff51b84b9 in g_signal_emit_by_name () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#22 0x00007ffff6c50f6a in ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
#23 0x00007ffff6c43390 in ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
#24 0x00007ffff4edbb3b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007ffff4edaf25 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007ffff4edb268 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007ffff4edb324 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007ffff547b54c in g_application_run () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#29 0x000000000042e129 in main (argc=1, argv=0x7fffffffe438) at nautilus-main.c:101
(gdb)
 

Dernière modification par daufinsyd (31-05-2013 22:56:58)


Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#5 31-05-2013 22:58:05

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Problèmes de mises à jour

Euh, essaye plutôt avec nautilus. Là, un script dans /usr/share ça n'est pas un exécutable.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#6 31-05-2013 23:00:42

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : Problèmes de mises à jour

? (j'ai fait un edit pour nautilus), a ok j'ai compris désolé, j'ai édité mon message (j'ai copié le message depuis l'ordi de mon frère, j'ai changé d'ordi)

Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#7 01-06-2013 00:57:17

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Problèmes de mises à jour

Eh bien, il y a des chances que ce soit la libgtk3 (libgtk-3-0) qui ne soit pas à jour, ou peut-être la bibliothèque de thèmes gtk3-engines-unico.

Tu as essayé de faire le safe-upgrade ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#8 01-06-2013 04:40:35

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Problèmes de mises à jour

daufinsyd a écrit :

" pour garder ton noyau"
nan, nan j'ai pas envi d'avoir un vieux noyaux smile je me demandait juste pourquoi le noyau ne recommandait pas les headers ?
je regarde pour gdb smile


Salut

Si ton noyau se met automatiquement à jour c'est parce que, j'imagine, tu as le paquet linux-image-amd64 (ou semblable) qui est installé. Pour les headers, il y a le paquet linux-headers-amd64 qui installe auto les headers. Perso, je n'ai ni l'un ni l'autre des paquets qui sont installés. Aussi quand je mets à niveau mon noyau, je pense toujours à faire de même pour le header.


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#9 01-06-2013 20:56:32

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : Problèmes de mises à jour

libgtk3 et gtk3-engines-unico sont à jours.
si non j'ai installé  linux-headers-amd64 et on verra bien si ça marche smile

Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#10 02-06-2013 19:17:18

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : Problèmes de mises à jour

Ah, lorsque je lance nautilus en tant que root ça marche hmm

Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#11 05-06-2013 11:07:52

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : Problèmes de mises à jour

Hum, en fait je pense que plusieurs paquets ne peuvent être mis à jour à cause du multiarch,
en effet si je prend l'exemple de gcc-4.8-base
http://packages.debian.org/sid/gcc-4.8-base
on a:

amd64    4.8.1-2
i386  4.8.1-1



en revanche pour kdenlive par exemple

 libmlt6 : Est en conflit avec: libmlt5 mais 0.8.8-2 est installé.


du coup:

     Supprimer les paquets suivants :                  
1)     kdenlive                                        
2)     libmlt5                                          
3)     melt                                            
4)     openshot                                        
5)     python-mlt5



Ça m'a l'aire bien compliqué ...

en revanche cela me semble tout de même bizard que gcc n'ai pas de nouvelles versions, c'est quand même un paquet important non ?


Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#12 05-06-2013 12:11:22

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Problèmes de mises à jour

Pour gcc, ça n'était simplement pas encore construit smile La i386 4.8.1-2 est prête maintenant.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

Pied de page des forums