Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-06-2013 17:24:40

anguille_sous_roche
Membre
Lieu : Paris
Distrib. : Stretch
Noyau : Linux 4.6.0-1-amd64
(G)UI : Xfce 4.12
Inscription : 16-02-2013

[Résolu] Dépendance absurde du paquet gnome a xul-ext-adblock-plus

Bonjour,

J'essaie de mettre à jour icedove depuis le dépôt "http://mozilla.debian.net/ wheezy-backports icedove-esr", apt me prévient qu'il va désinstaller les paquets xul-ext-* (c'est compréhensible) mais le problème c'est que d'après apt, gnome est dépendant du paquet xul-ext-adblock-plus.

aptitude install -t wheezy-backports icedove

Les paquets suivants ont des dépendances non satisfaites :
 xul-ext-adblock-plus : Casse: icedove (> 16.0~a1+) mais 17.0.5-2~bpo70+1 doit être installé.
Les actions suivantes permettront de résoudre ces dépendances :

     Supprimer les paquets suivants :                  
1)     gnome                                            
2)     xul-ext-adblock-plus                            

     Laisser les dépendances suivantes non satisfaites :
3)     task-gnome-desktop recommande gnome

apt-cache depends gnome | grep xul

Dépend: xul-ext-adblock-plus



Que faire ?

Dernière modification par anguille_sous_roche (03-06-2013 20:32:13)

Hors ligne

#2 03-06-2013 20:13:01

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Dépendance absurde du paquet gnome a xul-ext-adblock-plus

Hum, c'est une situation embêtante.

J'ai peur que tu doives te passer du meta-paquet gnome en n'en installant que les dépendances :

aptitude install '~i~R^gnome$'
aptitude remove gnome xul-ext-adblock-plus



Vérifie qu'il ne te vire pas tout. Après cela, tu devrais pouvoir installer icedove tranquillement.


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 03-06-2013 20:21:17

anguille_sous_roche
Membre
Lieu : Paris
Distrib. : Stretch
Noyau : Linux 4.6.0-1-amd64
(G)UI : Xfce 4.12
Inscription : 16-02-2013

Re : [Résolu] Dépendance absurde du paquet gnome a xul-ext-adblock-plus

Encore merci captnfab
T'aura répondu à tous mes post aujourd’hui smile .

Peux-tu s'il te plais  détailler l’argument '~i~R^gnome$' car j n'y comprend rien neutral .

Par avance merci

Hors ligne

#4 03-06-2013 20:25:42

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Dépendance absurde du paquet gnome a xul-ext-adblock-plus

Hop smile

Donc, ^gnome$ c'est une expression qui veut dire "les paquets dont le nom est exactement 'gnome'" (compare "aptitude search gnome" avec "aptitude search ^gnome$")
~R signifie "les paquets dont dépend", ce sont les dépendances "inverses" (reverse, d'où le R)
~i signifie "les paquets installés"

Du coup, ça donne : "les paquets installés dont dépend le paquet gnome".

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#5 03-06-2013 20:31:45

anguille_sous_roche
Membre
Lieu : Paris
Distrib. : Stretch
Noyau : Linux 4.6.0-1-amd64
(G)UI : Xfce 4.12
Inscription : 16-02-2013

Re : [Résolu] Dépendance absurde du paquet gnome a xul-ext-adblock-plus

ça marche, nickel.

Merci captnfab big_smile.

Hors ligne

Pied de page des forums