Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-06-2013 11:10:31

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

wiki - steam

Bonjour, je viens de créer une page expliquant la "procédure" pour l'installation de steam sous Debian.
http://debian-facile.org/doc:jeux:steam

librement,
daufinsyd

Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#2 24-06-2013 12:07:12

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : wiki - steam

Merci pour ce tuto trés clair.

Mais je me permet quelques remarques.



Il faudrait peut être  ajouter un peu de pinning pour Sid dans wheezy. (voir des spécialistes des mélanges de branches) big_smile

Et

apt-get install - t unstable steam



il faudrait aussi ne pas mélanger apt-get et aptitude.
Dans le wiki on prend apt-get par défaut.

Sinon je suis contant d'apprendre que l'installation de steam est aussi simple sous Debian.  smile

Dernière modification par deuchdeb (24-06-2013 13:46:51)

Hors ligne

#3 24-06-2013 13:03:40

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : wiki - steam

Bonjour

Il faudrait peut-être aussi supprimer les sudo dans chaque commande necessitant d'être root en indiquant en tant que root, par exemple, avec un lien qui revoit à ce tuto http://debian-facile.org/doc:systeme:superutilisateur (voir ce fil).

deucheb a écrit :

Sinon je suis contant d'apprendre que l'installation de steam est aussi simple sous Debian.



C'est vrai que ça ne semble pas compliqué mais st-il si facile de mélanger les branches ?
La question subsidiaire est donc : Peut-on considéré ce tuto comme à destination des débutants (comme indiqué dans l'en-tête) ? Je n'ai pas de réponse péremptoire, c'est pour avoir des avis wink

Dernière modification par bendia (24-06-2013 13:03:57)


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#4 24-06-2013 13:44:22

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : wiki - steam

Oui pour le mélange des branches cela ne me parrait pas judicieux.

Je pense qu'il vaut mieux dire que ce n'est dispo que pour Jessie et Sid et ne pas parler de stable.

Pour stable on pourrait renvoyer à ce tuto pour rétroporter un paquet de Sid vers la branche stable: http://debian-facile.org/doc:systeme:retroportage

Dernière modification par deuchdeb (24-06-2013 13:45:56)

Hors ligne

#5 24-06-2013 14:42:47

jean-kiki
Membre
Distrib. : Debian jessie
Noyau : Linux 3.9-1-amd64
(G)UI : xfce 4.10 + compiz 0.8.4-5.2
Inscription : 18-09-2012

Re : wiki - steam

bonjour,

oui ça à l'air tout simple.

Et qu'en est-il du support amd64 ?
Dans debian packages il est dans i386. Faut-il configurer le multiarch avant pour que steam soit installable directement ? Ou alors l'installation d'un paquet i386 installe automatiquement ce qu'il faut pour que ça fonctionne ?
En gros : est-ce que synaptic me liste les paquets i386 même si je suis en amd64 ? j’essaierai ce soir tient !

tchou

Ça, ce sont les sources. Le mouton que tu veux est dedans.
Merci, c'est tout à fait comme ça que je le voulais ! Crois-tu qu'il faille beaucoup de ressources à ce mouton ? Parce que ma config est toute petite...
Ça devrait aller. Tu peux te compiler un petit mouton.
Pas si petit que ça. Tiens ! il s'est mis en veille...

Hors ligne

#6 24-06-2013 15:21:12

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : wiki - steam

suites à vos conseils j'ai supprimé les lignes pour wheezy et mis une redirection vers la page rétro-portage.

pour le support amd64 je n'en sais rien, je n'ai que sid en multiarch à la maison, donc ce serait bien si tu pouvais nous dire si ça marche jean-kiki smile

si non je ne savais pas que apt-get était préfé à aptitude, mais pourquoi ?

Peut-on considéré ce tuto comme à destination des débutants


j'ai modifié pour wheezy en le déconseillant aux débutants smile


Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#7 24-06-2013 16:06:20

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : wiki - steam

Si on est en amd64 et que l'on veut avoir des paquets en i386 il faut ajouter cette architechture au système de la façon suivante:

dpkg --add-architecture i386



LA SYNTAXE GENERALE EST:

dpkg --add-architecture <arch>



http://wiki.debian.org/Multiarch/HOWTO

Hors ligne

#8 24-06-2013 16:55:17

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : wiki - steam

si non je ne savais pas que apt-get était préfé à aptitude, mais pourquoi ?


aptitude permet une gestion plus éclairée des paquets, notamment en renseignant sur ce qui va se passer et en faisant même des propositions. Un débutant peut être déstabilisé par ce comportement alors qu'il ne le sera pas avec apt-get qui accommode tout seul la commande. smile

Dernière modification par smolski (24-06-2013 16:55:43)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#9 24-06-2013 17:22:15

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : wiki - steam

hum, okay smile

Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#10 25-06-2013 11:03:41

jean-kiki
Membre
Distrib. : Debian jessie
Noyau : Linux 3.9-1-amd64
(G)UI : xfce 4.10 + compiz 0.8.4-5.2
Inscription : 18-09-2012

Re : wiki - steam

alors alors,
en amd64 sans surprise les paquets i386 n'apparaisse pas.
Je lance dpkg --add-architecture i386 et je pensais qu'il y aurai quelques lignes de commande, mais pas du tout c'est instantané et effectivement steam apparaît dans les paquet dispo à l’installation smile
du coup installation-> avec un paquet de dépendances, dont du libc6 ! ça n'a rien cassé et j'imagine c'est normal si on rajoute une architecture. Chez moi :

Paramétrage de libstdc++6:i386 (4.8.1-2) ...
Paramétrage de zlib1g:i386 (1:1.2.8.dfsg-1) ...
Paramétrage de libdrm2:i386 (2.4.45-3) ...
Paramétrage de libpciaccess0:i386 (0.13.1-2) ...
Paramétrage de libdrm-intel1:i386 (2.4.45-3) ...
Paramétrage de libdrm-nouveau1a:i386 (2.4.40-1~deb7u2) ...
Paramétrage de libdrm-radeon1:i386 (2.4.45-3) ...
Paramétrage de libexpat1:i386 (2.1.0-3) ...
Paramétrage de libffi6:i386 (3.0.13-4) ...
Paramétrage de libglapi-mesa:i386 (8.0.5-6) ...
Paramétrage de libxau6:i386 (1:1.0.7-1) ...
Paramétrage de libxdmcp6:i386 (1:1.1.1-1) ...
Paramétrage de libxcb1:i386 (1.8.1-2+deb7u1) ...
Paramétrage de libx11-6:i386 (2:1.5.0-1+deb7u1) ...
Paramétrage de libx11-xcb1:i386 (2:1.5.0-1+deb7u1) ...
Paramétrage de libxcb-glx0:i386 (1.8.1-2+deb7u1) ...
Paramétrage de libxfixes3:i386 (1:5.0-4+deb7u1) ...
Paramétrage de libxdamage1:i386 (1:1.1.3-2) ...
Paramétrage de libxext6:i386 (2:1.3.1-2+deb7u1) ...
Paramétrage de libxxf86vm1:i386 (1:1.1.2-1+deb7u1) ...
Paramétrage de libgl1-mesa-glx:i386 (8.0.5-6) ...
Paramétrage de libc6-i686:i386 (2.17-3) ...
Paramétrage de libgl1-mesa-dri:i386 (8.0.5-6) ...
Paramétrage de steam (1.0.0.39-1) ...
Paramétrage de zenity-common (3.8.0-1) ...
Paramétrage de zenity (3.8.0-1) ...


tout va bien steam apparaît dans jeu, au lancement il m'a fait 153 067 KB de mises à jour, impeccable limite trop facile cool ...et paf à la fin quand il veut se lancer :

You are missing the following 32-bit libraries, and Steam may not run:
libGL.so.1



suivie d'un :

fatal error : failed to load steamui.so



hum de ce que j'ai lu vite fait est-ce que ça ne correspondrai pas aux pilotes de la carte graphique qui sont en amd64 ? Quand je cherche libGL.so.1 dans synaptic j'ai le choix entre :
libgl1-mesa-swx11-i686:i386 ou libgl1-mesa-swx11 je sélectionne le 1er car j'imagine c'est le i386 qui nous intéresse. Avec synaptic il me dit :

à désinstaller :

libgl1-mesa-glx:i386
nvidia-glx
steam:i386

à installer :

libosmesa6:i386
 



ce qui est bizarre c'est qu'avec un aptitude -s install libgl1-mesa-swx11-i686:i386 il me désinstalle la moitié du système :

Les NOUVEAUX paquets suivants vont être installés :
  libgl1-mesa-swx11:i386{ab} libgl1-mesa-swx11-i686:i386 libosmesa6:i386{a}
Les paquets suivants seront ENLEVÉS :
  aptdaemon{u} aptdaemon-data{u} gir1.2-vte-2.90{u} libdconf0{u}
  python-aptdaemon{u} python-aptdaemon.gtk3widgets{u} python-defer{u}
  python-gnupginterface{u} python-pkg-resources{u}
  python-software-properties{u} software-properties-common{u}
  unattended-upgrades{u}
0 paquets mis à jour, 3 nouvellement installés, 12 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 3 041 ko d'archives. Après dépaquetage, 14,8 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 glx-diversions : Est en conflit avec: libgl1-mesa-swx11:i386 mais 8.0.5-6 doit être installé.
 libgl1-mesa-glx : Est en conflit avec: libgl1:i386 qui est un paquet virtuel
 libgl1-mesa-glx:i386 : Est en conflit avec: libgl1:i386 qui est un paquet virtuel
 libgl1-mesa-swx11:i386 : Est en conflit avec: libgl1 qui est un paquet virtuel
                          Est en conflit avec: libgl1:i386 qui est un paquet virtuel
                          Est en conflit avec: nvidia-glx mais 304.88-3 est installé.
Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                                          
1)      audacity                                                                
2)      brasero                                                                
3)      gimp                                                                    
4)      gir1.2-clutter-1.0                                                      
5)      gir1.2-cogl-1.0                                                        
6)      gir1.2-coglpango-1.0                                                    
7)      gir1.2-javascriptcoregtk-3.0                                            
8)      gir1.2-peas-1.0                                                        
9)      gir1.2-rb-3.0                                                          
10)     gir1.2-webkit-3.0                                                      
11)     glx-alternative-mesa                                                    
12)     glx-alternative-nvidia                                                  
13)     glx-diversions                                                          
14)     gnome-user-guide                                                        
15)     gvfs                                                                    
16)     gvfs-backends                                                          
17)     gvfs-daemons                                                            
18)     libbonoboui2-0                                                          
19)     libclutter-1.0-0                                                        
20)     libclutter-gst-1.0-0                                                    
21)     libclutter-gtk-1.0-0                                                    
22)     libclutter-imcontext-0.1-0                                              
23)     libclutter-imcontext-0.1-bin                                            
24)     libcluttergesture-0.0.2-0                                              
25)     libcogl-pango0                                                          
26)     libcogl9                                                                
27)     libgl1-mesa-glx                                                        
28)     libgl1-mesa-glx:i386                                                    
29)     libgl1-nvidia-glx                                                      
30)     libglu1-mesa                                                            
31)     libgnome2-0                                                            
32)     libgnomeui-0                                                            
33)     libmx-1.0-2                                                            
34)     libpeas-1.0-0                                                          
35)     libqt4-opengl                                                          
36)     librhythmbox-core6                                                      
37)     libseed-gtk3-0                                                          
38)     libvisual-0.4-plugins                                                  
39)     libwebkitgtk-1.0-0                                                      
40)     libwebkitgtk-3.0-0                                                      
41)     libwxgtk2.8-0                                                          
42)     libxvmcnvidia1                                                          
43)     libyelp0                                                                
44)     midori                                                                  
45)     mplayer                                                                
46)     nvidia-alternative                                                      
47)     nvidia-glx                                                              
48)     nvidia-kernel-common                                                    
49)     nvidia-kernel-dkms                                                      
50)     nvidia-settings                                                        
51)     python-gnome2                                                          
52)     rhythmbox                                                              
53)     rhythmbox-plugins                                                      
54)     steam:i386                                                              
55)     task-desktop                                                            
56)     task-xfce-desktop                                                      
57)     virtualbox-qt                                                          
58)     vlc                                                                    
59)     x11-utils                                                              
60)     xorg                                                                    
61)     xserver-xorg-video-nvidia                                              
62)     yelp                                                                    
63)     zenity                                                                  

      Laisser les dépendances suivantes non satisfaites :                      
64)     audacity-data recommande audacity                                      
65)     brasero recommande yelp                                                
66)     gimp-data recommande gimp                                              
67)     gnome-bluetooth recommande gvfs-backends                                
68)     gvfs-common recommande gvfs                                            
69)     libvisual-0.4-0 recommande libvisual-0.4-plugins                        
70)     quodlibet-plugins recommande python-gnome2                              
71)     quodlibet-plugins recommande brasero | k3b                              
72)     rhythmbox recommande rhythmbox-plugins                                  
73)     rhythmbox-data recommande rhythmbox                                    
74)     task-xfce-desktop recommande vlc                                        
75)     thunar recommande gvfs                                                  
76)     xdg-utils recommande x11-utils                                          
77)     xfce4 recommande xorg                                                  
78)     xfce4-settings recommande x11-utils                                    
79)     xterm recommande x11-utils                                              
80)     nvidia-xconfig recommande libgl1-nvidia-glx-any                        
81)     virtualbox recommande virtualbox-qt (= 4.2.10-dfsg-1+b1)                
82)     virtualbox recommande libgl1-mesa-glx | libgl1                          
83)     virtualbox recommande libqt4-opengl (>= 4:4.5.3)                        
84)     libgl1-nvidia-glx recommande nvidia-kernel-dkms (= 304.88-3) | nvidia-ke
85)     nvidia-kernel-dkms recommande nvidia-glx (>= 304.88)                    
86)     nvidia-vdpau-driver recommande nvidia-kernel-dkms (= 304.88-3) | nvidia-
87)     xserver-xorg-video-nvidia recommande nvidia-kernel-dkms (= 304.88-3) | n
88)     xserver-xorg-video-nvidia recommande nvidia-settings (>= 304)



bref autant dire que pour l'instant je touche à rien ! C'est de bidouiller les pilotes nvidia qui me fait peur. Mais si vous avez des idées je veux bien tester.
Sinon une version steam amd64 n'est-elle pas prévu ? big_smile


Ça, ce sont les sources. Le mouton que tu veux est dedans.
Merci, c'est tout à fait comme ça que je le voulais ! Crois-tu qu'il faille beaucoup de ressources à ce mouton ? Parce que ma config est toute petite...
Ça devrait aller. Tu peux te compiler un petit mouton.
Pas si petit que ça. Tiens ! il s'est mis en veille...

Hors ligne

#11 25-06-2013 11:20:14

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : wiki - steam

Pour cette fameuse libGL.so.1, on peut la retrouver dans plusieurs paquets:

http://packages.debian.org/cgi-bin/sear … &arch=i386


Pour des raisons de compatibilité avec de nombreux logiciels propriétaires sad  qui ne sont souvent proposés qu'en i386, il vaut mieux installer son système en i386, il sera alors plus facile de gérer les dépendances.

Malgré tout, en ajoutant l'architecture i386 dans un système amd64, on doit pouvoir y arriver mais c'est plus compliqué.

Dernière modification par deuchdeb (25-06-2013 15:32:49)

Hors ligne

#12 25-06-2013 11:31:46

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : wiki - steam

Bonjour

Reste le sudo à supprimer (voir là) wink

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#13 25-06-2013 12:23:54

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : wiki - steam

Reste le sudo à supprimer


pardon j'avais totalement zappé smile c'est fait smile

Edit: jean-kiki au tu réussi à régler ton problème ?
http://packages.debian.org/cgi-bin/sear … &arch=i386

Ce serait bien de le rajouter dans une partie "Problèmes", non ?

Dernière modification par daufinsyd (25-06-2013 12:27:27)


Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#14 25-06-2013 12:56:42

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : wiki - steam

Oui daufindsyd smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#15 25-06-2013 15:36:52

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : wiki - steam

Voilà un beau tuto pour les grands enfants que nous sommes. tongue

reste plus qu'a attendre le retour de jean-kiki cool

Dernière modification par deuchdeb (25-06-2013 15:38:20)

Hors ligne

#16 26-06-2013 11:27:42

jean-kiki
Membre
Distrib. : Debian jessie
Noyau : Linux 3.9-1-amd64
(G)UI : xfce 4.10 + compiz 0.8.4-5.2
Inscription : 18-09-2012

Re : wiki - steam

Et bien non pas réussi à le faire fonctionner. Synaptic ne veut pas installer libgl1-mesa-swx11-i686:i386 car il faut d'abord "réparez d'abord les paquets cassés". Je crois il  à raison de pas me laisser faire n'importe quoi roll

à savoir : je suis du coin de l’œil l'affaire steam depuis l'annonce pour ubuntu.... mais je ne l'utilise pas et je ne cherche donc pas spécialement à le faire fonctionner à tout prix. c'est juste que ça m'intéresserai si ça marchait de façon simple (pour dire que je préfère attendre un paquet en amd64 smile ).

Il semble que le problème soit très courant et chacun y vas de sa solution. Une des moins complexes et qui m'est apparu cohérente (pour peu que je l'ai bien comprise) c'est de désinstaller les pilotes graphiques et de les réinstaller en i386. Mais je ne sais pas quelles pourraient être les conséquences (prise en charge du matériel et du système identique ?) sans compter qu’apparemment mesa c'est pas pareil que openGL (d'où le fait qu'il me désinstalle la moitié du système ?) et que je ne sais pas si je peux réinstall opengl après (qui peut aussi faire planter steam si pas présent, donc rien n'est garantie)... bon, pour faire clair : je patauge tongue

pour deuchdeb et daufinsyd : dans la liste seul libgl1-mesa-swx11 n'est pas installé (exception faite des paquets pour ati, je suis sur nvidia).

également : j'ai un pc test en 32bits. j'ai donc suivi le tuto à la lettre wink et là : aucune dépendance il m'installe juste steam ! youhou cool.... mais non ! roll car rien ne se passe lorsque je clique dessus. Je le lance dans un terminal et :

Illegal instruction /usr/games/steam: 16: /usr/games/steam: /home/jeankiki/.steam/steam.sh: not found



et dans mes fichiers j'ai : ~/.steam/ubuntu12_32 qui contient un exécutable nommé steam (tout court sans .sh). J'ai essayé le renommage, le déplaçage dans ~/.steam, le double-clicage. mais bien sûr rien n'y fit smile

simplement pour savoir, rassurez moi, le tuto il marche et il n'y a que chez moi ou debian me fait comprendre que je ferai mieux de travailler plutôt que de jouer aux jeux vidéos lol lol lol


Ça, ce sont les sources. Le mouton que tu veux est dedans.
Merci, c'est tout à fait comme ça que je le voulais ! Crois-tu qu'il faille beaucoup de ressources à ce mouton ? Parce que ma config est toute petite...
Ça devrait aller. Tu peux te compiler un petit mouton.
Pas si petit que ça. Tiens ! il s'est mis en veille...

Hors ligne

#17 26-06-2013 14:11:40

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : wiki - steam

Appel à volontaires pour tester le tuto steam.

Sinon il y a un autre tuto sur ce site qui est a tester. http://www.dadall.info/blog/index.php?p … ian-64bits

debian me fait comprendre que je ferai mieux de travailler plutôt que de jouer aux jeux vidéos



Non, non, non, joue, joue, joue!!!!

Travailler c'est trop dure lalala  lalala.

Dernière modification par deuchdeb (26-06-2013 14:16:16)

Hors ligne

#18 27-06-2013 17:13:51

jean-kiki
Membre
Distrib. : Debian jessie
Noyau : Linux 3.9-1-amd64
(G)UI : xfce 4.10 + compiz 0.8.4-5.2
Inscription : 18-09-2012

Re : wiki - steam

deuchdeb a écrit :

Non, non, non, joue, joue, joue!!!!
Travailler c'est trop dure lalala  lalala.


bon ben je reboot sur winchose alors ? tongue

bon allé tu m'a eu, quand j'aurais 2min je retente le coup sur mon pc test en 32bits un peu plus proprement et si ça passe (et que steam vaut le coup) je retenterai sur ma config de gamer cool (nan parce-que bon halfe-life quoi quand même !!! lol )

nb : et sinon oui j'avais vu ce tuto mais il a pas très bien expliqué son dépatouillage de carte graphique à la fin...


Ça, ce sont les sources. Le mouton que tu veux est dedans.
Merci, c'est tout à fait comme ça que je le voulais ! Crois-tu qu'il faille beaucoup de ressources à ce mouton ? Parce que ma config est toute petite...
Ça devrait aller. Tu peux te compiler un petit mouton.
Pas si petit que ça. Tiens ! il s'est mis en veille...

Hors ligne

#19 30-06-2013 00:39:22

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : wiki - steam

Bon j'ai mis du temps à revenir, mais je suis là.
J'ai également voulu installer steam sur l'ordi de mon frère et y avait le même problème.
J'ai simplement ajouté l'architecture 32bits et installé libgl1-nvidia-glx:i386 (qui n'était pas installé automatiquement)
Je rajoute ce-ci sur le wiki.
Je suppose que ça n'a pas marché chez toi cette méthode jean-kiki ?
Edit: j'ai rajouté un paragraphe concernant un bug (un crash), mais je ne l'ai pas encore testé, je le fais au plus vite smile

Dernière modification par daufinsyd (30-06-2013 01:09:03)


Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#20 01-07-2013 18:30:22

jean-kiki
Membre
Distrib. : Debian jessie
Noyau : Linux 3.9-1-amd64
(G)UI : xfce 4.10 + compiz 0.8.4-5.2
Inscription : 18-09-2012

Re : wiki - steam

yep ! bien joué daufinsyd !

le paquet libgl1-nvidia-glx:i386 ne s'affiche pas avec synaptic. C'est la paquet libgl1-nvidia-glx tout court qui est affiché et déjà installé. À tout hasard je tente le :

apt-get install libgl1-nvidia-glx:i386

et là hop il le trouve et me l’installe avec 4 autres dépendances :

libxv1:i386 libxvmc1:i386 libxvmcnvidia1:i386


Je ne sais pas si ça joue mais j'ai un fichier préférence pour ne pas installer les "recommends" et "suggests" paquets de APT (depuis qu'il à voulu m'installer tout gnome sur xfce !)

je reclic sur steam et là : tadam !!! ça fonctionne big_smile

je peux désormais dire que-c'est-presque-pas-trop-dur d'installer steam sur debian :lol

[edit]:
pour deuchdeb : noooooon je vais être obligé de jouer !!!

Dernière modification par jean-kiki (01-07-2013 18:32:10)


Ça, ce sont les sources. Le mouton que tu veux est dedans.
Merci, c'est tout à fait comme ça que je le voulais ! Crois-tu qu'il faille beaucoup de ressources à ce mouton ? Parce que ma config est toute petite...
Ça devrait aller. Tu peux te compiler un petit mouton.
Pas si petit que ça. Tiens ! il s'est mis en veille...

Hors ligne

#21 01-07-2013 19:24:37

daufinsyd
Membre
Lieu : Alsace, Haut Rhin
Distrib. : Manjaro + Tanglu + Debian Stable + Xubuntu
Noyau : Linux 4.4-amd64
(G)UI : Plasma 5 & Gnome
Inscription : 02-02-2013

Re : wiki - steam

Super !!! content que ça marche ! smile

Aspire V3-772G + SSD 850Evo (msata)
Intel i7-4790 4 (8) * 3.6Ghz - 12Go - GTX460 1Go - 1To + 500Go DD
Intel i7-6700 - 8Go - AMD R9 280X 3Go - 1To HDD + 2To HDD + SSD 850Evo (2.5)

Hors ligne

#22 22-01-2015 10:45:12

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : wiki - steam

Pour Jessie le paquet Steam semble gérer ses dépendances correctements et installer la libgl1 qui manque tout seul.

fonts-liberation gcc-4.9-base:i386 libbsd0:i386 libc6:i386 libc6-i686:i386
  libdrm-intel1:i386 libdrm-nouveau2:i386 libdrm-radeon1:i386 libdrm2:i386
  libedit2:i386 libelf1:i386 libexpat1:i386 libffi6:i386 libgcc1:i386
  libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386 libllvm3.5:i386
  libpciaccess0:i386 libstdc++6:i386 libtinfo5:i386 libtxc-dxtn-s2tc0:i386
  libudev1:i386 libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-dri2-0:i386
  libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386 libxcb-sync1:i386
  libxcb1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386
  libxinerama1:i386 libxshmfence1:i386 libxxf86vm1:i386 steam:i386 zlib1g:i386



Pas besoin de la ligne

apt-get install libgl1-nvidia-glx:i386


Notamment parcequ'elle installe les pilotes Nvidia et peut flinguer une config.
J'ai du faire un remove pour pouvoir faire démarrer à nouveau ma machine

apt-get remove libgl1-nvidia-glx:i386


Je suggére que l'on déplace cette ligne ailleurs.
La recommendation d'utilisation des pilotes propriétaires n'est peut être pas des plus utiles. Une suggestion pour améliorer les performances si nécessaire devrait suffire.
Je joue sur les mots, mais on peut très bien jouer sans les pilotes proprio.

Hors ligne

#23 22-01-2015 11:35:59

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : wiki - steam

Un avis de dézinguage des configurations par l'utilisation des pilotes proprios me paraît plus leste que la suppression d'une explication... smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#24 22-01-2015 13:00:09

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : wiki - steam

N'oublions pas que, sauf mention contraire, c'est de Wheezy dont il s'agit.  smile
Et cette page me semble mêler joyeusement stable, testing et sid.  wink

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#25 22-01-2015 13:37:54

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : wiki - steam

alors reporter la distinction pour chacune ?

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums